mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Stromquelle in LTSpice


Autor: Gerd F. (gerd_f)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

kann mir jemand sagen wie ich eine Stromquelle in LTSpice erstellen 
kann? Ich brauche ein Strom Dreieckssignal das mit einen Strom von 0 - 
12 uA und wieder zurück nach 0 liefert. Möchte damit das Ausgangssignal 
des INA138 simulieren.

Gruss
Gerd

Autor: Johann (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So?

Autor: John Drake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
F2, current <ENTER>, <left click>, <right click>, "advanced" anklicken, 
"PULSE" auswählen, I1[A]: 0, I2[A]: 12u, den Rest weißt nur du...

Autor: Lafuter Z. (lafuter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PULSE(0 12u 0 1m 1m 0 2m)

Autor: Gerd F. (gerd_f)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank, werd ich ausprobieren. Ich möchte gerne diese Schaltung 
simulieren bevor ich alles aufbaue, insbesondere ob der Komparator 
sauber umschaltet zwischen Charge und Load.

Seht Ihr da vielleicht schon was auffälliges, was noch zu verbessern 
wäre?

Grüsse
Gerd

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gerd F. schrieb:
> Ich möchte gerne diese Schaltung simulieren bevor ich alles aufbaue,
> insbesondere ob der Komparator sauber umschaltet zwischen Charge und Load.
Interessanter ist eigentlich eher, was er macht, wenn gar kein Strom 
fließt...
Aber nachdem du die Schaltung einfach dem DB entnommen hast, dürften die 
Chancen auf ein funktionsfähiges System gar nicht so schlecht stehen... 
;-)

Autor: Gerd F. (gerd_f)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> Interessanter ist eigentlich eher, was er macht, wenn gar kein Strom
> fließt...

Ja, deshalb wollte ich das erst mal in LTSpice simulieren, so wir ich 
das sehe, springt mit der Komparatorausgang im Ruhezustand 
wahrscheinlich auf 2-3 Volt, das gefällt dem Digital Port nicht so gut. 
Deshalb hab ich da vorsichtshalber Potis vorgesehen, die ich dann ganz 
minimal asynchron einstellen kann, so dass der + Eingang ein paar uV 
unter dem invertierenden liegt. Das müsste dann eigentlich reichen um 
den Ausgang sauber auf log.0 zu legen.

Gruss
Gerd

Autor: Gerd F. (gerd_f)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johann schrieb:
> So?

Ja genau, danke!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.