mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit LM386-Verstärkerschaltung


Autor: Andreas Finkler (Firma: //) (andifin)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich wollte eine simple Verstärkerschaltung für einen Lautsprecher (8 
Ohm) bauen. Dazu habe ich einen LM386N-1 als OpAmp genommen und die mich 
zunächst an die Schaltung gehalten, die auf dieser Seite als erstes 
aufgelistet ist:
http://www.techlib.com/electronics/audioamps.html
Diese ist fast identisch mit der im Datenblatt beschriebenen (Amplifier 
with Gain = 200). Die Lautsprecher sind EKULIT LSM-77F (lustigerweise 
finde ich auf der Herstellerseite nur die LSM-77A, die eine max. 
Leistung von 1,5W haben, aber bei meinen steht auf der Packung 0,5W 
drauf, sie sind vom örtlichen Elektronikladen).

Die Schaltung habe ich also zunächst auf dem Steckbrett aufgebaut und an 
eine 9V-Batterie gehangen. Nur habe ich ein äußerst seltsames Problem:

Stecke ich das Poti (habe ein logarithmisches genommen) wie in dem 
Schaltplan gezeigt ein, bekomme ich nur ein sehr verzerrtes Signal aus 
dem Lautsprecher, dieses dafür höllisch laut. Stecke ich das Poti aus 
und lasse den Rest so, wie er ist (d.h., der Pluspol vom Audioeingang 
hängt eigentlich nur in der Luft! es besteht keine richtige Verbindung 
zu Pin 3 des ICs!), habe ich zwar eine deutlich geringere Lautstärke (so 
laut, wie wenn ich die Box direkt mit dem Eingangssignal verbinde), aber 
dafür glasklar - aber nur, solange die Versorgungspannung eingeschaltet 
ist.
Auch wenn ich den 10uF-Kondensator zwischen Pin 1 und 8 weglasse (was 
einen Gain von max. 20 bedeuten sollte), bleibt das Signal so extrem 
verzerrt.
Zuerst dachte ich, der IC bringt zuviel Leistung für den Lautsprecher, 
aber laut Datenblatt sollte der LM386N-1 maximal 325mW liefern.

Was genau ist da los? Wie kommt das Signal überhaupt an den 
Lautsprecher, wenn der Pluspol des Eingangssignals eigentlich gar nicht 
mit ihr verbunden ist? Elektromagnetische Schwingungen? Wieso ist der 
Ton komplett weg, wenn ich die Versorgungsspannung ausschalte?

Hoffentlich kann man überhaupt verstehen, worum es mir geht.

LG und ein herzliches Dankeschön an alle, die mir helfen können,
Andi

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast die Schaltung auf einem Steckbrett aufgebaut. Das und das 
geschilderte Verhalten lässt mich annehmen, daß der Verstärker schwingt.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe nur die Wörter Verzerrung, Steckbrett und Verstärker gelesen.
Das Teil schwingt! Eine Fledermaus wird es sogar hören können.

Autor: Andreas Finkler (Firma: //) (andifin)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm. Heißt das, ich MUSS es zwingend auflöten, um zu sehen, ob es 
funktioniert? Hab ich keine andere Möglichkeit, es vorher zu testen?

Der Grund ist simpel: Habe für die Handvoll Bauteile (habe alles doppelt 
gekauft, soll eine Stereobox werden) 25€ auf den Tisch geblättert, weil 
ich mir gesagt habe "stärkst du halt mal die heimische Wirtschaft, 
anstatt ständig im Internet zu bestellen".
Ich könnte natürlich, wenn es nicht funktioniert, alle Teile wieder 
auslöten, aber das ist doch auch nicht das Wahre, oder?

Wie würdet ihr das Problem lösen? Einfach dem Schaltplan vertrauen?

Übrigens, das Datenblatt, hatte ich ganz vergessen:
http://www.ak-modul-bus.de/cat/documentation/LM386N-1.pdf

Welche Schaltung ist sinnvoller? Die aus dem Datenblatt oder aus obigem 
Link? An sich unterscheiden sie sich ja nur wenig.

Und vielen Dank für eure Hilfe!

Autor: Harald Wilhelms (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Finkler schrieb:
> Hm. Heißt das, ich MUSS es zwingend auflöten, um zu sehen, ob es
> funktioniert? Hab ich keine andere Möglichkeit, es vorher zu testen?

Ich würde eine solche Schaltung auf einer Lochrasterplatte aufbauen
und dabei eine Fassung für das IC nehmen. Da sind Änderungen nicht
allzuschwierig. Man sollte allerdings auch hier die Drähte nicht
länger als nötig machen.

> Welche Schaltung ist sinnvoller? Die aus dem Datenblatt oder aus obigem
> Link?

Grundsätzlich ist die Funktionssicherheit von Schaltungen aus dem
Datenblatt wesentlich höher. Fehler im Originaldatenblatt des
Herstellers sind äusserst selten.
Gruss
Harald

Autor: Andreas Finkler (Firma: //) (andifin)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gut, vielen Dank, Harald. Die Schaltung soll noch etwas erweitert 
werden. Gleichzeitig zur Musik sollen noch LEDs im Takt der Musik 
leuchten. Bevor ich das ganze dann aufbaue, erstelle ich nochmal einen 
kompletten Schaltplan und stelle ihn hier ein.

Jetzt mach ich mich aber erstmal auf die Suche nach einem kostenlosen 
Programm um sowas auf dem PC zu erstellen, dass ihr euch nicht mit 
meinen selbstgemalten Kritzeleien rumschlagen müsst.

LG Andi

Autor: us73 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Finkler schrieb:
> Jetzt mach ich mich aber erstmal auf die Suche nach einem kostenlosen
> Programm um sowas auf dem PC zu erstellen, dass ihr euch nicht mit
> meinen selbstgemalten Kritzeleien rumschlagen müsst.

eagle ?

Autor: Andreas Finkler (Firma: //) (andifin)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, hatte es gerade schon heruntergeladen, bin über die Suchfunktion 
auf die Seite mit den Schaltplaneditoren gekommen.

LG Andi

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist Du wirklich gaaaaaaaaaanz sicher dass Du die Schaltung auf dem 
Steckbrett korrekt aufbebaut hast?

Autor: Andreas Finkler (Firma: //) (andifin)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe an sich alles mehrfach überprüft. Allerdings habe ich auch nicht 
die Schaltung aus dem Datenblatt genommen, sondern die von der Website. 
Werde es auch nochmal mit der aus dem Datenblatt probieren.

LG Andi

Autor: Andreas Finkler (Firma: //) (andifin)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,
ihr hattet Recht, ich hätte lieber mal dem Datenblatt vertrauen sollen.
Denn jetzt funktioniert es auch auf dem Steckbrett, Verstärkung ist gut, 
nur leider muss ich jetzt feststellen, dass ich doch mehr als 3€ in die 
Lautsprecher hätte investieren sollen, da die sehr schnell verzerren bei 
höheren Lautstärken. Für Raumbeschallung wenn ich alleine bin reicht die 
Lautstärke, bis zu der die Qualität noch ok ist aus, aber die Boxen 
sollen insbesondere außen zum Einsatz kommen.

Kann hier vielleicht jemand was empfehlen?

LG Andi

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.