mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR GCC Problem


Autor: Hiiiilfe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

habe seit gestern Abend ein Problem beim Kompilieren:

rm -rf AT².o Led.o Servo.o adc.o I²C.o Sound.o uart.o Bluetooth.o Lcd.o 
Motor.o Robot.o  AT².elf dep/* AT².hex AT².eep
Build succeeded with 0 Warnings...
avr-gcc  -mmcu=atmega2560 -Wall -gdwarf-2 -std=gnu99 
-DF_CPU=16000000UL -Os -funsigned-char -funsigned-bitfields 
-fpack-struct -fshort-enums -MD -MP -MT AT².o -MF dep/AT².o.d  -c 
../AT².c
make: *** [AT².o] Error 259
Build failed with 1 errors and 0 warnings...


Diesen Text gibt er mir jetzt immer unten aus.
Eine Hex-File wird nicht erstellt.
Da ist doch irgendwas komisch?!!

Hoffe mir kann irgendjemand helfen!

Danke schonmal!

Autor: Kai S. (zigzeg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht liegts am kranken File-namen ? Einfach mal das "Quadrat" 
durch ne simple 2 ersetzen ?

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Da ist doch irgendwas komisch?!!

Sehr komisch sind die Sonderzeichen in deinen Dateinamen.

Autor: Hiiiilfe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja die Software gibts schon ne gaaaaanz weile ;) Ich glaube nicht 
wirklich, dass es daran liegt, ich kompiliere die so oft und der Fehler 
trat einfach so auf!

Autor: Hiiiilfe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also hier nochmal ein Ausschnitt...

make: *** [I2C.o] Error 1
Build failed with 1 errors and 0 warnings...


Ich kann das sehr oft ausführen, jedesmal nagt er an einer anderen Datei 
herum.
Wenn ich MAKE oft ausführe kommt irgendwann die meldung, dass alles in 
Ordnung sei und das die HEX erstellt wurde...

Ich hab jetzt schon AVRStudio und WINAVR neu installiert...

Autor: Martin Thomas (mthomas) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>[...]seit gestern Abend ein Problem beim Kompilieren
was wurde zwischen "gestern Abend" und gestern Mittag geändert an 
System, Makefile, Quellcode? Aufruf mit "make clean all"? Wenn ja, 
testweise erst "make clean" dann "make all". Könnte sein, dass ein 
Rennzustand zwischen Löschung von Objektdateien und Neuanlage durch den 
Compiler auftritt. make --help zeigt Schalter zur Aktiverung von 
Debug-Ausgaben.

Autor: Kai S. (zigzeg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hiiiilfe schrieb:
> Ich kann das sehr oft ausführen, jedesmal nagt er an einer anderen Datei
> herum.

Hm, klingt nach irgendwas wie Festplatte voll oder Rechner kaputt. Sonst 
waere der Fehler immer in der gleichen Datei.

ZigZeg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.