mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRISP mkII unter Win7 (64bit) Base Mode


Autor: Meeg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich wollte gerne den ARVISP mkII unter Win7 64Bit benutzen und im 
Internet findet man auch viele Anleitungen dass das funktionieren soll.
Hab auch alles so gemacht wie beschrieben, aber wenn ich den BaseMode 
(zum Firmware ändern) benutzen will wird keine Hardware erkannt. Zum 
Firmware ändern benutze ich USBProg.

Kann mir da einer weiterhelfen?

LG Meeg

Autor: Kai S. (zigzeg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meeg schrieb:
> Hallo,
>
> Ich wollte gerne den ARVISP mkII unter Win7 64Bit benutzen und im
> Internet findet man auch viele Anleitungen dass das funktionieren soll.

Du hast also einen Original AVRISP mkII ?

> Hab auch alles so gemacht wie beschrieben, aber wenn ich den BaseMode

BaseMode ?

> (zum Firmware ändern) benutzen will wird keine Hardware erkannt. Zum
> Firmware ändern benutze ich USBProg.

USBProg ist doch eine Hardware ???
Welche Software benutzt Du denn ?

Irgendwie verwirrend. Vielleicht kannst Du präziser sagen, was das 
Problem genau ist ?

ZigZeg

Autor: Meeg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für den AVRISPmkII gibt es ja verschiede "Programme" wie AVRISPmkII 
Clode, LED-Blink, usbprogRS232...und die würde ich gerne auf den USBprog 
v3.0 übertragen.

Sry hab mich oben auch falsch ausgedrückt, hab den USBprog v3.0, den ich 
als AVRISPmkII nutzen will :/.

Und als Software benutze ich USBProg, womit man halt die verschiedenen 
Modi übertragen kann.

LG

Autor: Frank Link (franklink)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Meeg,
schau als erstes mal nach, ob Dein USB-Treiber von Windows 7 akzeptiert 
wird. Wird er das nicht must Du die erste Hürde  nehmen. D.h. Du must 
Windows 7 in den Testmodus setzen, Anleitung im Internet, anschliessend 
neu booten. Dann sollte der USB_Treiber korrekt funktionieren und das 
flashen auch.

Alternativ, kannst Du auch eine VM-Ware z.B. mit Windows XP aufsetzen, 
dann funktionieren Deine Treiber innerhalb der VM korrekt. So mache ich 
das jetzt seit einem halben Jahr ohne Probleme.

Gruß
Frank

Autor: Kai S. (zigzeg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Halle Meeg,

Meeg schrieb:
> Für den AVRISPmkII gibt es ja verschiede "Programme" wie AVRISPmkII
> Clode, LED-Blink, usbprogRS232...und die würde ich gerne auf den USBprog
> v3.0 übertragen.
>
> Sry hab mich oben auch falsch ausgedrückt, hab den USBprog v3.0, den ich
> als AVRISPmkII nutzen will :/.

Ok, prima. Ich habe übrigens auch ein USBprog v3.0, und benutze es mit 
AVR Studio unter 64 Bit W7 als AVRISPmkII Clone.

Wenn ich Dich richtig verstanden habe, so scheiterst Du bei dem Schritt, 
die AVRISPmkII Clone Firmware aufzuspielen?

Welche Version vom USBprog v3.0 hast Du eigentlich genau ?

Es gibt ja folgende drei:
- "vormontiert"
- "programmiert mit AVRISPmkII Klon"
- "programmiert mit openOCD"

ZigZeg

Autor: Meeg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab die Version, wo ich mir alles selber zusammengelötet hab und 
anschließend mit nem Programmieradapter geflasht hab.

Das Problem ist halt nur dass ich den unter Win7 64 bit nich ans Laufen 
bekomme, bei meinem 32bit Laptop läuft alles ohne Probleme.

Autor: Kai S. (zigzeg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meeg schrieb:
> Ich hab die Version, wo ich mir alles selber zusammengelötet hab und
> anschließend mit nem Programmieradapter geflasht hab.
>
> Das Problem ist halt nur dass ich den unter Win7 64 bit nich ans Laufen
> bekomme, bei meinem 32bit Laptop läuft alles ohne Probleme.

Damit der USBProg, geflasht als AVRISPmkII Klon, unter AVR Studio zu 
benutzen musste ich erst eine neue Version des Jungo Treibers 
installieren, heruntergeladen von folgender Seite:

http://www.atmel.no/beta_ware/

Was das Flashen von anderer Firmware des USBprog angeht: Das habe ich 
(glaube ich) bisher nur unter Mac OS gemacht. Kann ich aber heute abend 
mal unter Win7 ausprobieren.

Den Jumper has Du aber gesetzt, so wie im Manual beschrieben
(Ich glaube auf Pin 2+3 von JP3 ?) ?

Anderseits sagst DU ja dass es auf dem Laptop klappt ?
Ist auf dem 32 bit Laptop auch Win7 ?

ZigZeg

Autor: Meeg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja das mit dem Jumper hab ich gemacht.
Auf dem Laptop ist Win7 32-Bit und vom Laptop aus kann ich auch z.B. die 
Fuses vom ATMEL lesen oder Programme übertragen etc.

Hmm mit AVR Studio müsst ich ma schauen ob ich das ans Laufen bekomme, 
hab ich noch nie mit gearbeitet, werd ich aber gerne mal ausprobieren.

Autor: Kai S. (zigzeg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe es jetzt bei mir mal ausprobiert. Scheint alles zu funktionieren:

0) usbProg.2.0.exe installiert
1) Jumper auf Pin 2+3 von JP3 gesetzt.
2) USB Kabel eingesteckt
 => erscheint im Control-Panel "Devices and Printers" als usbprogBase 
Mode
3) Jetzt usbProg GUI gestartet
4) Device "0: USBprog in update mode" ausgewählt
5) Firmware ausgewählt: "AVRISK mk2 Clone"
6) Upload => Update successfull
 => AVRISP mk2 Clone erscheint im Control Panel "Devices and Printers"

Habe immer noch nicht genau verstanden, bei welchem Schritt es bei Dir 
hakt ?

ZigZeg

Autor: Meeg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also habs jetzt mal mit AVR Studio ausprobiert und nachdem ich den einen 
Treiber installiert hab wo du drauf hingewiesen hast kann ich über AVR 
Studio problemlos den µC flashen.

Aber sobald ich den USBProg im Updatemodus reinstecke kommt die Meldung 
dass keine Treiber gefunden wurden. Also kann ich auch nicht drauf 
zugreifen.

Aber ich bin schon mal froh, dass das unter AVR Studio läuft, also dafür 
schonmal vielen Dank:)

Autor: Mark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich wollte eure Erfahrungen von dem mkII unter Win7 64bit hören. Ich 
möchte mir den Programmer auch zulegen weil mein Serial-to-USB auch 
nicht richtig funktioniert.
Als Software nutze ich das AVR Studio und die Hardware ist das STK500.
Also wird der Programmer erkannt ohne auf eine virtuelle Maschine zu 
greifen?
Vielen Dank im Vorraus.

Gruß Mark

Autor: Kai S. (zigzeg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mark,

Mark schrieb:
> ich wollte eure Erfahrungen von dem mkII unter Win7 64bit hören. Ich

AVRICEmkII ? Oder AVRISP mkII ? Oder Canon EOS 5D mkII ?

mkII (oder "Mark II") heisst nur soviel wie "Version 2.0", also wenig 
spezifisch.

Hier im Thread ging es um den USBProg 3.0 als AVRISPmkII Clone. Das 
funktioniert unter W7 64bit - mit dem passenden Treiber (s.o.). Ein 
AVRICEmkII laeuft bei mir auch.

Ein STK500 laeuft auch bei mir unter Win7 64bit, musste allerdings ein 
bischen an Treiber "fummeln" (Details habe ich vergessen, haengt ja auch 
vom verwendeten USB2Seriell Adapter ab). Vielleicht einfach nochmal ein 
bischen am Treiber basteln ?

ZigZeg

Autor: Mark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es geht um den AVRISP mkII, wie im ersten Beitrag dieses Threads.
Ich weiss nicht wo das Problem liegt bei dem Kabel. Mein STK wird aber 
und zu erkannt. Letztens hatte ich einen MAX232 über das Kabel 
angeschlossen undas funktioniert einwandfrei. Auch nach mehrfachen 
wiederholen. Daher bin ich es leid und wollte auf einen Programmer 
umsteigen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.