mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Parasitäre oszillationen bei Parallelschaltung von MOSFets


Autor: ASZ18 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,
ich hab da mal wieder ein altes Problem:
Bei einer Schaltung von mir sollen in einem Drosselkreis
50A Dauerstrom eingeregelt werden.
Hierzu hab ich 2 dicke CoolMOS Parallelgeschaltet.
Die Ansteuerung ist je MOS ein eigener Treiber MIC4426 und ein 
Gatevorwiderstand (10R tbd.)
Die Problematik ist nun, dass je nach Gatewiderstand bei Strömen ab 30A
plötzlich Parasitäre Oszillationen auftreten, größer 100MHz und meine 
Karte
(zum Glück) sofort abschaltet aufgrund einer Störung der 5V-Versorgung, 
die überwacht wird.

Mit Infineon-IPW60R045 hab ichs dadurch zum laufen geberacht, indem ich 
eine Ferritperle aufs Gate jedes MOS geschoben hab.
Das hat aber bei den IXKK85N60 von IXYS leider nicht funktioniert.
Diese wollte ich eigentlich aufgrund des geringeren RDSon und dem 
größeren Gehäuse (TO264) einsetzen.

Das Layout ist sehr Flächig und die Treiber sind direkt überm MOS, alles 
geblockt usw.

Hat jemand schon mal so einen Effekt beobachtet und wie kann man den 
bekämpfen außer mit Ferritperlen?

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die Ansteuerung ist je MOS ein eigener Treiber MIC4426

Das ist eigentlich nicht so optimal, da kann es nämlich passieren, dass 
die unterschiedlich schnell schalten. Besser ist ein kräftiger 
gemeinsamer Treiber für beide Mosfets.

> Mit Infineon-IPW60R045 hab ichs dadurch zum laufen geberacht

Du meinst vermutlich IPW60R045CP? Da hast du dir von allen 
Coolmos-Familien genau IPW60R045 rausgesucht, bei der das 
Schaltverhalten am schwierigsten zu beherrschen ist.

Zeichne doch mal ein Schaltpbild und beschreib die Anwendung (also 
welche Schaltfrequenz, was ist als Last angeschlossen, was ist die 
Aufgabe der Schaltung), dann kann man eher helfen.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johannes schrieb:
> Besser ist ein kräftiger
> gemeinsamer Treiber für beide Mosfets.

Genau das Gegenteil wird im Application Note von Infineon empfohlen. Je 
eine Transistor Halbbrücke pro Gate.
Zusätzlich wird auch noch drigend eine Ferritperle auf dem Gate 
empfeohlen.
Zudem gibt es noch wichtige Hinweise zur Leiterbahnführung, das die FETs 
so rasend schnell sind.

Schaut selbst:

http://www.infineon.com/dgdl/IPW60R045CP_rev2%5B1%...

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Genau das Gegenteil wird im Application Note von Infineon empfohlen. Je
> eine Transistor Halbbrücke pro Gate.

Du beziehst Dich vermutlich auf die "AN-CoolMOS-CP- 01", Figure 18.

Dort werden zwei Boost-Stufen aus Bipolartransistoren für die beiden 
Leistungs-Mosfets verwendet. Davor sitzt aber trotzdem ein gemeinsamer 
Gate-Treiber, der die Pegelwandlung macht.

Dieser Pegelwandler hat eine bestimmte Propagation Delay, die eine 
gewisse Streuung aufweist. Wenn man zwei solche Treiber-ICs für eine 
Parallelschaltung verwendet, kann es passieren, dass diese 
unterschiedlich schnell schalten und es dadurch zu Problemen kommt.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johannes schrieb:
> Dieser Pegelwandler hat eine bestimmte Propagation Delay, die eine
> gewisse Streuung aufweist. Wenn man zwei solche Treiber-ICs für eine
> Parallelschaltung verwendet, kann es passieren, dass diese
> unterschiedlich schnell schalten und es dadurch zu Problemen kommt.

Ja, da habe ich mich undeutlich ausgedrückt.
Zwei echte eigenständige Gatetreiber ICs haben natürlich 
unterschiedliche Propagation Delays.
Allerdings ist die von Dir empfohlene Variante "einen kräftigen 
Gatetreiber für beide MOSFETs zu nehmen" gerade bei den hier 
möglicherweise eingesetzten FETs laut Hersteller nicht empfohlen.

Autor: ASZ18 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Anbei mal die Schaltung. Es handelt sich um eine Pulsstromquelle.
Es wird mit den Transistoren oben links ein Strom im Drosselkreis 
aufrechterhalten, die obere Stufe muss also im Prinzip die Verluste 
nachladen. Die Stufe unten Rechts ist geschlossen. Wenn diese öffnet 
wird ein Stromimpuls über die Diode ausgekoppelt.
Das Schaltungsprinzip war deshalb notwendig, weil die Verlustleistungen 
einer linearen Endstufe viel zu hoch gewesen wären.

Die Ladefrequenz variiert je nach Betriebsfall, ist aber maximal 
50-60kHz.

Ich hab mal die Laufzeitdifferenzen der Treiberbausteine gemessen,
die liegen unterhalb 1 ns! ich denke nicht, dass das die Ursache sein 
kann.

Die Transistoren mit denen das alles Funktioniert (nur mit Ferritperlen) 
sind IPW60R045CS nicht CP, die hab ich garnicht hergekriegt.
Aufgrund des hohen Dauerstroms hatte ich jetzt auch nicht so ne große 
Auswahl an MOSfets, da alles über 50mOhm eigentlich zu viel Verluste 
produziert. Schnell schalten will man ja eigentlich auch um die 
Schaltverluste klein zu halten, daher die Wahl.
Die Infineons hab ich eigentlich nur eingesetzt, weil ich die IXYS auch 
nicht hergekriegt hatte. (zur Info, in den IXYS sind auch Infineonchips 
drin bei den COOLMOS)

Autor: ASZ18 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gerade eben noch die Gatevorwiderstände auf 2,2 Ohm verringert, dann 
tritt der Effekt nicht mehr auf.
Das Widerspricht sich nur leider mit allem, was ich bislang darüber an 
Applikation-notes gelesen hab.

Autor: ASZ18 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK zu früh gefreut, die Schwingungen treten jetzt bei 51,5A auf, sind da 
allerdings Tödlich.
Woher kommen diese Oszillationen, wie kann man entgegenwirken?

Autor: Jörg Rehrmann (Firma: Rehrmann Elektronik) (j_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ASZ18 schrieb:
> OK zu früh gefreut, die Schwingungen treten jetzt bei 51,5A auf, sind da
> allerdings Tödlich.
> Woher kommen diese Oszillationen, wie kann man entgegenwirken?

Woher die kommen ist doch klar. Das Ersatzschaltbild des Transistors 
enthält einige Induktivitäten und Kapazitäten. Für die Sourcezuleitung 
kannst Du mal 10 nH rechnen. Dazu kommt dann noch die Induktivität der 
Leiter(bahnen). Jetzt soll der Transistor 50 A in 100ns schalten. Das 
sind dann 500A/µs. Da wird alleine im Source-Pin eine Spannung von ca. 5 
Volt induziert, die sich wiederum zur Gate-Source-Spannung addiert. 
Zusammen mit den restlichen parasitären Induktivitäten, Kapazitäten und 
Laufzeiten ergibt sich eine Vielzahl von Schwingungsbedingungen im 
UKW-Bereich.
Gegenmaßnahmen sind:
1. Leitungen so großflächig und kurz wie möglich halten
2. Bezugspotenzial der Gateansteuerung (zum Source-Pin) möglichst dicht 
am Transistorgehäuse verbinden.
3. Schaltgeschwindigkeit durch Gatewiderstände auf unkritische Werte 
reduzieren.

Jörg

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Woher kommen diese Oszillationen, wie kann man entgegenwirken?

Treten die Oszillationen eher beim Einschalten oder beim Ausschalten 
auf? Wenn es beim Ausschalten ist, dann hilft es evtl. den Mosfet mit 
einer negativen Gate-Spannung anzusteuern. Wenn die Oszillationen beim 
Einschalten bzw. während einem High-Pegel am Gate auftreten, dann 
könntest Du versuchen, die Gatespannung größer zu machen.

Durch eine höhere bzw. negative Gate-Spannung kann man die Effekte der 
Source-Induktivität etwas kompensieren; manchmal reicht es um diese 
Oszillationen zu verringern.

Wie hoch ist denn die Versorgungsspannung des Gate-Treibers?

Autor: ASZ18 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Versorgung des Treibers ist 15V.
Ich hab jetzt mal um zu testen den Sourcedraht des Transistors länger 
gemacht (kürzer geht nicht) um zu schauen, obs dann schlimmer wird.
Schlimmer ist es nicht geworden, die Oszillationen sieht man bei 
insgesamt 30A auftreten. Scheint also eher nicht die primäre Ursache zu 
sein.
Die Ratschläge von Jörg hab ich imo realisiert.

Autor: Danilo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du das Problem mittlerweile lösen, bzw. die Ursache dafür finden 
können?

Autor: Hp M. (nachtmix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nach fast 5 Jahren dürfte das Problem aus der Welt sein, und die 
Ursachen sind bekannt.

Autor: Sapperlot W. (jetztnicht)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es waren alles N-FET, Die Ansteuerung der Oberen war nicht 
potentialgetrennt. Eigentlich haette es nie laufen duerfen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.