mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Amüsantes Problem mit Steuerleitung beim L297


Autor: Alexander B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

ich habe eine Schrittmotorsteurung mit einem L297 und L298 gebaut. Nach 
ersten Test habe ich herausgefunden, dass die Taktleitung und die 
Richtungsleitung am L297 Probleme haben. Erst als ich mit dem Oszi an 
den jeweiligen Pins gemessen hatte, erfüllten sie ihre Funktion und der 
Schrittmotor drehte sich.
Darauf hin habe ich wie am Eingang des Oszi einen 1MOhm Widerstand und 
einen 10pF Kondensator parallel geschalten und vom entsprechenden Clock 
Pin  zur Masse hin angelötet. Das selbe mit der Richtungsleitung. Und 
siehe da, es funktioniert.

Weiß jemand an was es liegt, dass es nur mit diesem Widerstand und 
diesem Kondensator funktioniert ?

Autor: Yoschka (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wahrscheinlich reicht der C aus.
Wahrscheinlich reicht dieser aus, um Störungen (Spikes) zu unterdrücken.
Diese Störungen hast Du Dir durch einen schlechten Schaltungsaufbau 
selbst gemacht.

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yoschka schrieb:
> Wahrscheinlich reicht der C aus.
> Wahrscheinlich reicht dieser aus, um Störungen (Spikes) zu unterdrücken.
> Diese Störungen hast Du Dir durch einen schlechten Schaltungsaufbau
> selbst gemacht.

Passt nicht dazu:

Alexander Bartler schrieb:
> Erst als ich mit dem Oszi an
> den jeweiligen Pins gemessen hatte, erfüllten sie ihre Funktion und der
> Schrittmotor drehte sich.

Störungen würden bedeuten, daß er sich unkontrolliert dreht.

MfG Klaus

Autor: Alexander B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten. Also mit dem Widerstand und dem Kondensator 
funktioniert es einwandfrei. Hat jemand eine Idee an was es dann liegen 
könnte ?

MfG Alex

Autor: Werner B. (werner-b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alexander Bartler schrieb:
> Hat jemand eine Idee an was es dann liegen könnte ?

Murphy's Law ?!

http://de.wikipedia.org/wiki/Murphys_Gesetz

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Weiß jemand an was es liegt, dass es nur mit diesem Widerstand und
> diesem Kondensator funktioniert ?

Fast immer ist eine miese Leiterbahnführung, vor allem der
Masseleitung und der Hochstromverbindungen dran schuld,
wenn der L297 sich stören lässt, denn die Leute irnorieren
aus Unkenntnis daß es sich um ein mehrkanaliges
Schaltnetzteil handelt.

Manchmal fehlen auch die Freilaufdioden.

Autor: wasistdas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
poste doch mal ein bild!

Autor: Dr.Who (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch wenn es ein alter Thread ist, einfach mal für die Nachwelt:

Dieses Problem ist nicht zu ignorieren. Vor allem auf 
Lochrasteraufbauten.
Bei mir war genau das gleiche Problem, der Scheiss Motor hat nicht 
einmal gezuckt! 10pF und 1MOhm dran und der läuft. Allerdings ist der 
1MOhm wirklich notwendig. Wahrscheinlich ginge auch ein anderer Wert, 
aber ich dachte mir  ich übernehme doch gleich die realen Bedingungen.

Ein super Beispiel dafür, dass schlechter Schaltungsaufbau eine ganze 
Schaltung ausser Gefecht setzen kann.

Hat mich jetzt einen ganzen Tag gekostet, der Scheiss.

Gruss

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.