Forum: Analoge Elektronik und Schaltungstechnik LM334 Temperatur kompensieren


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Tino B. (neihaader)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

...ja wiedermal der LM 334 als Konstantstromquelle.

Ich habe hier einen LM 334 der mir bei schwankender Umgebungstemperatur 
zw.10 und 34°C meinen Messwert um ca. 3K verfälscht.
Das Teil ist nach dem Datenblatt schon dementsprechend 
beschalten,allerdings nicht mit ner Diode(1N4148),sondern mit einem 
BC547 und kurzgeschlossenem Kollektor-Basis.(habe ich an anderer Stelle 
im Netz gefunden, und brachte mir bessere Ergebnisse)
Wie kann ich das verhindern, das mir der Messwert so stark verfälscht 
wird.

Ich möchte ja eigentlich nur mit einem PT1000 eine Temperatur 1°C genau 
messen!

Habe jetzt festgestellt das der LM 334 um 0.041%/K driftet.
Bei 10°C Umgebungtemp. fallen an einen 1K Widerstand 976mV ab, und bei 
34°C Umgebungtemp.fallen 985mV ab.
Geht das mit dem LM344 überhaupt besser(genauer) zu machen?


Danke für eure Hilfe.

: Verschoben durch Moderator
von Yalu X. (yalu) (Moderator)


Bewertung
0 lesenswert
nicht lesenswert
Nicht umsonst wird der LM334 im Datenblatt auch als "ideal remote
temperature sensor" angepriesen :)

Wenn du trotzdem an diesem Baustein festhalten möchtest, musst du die
Temperaturkompensation mit der Diode (bzw. dem Transistor) so dimensio-
nieren, dass sie wenigstens in dem Temperaturbereich deiner Anwendung
halbwegs funktioniert. Eigentlich sind ja 0,041% gar nicht schlecht im
Vergleich zu den 0,34% ohne Kompensation. Etwas genauer wird die Sache
sicher noch, wenn du den Widerstand von der Kathode der Diode zum R-Ein-
gang des LM334 geeignet anpasst. Da der Temperaturkoeffizient im Moment
positiv ist, musst du den Widerstand etwas vekleinern. Am besten ermit-
telst du durch Ausprobieren den besten Wert. Dadurch berücksichtigt die
Kompensation die Temperaturkoeffizienten aller beteiligter Bauteile,
nämlich des LM334, der Diode (des Transistors) und der Widerstände.

Edit:

Falls du die gemessene Temperatur mit einem Mikrocontroller auswertest,
kannst du die Kompensation natürlich auch softwaremäßig durchführen und
den zusätzlichen Transistor weglassen. Falls der vom LM334 gelieferte
Strom tatsächlich proportional zur absoluten Temperartur ist (wie im
Datenblatt angegeben), sollte die Kompensation mit einer einfachen Drei-
satzrechnung zu bewerkstelligen sein.

von Andrew T. (marsufant)


Bewertung
0 lesenswert
nicht lesenswert
Tino B. schrieb:
> Habe jetzt festgestellt das der LM 334 um 0.041%/K driftet.

Herzlichen Glückwunsch. Du hast die Datenblattwerte verifiziert.

Lesen des DB und Auswahl des passenderen ICs hätte vermutlich Dein 
Problem auch gelöst.
Wäre aber wohl nicht innovativ genug.

> Ich möchte ja eigentlich nur mit einem PT1000 eine Temperatur 1°C genau
> messen!


Na das Thema hatten wir hier bisher noch nicht, somit konnte die 
forums-Suchfunktion Dir sicher nicht helfen.

von Tino B. (neihaader)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für die Antworten.

@ marsufant:

Man soll es nicht denken, aber ich hier im Forum gesucht!!!
Muss man aber wahrscheinlich Immer dazu schreiben!!!
Und ich habe auch passendes dazu gefunden!!!
Und ich habe bei dem Schaltungsvorschlag auch noch den dort verwendeten
LM317 der "KEINE" 1mA liefern kann, gegen den LM334 getauscht!!!

...nur soviel dazu...Sorry!!!
...Yalu hat mein Problem wesentlich besser erkannt!!!


@ Yalu:

danke für dem Tipp.

Ich habe bei dem LM334 nur leider auf das "adjustable current
source", und die entspr. Beschaltung vertraut.

Ja ich will zumindest in dem Fall beim LM334 bleiben, da mein 
Streifenraster fast fertig "geschnitzt" und bestückt ist.
Ich werde das mit dem Widerstand verkleinern dann mal testen.

Welche ähnlich günstige Alternative im TO92 gäbe es dazu?

Sind die 1mA für dem PT1000 schon zu viel?(darüber steht ja auch 
unterschiedliches geschrieben...der Sensor ist später Wasser-berührt)

Nochmals Danke,...du hast mein Problem bei der Sache wesentlich besser 
erkannt.

Mfg
neihaader


kleiner Nachtrag:Ich bin kein Elektroniker,ich mache das als Hobby.

von Arc N. (arc)


Bewertung
0 lesenswert
nicht lesenswert
Auch hier mal wieder der Tipp: Ratiometrisch messen -> Drift der 
Stromquelle unerheblich und einen passenden ADC wie die AD7792/AD7793 
verwenden.

von Anja (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Tino B. schrieb:
> Ja ich will zumindest in dem Fall beim LM334 bleiben, da mein
> Streifenraster fast fertig "geschnitzt" und bestückt ist.
> Ich werde das mit dem Widerstand verkleinern dann mal testen.

Ich habe den LM334 auch mal für eine 1mA Stromquelle kompensiert.
Gegenüber dem Datenblatt (Dort steht Widerstandsverhältnis ca 1:10) 
mußte ich das Widerstandsverhältnis abändern. Die Finalen Werte waren 
135 Ohm und 1200 Ohm bei der einen Quelle und 147 Ohm und 1200 Ohm bei 
der anderen. Ich habe mit Metallfilmwiderständen ca 30ppm/K erreicht. 
Wichtig ist noch eine gute Thermische Kopplung von LM334 und der Diode. 
(z.B. mit Uhu Plus) und kurzen Anschlußdrähten.

Gruß Anja

von Tino B. (neihaader)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Danke für die Widerstandswerte.
Welche Diode hattest du dafür genommen?
Mit einer 1N4148 bekomme ich´s nicht auf die Reihe.
Hab´s jetzt (wie schon geschrieben) mit einem BC547C versucht, die 
Planflächen mit Wärmeleitpaste aneinander gepresst.
Aber auf 30 ppm/K bin ich noch nicht gekommen.
Kann man das ganze auch "überkompensieren" so das die Spannung trotzdem 
wieder ansteigt,oder würde die Spannung dann genauso weit fallen wie sie 
vorher gestiegen ist?
...hab ich da jetzt nen Knoten im Hirn (Kopfkratz)?

Ich glaube fast das ich am "Idealpunkt" schon vorbei getestet 
habe(Potentiometer)? ...geändert habe ich nur den großen Widerstand...

Gruß Tino

von Anja (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Tino B. schrieb:
> Welche Diode hattest du dafür genommen?
Ich habe eine 1N4148 verwendet.

Tino B. schrieb:
> habe(Potentiometer)?
Also mit Poti kann das nix werden die haben so 200 bis 600 ppm/K.

Gruß Anja

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.