mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Schaltung schwingt. Wieso?


Autor: Philipp H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nabend die Herren (und Damen?),

um ein paar Röhrenschaltungen zu testen, habe ich vorhin mal folgendes 
Netzteil nachgebaut:

http://www.roehrenkramladen.de/hboexp4/hboexp4.htm

Da das ganze ne recht spontane Idee war, hatte ich natürlich keinen 
IRF840 zur Hand und habe stattdessen einen IRF330 im TO-3 Gehäuse 
eingesetzt. Was ja eigentlich kein Problem sein sollte (?).


Die gesiebte Gleichspannung beträgt rund 290V und meine 
Zener-Referenzspannung beträgt 210V. Der Zenerstrom etwa 5,7mA. Anstelle 
des 250k Potis zur Spannungseinstellung habe ich eins mit 470k genommen. 
Anstelle des BC547 einen BC550.


Will ich der Schaltung jetzt aber einen Strom von über ca. 9mA 
entnehmen, fängt das ganze wie verrückt an zu schwingen (Oszi). Das 
ganze scheinbar relativ unabhängig von der angeschlossenen Last. Habe 
mehrere Lastwiderstände von 1k bis 22k ausprobiert.

Habe jetzt auch schon ein bissien rumprobiert, indem ich die Widerstände 
und Kapazitäten verändert oder auch mal den BC550 zur Strombegrenzung 
rausgenommen habe, jedoch ohne Erfolg.



Also, hat jemand ne Idee? Was kann ich tun?



Herzlichen Dank für Tipps schon mal vorab!

Gruß,
Philipp

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe diese Schaltung auch aufgebaut und bei mir arbeitet sie normal.
Häng Dich doch mal (über einen entsprechenden Spannungsteiler) mit dem
Oszi zwischen den Schleifer des Potentiometers und Masse und guck, ob
die Referenzspannung stabil ist.

MfG Paul

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach so: Mach mal in der Not den Z-Diodenstrom ein bisschen höher, im dem
Du den R3 kleiner machst. Die 0,47µF hast Du aber drin?

MfG Paul

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp H. schrieb:
> auch mal den BC550 zur Strombegrenzung rausgenommen habe, jedoch ohne
> Erfolg.

Spätestens dann sollte eigentlich nichts mehr schwingen, da damit die
Rückkopplungsschleife offen ist. Der Mosfet wird in Drain-Schaltung
betrieben, also mit Verstärkung <1, was sowieso gutmütig sein sollte.

Mit welcher Frequenz schwingt die Schaltung? Zwischen welchen Werten
schwingt die Ausgangsspannung hin und her? Ist die gesiebte Versorgungs-
spannung an C2 noch einigermaßen eben (vielleicht geht ja der Trafo
schon in die Knie)?

Und Pauls Vorschlag schließe ich mich an:

> guck, ob die Referenzspannung stabil ist.

Autor: Philipp H. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank erst mal. Also ich habe mich eben nochmal drangesetzt.


Die Freuquenz beträgt so schätzungsweise 50Mhz... die Zeitbasis von 
meinem Oszi ist dann aber schon am Anschlag. Die Ausgangsspannung 
schwankt dann bei voll aufgedrehtem Spannungspoti um etwa 5V.

Sobald die Schaltung anfängt zu schwingen ist auch die Ref.Spannung 
(schwingt um 1V mit der selben Freq.) und die Spannung am Siebelko 
"verseucht". Ansonsten relativ glatt bis auf einen kleinen 100Hz Brumm. 
Der Trafo ist ziemlich groß und liefert die paar mA locker.

Den 470nF habe ich drinne.


Im Anhang noch ein Bild von meinem Platinenlayout. Hast du deine Platine 
vom Röhrenkramladen übernommen, Paul?


Gruß,
Philipp

Autor: Philipp H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PS: Auch wenn ich die Ref.Spannung mit einem externen Netzteil 
einspeise, fängt die Schaltung ab 10mA Ausgangsstrom an zu schwingen...

Irgendwas läuft da schief.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Phillipp schrob:
>Hast du deine Platine vom Röhrenkramladen übernommen, Paul?

Nein, bei mir ist sie Bestandteil eines Netzgerätes mit etlichen 
Spannungen
und einer eigenen Platine. Die kann ich Dir aber nicht mehr zeigen, da
ich sie vor Jahrzehnten noch auf Millimeterpapier gemacht hatte.
Die ist verschütt' gegangen...

>Auch wenn ich die Ref.Spannung mit einem externen Netzteil
>einspeise, fängt die Schaltung ab 10mA Ausgangsstrom an zu schwingen...

Seltsam...

Ist der Trafo zu "weich", d.h. geht er "in die Knie", wenn Du ihn
belastest? Ist das Potentiometer in Ordnung -> "springt" es, wenn Du
Dich an den Schleifer mit dem Oszi hängst?

MfG Paul

Autor: Philipp H. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin, der Trafo ist groß und liefert auch 1A wenns sein muss. Habe 
gestern Abend aber auch mal probeweise einen anderen Trafo mit 50VAC 
angeschlossen gehabt, mit dem gleichen Schwing-Problem.

Auch habe ich die Spannung mal extern gleichgerichtet, mit 220µF gesiebt 
und dann direkt in den Siebelko (100µF/350V, den ich übrigends auch 
schon mal ausgetauscht habe) der Schaltung eingespeist. Ohne Erfolg.

Im Anhang mal noch ein Oszillosgram vom Ausgang der Schaltung. Die 
Zeitbasis beträgt 10ms/div. Es sieht also schon so aus, als würde das 
irgendwie mit dem Brumm der Gleichrichtung zusammenhängen. Auf dem 2. 
Foto mit 20MHz Bandbreitenbegrenzung.


Habe jetzt so ziemlich alles erfolglos ausprobiert. Hat nicht noch 
jemand ne Idee was die Schaltung zum schwingen bringt?

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Philipp

Du hast möglicherweise einen Colpitts Oszillator gebaut. Hört die 
Schwingung auf, wenn Du in die Drainleitung einen 100 Ohm Widerstand 
einfügst?

Gruß, Bernd

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm erst mal den Transistor von der Strombegrenzung raus. Dann sind 
nicht
mehr viele Kollegen beteiligt, die eine Schwingung erzeugen können.
"Spiele" dann mal ein wenig mit der Größe des 0,47µF -Kondensators am
 Gate des Mosfet.
Hast Du mal den R3 verkleinert, um einen höheren Querstrom durch die 
Z-Dioden
 zu erzeugen?

Im Layout ist der 0,47µF auch ziemlich weit weg von dem Mosfet und an 
ihm
geht die Ausgangsleitung vorbei. Das Ganze Ding ist recht hochohmig, so
daß man sich schnell mal ein bisschen Mist einfängt.


OH!!
Ich denke bald, daß der Mosfet falsch drinsitzt! Guck Dir mal dieses
Datenblatt an:
http://www.datasheetcatalog.org/datasheet/irf/jantx2n6760.pdf

MfG Paul

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es sein, dass C4 nicht aufs Gate geht, sondern an den Schleifer vom 
Poti R7? Dadurch wäre das Gate hochohmig offen.

Bernd

Autor: Philipp H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
B e r n d W. schrieb:
> Du hast möglicherweise einen Colpitts Oszillator gebaut.

Schon verrückt, was man so alles bauen kann ohne jemals davon gehört zu 
haben ;)

B e r n d W. schrieb:
> Hört die
> Schwingung auf, wenn Du in die Drainleitung einen 100 Ohm Widerstand
> einfügst?

Hatte -bevor ich deinen Post laß- mal einen 100 Ohm Widerstand in die 
GATE-Leitung direkt am Fet eingefügt mit dem Ergebnis, dass das 
Schwingen jetzt verschwunden ist und die Schaltung nun arbeitet wie sie 
soll.


Worauf deutet das bezüglich der Schwing-Ursache hin?

Stellt das eine zuverlässige und dauerhafte Lösung dar oder sollte ich 
mir lieber ein besseres Platinenlayout ausdenken?

Sollte ich trotzdem noch einen Widerstand in die Drain Leitung einfügen?

Paul Baumann schrieb:
> Hast Du mal den R3 verkleinert, um einen höheren Querstrom durch die
> Z-Dioden
>  zu erzeugen?

Hatte ich mal probiert, aber die Zenerdiode ist schon ziemlich am Limit.

Paul Baumann schrieb:
> Im Layout ist der 0,47µF auch ziemlich weit weg von dem Mosfet und an
> ihm
> geht die Ausgangsleitung vorbei. Das Ganze Ding ist recht hochohmig, so
> daß man sich schnell mal ein bisschen Mist einfängt.

Erlich gesagt ist der 0,47µF bei mir nur ein 0,22µF... aber auch als ich 
den Wert mal erhöht hatte, veränderte sich nichts. Aber etwas näher am 
Fet hätte ich ihn wirklich platzieren können...

Autor: Thorsten S. (thosch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> OH!!
> Ich denke bald, daß der Mosfet falsch drinsitzt! Guck Dir mal dieses
> Datenblatt an:
> http://www.datasheetcatalog.org/datasheet/irf/jantx2n6760.pdf

Hmm, nö. Der Mosfet sitzt schon richtig rum drin, die Platine zeigt die 
Draufsicht, während das Datenblatt die sicht von unten auf den Flansch 
zeigt.


Aber die Schaltung beim Röhrenkramladen entspricht nicht der Platine 
dort!
In der Schaltung ist der 0,47µF Kondensator direkt am Gate, während im 
dortigen Platinlayout der Kondensator am Potischleifer liegt und das 
Gate von dort über den 220k Widerstand angeschlossen ist, der im 
Schaltplan zwischen Potischleifer und 0,47µF Kondensator liegt.

Der Unterschied zwischen der Platine vom Röhrenkramladen und der von 
Philipp H. liegt also darin, daß bei ersterer die 220k eine 
Gate-Bedämpfung bewirken.

Der Mosfet wird hier schwingen, da kein Dämpfungswiderstand am Gate 
hängt.
Ich würde einfach mal die Leiterbahn direkt vor dem Gate-Anschluß des 
Mosfets kappen und dort einen SMD-Widerstand von ein paar Kiloohm 
einfügen.
Das sollte die Schwingneigung beseitigen.

Gruß,
Thorsten

Autor: Paul B. (paul_baumann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, dann geht's ja, wenn's geht.

;-)
MfG Paul

Autor: B e r n d W. (smiley46)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung kann schwingen, wobei die Sperrkapazität der Diode die 
Miller-Kapazität erhöht.

Dämpfung:
Ob der Widerstand sich in der Gate- oder Drainleitung befindet, ab ca. 
50 Ohm hören die Schwingungen auf. In der Drainleitung erhöhen sich die 
Verluste, im Gate wird das Regelverhalten minimal langsamer. Also lass 
ihn in der Gateleitung, das sollte ok sein.

Gruß, Bernd

Autor: Philipp H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
B e r n d W. schrieb:
> Kann es sein, dass C4 nicht aufs Gate geht, sondern an den Schleifer vom
> Poti R7? Dadurch wäre das Gate hochohmig offen.
>
> Bernd

Thorsten S. schrieb:
> Aber die Schaltung beim Röhrenkramladen entspricht nicht der Platine
> dort!
> In der Schaltung ist der 0,47µF Kondensator direkt am Gate, während im
> dortigen Platinlayout der Kondensator am Potischleifer liegt und das
> Gate von dort über den 220k Widerstand angeschlossen ist, der im
> Schaltplan zwischen Potischleifer und 0,47µF Kondensator liegt.


Sorry Leute, das stimmt schon. Habe bloß versehentlich die Bezeichnung 
von C3 und C4 vertauscht.


Aber vielen Dank für die ganzen Tipps! Jetzt bin ich happy, dass die 
Schaltung doch noch funktioniert :)

Gruß,
Philipp

Autor: Peter R. (pnu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Warum eigentlich jeder Emitter- oder Sourcefolger zum Schwiongen neigt:

Die Schaltung im Anhang ist ein Colpitts-Oszillator mit TS oder MOSFET.

C1 und C2 sind in nahezu allen Verstärkerschaltungen vorhanden, es fehlt 
eigentlich nur noch die Induktivität, angekoppelt mit C3

Die findet sich aber schnell in Form einer Leiterbahn, eines 
Leitungsstückes usw.

Deshalb sollte z.B. jeder Eingang mit längerer Zuleitung einen 
Serienwiderstand von 100Ohm....einige kOhm haben.

PS: den Emitterwiderstand habe ich vergessen, bitte selbst dazudenken.

Autor: Philipp H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich bins noch einmal.

Die Schaltung funktioniert jetzt zwar wunderbar, aber mich würde mal 
noch interessieren, wie das mit der Strombegrenzung eigentlich 
funktioniert. Ich kenne mich leider noch nicht so gut aus.


An R1 und R2 fällt eine Spannung ab, die dem Transistor T1 am Emitter 
zugeführt wird. Fallen dort also 0,7V ab wird der Transistor leitend 
(wenn der Poti ganz am Anschlag steht). Aber was passiert jetzt?


Wäre nett, wenn mir das mal kurz jemand näher bringen könnte.

Gruß,
Thomas

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Gatespannung des IRF840 wird vom Kollektor des T1 runtergezogen 
(negativer), bis sich ein Gleichgewicht einstellt und an den beiden 10 
Ohm Widerständen ~0,6V abfallen.

Dann beträgt der Ausgangsstrom
I = U / R = 0,6V / 20 Ohm
I = 30mA

Zu den 0,6V:  Die Basis - Emitter - Strecke des T1 verhält sich wie eine 
Diode. Der Spannungsabfall an dieser Diode ist vom Basisstrom abhängig. 
Da am Kollektor nur eine sehr hochohmige Last hängt, fließt hier nur ein 
kleiner Basistrom im unteren µA Bereich und zwar:
Ib = Ic / Hfe
Basisstrom = Kollektorstrom / Stromverstärkung

Die Stromverstärkung eines Bipolar-Transistors unterliegt einer großen 
Exemplarstreuung und kann hier je nach Typ A, B oder C
110-220, 200-450 oder 420-800 betragen.

Aus dem BC547 Fairchild Datenblatt:
Ib       Ube
-------------
10µA  -> 0,5V (geschätzt)
0.2mA -> 0,6V
4.0mA -> 0,7V
100mA -> 0,8V

Gruß, Bernd

Autor: Philipp H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernd, vielen Dank!

B e r n d W. schrieb:
> Die Gatespannung des IRF840 wird vom Kollektor des T1 runtergezogen...

Runtergezogen, weil die Ausgangs-Spannung minimal negativer als die 
Gate-Spannung ist? (bei 50V Ausgangsspannung habe ich 52,8V 
Gate-Spannung gemessen)

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der IRF840 ist selbstsperrend. Falls die Gate-Source-Spannung 0V 
beträgt, sperrt er komplett.

Der Mosfet verhält sich hier ähnlich wie eine Kollektorschaltung. Die 
Sourcespannung beträgt immer um Vgs (ca. 3V) weniger als die 
Gatespannung.
Vgs = Gate threshold voltage = Abschnürspannung

Der BC547 reduziert die Gatespannung und damit die Sourcespannung nur 
soweit, bis der eingestellte Strom dem Sollwert entspricht.

Gruß, Bernd

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.