Forum: Analoge Elektronik und Schaltungstechnik Problem beim FET-Treiber im Schaltnetzteil


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Martin (Gast)


Angehängte Dateien:

Lesenswert?

Hallo alleman(n),

ich habe ein Problem an meiner Schaltung PWM-Netzteil!
Da ich selbst schon 4 Treiber verheizt habe und den fehler einfach nicht 
sehe bitte ich euch einmal zu überlegen wo der Fehler sitzt.

Einmal zusammengefasst habe ich vor mir ein gutes Schaltnetzteil zu 
bauen damit ich auch für Niederspannungsanwendungen viel saft zur 
verfügung habe. Da sah ich die Schaltung mit dem MJ15004 die mir erstmal 
gut gefiel jedoch etwas zu altmodisch war. Damir ich einen besseren 
Wirkungsgrad erreiche dachte ich sofort an einen FET mit sehr kleinem 
RDSon.

Nachdem ich alles zusammen hatte war nur keine Funktion. Also gemessen 
und festgestellt das der PWM bis zum Pin 1 am IR2181 anlag, jedoch nicht 
am FET

Nach einigen versuchen hatte ich zum Test den HO an +50V und den VS an 
GND gelegt, wobei ich testweise nur mit 25V anstatt 50V gespeist hatte, 
und voila es ging perfekt! Jedoch ist der IR2181 nur mit ~25V offset 
angegeben, also brennt er bei voller Betriebsspannung (50V) durch.

Die schaltung LED smps habe ich auch aus dem Netz geladen um zu schauen 
was jemand fremdes anders macht, jedoch ist alles gleich bis auf den 
100k und Z-diode als Spannungsblocker.

Meint ihr das ist alles?? ich will nicht noch mehr Treiber verheizen, 
die sind teuer! Über Hilfestellung würde ich mich sehr freuen! Vielen 
Dank

von billydeedaniels (Gast)


Lesenswert?

Also irgendwie verstehe ich beim LED_SMPS nicht die Beschaltung mit den 
36V und den ganzen Dioden und das dann noch auf GND geht. Schaut alles 
ein wenig wirr aus. Sicher das das so sein soll? Bzw. könnest du das mal 
erklären, die Funktion?

von billydeedaniels (Gast)


Lesenswert?

Ah das soll die Brückenschaltung sein 36V AC

von Ben _. (burning_silicon)


Lesenswert?

C15 im zweiten Bild find ich kacke. Den würd ich weglassen.

Ich kenn den IR2181 jetzt nicht so richtig. Ich hab mal was 
vergleichbares mit dem IR2110 gebaut, der verträgt ausgangsseitig bis 
500V.

Für die Versorgung des TL494 hast Du ja wohl sowieso 12V. Die würde ich 
auch für die Niederspannungsseite des IR21xx verwenden. Den Bootstrap-C 
finde ich etwas klein, ich würd da 470nF nehmen, wenn ich Platz habe 
evtl. sogar noch einen kleinen Elko parallel. Diese Schaltungsart ist 
zwar sehr einfach, verursacht aber schnell Probleme wenn VS bei 
irgendwelchen Schaltzuständen nicht zuverlässig, regelmäßig und ein 
gutes Stück weit unter Vcc fällt.

von Simon K. (simon) Benutzerseite


Lesenswert?

Du hast 25V an den HO Ausgang gelegt? Weißt du eigentlich überhaupt, was 
der IR2181 macht? Weißt du was du da machst?

von Johannes E. (cpt_nemo)


Lesenswert?

Martin schrieb:
> Nachdem ich alles zusammen hatte war nur keine Funktion. Also gemessen
> und festgestellt das der PWM bis zum Pin 1 am IR2181 anlag, jedoch nicht
> am FET

Das kommt vermutlich durch die Bootstrap-Versorgung des High-Side 
Treibers. Damit der arbeiten kann, muss erst mal der Kondensator C20 
aufgeladen werden, dazu muss durch D1 ein Strom fließen, so dass die 
Spannung an VS auf GND-Potential liegt.

Dieser Treiber ist für so eine Schaltung nicht geeignet, du brauchst 
noch zusätzlich einen Low-Side Transistor als Synchrongleichrichter, 
damit kann auch der Bootstrap-Kondensator zuverlässig aufgeladen werden. 
Dieser Transistor muss immer in der Zeit eingeschaltet werden, wenn der 
High-Side Transistor aus ist.

Damit arbeitet das Netzteil aber ständig im nicht-lückenden Betrieb, was 
speziell bei wenig Last nicht so ideal ist.

Ich würde eher einen High-Side Treiber mit separater potentialfreier 
Versorgung einsetzen, damit bekommst du am wenigsten Probleme und 
brauchst keine Synchrongleichrichtung.

von Simon K. (simon) Benutzerseite


Lesenswert?

Ein Bootstrap Treiber braucht nicht zwangsläufig eine 
Synchrongleichrichtung. Es muss lediglich dafür gesorgt werden, dass im 
Freilauffalle der Strom lange genug weiterfließt.

von Johannes E. (cpt_nemo)


Lesenswert?

Simon K. schrieb:
> Ein Bootstrap Treiber braucht nicht zwangsläufig eine
> Synchrongleichrichtung. Es muss lediglich dafür gesorgt werden, dass im
> Freilauffalle der Strom lange genug weiterfließt.

Und wie soll das zuverlässig funktionieren, ohne einen Transistor?

Wenn z.B. beim Einschalten der Ausgangskondensator noch geladen ist, 
also wenn schon eine Spannung am Ausgang anliegt, dann liegt auch der 
VS-Pin auf dieser Spannung. Das Bootstrap-Kndensator kann also gar nicht 
geladen werden, egal wie das Einschaltverhältnis ist.

Ein ähnliches Problem hat man auch, wenn man den Sollwert für die 
Ausgangsspannung nach unten verändert; dann bleiben auch die 
Ausgangs-Elko für eine gewisse Zeit geladen während der Mosfet 
ausgeschaltet und der Bootstrap-Kondensator kann sich dabei entladen.

Man könnte hier zwar ein bestimmtes Mindest-Einschaltverhältnis 
vorgeben, aber dann müsste man auch eine gewisse Mindest-Last am Ausgang 
haben.

Bei einem Festspannungsnetzteil, mit dem eine konstante Last betrieben 
wird, könnte man so etwas machen. Aber nicht bei einem regelbaren 
Netzgerät, das ist Pfusch!

von Simon K. (simon) Benutzerseite


Lesenswert?

Johannes E. schrieb:
> Bei einem Festspannungsnetzteil, mit dem eine konstante Last betrieben
> wird, könnte man so etwas machen. Aber nicht bei einem regelbaren
> Netzgerät, das ist Pfusch!

Da hast du Recht. Man benötigt auf jeden Fall eine Last mit der man 
Rechnen kann um sowas zu machen.

In dem Falle würde ich dem TO einfach einen "richtigen" Schaltregler 
empfehlen. Von mir aus auch mit gescheiter synchroner Gleichrichtung.

von Martin (Gast)


Lesenswert?

Johannes E. schrieb:
> Dieser Treiber ist für so eine Schaltung nicht geeignet

Das habe ich auch so gedacht, jedoch hat reichelt kaum Auswahl an 
Treibern. Wie würdest du diesen Treiber ersetzen?
Mindestlast ist ein 5W Widerstand am Ende, sind nur ein paar mA aber 
entläd sich rasch.

Danke für eure Analysen!

von Martin (Gast)


Lesenswert?

Simon K. schrieb:
> Du hast 25V an den HO Ausgang gelegt? Weißt du eigentlich überhaupt, was
> der IR2181 macht? Weißt du was du da machst?

Entschuldigt bitte, es sollte heißen VB auf keinen Fall HO..
Man ist das jetzt peinlich....

von Simon K. (simon) Benutzerseite


Lesenswert?

25V wären dann aber auch zu viel, da die meisten MOSFETs nur bis 20V 
Gate-Source-Spannung spezifiziert sind. Wenn Source dann auf 0V liegt, 
hast du ruckzuck den MOSFET kaputt.

von Martin (Gast)


Lesenswert?

Wie gesagt ist mir das klar aber ich habe nur aus Verzweiflung alles 
probiert um ein Ergebnis zu bekommen. Es hat ja auch funktioniert. Also 
wusste ich danach das dem Treiber am VS der Bezug zu gnd fehlt. Habt ihr 
eine Idee für mich?

von GB (Gast)


Lesenswert?

Nimm z.B den High-Side-Kanal diese Treibers, der stellt gleich eine 
interne Ladungspumpe für den High-Side-MOSFET zur Verfügung:

Allegro A3946

von Johannes E. (cpt_nemo)


Lesenswert?

Martin schrieb:
> Das habe ich auch so gedacht, jedoch hat reichelt kaum Auswahl an
> Treibern. Wie würdest du diesen Treiber ersetzen?

Es gibt unterschiedliche Methoden; am einfachsten wäre wie schon 
vorgeschlagen ein Treiber mit integrierter Ladunsgpumpe.

Ansonsten könnte man auch einen einfachen Low-Side Treiber nehmen und 
den mit einen Optokoppler oder kapazitiv/induktiv gekoppeltem Isolator 
ansteuern. Da brauchst du dann zusätzlich noch eine separate 
potentialfreie Versorgungsspannung. Das ist aber schon ein relativ 
großer Aufwand; das lohnt sich eigentlich nur, wenn man entweder eine 
sehr hohe Treiberleistung braucht oder sowieso eine Potentialtrennung 
vorgesehen bzw. notwendig ist.

Alternativ könnte man den Mosfet auch mit einem Übertrager ansteuern, 
aber da gibt es auch wieder Einschränkungen mit dem Einschaltverhältnis.

von Martin (Gast)


Lesenswert?

Vielen Dank für die guten Hinweise!

Der Allegro sieht gut aus und ist perfekt für 50V
Die Übertrager sache ist auch gut, sowas habe ich schonmal aufgebaut.

Ich melde mich später erneut wenn ich alles zusammen habe!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.