Forum: Mikrocontroller und Digitale Elektronik Was ist das für ein IC (Motortreiber Münzersteuerung)


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Spice (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich habe eine Münzersteuerung der Firma Lehrmacher, wo ein 8pinner 
unkenntlich gemacht wurde (Motortreiber). Ich vermute, dass mir genau 
dieser Motortreiber abgeraucht ist, alledings suche ich gerade "die 
Stecknadel im Heuhaufen".
Vielleicht kennt sich damit jemand aus, oder kennt Ersatztypen, die man 
verwenden könnte. Auf meiner Platine ist ein BinaryCounter, 2x Quad NAND 
Gatter und ein wenig Hühnerfutter und eben dieser 8Pinner. Der Motor 
muss sich quasi in beide Richtungen bewegen, wenn eine Münze eingeworfen 
wird, allerdings dreht sich das Teil nur in eine Richtung.

Hier ein Link zu einer ähnlichen Steuerung...

Ebay-Artikel Nr. 270660685017

Vielleicht kann jemand helfen?

Besten Dank im voraus
Gruß Spice

von Andreas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wichtig wäre zu wissen was denn von den 8 Pins weggeht, an welche 
Bauteile mit welchem Wert.

von STK500-Besitzer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
in der Ebay-Anzeige kann man nicht wirklich viel erkennen...
Könnte ein "Bruder" (oder eine Schwester) des L293 sein.

von Andreas (Gast)


Bewertung
0 lesenswert
nicht lesenswert

von Spice (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Wichtig wäre zu wissen was denn von den 8 Pins weggeht, an welche
>Bauteile mit welchem Wert.

Kommt sofort, ich versuche die Schaltung nachzuvollziehen und relevante 
Stellen abzuzeichnen...

von Spice (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Anbei mal der Teil vom Treiber und Motor...

Die pullups etc habe ich mal weggelassen... Vielleicht reicht es, anhand 
des Pinnings das Bauteil zu identifizieren...

Ich schau mir nun mal die L293


Danke nochmal und Gruß
Spice

von Andreas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wo ist denn Pin 1 am unbekannten Bauteil?

von Spice (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Fan8082
Leider nicht...

>L293
Leider auch nicht... Viel zu viele Pinne...

Ich vermute halt einen Fehler bei dem Treiber, wobei der halt in eine 
Richtung dreht aber nicht in die andere...
Es kann auch sein, dass die Hallsensoren "einen Hau" haben. Der Motor 
dreht einfach... Wenn ich einen Magnet an Hallsensor_1 halte, stopt der 
Motor. Wenn ich einen Magnet an den Hallsensor_2 halte, passiert nix und 
der Motor dreht weiter...
Sobald ich mit einem Tastkopf an Hallsensor_1 messen will, stopt der 
Motor ebenfalls... Wenn ich mit dem Tastkopf an Hallsensor_2 messe und 
mit einem Magneten dran vorbeifahre, bekomme ich ein Low-Pegel...
Wieso kann ich nicht an Hallsensor_1 messen, ohne dass dann der Motor 
stopt? Kapazitive Belastung (wohl weniger), Magnetischer Tastkopf 
(komisch), Hallsensor_1 defekt? (warum schaltet der dann?)

Danke und Gruß
Spice

von Spice (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Wo ist denn Pin 1 am unbekannten Bauteil?

Da hat man drauf rumgefeilt und drauf rumgedrehmelt, dass man die 
Bondingdrähte nicht sieht ist alles, aber die Kerbe oben mittig haben 
die zur hälfte da gelassen :-)

Pin 1 ist NC und Pin3 ist GND, also unten links in meiner Zeichnung...

von Andreas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe nochmal andere Treiebr gesucht, aber nichts passendes gefunden.
Kannst du das Signal der Hallsensoren denn mal testweise tauschen?

von Magnus M. (magnetus) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Spice schrieb:
>>Wo ist denn Pin 1 am unbekannten Bauteil?

(...)

> Pin 1 ist NC und Pin3 ist GND, also unten links in meiner Zeichnung...

Du hast das Bauteil also von unten (Lötseite) gezeichnet?

von --- (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> Du hast das Bauteil also von unten (Lötseite) gezeichnet?

Treiber ala TSC426/427

von Spice (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Also,

wenn ich Hall_1 durch Hall_2 ersetze, habe ich das selbe Problem... Bei 
magnetischer Erregung bleibt der Motor stehen, allerdings auch wieder 
mit dem Tastkopf... Hat der Gatter einen abbekommen?
Was denkt ihr wie ich den Treiber ansteuern muss? Ich habe 2 
Signalleitungen... Muss ich pulsen, oder reicht ein Pegel?

von Spice (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Also nachgemessen habe ich ein statisches Signal an einem der 
Treiberleitungen zum Gatter hin. Wenn ich mit einem Magneten und dem 
Hallsensor den Motor stoppe und an Pin2 mal kurz 12V draufgebe, läuft 
der Motor anders herum...
Ich denke nun, dass der Treiber ok ist, aber die "Steuerlogik" eventuell 
was falsches tut...

von Anja (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Könnte ein L272 oder L2722 oder TCA0372 sein.

Gruß Anja

von Spice (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hey,
danke für die Antworten, ich glaube ich brauch nun definitiv einen neuen 
Motortreiber, der hat sich mit stotterndem Motor verabschiedet, nachdem 
ich unglücklicherweise irgendwas unüberlegtes getan hab. Ich werde mich 
nun auf die "Suche" nach den Bauteilen machen und alles tauschen...
Vielleicht kennt jemand Bezugsquellen für diese uralt Logikgatter....

1. MC14029BCP
2. MC14093BCP 2mal drauf
paar Transistoren und der Motortreiber...

danke nochmal an alle

Gruß Spice

von Spice (Gast)


Bewertung
0 lesenswert
nicht lesenswert
TSC426/7 ist es... und RS oder Farnell haben die Dinger...

Besten Dank nochmal an alle...

von Anja (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Spice schrieb:
> Vielleicht kennt jemand Bezugsquellen für diese uralt Logikgatter....
>
> 1. MC14029BCP
> 2. MC14093BCP 2mal drauf

Einfach nach CMOS 4029(B)  oder 4093(B) suchen.
Bei RCA hießen die CD4029 bei Philips HEF4029 bei ST HCF4029
"B" ist die gebufferte Version mit mehr Ausgangsstrom

Gruß Anja

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.