Forum: Analoge Elektronik und Schaltungstechnik Triac Probleme mit MOC3043


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Mathias H. (innovator)



Lesenswert?

Hallo alle zusammen,

ich bräuchte mal eure Hilfe. Ich habe eine Schaltung entwickelt die 
einen Triac ansteuert (BTB16) mithilfe eines Triac Optokopplers 
(MOC3043), die Beschaltung des Triacs habe ich genau so aufgebaut wie im 
Datenblatt des Optokopplers von Fairchild beschrieben wird. Leider 
funktioniert das Gesamtkunstwerk nun nicht so wie es soll.
Ich habe sowohl auf der Platine als auch auf einem Steckbrett aufgebaut 
und versuche den Triac zum Durchschalten zu bewegen. Wenn ich den Triac 
einzeln ohne Opto am Gate anrege klappt das auch, habe ich aber den 
Optokoppler drin funktionierts nicht. Nun bin ich leicht verzweifelt 
woran es denn liegen könnte da ich mich beim Beschalten genau ans 
Datenblatt gehalten habe. Es wäre toll wenn ihr mir vielleicht helfen 
könntet

Vielen Dank schon mal

Mathias

PS: Passen vielleicht Triac und Optokoppler nicht zusammen? Die Werte 
aus  dem Datenblatt sind mir bis jetzt keine große Hilfe gewesen denn 
nach denen müsste es eigentlich passen.

: Verschoben durch Moderator
von oszi40 (Gast)


Lesenswert?

Liefert denn Dein Optokoppler AUSREICHEND Zündstrom? >10mA ?

von Harald W. (wilhelms)


Lesenswert?

Mathias Haspel schrieb:
> Hallo alle zusammen,
>
> ich bräuchte mal eure Hilfe. Ich habe eine Schaltung entwickelt die
> einen Triac ansteuert (BTB16) mithilfe eines Triac Optokopplers
> (MOC3043). Leider
> funktioniert das Gesamtkunstwerk nun nicht so wie es soll.

Hast Du vielleicht die Anschlüsse des Triacs vertauscht?
Gruss
Harald

von Harald (Gast)


Lesenswert?

Wenn ich mich recht erinnere darf man A1 und A2 nicht vertauschen, sonst 
steuert der MOC den Triac nicht durch.
Nur so eine Idee...

von Harald (Gast)


Lesenswert?

Zweimal Harald, ein Gedanke :-)

von Mathias H. (innovator)


Lesenswert?

Harald schrieb:
> Wenn ich mich recht erinnere darf man A1 und A2 nicht vertauschen, sonst
> steuert der MOC den Triac nicht durch.
> Nur so eine Idee...

Ja das is mir auch in den Sinn gekommen, habs aber x-Mal nach 
kontrolliert dass es richtig is. Es ist auch so dass wenn ich aufm 
Steckbrett den Opto rausnehme und stattdessen die Verbindung zwischen 
PIN 4und 6 von Hand mit nem Stück Kabel simuliere es optimal 
funktioniert, wenn ich jedoch den Optokoppler wieder einbaue und 
ansteuere nichts läuft bzw. heizt.

PS: Ich habs auch schon mit mehreren Optos des gleichen Typs probiert, 
um zu testen ob einer kaputt war bzw. ich ihn ins Nirvana geschossen 
hab, aber es war immer die gleiche Reaktion

von oszi40 (Gast)


Lesenswert?

Mathias Haspel schrieb:
> immer die gleiche Reaktion
Was sagt das Opto-Datenblatt? Wieviel mA hast Du gemessen? Vorsicht 
230V!

von MaWin (Gast)


Lesenswert?

Obwohl die Schaltung wenn sie denn so aufgebaut ist erfahrungsgemäß 
funktioniert, sogar mit snubberless TRIACs die im 3. Quadraten nicht 
zünden, aber:

Dir ist schon klar, daß der MOC3043 eigentlich für deutsche 230V~ Netze 
unterdimensioniert ist, mit 400V Sperrspannung ist er für amerikanische 
115V~ Netze "simplifies logic control of 115VAC" , aber bei deutschen 
Netzen nicht ausreichend überspannungsfest (kein zum Schutz eingebauter 
VDR der 250V noch durchlässt wird bei unter 400V sicher begrenzen). Hier 
sollte man den MOC3063 einsetzen.

von Mathias H. (innovator)


Lesenswert?

oszi40 schrieb:
> Mathias Haspel schrieb:
>> immer die gleiche Reaktion
> Was sagt das Opto-Datenblatt? Wieviel mA hast Du gemessen? Vorsicht
> 230V!

Das Optodatenblatt (siehe oben) spricht von einem Itsm von 1A mehr 
Angaben über den Strom des Detektors findet man soweit ich gesehen habe 
nicht. Da fällt mir ein kann es sein dass dieser Optokoppler nicht für 
einen permantenten Eingang geschaffen ist sondern nur für Impulse ? Oder 
ist das egal für den Optokoppler?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Mathias Haspel schrieb:
> Oder
> ist das egal für den Optokoppler?

Das ist ihm wurscht. Solange du den Eingang wie eine normale LED 
behandelst ist alles ok.

von Mathias H. (innovator)


Lesenswert?

Auch benötigt mein Triac BTB16 einen Gatestrom Igt von max. 50mA das ist 
doch nicht zu viel für meinen Optokoppler oder ?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Hmm, ich hatte mit dem MOC und den BTAs noch keine Probleme, aber in 
deinem Fall (mit dem BTB) könntest du ja probieren, den 330 Ohm 
Widerstand (den am Gate) mal grösser zu machen, damit der Triac mehr 
Saft kriegt. Irgendwas zwischen 470 und 1k.
Wenn das immer noch nicht reicht, langsam den 360 Ohm mal verringern, 
330, 270 usw., bis der Triac sicher zündet.

von Juppi J. (juppiii)


Lesenswert?

@Matthias Sch.

Kann man machen,wenn aber durch eine Überbrückung des Opto Triacs
der Leistungstriac zündet,dürfte dies erfolglos sein.

Hatte auch mit den Mocs noch keine Schwierigkeiten.

Trotzdem ,Moc getrennt ,ohne LeistungsTriac testen!

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Juppi J. schrieb:
> Kann man machen,wenn aber durch eine Überbrückung des Opto Triacs
> der Leistungstriac zündet,dürfte dies erfolglos sein.

Wundert mich ja auch, aber ich wollte ihn nicht hängen lassen. Ach, 
übrigens benötigen die BTA/BTB Triacs lt. Datenblatt keine 
Snubberbeschaltung, wenn die Bezeichnung auf BW oder CW endet.

von Harald (Gast)


Lesenswert?

Schon weitergekommen?
Schließe doch anstelle des Triacs einfach eine kleine 5..10W/230V 
(Backofen-) Lampe in Reihe mit dem Netz direkt an den MOC, ob der 
durchschaltet. Von den "absolute maximum ratings" her kann der das ja 
kurzfristig. Zumindest habe ich das bei MOC3020/3041 Designs gemacht, 
wenn es ein Problem gab und ich im Zweifel war.

von MCUA (Gast)


Lesenswert?

>Auch benötigt mein Triac BTB16...
TIC.. wäre andere Möglichkeit

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Harald schrieb:
> Schließe doch anstelle des Triacs einfach eine kleine 5..10W/230V
> (Backofen-) Lampe in Reihe mit dem Netz direkt an den MOC, ob der
> durchschaltet.

Da passieren komische Sachen. Mir ist es bisher nicht gelungen, auch die 
kleinste (allerdings induktive) Last bei Netzspannung oder z.B. 48 Volt 
AC direkt mit dem MOC3043 zu schalten. Er schaltet dann zwar an, aber 
nie wieder aus, bis der Laststrom extern abgeschaltet wird. 
Funktionieren tut es allerdings mit TTL-Logikleveln. In einem kleinen 
Projekt habe ich mal Tasten eines PS/2 Keyboards direkt mit dem MOC 
durchgeschaltet. Einen 48Volt/20 Watt Lüfter schafft er aber nicht, da 
bleibt er kleben.
Versuch macht aber kluch - die Glühlampe ist ja auch nahezu rein ohmsch 
und bis 200-300mA sollte der MOC ja können.

von Harald W. (wilhelms)


Lesenswert?

Matthias Sch. schrieb:

> Einen 48Volt/20 Watt Lüfter schafft er aber nicht, da
> bleibt er kleben.
> Versuch macht aber kluch - die Glühlampe ist ja auch nahezu rein ohmsch
> und bis 200-300mA sollte der MOC ja können.

Achtung! Anlaufstrom beachten.
Gruss
Harald

von Scotty (Gast)


Lesenswert?

Ich steuere mit je einem MOC3043 einen BT136 bzw. einen BT138 an. Die 
Widerstände sind beide 1k. Snubber habe ich keinen. Klappt wunderbar. 
Der BT138 braucht aber einiges an Kühlung bei einer Last von ~ 1 KW.

Die LEDs habe ich direkt mit 470 an je einen Ausgang eines 12F510 
gehängt (ohne Schalttransistor). Auch das läuft ohne Probleme.

von Rudi M. (rudimentaer)


Lesenswert?

Matthias Sch. schrieb:
> (allerdings induktive) Last bei Netzspannung

Nulldurchgangsschalter sind Gift für induktive Lasten:

http://de.wikipedia.org/wiki/Nulldurchgangsschalter

Dafür verwendet man Phasenanschnitt.

Probier mal was Ohmsches.

Rudi

von Pfiffikus (Gast)


Lesenswert?

Rudi M. schrieb:
> Nulldurchgangsschalter sind Gift für induktive Lasten:
> Dafür verwendet man Phasenanschnitt.

Autsch!! Ersetze ab durch ab!!

von Pfiffikus (Gast)


Lesenswert?

Pfiffikus schrieb:
> Autsch!! Ersetze ab durch ab!!

> Autsch!! Ersetze an durch ab!!

Die Tasten liegen wirklich zu eng beieinander :-))

von Rudi M. (rudimentaer)


Lesenswert?

Pfiffikus schrieb:
>> Autsch!! Ersetze an durch ab!!

Oh ja, Mist da hab ich's glatt verwechselt. Danke fürs Aufpassen ;-)

Also Phasenabschnitt für induktive Lasten!

Rudi

von Harald W. (wilhelms)


Lesenswert?

Pfiffikus schrieb:
> Rudi M. schrieb:
>> Nulldurchgangsschalter sind Gift für induktive Lasten:
>> Dafür verwendet man Phasenanschnitt.
>
> Autsch!! Ersetze ab durch ab!!

Normalerweise erzeugt schnelles abschalten eine hohe Induktions-
spannungsspitze, die irgendwie abgefedert werden muss. Deshalb
ist Phasenanschnitt prinzipiell richtig. Wegen der Phasenver-
schiebung muss man aber bei Induktiven Lasten den Steller etwas
modifizieren, z.B. durch ein paralleles RC-Glied.
Gruss
Harald

von Werner (Gast)


Lesenswert?

Harald Wilhelms schrieb:
> Normalerweise erzeugt schnelles abschalten eine hohe Induktions-
> spannungsspitze, die irgendwie abgefedert werden muss.

Aber nur, wenn man in einem Moment schaltet, wo Strom fließt. Und der 
TRIAC schaltet von sich aus ab, wenn der Haltestrom von ein paar zehn mA 
unterschritten wird. So schlimm kann die Spannungsspitze da IMHO doch 
nicht sein.

von Harald W. (wilhelms)


Lesenswert?

Werner schrieb:
> Harald Wilhelms schrieb:
>> Normalerweise erzeugt schnelles abschalten eine hohe Induktions-
>> spannungsspitze, die irgendwie abgefedert werden muss.
>
> Aber nur, wenn man in einem Moment schaltet, wo Strom fließt. Und der
> TRIAC schaltet von sich aus ab, wenn der Haltestrom von ein paar zehn mA
> unterschritten wird. So schlimm kann die Spannungsspitze da IMHO doch
> nicht sein.

Abschaltung im Nullduchgang des Stroms ist ja auch in Ordnung. Bei
hohen Strom abzuschalten aber nicht (Siehe Freilaufdiode bei Relais).
Und gerade das tut ein Phasenabschnittsdimmer.
Gruss
Harald

von Rudi M. (rudimentaer)


Lesenswert?

Harald Wilhelms schrieb:
> Normalerweise erzeugt schnelles abschalten eine hohe Induktions-
> spannungsspitze, die irgendwie abgefedert werden muss. Deshalb
> ist Phasenanschnitt prinzipiell richtig.

Ja, jetzt habe ich noch mal langsam den Wiki Artikel gelesen:
http://de.wikipedia.org/wiki/Phasenanschnitt#Phasenanschnitt-_und_Phasenabschnittsteuerung

"Hingegen sind Phasenabschnittsteuerungen nicht für induktive Lasten 
geeignet (Spannungsspitze beim Abschalten des Stromes)."

Außerdem schalten Phasenabschnitt Steuerungen ja auch im Nulldurchgang 
ein, genau wie Nulldurchgangsschalter.

Phasenanschnitt schaltet verzögert ein und im Nulldurchgang aus.
Macht einen ja ganz kirre...
Also Kommando wieder zurück? Oder hab ich noch was überlesen?

Grüße,
Rudi

von Niklas B. (niklas90)


Angehängte Dateien:

Lesenswert?

Ohne jetzt die anderen Beiträge alle durchgelesen zu haben, du 
versuchst, eine 230V Last per Triac an- und auszuschalten?  Ich habe das 
damals mit meinem "Flackergenerator" so gemacht wie in dem Anhang, 
vielleicht hilft es dir ja weiter. (genauer gesagt habe ich allerdings 
den MOC3052 verwendet und den BT139)

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Rudi M. schrieb:
> Matthias Sch. schrieb:
>> (allerdings induktive) Last bei Netzspannung
>
> Nulldurchgangsschalter sind Gift für induktive Lasten:
>
> http://de.wikipedia.org/wiki/Nulldurchgangsschalter
>
> Dafür verwendet man Phasenanschnitt.
>
> Probier mal was Ohmsches.

Freunde, das bezog sich einzig auf das Thema 'Direkt den MOC als 
Schalter für was benutzen', nicht auf seine eigentliche Funktion als 
Triacansteuerung. Es steht auch ausdrücklich im Datenblatt, das er dafür 
nicht geeignet ist. Und Phasenan- oder abschnitt geht mit ihm doch gar 
nicht, er hat doch den ZeroCross Detektor :P Meinen Lüfter steuert jetzt 
ein kleiner Schmutztriac ZC-sowienoch über den MOC.

von Mathias H. (innovator)


Lesenswert?

Guten Morgen zusammen,

habe das mit dem MOC3043 schon ein paar mal ohne TRIAC und auf einem 
Steckbrett ohne feste Beschaltung probiert. Außerdem hab ich ne kleine 
Last in Form einer Lampe angehängt und trotzdem tut sich nix. Kann es 
sein dass diese MOC3043 sehr empfindlich reagieren?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Mathias Haspel schrieb:
> Kann es
> sein dass diese MOC3043 sehr empfindlich reagieren?

Eigentlich sind sie schon recht robust, es kann natürlich trotzdem sein, 
das die LED durch ein Experiment gelitten hat ;-P. Wenn du den MOC 
durchsteuerst, sollte er auf der Triacseite wie eine antiparallel 
geschaltete Diode anzumessen sein, also in beide Richtungen leiten mit 
ca. 0,7 Volt Abfall.
Die LED Seite reagiert natürlich wie eine rote bzw. infrarote LED.
Mess mal, ob da ein LED typischer Strom fliesst und denke an den 
Vorwiderstand.

von Patrick Schlegel (Gast)


Lesenswert?

Der MOC3043 LED Trigger Current max 5mA ... dein Vorwiderstand 150 Ohm 
ergibt fast 30mA fuer IFT

von MaWin (Gast)


Lesenswert?

Patrick Schlegel schrieb:
> Der MOC3043 LED Trigger Current max 5mA ... dein Vorwiderstand 150
> Ohm ergibt fast 30mA fuer IFT

Nach 8 Jahren eine falsche Problemanalyse, Wow.

Und dafür einen thread exhumieren.

30mA sind für den MOC3043 nach Datenblatt maximal erlaubt, 5mA ist das 
Minimum.

Passt also.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.