mikrocontroller.net

Forum: HF, Funk und Felder USB Lautsprecher entstören


Autor: Megatron (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

ich habe hier so einen aktiv-lautsprecher, der eigentlich über 3 AA 
Batterien betrieben wird.

Habe es geöffnet und ein USB Kabel drangelötet, damit ich es darüber 
laufen lassen kann.

Wenn ich es nun an mein 5V 1A Netzteil anschließe läuft es wunderbar, 
aber sobald ich es an meinem USB Port anschließe, habe ich starke 
Störgeräusche, bzw. man kann die Musik kaum noch verstehen.
Jetzt habe ich gehört, dass dies wegen den Störsignalen im Laptop 
passiert, daher soll man ein Feritkern um das Kabel anbringen.

Glaubt ihr, dass dieser Feritring etwas bringt?

Danke EUCH für jede Hilfe!

http://www.reichelt.de/Amidon-Ferrit-Ringkerne/FERRITRING-3-5/index.html?;ACTION=3;LA=444;GROUP=B522;GROUPID=3187;ARTICLE=7673;START=0;SORT=artnr;OFFSET=16;SID=13T4rsy38AAAIAAH3yJhc22d66d7dab7efacf5c5c55078ad123c0

Autor: Bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kauf dier besser eine Richtige PC-Boxen.

Autor: Megatron (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Danke für deine Antwort.

ich habe mehrere richtige gute PC Boxen.

Dieser aktiv-lautsprecher, den ich oben aufgeführt habe, war ein 
Geschenk von Pringles, dass man an eine Pringles Dose drafusteckt.

Ich will 2 von den Dingern an eine Pringles Dose anbringen und so Stereo 
Musik und Strom über Notebook haben.
Ich mache es also eher aus Spaß, weil die Dinger lustig aussehen.

Autor: Bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entstörung der Stromversorgung:
Mann nehme zwei Spulen(ein in + eine in -) und einen Elko dahinter in 
die Stromversorgung.
Schätze 470µH und 220-470µF sollten reichen.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Megatron schrieb:
> dass dies wegen den Störsignalen im Laptop

Meine Glaskugel meint, daß es auch Masseschleifen über das Netzteil 
geben könnTE. Dann hört man wahrscheinlich ein 50Hz-Brummgeräusch.

Autor: Om P. (ompf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
470µF am USB setzt voraus, dass der Host genauso wenig die Spezifikation 
einhält wie der Client. Sonst ist danach erstmal Neustart angesagt, um 
die Ports wiederzubeleben.

Hol die 5V lieber aus dem PS/2, wenn noch vorhanden. Den kann man besser 
filtern.

Autor: Klaus D. (kolisson)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke mal eher, dass dir die galvanische Trennung der DC nun fehlt.
Ob sich allerdings ein DC/DC Wandler für sowas lohnt ?

Gruss k.

Autor: Winfried J. (Firma: Nisch-Aufzüge) (winne) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat,

vielleicht schon mal jemand daran gedacht, das nur 100mA ohne Anmeldung 
aus dem USB Port kommen? Die Aktivbox aber gere einen größeren Schluck 
hätte, weshalb die Spannung periodisch einbricht und damit die Geräusche 
verursacht?

Oh Herr lass es Hirn regnen.

Namaste

Autor: Harald W. (wilhelms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Megatron schrieb:

> Wenn ich es nun an mein 5V 1A Netzteil anschließe läuft es wunderbar,
> aber sobald ich es an meinem USB Port anschließe, habe ich starke
> Störgeräusche,

Hat Dein Rechner noch einen Tastaturanschluss? Dann hol Dir die
5V doch von da, vielleicht klingt das besser. Aber vorsicht!
Dieser Port hat keine Strombegrenzung; man sollte also eine
Sicherung in Reihe schalten.
Gruss
Harald

Autor: Old P. (old-papa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also mal ehrlich, was soll aus so einer Prömpelei denn rauskommen? Bei 
5Volt, max. 500mA an 4 Ohm Lautsprecher wird das doch nur eine 
Flüstertüte.

Old-papa

Autor: Michael R. (mexman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Old Papa schrieb:
> Also mal ehrlich, was soll aus so einer Prömpelei denn rauskommen? Bei
> 5Volt, max. 500mA an 4 Ohm Lautsprecher wird das doch nur eine
> Flüstertüte.

Wenn man das richtig macht, durchaus Zimmerlautstaerke!

Ich habe sowas mehrfach und mit weniger Betriebsspannung (LiIon-Akku) 
und es ist allemal lauter als eingebaute Laptop-Lautsprecher und klingt 
dazu wesentlich besser!

Gruss


Michael

Autor: oszi50 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Old Papa schrieb:
> 5Volt, max. 500mA

Die 500mA kommen nur raus wenn USB möchte. Der USB-Standard sieht vor, 
dass Geräte zunächst im Low Power-Mode (100 mA oder 150 mA) starten.
Lies http://de.wikipedia.org/wiki/Universal_Serial_Bus#Kurioses

Megatron schrieb:
> habe ich starke Störgeräusche, bzw. man kann die Musik kaum noch verstehen.

Verzerrte Musik? Spannung zusammengebrochen?
5V Spannung gemessen? j/n

Autor: Megatron (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

@Old Papa die Lautstärke ist sehr hoch glaub mir. :-D

@Winfried J. da bin ich auch der Meinung, ja Herr lass Hirn regnen.
Das Problem ist komplizierter als Sie denken.
Wenn Sie recht haben sollten, dann dürfte folgendes nicht funktionieren.
USB Stromversorgung über Macbook und Musik über ein anderes Gerät---> 
läuft wunderbar.
USB  Stromversorgung über Macbook und Musik über Macbook---> Störung.

D.h. wenn ich die Versorgung mit einem externen Netzteil mache und die 
Musik über Macbook gibt es keine Probleme.
Und wiederrum Stromversorgung über Macbook, aber Musik über ein anderes 
Gerät, auch keine Problem.

Es gibt nur Probleme, wenn ich beides an mein Macbook anschließe.

@Harald Wilhems habe leider keinen Tastaturanschluss.

Hab mal mit einem an der Hochschule darüber gesprochen, er meinte das es 
wegen den Störsignalen im Laptop zu dieser Störung kommen kann.
D.h. ich müsste einen Feritkern über mein Kabel anbringen.

Es könnte aber auch an der fehlenden galvanischen Trennung liegen, keine 
Ahnung.

Hab hier noch einen DC/DC Wandler von einem KFZ Ladegerät rumliegen, 
dass bis zu 16V zu 5V runterregeln kann.
Da er aber als Input mehr als 5V braucht, werde ich im Output natürlich 
weniger als 5V bzw. ungefähr 4V bekommen, was eigentlich nicht so 
schlimm ist.

Melde mich nochmal, wenn es besser werden sollte.

Danke nochmal an alle!

Autor: Harald W. (wilhelms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi50 schrieb:

> Die 500mA kommen nur raus wenn USB möchte. Der USB-Standard sieht vor,
> dass Geräte zunächst im Low Power-Mode (100 mA oder 150 mA) starten.
> Lies http://de.wikipedia.org/wiki/Universal_Serial_Bus#Kurioses

Ja, besonders gefällt mir da der Weinabfüllhahn mit USB-Anschluss.
Der Preis ist mit knapp 10€ auch moderat. Aber ich glaube, wenn
man da mehr als 100ml rausholen will, muss man das auch beim
Betriebssystem anmelden.
Gruss
Harald

Autor: hmo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tipp, das funktionuckelt einwandfrei: zwei Spulen 470 uH 
und ein Elko 220 uF dahinter. Passt sogar noch prima in das 
Lautsprechergehäuse hinein. Die Klangqualität ist natürlich nicht 
überragend, aber für eine Skype- oder Lync-Konferenz ist der kleine 
Lautsprecher das perfekte Mitnahmeteil.

Übrigens: keine Sorge, dass der USB-Anschluss das nicht leistet: Der 
Pringles-Lautsprecher verbläst gerade mal 1W. Entweder ist der 
USB-Anschluss auf 100 mA strombegrenzt (so sollte es laut Norm sein), 
dann bekommt der Verstärker im Pringles-Spekaer halt nicht mehr als 500 
mW, oder der USB liefert gleich 500 mA (das ist meist der Normalfall), 
dann wird diese Leistung vom Verstärker gar nicht aufgenommen.

Autor: Robin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ebenfalls USB Lautsprecher, welche Geräusche machen, wenn ich 
sie per USB-Anschluss am PC betreibe.

Ich will das mit der Spule und dem Kondensator testen. Eine Spule wird 
also in die + und die andere in - Leitung eingebaut und den Kondensator 
zwischen + und -. Liege ich da jetzt richtig?

VG Robin

Autor: Harald W. (wilhelms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robin schrieb:

> Ich habe ebenfalls USB Lautsprecher, welche Geräusche machen, wenn ich
> sie per USB-Anschluss am PC betreibe.

Üblicherweise werden Störungen an der Quelle bekämpft und nicht am
gestörtem Gerät. Du solltest also versuchen, die Störquelle zu finden.

Autor: Rolf S. (audiorolf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es auch sein, dass es eine schlechte Signalrekonstruktion ist?

Ich hatte auch Probleme mit einem USB-getriebenen Monitoren und seit ich 
den REGEN verwende, ist das alles paletti.

http://uptoneaudio.com/products/usb-regen

Autor: Elektrolurch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Harald W. schrieb:
> Üblicherweise werden Störungen an der Quelle bekämpft und nicht am
> gestörtem Gerät. Du solltest also versuchen, die Störquelle zu finden.

Die ist doch gefunden: es ist der Laptop

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.