Forum: Analoge Elektronik und Schaltungstechnik BF420 zum Schalten eines Synchronmotors 230V


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Hendrik N. (hinnerk)


Angehängte Dateien:

Lesenswert?

Hallo Freunde der Feinwerktechnik!

Ich habe auf einer lochraterplatine einen µC (Mega32), der alle 
2Sekunden einen Ausgang toggelt. Das funktioniert soweit.
Die Schaltung sieht so aus: [Foto]
Problem: Obwohl das Gate toggelt, fleißt immer Strom. Warum?!?

Vielen Dank schon mal!!!!

von karadur (Gast)


Lesenswert?

Hallo

AC schaltet man nicht mit einem Transistor !!!

von andreas6 (Gast)


Lesenswert?

Hallo,

dieser Kleinsignal-Transistor ist zum Schalten solcher Spannungen 
ungeeignet. Er wird nun defekt sein, daher schaltet dort nichts mehr. 
Wenn die Speisung tatsächlich die Netzwechselspannung sein sollte, so 
ist dort ein Transistor ohnehin nicht sinnvoll als Schalter verwendbar.

MfG. Andreas

von Hendrik N. (hinnerk)


Lesenswert?

Das ist sicher richtig. Der Transistor ist bestimmt kaputt! Im 
Datenblatt soll er jedenfalls bis 300 (DC!!!) schalten.
Ich hätt gedacht, dass Die Wechselspannung einem Bipolartransistor 
nichts ausmacht.
Die 230V sind tatsächlich direkt aus der Steckdose.
Hat vllt jemand eine Idee, wie man die Schaltung alternativ aufbauen 
könnte?
Der Synchronmotor ist nur ganz gelegentlich für ein paar Sekunden im 
Einsatz.
Technische Daten:

230V AC Betriebsspannung
4W
Daraus folgt ein Strom von ca. 17mW

Der µC kann ja bekanntlich max 20mW am Gate zur Verfügung stellen.
Bin für alle Ideen offen, was man möglichst einfach auf Lochraster löten 
kann. Ich muss sowiwso nochmal bestellen ;)

von Elektroniker (Gast)


Lesenswert?

> Daraus folgt ein Strom von ca. 17mW

Du meinst sicherlich 17 mA , da 230V~ x 0,017 A = 3,91 VA, bei 18mA sind 
es schon 4,14 VA

Nimm einen Thyristor in einer Graetzbrücke und diese in Reihe vor den 
Motor, sodas der Thyristor am positiven und negativen Pol angeschaltet 
ist.
Ein entsprechend U-fester Transistor würde das in der Konstruktion wohl 
besser erledigen, weil er keine Haltezeit hat.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Hendrik N. schrieb:
> Strom von ca. 17mW

Naja, Strom misst man in Ampere und nicht in Watt. Aber ist ja egal, du 
meinst sicher 17mA.
Man kann sehr wohl mit einem Transistor Wechselspannung schalten,dazu 
braucht man noch einen Brückengleichrichter. Du schliesst den Transistor 
mit dem Kollektor an den + des GR,der Emitter geht an -

Der Schalter ist dann über den Wechselspannungsanschlüssen:

                    -------
o----(Motor)-------|~     +|----
                   |       |   C \|  B
230V~              |       |      |-------
o------------------|~     -|-----/|
                    -------    E

Allerdings ist da natürlich nichts netzgetrennt. Die Basis des 
Transistors sollte also mit einem Optokoppler oder so angesteuert 
werden.

von Hendrik N. (hinnerk)


Lesenswert?

Die Idee mit dem Gleichrichter klingt sehr gut. Ich hab sowas noch nie 
gebaut und daher frage ich mich:
Wurde der Transistor in meiner Schaltung durch die starken 
Spannungsgefälle zerstört? Dann würd ein Gleichrichter mir vllt ja gar 
nicht helfen, es sei denn ich puffer die Spannung anschließend noch mit 
Kondensatoren.

Elektroniker schrieb:
> Ein entsprechend U-fester Transistor würde das in der Konstruktion wohl
> besser erledigen, weil er keine Haltezeit hat.

Reicht der BF420 nicht aus? 300V ist die max. 
Kollektor-Emitter-Spannung.
Haltezeiten sind in meiner Schaltung unrelevant, aber hatte ich nicht 
bedacht, danke für den hinweis.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Hendrik N. schrieb:
> Reicht der BF420 nicht aus? 300V ist die max.
> Kollektor-Emitter-Spannung.

Es ist sehr knapp. Die effektive Netzspannung ist 230 Volt, das bedeutet 
eine Spitze Spitze Spannung von 230*1,41 = 325 Volt. Der Transistor wird 
nicht gleich kaputtgehen, wird aber echt an der Grenze betrieben. Ein 
kleiner Triac mit einem MOC3063 Zerocross Optokoppler ist sicher die 
zuerlässigere Variante.

von Ben _. (burning_silicon)


Lesenswert?

Ist nicht euer Ernst, oder?! 230V direkt an aus der Dose und dann "in 
den Fingern" eines komplett Ahnungslosen. Also im Prinzip finde ich 
solche Bastelwut toll und unterstütze auch oft gegen irgendwelche 
Vorschriften, aber wer sowas verzapft und sich nicht mal mit der 
Netzwechselspannung (zB. dem Spitzenwert von 330V) auskennt ... sorry da 
ist bei mir das Ende der Fahnenstange erreicht!

Erstmal einlesen:
- sichere elektrische Trennung (des Anwenders) vom Stromnetz
- Sinus
- Transistoren
- elektrische Größen
- erste Hilfe bei Stromunfällen (für allem für Deine Frau interessant)

von Paul Baumann (Gast)


Lesenswert?

Vielleicht hat er sich schon mit dem Netz synchronisiert und macht mit 
50Hz
einen weg....

Wenn ich das in meinem Dorfe erzähle....

MfG Paul

von Ben _. (burning_silicon)


Lesenswert?

Bis zum Höhepunkt schon ganz verkohlt,
wer sich mit 50Hz einen runterh*lt.

von andreas6 (Gast)


Lesenswert?

Hallo,

zunächst mal kann ich einem solchen Transistor keine 
Netzspannungstauglichkeit bescheinigen. Noch dazu ist er für 
Wechselspannungen untauglich. Als Schaltelement an dieser Stelle wäre 
bei ordentlicher Netztrennung ein Optokoppler spezieller Art geeignet. 
Ein Moc30xx oder Moc31xx ist dafür nutzbar. Ebenso ein Aqv214 oder 
besser. Das sind Opto-Triacs mit Wechselspannungsausgängen, sie können 
kleine Lasten am Netz schalten.

MfG. Andreas

von Hendrik N. (hinnerk)


Angehängte Dateien:

Lesenswert?

Danke schonmal für die ganzen Anregungen!

Ich habe den Vorschlag von andreas6 weiterverfolgt

andreas6 schrieb:
> Als Schaltelement an dieser Stelle wäre
> bei ordentlicher Netztrennung ein Optokoppler spezieller Art geeignet.

Danach habe ich mir nun folgende Schaltung aufgebaut [Foto].
Der Moc3023 scheint eine gute Wahl für die Schaltung zu sein.
Der Triac TIC225M hat eine peak voltage von 600V.
In einer ähnlichen Schaltung war von Pin4 des Optokopplers zu einer 
Phase ein Widerstand um Leckströme abzufangen, ich denke jedoch, dass 
ist nicht notwendig.
R4 ergibt sich aus [(5V - Spannungsabfall am Optokoppler(=1,5V)] / 20mA) 
= 175 Ohm.

Endeckt jemand noch grobe Schnitzer?
Im Vergleich zu  meinem ersten Versuch finde ich diese Lösung schon sehr 
elegant ;)

von Dietrich L. (dietrichl)


Lesenswert?

Hendrik N. schrieb:
> Der Moc3023 scheint eine gute Wahl für die Schaltung zu sein.
> Der Triac TIC225M hat eine peak voltage von 600V.

Der TIC225M ist unnötig groß und hat daher einen hohen Haltestrom 
(Max-Wert=20mA) und Du brauchst ja nur 17mA. "Typisch" wird es gehen.

Aber der MOC3023 reicht doch alleine schon: er ist bei Maximum Ratings 
mit 60mA angegeben.

Gruß Dietrich

von Hendrik N. (hinnerk)


Angehängte Dateien:

Lesenswert?

Moin Moin,

ich habe die Schaltung nun ohne den Triac und ohne LED aufbebaut (siehe 
Foto).

Mein Problem ist, dass der Optokoppler nicht schaltet!
Wenn 5V Spannung dran liegen, schaltet er die 230V nicht durch.
Ich bin soweit gegangen, dass 230V am Koppler dran waren und habe 5V aus 
einem Netzteil an den Eingang gelegt. Funktioniert nicht! Am Koppler 
liegts auch nicht, ich habe das bereits mit einem Neuen ausprobiert.
Habe ich nen groben Schnitzer in der Schaltung?
Nochmal: Synchronmotor:
    230V AC Betriebsspannung
    4W
    Daraus folgt ein Strom von ca. 17mA

Danke nochmal

von fonsana (Gast)


Lesenswert?

Hendrik N. schrieb:
> und habe 5V aus
> einem Netzteil an den Eingang gelegt

Dann wird die LED im Koppler jetzt hin sein.

fonsana

von Paul B. (paul_baumann)


Lesenswert?

Warum hast Du denn den R2 da drin? Der Motor ist doch für 230 Volt
angegeben.

Mensch, sei bloß vorsichtig, wenn Du da so frei dran herumbaust....

MfG Paul

von Hendrik N. (hinnerk)


Lesenswert?

Paul Baumann schrieb:
> Warum hast Du denn den R2 da drin? Der Motor ist doch für 230 Volt
> angegeben.

R2 habe ich noch von der vorherigen Schaltung mit Triac. Hm meinst du 
der Strom wird dadurch zu groß für den koppler?

Ich sicher mich hier 3-4 mal ab, bevor ich mit den 230V rumspiel, keine 
Angst!!!

von fonsana (Gast)


Lesenswert?

Hendrik N. schrieb:
> Hm meinst du
> der Strom wird dadurch zu groß für den koppler?

Wie soll der Strom zu gross werden, wenn ein Widerstand in Reihe dazu 
kommt?
(Rechne mal nach - mit und ohne R2 - Ohmsches Gesetz)

Laeuft der Motor, wenn Du die Pins 4+6 brueckst?
Welcher Strom fliesst durch die LED?

fonsana

von Hendrik N. (hinnerk)


Lesenswert?

fonsana schrieb:
> Wie soll der Strom zu gross werden, wenn ein Widerstand in Reihe dazu
> kommt?
> (Rechne mal nach - mit und ohne R2 - Ohmsches Gesetz)

hast Recht- ich bin hier ja in Reihe. Der Motor hat einen Widerstand von 
ca. 11kOhme, da sollte der kleine Widerstand nocht stören.

Bei Überbrückung läuft der Motor.
Der Stomr durch die LED des Kopplers ist anscheinend sehr gering- ich 
kannn den nicht messen.

von Ben _. (burning_silicon)


Lesenswert?

> Der Stomr durch die LED des Kopplers ist anscheinend
> sehr gering- ich kannn den nicht messen.
Wenn Du die typischen 5..15mA nicht messen kannst würde ich Dir 
DRINGEND empfehlen Dir ein geeignetes Messgerät zu besorgen oder - was 
vielleicht besser wäre - jemanden an dem Ding bauen zu lassen, der sich 
damit auskennt.

An dem Triac-Ausgang fehlt der Snubber. Auch wenn das Ding im 
Nulldurchgang schaltet würd ich sowas bei induktiven Lasten immer 
dranpacken. Sicher ist sicher und vielleicht hat das Ding deswegen 
bereits dicke Backen gemacht. An seiner Stelle würde ich Dir meinen 
Gehäusedeckel ins Auge schmeißen!

> Ich sicher mich hier 3-4 mal ab, bevor ich mit den 230V rumspiel,
Mit 3x63A? ;)

von Hendrik N. (hinnerk)


Lesenswert?

Den Snubber habe ich eingebaut, wobei der Motor auch ohne Snubber was 
sagen sollte.
Funktioniert leider immer noch nicht.
Anscheinend fließt kein Strom durch die LED, wobei der Ausgang meines 
µCs die Spannung alle 5s toggelt- trotzdem fließt nix.
Ich sollte mir dabei aber höchstens 2 Koppler zerschossen haben. 
Komisch.

von Hendrik N. (hinnerk)


Lesenswert?

Also wenn ich zwischen Pin 1&4 eine LED löte, toggelt die LED, aber der 
Koppler schaltet einfach nicht (bei Schaltplanbeschaltung+Snubber)!! Zum 
Mäusemelken!

von fonsana (Gast)


Lesenswert?

Hendrik N. schrieb:
> Also wenn ich zwischen Pin 1&4 eine LED löte

Das kann schlecht sein, dann ist Dein Schaltplan falsch.

fonsana

von Hendrik N. (hinnerk)


Lesenswert?

fonsana schrieb:
> Hendrik N. schrieb:
>
>> Also wenn ich zwischen Pin 1&4 eine LED löte
>
>
>
> Das kann schlecht sein, dann ist Dein Schaltplan falsch.

Verzeihung ich meinte zwichen Pin1 und Pin2 des Optokopplers.

von fonsana (Gast)


Lesenswert?

Hendrik N. schrieb:
> Verzeihung ich meinte zwichen Pin1 und Pin2 des Optokopplers.

Anode und Kathode wo angeschlossen?

fonsana

von Dietrich L. (dietrichl)


Lesenswert?

Hendrik N., Du wirst doch noch die LED im MOC3023 durchmessen können!

Bau das Ganze mal ohne µC und sonstigem Gedöhns auf:
- +5V an Pin 1
- Widerstand zwischen Pin 2 und GND
- Spannung am Widerstand messen
- Strom berechnen: wenn = 0: MOC kaputt
- zur Sicherheit Pin 1 und 2 vertauschen und nochmal messen (falls da 
irgend etwas verpolt ist)
Wenn dann immer noch kein Strom fließt: wirklich kaputt
Wenn Strom fließt: wieviel? Ist es genug? Oder zuviel (Gefahr der 
Zerstörung)? Ggf. Widerstandswert ändern.
Weiter: Aufbau kontrollieren. +5V messen. Spannung zwischen Pin 1 und 2 
messen. Sind die Werte plausibel? ....

Das sollte doch wirklich nicht so schwer sein...

Gruß Dietrich

von Ingo (Gast)


Lesenswert?

Alter, der bastelt mit Netzspannung und hat überhaupt keinen Plan, dass 
ihr da noch Tips gebt... Unglaublich

von Max D. (max_d)


Lesenswert?

Ingo schrieb:
> Alter, der bastelt mit Netzspannung und hat überhaupt keinen Plan, dass
> ihr da noch Tips gebt... Unglaublich

Sollen wir den sich einfach so frittieren lassen, lieber er schaffts 
irgendwann... Und: man muss schon ziemlich dumm hinlangen, dass man bei 
230V was ernsthaftes abkriegt....

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Im Datenblatt des MOC3023/43/63 steht ausdrücklich, das er nicht zum 
direkten Schalten von Lasten gedacht ist:
>* This optoisolator should not be used to drive a load directly. It is in-
> tended to be a trigger device only.

Diese Einschränkung gibt es beim MOC 3021 und Konsorten ohne ZC 
Schaltung nicht.
Ich habe auch schon vergeblich versucht, Kleinst Wechselstrom Motoren 
mit dem MOC3043 direkt zu schalten, es geht nicht. Entweder schaltet der 
MOC nicht durch oder er bleibt im Einzustand 'kleben'.

Matthias Sch. schrieb:
> Ein
> kleiner Triac mit einem MOC3063 Zerocross Optokoppler ist sicher die
> zuerlässigere Variante.

Deswegen schrieb ich das mit dem kleinen Triac.

Ingo schrieb:
> Alter, der bastelt mit Netzspannung und hat überhaupt keinen Plan, dass
> ihr da noch Tips gebt... Unglaublich

Nu übertreibt mal nicht. Ist ja schon peinlich, für wie doof du den TE 
hälst.

von Otto (Gast)


Lesenswert?

ich wollte nur mal nachfragen, lebt TE noch?

von Niemand (Gast)


Lesenswert?

Otto schrieb:
> ich wollte nur mal nachfragen, lebt TE noch?

der April hat ja auch noch über eine ganze Woche

von voltwide (Gast)


Lesenswert?

Matthias S. schrieb:
> Ich habe auch schon vergeblich versucht, Kleinst Wechselstrom Motoren
> mit dem MOC3043 direkt zu schalten, es geht nicht. Entweder schaltet der
> MOC nicht durch oder er bleibt im Einzustand 'kleben'.
>
> Matthias Sch. schrieb:

Ja, die Erfahrung habe ich auch gemacht. Das liegt daran, dass beim 
geplanten Abschalten der induktiven Last der Induktionspuls den MOC 
wieder triggert ("Über-Kopf-Zündung"). Erschwerend kommt hinzu, dass der 
MOC nur eine ziemlich niedrige Festigkeit gegen Spannungtransienten 
aufweist (dV/dt).

Andererseits ist bei solch kleiner Last der Stromfluß so niedrig, dass 
kaum der Haltestrom für den TRIAC zustande kommt.

Von daher erscheint mir ein N-Kanal-PowerMOSFET in Verbindung mit einer 
Gleichrichterbrücke praxistauglicher.

von Peter D. (peda)


Lesenswert?

Hallo, das ist 6 jahre her!

von voltwide (Gast)


Lesenswert?

Zu jener Zeit gab es auch schon MOSFETs

von Harald W. (wilhelms)


Lesenswert?

Peter D. schrieb:

> Hallo, das ist 6 jahre her!

Ja, der Thread kommt bald in die Schule. :-)

von Dieter W. (dds5)


Lesenswert?

Harald W. schrieb:
> Peter D. schrieb:
>
>> Hallo, das ist 6 jahre her!
>
> Ja, der Thread kommt bald in die Schule. :-)

Ob er da noch was lernen kann?  ;-))

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.