Forum: Analoge Elektronik und Schaltungstechnik Konstantspannungsquelle mit komischen Verhalten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Vreg (Gast)


Angehängte Dateien:

Lesenswert?

Hallo Leute,

anbei der Schaltplan meiner Konstantspannungsquelle, die eine konstane 
Spannung zum laden eines Akkus bereitstellen soll. Zurzeit wird die Last 
nicht durch einen Akku sondern durch einen Widerstand simuliert. Die 
Schaltung soll einen max. Strom von 2A liefern können, der über den 
BSR14 begrenzt werden soll. In der Simulation funktioniert die Spannung 
wunderbar. Im realen einsatz auch, die Spannung CTRL_VOLTAGE_SRC wird 
durch einen Mikrocontroller im berich von 0...5V vorgegeben. Einstellbar 
soll die Spannung über der Last von ~0...30V sein. Deswegen der 
Spannungsteiler mit 1k und 5k. Problematisch wird es wenn wenn man die 
Schaltung belastet, also eine Strom von z.B. 1,5A entnimmt, dann stellt 
sich nicht die eingestellte Spannung von z.B. am Lastwiderstand ein 
sondern die Spannung steigt bis auf ca. 25V. Misst man am Ausgang sieht 
man das die Spannung angehoben wird, sollte diese aber nicht absinken, 
damit der Spannungsfall am Transistor größer wird?
Hoffe auf eure Hilfe.

mfg Vreg

: Verschoben durch Moderator
von Jens G. (jensig)


Lesenswert?

Zuallererst solltest Du dem OPA eeinen Serien-R am Ausgang spendieren, 
denn sonst tut dein Strombegrenzungstransistor dessen Ausgang voll auf 
die Last klemmen, was der OPA bestimmt nicht mag.
Denn wenn der BSR14 durchschaltet, schaltet er quasi den TIP142 ab, und 
der OPV versucht jetzt auf Biegen und Brechen, die Spannung trotzdem 
aufrecht zu erhalten.

Ansonsten könnte es auch sein, daß die V502/V503-Kombination in 
Schwingungen gerät, und damit alles verfälscht.

Und zu guter Letzt kann es am möglicherweise miserablen Aufbau 
(Steckbrett?) liegen, mit komischer Leitungs/Masseführung.

von Vreg (Gast)


Lesenswert?

Jens G. schrieb:
> Zuallererst solltest Du dem OPA eeinen Serien-R am Ausgang spendieren,
> denn sonst tut dein Strombegrenzungstransistor dessen Ausgang voll auf
> die Last klemmen, was der OPA bestimmt nicht mag.
Ja, der OP soll ja angeblich dauerhaften Kurzschluss am Ausgang, also 
somit auch eine hohe Stromaufnahme verkraften können. Der BSR14 soll 
eig. als zusätzliches Glied dem TIP142 den Basisstrom entziehen. 
Testweise kann ich den Ausgang aber mal einen Wiederstand spendieren.

> Denn wenn der BSR14 durchschaltet, schaltet er quasi den TIP142 ab, und
> der OPV versucht jetzt auf Biegen und Brechen, die Spannung trotzdem
> aufrecht zu erhalten.
Ja, kann er aber nicht, deswegen wird nach kurzer Zeit die Spannung 
abfallen, was dem BSR14 in den nichtleitenden Zustand versetzen sollte. 
Dann steuert der OP wieder den TIP142, sollte eigentlich gehen. 
(http://www.elektronik-kompendium.de/sites/slt/0204132.htm) Da ich denke 
das dies nur kurzzeitig geschieht.

>
> Ansonsten könnte es auch sein, daß die V502/V503-Kombination in
> Schwingungen gerät, und damit alles verfälscht.
Das klingt interessant, wie kann ich erkennen ob es in Schwingungen 
gerät und wenn ja, was ist die Lösung das zu unterbinden?


> Und zu guter Letzt kann es am möglicherweise miserablen Aufbau
> (Steckbrett?) liegen, mit komischer Leitungs/Masseführung.
Das ist auszuschließen, ist alles auf einem PCB aufgebracht.

von Vreg (Gast)


Lesenswert?

Vom Prinzip ist es ja sie wie die Schaltung auf Wikipedia 
(http://de.wikipedia.org/w/index.php?title=Datei:Stab_ov.svg&filetimestamp=20070709180531) 
nur halt dass die Spannung am nichinvertierenden OP-Eingang über den 
Mikrocontroller vorgegeben wird und das noch eine 
Strombegrenzungsschaltung eingebaut ist.

Die Verstärkung des TIP142 sollte so im bereich von 250-500 liegen. 
Somit bei Ic = 2A --> Ib = 4-8mA. Das Sollte der OP locker verkraften 
können.

von Jens G. (jensig)


Lesenswert?

>Das klingt interessant, wie kann ich erkennen ob es in Schwingungen
>gerät und wenn ja, was ist die Lösung das zu unterbinden?

Mit einem Oszilloskop

>Das ist auszuschließen, ist alles auf einem PCB aufgebracht.

PCB schließt auch nicht aus, daß das Layout miserabel ist. Auch da kann 
man die Leitungsführung kräftig verhunzen.

Auserdem sollte wohl die Rückkopplung nicht vor dem R505 abzweigen, 
sondern dahinter, damit wir auch wirklich die Spannung an der Last 
regeln, und nicht an Last+Strommeßwiderstand.

von Vreg (Gast)


Lesenswert?

Jens G. schrieb:
> Auserdem sollte wohl die Rückkopplung nicht vor dem R505 abzweigen,
> sondern dahinter, damit wir auch wirklich die Spannung an der Last
> regeln, und nicht an Last+Strommeßwiderstand.

Ja, das hat in der Simulation dazu geführt dass es nicht mehr ging, 
deswegen wurde der Abgriff so gewählt. Ich denke der Spannungsfall 
zwischen Basis und Emitter sollte zu vernachlässigen sein, oder?

von Vreg (Gast)


Lesenswert?

Vreg schrieb:
> Jens G. schrieb:
>> Auserdem sollte wohl die Rückkopplung nicht vor dem R505 abzweigen,
>> sondern dahinter, damit wir auch wirklich die Spannung an der Last
>> regeln, und nicht an Last+Strommeßwiderstand.
>
> Ja, das hat in der Simulation dazu geführt dass es nicht mehr ging,
> deswegen wurde der Abgriff so gewählt. Ich denke der Spannungsfall
> zwischen Basis und Emitter sollte zu vernachlässigen sein, oder?

Ach ich bin an der falschen stelle, ja am R505 würden mas 0,6-0,7V 
abfallen, das kann ich tolerieren. In der Simulation hatte sich gezeigt 
das wenn man den Abgriff hinter der R505 legt, dass ganze nicht mehr 
klappt. Wird wohl dann daran liegen, das der BSr14 bei 2A 
(Strombergenzung) den Messzweig mit dem Ausgang des OP verbindet.

von Jens G. (jensig)


Lesenswert?

Wieso Basis und Emitter - der interessiert hier nicht. Sondern der 
Spannungsabfall am R505, der zu einer Lastabhängigen Spannung an der 
Last führt. Das erklärt zwar nicht das beschriebene Verhalten, ist aber 
trotzdem schlechtes Design.

>Ja, das hat in der Simulation dazu geführt dass es nicht mehr ging,

Wieso - was ging nicht? Das sollte auf alle Fälle gehen.

von Vreg (Gast)


Lesenswert?

hmm, hab es nocml in der simulation getestet, jetzt ght es. gut die 
schaltung würde dan den spannungsfall am r505 mit ausregeln, wenn sie 
richtig funktionieren würde...

von Thomas K. (thomas_k39)


Lesenswert?

Hmmm, also Du stellst eine Ausgangsspannung von 15V ein, hängst einen 10 
Ohm Widerstand als Last an, und dann steigt die Ausgangsspannung (über 
dem 10 Ohm Widerstand) auf 25V an?

von Vreg (Gast)


Lesenswert?

Jap, genauso sieht es aus, der OP scheint das ganze nicht auszuregeln

von ArnoR (Gast)


Angehängte Dateien:

Lesenswert?

> der OP scheint das ganze nicht auszuregeln

Wenn du als Last nur einen reinen Widerstand anschließt, dann sollte das 
gehen (grüne Kurve oben im Anhang). Bei kapazitiver Last schwingt die 
Schaltung (rote Kurve oben) und regelt nicht mehr richtig. Auch ein Akku 
geht deutlich in Richtung kapazitive Last. Die 100µ sind hier nur 
beispielhaft, um die prinzipielle Wirkung zu zeigen.

Eine gewisse Verbesserung erreichst du mit einem kleinen Kondensator 
über dem 5K-Widerstand.

von Vreg (Gast)


Lesenswert?

Ja im Moment schalte ich eine elektronische Last zu, ob die rein ohmsch 
belastet, weiß ich nicht. Ich hab jetzt mal den BSR14 entfernt un den 
R505 überbrückt, das Problem bleibt, das bei bestimmten eingestellten 
Spannungen bei Belastung die Spannung vom OP falsch nachgeregelt wird.

von Vreg (Gast)


Lesenswert?

Ja, es liegt tatsächlich daran, dass der Ausgang anfängt zu schwingen, 
habe jetzt mal mit dem Oszilloskop gemessen. Wie würde man jetzt einen 
Kondensator berechnen für einen max. Ladestrom von 2A?

von Vreg (Gast)


Angehängte Dateien:

Lesenswert?

Im anhang habe ich mal ein Bild von den Rippeln gemacht. Ich habe eine 
Spannung von 12V eingestellt. Sobald die Schaltung über 180mA belastet 
wird hört man ein zischen aus der elektronischen Last. Die Spannung des 
Rippels ist auf dem Bild zu erkennen. Kann man auch einen Kondensator an 
den Ausgang des OP schalten, würde das die Schwingungen unterbinden?

von Jens G. (jensig)


Lesenswert?

Vielleicht ist das auch Deine elektronische Last, die hier anfängt zu 
spinnen. Denn immerhin arbeiten damit zwei Regler gegeneinander.
Versuch es mal mit einem wirklich rein ohmschen R.

von Uwe (Gast)


Lesenswert?

Nimm als Ersatzschaltung des Akkus eine Spannungsquelle mit 
Innenwiderstand.

von Vreg (Gast)


Lesenswert?

Ja kann ich auch machen, allerdings möchte ich auch die Schaltung bis an 
die Belastungsgrenze fahren. Was auch erstaunlich ist, die Schaltung 
schwingt wie oben auf dem Bild zu sehen. Sobald man mit einem Fluke DMM 
am Ausgang der Konstantspannugsquelle misst, hört das zischen auf und 
die Schaltung regelt sauber aus.

von Vreg (Gast)


Lesenswert?

Wie ermittele ich den jetzt den erforderlichen Kondensator, damit die 
Spannungsquelle nicht mehr schwingt?

von Helmut S. (helmuts)


Lesenswert?

Du musst zwischen Opamp-Ausgang und -Eingang des Opamp einen Kondensator 
mit 1nF bis 10nF einbauen. Die Mindestgröße des Kondensators hängt von 
den Widerständen (hier 1k und 5k) und der kapazitiven Belastung am 
Ausgang des Reglers ab. Es ist übrigens Standard diesen extra 
Kondensator einzubauen.

von Vreg (Gast)


Lesenswert?

Ok danke, auf so eine Antwort habe ich gewartet. Das ich den Kondensator 
benötige war mir allerdings nicht klar, bis die schwingungen angefangen 
haben. Aber so lernt man aus fehlern

von Helmut S. (helmuts)


Lesenswert?

Ich habe vergessen zu sagen, dass du in die Basis des Transistors noch 
100Ohm einfügen solltest um die kapazitive Belastung des Opamps zu 
reduzieren.

von Vreg (Gast)


Lesenswert?

Ein Frage hätte ich noch, ist die Schaltung den generell zu gebrauchen? 
Ich will einen Strom vom max. 2A haben. Dabei soll die Spannungsquelle 
von ca. 0V bis 30V einstellbar sein. Ist das mit einem TIP142 zu 
bewerkstelligen?
Da er ja im linearen Bereich betrieben wird.

von M. K. (sylaina)


Lesenswert?

Vreg schrieb:
> Ich will einen Strom vom max. 2A haben. Dabei soll die Spannungsquelle
> von ca. 0V bis 30V einstellbar sein. Ist das mit einem TIP142 zu
> bewerkstelligen?

Wenn du den TIP142 kühlst ist das durchaus machbar, da sehe ich keine 
Probleme.

von Vreg (Gast)


Lesenswert?

Michael Köhler schrieb:
> Wenn du den TIP142 kühlst ist das durchaus machbar, da sehe ich keine
> Probleme.

Ja das ist ja das Problem. Gekühlt wird mit einem 0,24 K/W Kühlkörper. 
Allerdings hat der bei 20V und 1,5A schon ca. 60°C. Für meine 
verständnisse zu warm, sind ca. 30W Verlustleistung. Vllt. doch zwei 
parallel, oder mache ich etwas anderes falsch?

von Vreg (Gast)


Lesenswert?

Dann hätte ich nich eine Frage zu einem Datenblattwert und zwar steht 
bei Absolute Maximun Ratings im TIP142 Datenblatt ein wert von 5 V für 
Emitter-Base Voltage, wie ist das zu verstehen? Darf das 
Emitterpotential nicht 5V über dem der Basis liegen?

von ArnoR (Gast)


Lesenswert?

> im TIP142 Datenblatt ein wert von 5 V für
> Emitter-Base Voltage, wie ist das zu verstehen?

Die Basis-Emitter-Spannung in Sperr-Richtung.

> Darf das Emitterpotential nicht 5V über dem der Basis liegen?

Genau das bedeutet es.

von Vreg (Gast)


Lesenswert?

Das heißt ja im umkehrschluss, das wenn ich in meiner Schaltung den 
Lastwiderstand RL durch einen Akku ersetze und der OP keine Spannung an 
seinem Ausgang liefert, dass der TIP142 dann zerstört ist? Kann ich mir 
irgendwie nicht vorstellen.

von ArnoR (Gast)


Lesenswert?

Nur durch eine zu hohe Spannung geht da nichts kaputt. Im Durchbruch 
muss zur Zerstörung auch genug Strom fließen.

von Vreg (Gast)


Lesenswert?

Ahh ok, das heißt ja, da der Strom der in meinen OP Ausgang reinfließen 
kann begrenzt ist, kommt es nicht zu einem druchbruch.
Wie sieht das aus mit der Wärmeentwicklung des TIPs, bei 30V und 2A wird 
ja im ungünstigsten Fall am Transistor bis zu 60W Verlustleistung 
anfallen. Bei einem Wärmewiderstand von 1 K/W als ca. 60°C + 25°C = 
85°C, eher mehr. Ist das noch ok? Oder lieber zwei TIPs parallel 
schalten?

von ArnoR (Gast)


Lesenswert?

> Ahh ok, das heißt ja, da der Strom der in meinen OP Ausgang reinfließen
> kann begrenzt ist, kommt es nicht zu einem druchbruch.

Zu einem Durchbruch kommts bei zu großer Spannung in jedem Fall, nur 
evtl. nicht zur Zerstörung.

>  bei 30V und 2A wird  ja im ungünstigsten Fall am Transistor bis zu 60W
> Verlustleistung  anfallen. Bei einem Wärmewiderstand von 1 K/W als ca. 60°C > + 
25°C =  85°C, eher mehr. Ist das noch ok?

DB Fig.5. Bei 60W max. 90°C, wäre mir zu knapp.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.