Forum: Analoge Elektronik und Schaltungstechnik M542 defekt??


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Stanislav M. (Firma: GSix) (staniam)


Lesenswert?

Hallo Leute ich hab ein großes Problem mit meinen Schrittmotorendstufen.
Ich habe mir 3 Stück gekauft und leider ist mir beim Testen an einer 
Endstufe eine Motorwicklung kurzgeschlossen worden worauf die rote LED 
angefangen hat zu leuchten ( das ist normal bei Unter/Überspannung und 
Kurzschlüssen).Normalerweise sollte man das ganze einfach aus und wieder 
anmachen und dann gehts wieder , macht es aber nicht.Erst kam nichts, da 
hab ich gelesen ,dass die Endstufe eine Sicherung hat die wirklich durch 
war, sodass ich diese umgetauscht habe.

Dann fing die grüne LED an zu blinken.Ich hab die Vollbrücken mal 
durchgecheckt und gesehen ,dass ein MOSFET defekt war (IRF9Z34) welchen 
ich durch einen IRF9530 ausgetauscht habe.Und jetzt blinkt erst die 
grüne und dann die rote so eine Art lauflicht.

Eigendlich steht in dem Datenblatt, dass die Endstufe Kurzschlussfest 
ist ( Kurzschluss an den Motorspulen ) und trotzdem ist das Teil kaputt.
Kann ich das irgendwie selber reparieren ??
Oder kann ich das noch umtauschen lassen, weil das eigemndlich 
Kurzschlussfest ist.
Danke

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Lesenswert?

Stanislav Malorodov schrieb:
> Oder kann ich das noch umtauschen lassen, weil das eigemndlich
> Kurzschlussfest ist.
Hättest du probieren können, bevor du das getan hast:
> welchen ich durch einen IRF9530 ausgetauscht habe.

Jetzt kannst du nur noch z.B. durch Vergleichsmessungen die defekten 
Bauteile ermitteln und tauschen.

von Stanislav M. (Firma: GSix) (staniam)


Lesenswert?

Ja ich könnte ja alles zurücklöten und alles schön sauber machen und 
ausprobieren
Was aber echt komisch ist, dass beim Kurzschluss der Wicklung ( normal 
1.8 Ohm und in dieser kurzen Zeit 0 Ohm ) ein MOSFET durch war ( es sind 
insgesammt 8 also 2 Vollbrücken für die 2 Wicklungen.

Ich habe diesen durch einen ÄHNLICHEN ausgetauscht und jetzt blinken die 
LEDs in rheinfolge ( erst grün dann rot , lauflicht halt ), obwohl alle 
MOSFETS heile sind und auch alles drumrum ( es riecht nicht einmal der 
hat sich ganz schnell verabschiedet)

Ich könnte jetzt den Hersteller fragen was diese LED rheinfolge zu 
bedeuten hat und mir den richtigen MOSFET besorgen ( original: IRF9Z34 
und ich hab einen IRF9530 genommen ).

Find ich aber echt seltsam sowas

von Jens G. (jensig)


Lesenswert?

Der IRF9530 ist aber schwächer als der andere. Für'n Test ok, sollte 
aber später wieder durch einen stärkeren ersetzt werden, wenn die Daten 
der Endstufen wieder einigermaßen stimmig sein sollen.
Hat aber nichts mit dem Geblinke zu tun.

von Stanislav M. (Firma: GSix) (staniam)


Lesenswert?

Was soll ich jetzt machen bzw. wie soll ich vorgehen bei der Fehlersuche 
?

Kann es denn nicht wirklich am MOSFET liegen, da erst das grüne Lämpchen 
leuchtet was ja heißt, dass es an ist und dann direkt das rote, was für 
Kurzschluss steht.Vielleicht steuert der den MOSFET nicht schnell genug 
oder so und es gibt einen Kurzen zwischen einer Vollbrücke

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.