Forum: Analoge Elektronik und Schaltungstechnik Arduino: Schaltung LEDs mit Transistoren


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Reiner Wahnsinn (Gast)


Lesenswert?

Hallo,

ich versuche einen Stab zu bauen, an dem ca. 40 Leds in einer Reihe 
angebracht sind. Jede von denen soll einzeln und vom Arduino, mit einem 
Transistor gesteuert, leuchten.
Ich habe mir eine Schaltung gesteckt:

http://www.abload.de/image.php?img=2012-10-0712.04.301ofam.jpg

So wie die Schaltung ist leuchtet die LED im Takt der Programierung ( 
das ist ja an dem Kontrollämpchen für Pin 13 auf dem Arduino zu sehen.

Wenn ich jetzt aber das kabel aus dem Arduino ziehe, dann leuchtet die 
Led dauerhaft.
Meine Frage ist, wieso ist das so? Und ist meine Schaltung im Prinzip 
richtig?

: Verschoben durch Admin
von Harald W. (wilhelms)


Lesenswert?

Reiner Wahnsinn schrieb:

> Und ist meine Schaltung im Prinzip richtig?

Ohne Schaltplan lässt sich das nur schwer erkennen.
Gruss
Harald

von Reiner Wahnsinn (Gast)


Angehängte Dateien:

Lesenswert?

Hallo,

ich dacht, das Bild könnte helfen.

Ich hoffe das so eine Zeichnung per Hand geht.
Und die Spannungsquelle sind 6V Gleichstrom.

von Harald W. (wilhelms)


Lesenswert?

Reiner Wahnsinn schrieb:
> Hallo,
>
> ich dacht, das Bild könnte helfen.
>
> Ich hoffe das so eine Zeichnung per Hand geht.
> Und die Spannungsquelle sind 6V Gleichstrom.

Schau Dir mal diese Schaltungen an und vergleiche:
http://www.mikrocontroller.net/articles/Relais_mit_Logik_ansteuern
Die bei Relais notwendigen Paralleldioden kannst Du natürlich
weglassen. Dafür brauchen LEDs Vorwiderstände
Gruss
Harald

von Reiner Wahnsinn (Gast)


Lesenswert?

Danke für den Link.

Ein paar Fragen dazu habe ich:

GND ist der Minuspol der Batterie?

Die beschriebenen Transistoren sind nicht die, die ich habe. Inwiefern 
ändert das die Betriebsspannung bzw den Widerstand für die 
Betriebsspannung?

D2 ist eine LED mit Vorwiderstand passend für in meinem Fall 6V 
Spannung.

Was ist K2?

Und generell:
Ist es egal wie rum ich den Transistor benutze, also Minuspol an 
Kollektor oder Emitter?

Und könntet ihr mir sagen ob das Datenblatt zu den Transistoren passt, 
die ich hab. Auf dem steht BC639 und in der nächsten Zeile 031
http://www.datasheetcatalog.org/datasheet/fairchild/BC639.pdf

von Karl H. (kbuchegg)


Lesenswert?

Reiner Wahnsinn schrieb:

> GND ist der Minuspol der Batterie?

Ja

> Die beschriebenen Transistoren sind nicht die, die ich habe. Inwiefern
> ändert das die Betriebsspannung bzw den Widerstand für die
> Betriebsspannung?

Dein BC639 ist ein ähnlicher Transistor. Er ist genauso ein NPN Typ. Und 
mit einem hFe von ca 30 ist der vergleichbar. Mit Maximalstrom und 
Maximalspannung hast du mit einer popeligen LED sowieso keine Probleme.

> D2 ist eine LED mit Vorwiderstand passend für in meinem Fall 6V
> Spannung.

Nein.
D2 ist dort in der Zeichnung die Freilaufdiode. Die brauchst du nicht, 
weil du ja kein Relais hast.

>
> Was ist K2?

Die Relaisspule. Das was bei dir die LED ist.

> Und generell:
> Ist es egal wie rum ich den Transistor benutze, also Minuspol an
> Kollektor oder Emitter?

Nein. Ist nicht egal. Dein Emitter kommt an GND. An den Collector kommt 
der Verbraucher. In deinem Fall eben die LED mit dem Vorwiderstand.
(UNd darum wird in Schaltbildern auch immer der Pfeil eingezeichnet und 
nicht einfach nur 3 Linien)

> Und könntet ihr mir sagen ob das Datenblatt zu den Transistoren passt,
> die ich hab. Auf dem steht BC639 und in der nächsten Zeile 031
> http://www.datasheetcatalog.org/datasheet/fairchild/BC639.pdf

Passt schon. BC639 ist der wichtige Teil.

von Reiner Wahnsinn (Gast)


Lesenswert?

Jetzt funktioniert das!
Vielen Dank für die Hilfe!

Ich hab einfach mal versucht die Basiswiderstände wegzulassen. Und es 
funktioniert genau wie mit. Besteht da ein Problem, wenn ich die 
weglasse?

von vn nn (Gast)


Lesenswert?

Reiner Wahnsinn schrieb:
> Ich hab einfach mal versucht die Basiswiderstände wegzulassen.

Grund?

Reiner Wahnsinn schrieb:
> Besteht da ein Problem, wenn ich die
> weglasse?

Ja.

von Harald W. (wilhelms)


Lesenswert?

Reiner Wahnsinn schrieb:

> Ich hab einfach mal versucht die Basiswiderstände wegzulassen. Und es
> funktioniert genau wie mit. Besteht da ein Problem, wenn ich die
> weglasse?

Ja, aber vielleicht wirds ja ein interessanter Test: Was brennt eher
durch, Dein Transistor oder Dein Arduino?
Gruss
Harald

von Dietrich L. (dietrichl)


Lesenswert?

Harald Wilhelms schrieb:
>> Ich hab einfach mal versucht die Basiswiderstände wegzulassen. Und es
>> funktioniert genau wie mit. Besteht da ein Problem, wenn ich die
>> weglasse?
>
> Ja, aber vielleicht wirds ja ein interessanter Test: Was brennt eher
> durch, Dein Transistor oder Dein Arduino?

Nach dem Foto sieht es so aus, dass die LED am Emitter des BC639 
angeschlossen ist. Dann braucht es keinen Basiswiderstand.

Gruß Dietrich

von Harald W. (wilhelms)


Lesenswert?

Dietrich L. schrieb:

> Nach dem Foto sieht es so aus, dass die LED am Emitter des BC639
> angeschlossen ist. Dann braucht es keinen Basiswiderstand.

Ich dachte er hätte jetzt auf die Schaltung im µC-Link umgebaut.
Gruss
Harald

von Dietrich L. (dietrichl)


Lesenswert?

Harald Wilhelms schrieb:
> Ich dachte er hätte jetzt auf die Schaltung im µC-Link umgebaut.

Wenn das so ist, hast Du natürlich recht.
Aber seine Ur-Schaltung müsste eigentlich auch funktionieren. Warum sie 
das nicht tat, bleibt noch ein Geheimnis...

Gruß Dietrich

von Harald W. (wilhelms)


Lesenswert?

Dietrich L. schrieb:

> Aber seine Ur-Schaltung müsste eigentlich auch funktionieren. Warum sie
> das nicht tat, bleibt noch ein Geheimnis...

Vielleicht Emitter und Collektor vertauscht?
Gruss
Harald

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.