Forum: Mikrocontroller und Digitale Elektronik LED-Treiber (TLC5941) Problem


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Mathias S. (merzi1993)


Angehängte Dateien:

Lesenswert?

Hallo!

Ich bin gerade dabei den LED-Treiber TLC5941 in Betrieb zu nehmen.

Als erstes wollte ich die DotCorrection (6bit) in Betrieb nehmen. Dazu 
habe ich auf meinem ATMEGA48 eine 6Bit-SoftSPI erzeugt. (Bild SPI1.png 
zeigt die mit einem Logicanalysator aufgenommene SoftSPI)

Da der TLC 16 Channels besitzt, muss dieser Vorgang 16 mal wiederholt 
werden, wie in SPI.png gezeigt wird.

Wenn ich die Spannungsversorgung trenne und wieder verbinde, leuchten 
jedes mal andere LEDs.
Wenn ich SIN permanent auf HIGH lasse, leuchten auch nicht alle LEDs.

Die Schaltung siehtfolgendermaßen aus:
MODE = 5V
SIN und SCLK sind mit der SoftSPI des ATMEGA verbunden.
XLAT ist auch mit dem ATMEGA verbunden (siehe SPI.png -> CH3)
BLANK = GND
und zwischen IREF und GND wurde ein 1.5k Widerstand verwendet.

Programm befindet sich im Anhang.

Woran könnte es liegen, dass die LEDs nicht leuchten wie erwartet bzw. 
das sie nach trennen der Stromversorgung immer anders leuchten?

Gruß

von Karl H. (kbuchegg)


Lesenswert?

Mathias S. schrieb:

> Programm befindet sich im Anhang.

Machs für erste Tests nicht zu kompliziert

  MODE auf 1
  SIN auf 1 setzen
  96 mal SCLK toggeln
  XLAT toggeln

  MODE auf 0
  SIN auf 1 setzen
  192 mal SCLK toggeln
  XLAT toggeln

und alle LED müssten an sein

> Woran könnte es liegen, dass die LEDs nicht leuchten wie erwartet bzw.
> das sie nach trennen der Stromversorgung immer anders leuchten?

Der Inhalt der Schieberegister im TLC ist zufällig
Die Dot-Correction ist nur eine Korrektur des Stromwertes. Die 
Helligkeit stellst du im Grayscale Modus ein. Dann siehst du dir an, ob 
alle LED gleich hell leuchten und kannst über die Dot-Correction da 
Helligkeitskorrekturen vornehmen.

D.h. du willst erst mal den Grayscale Modus in Betrieb nehmen

: Wiederhergestellt durch User
von MagIO (Gast)


Lesenswert?

Hat der denn einen Speicher in dem die dot-correction dauerhaft 
hinerlegt wird? Ich würde doch mal davon ausgehen, dass man solche 
Einstellungen im uC speichern muss, oder?

von MagIO (Gast)


Lesenswert?

Ok, laut datasheet hat der TLC5941 KEIN EEPROM zum speichern der dot 
correction, der TLC5940 dagegen hat EEPROM.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.