Forum: Analoge Elektronik und Schaltungstechnik LTSpice-Simulation mit TL071 Modell fehlerhaft


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Spicer (Gast)


Angehängte Dateien:

Lesenswert?

Hallo,

für die Realisierung eines Pegelumsetzers (Levelshifter von +-10V zu 
0...+3,2V) habe ich die angefügte Schaltung mit LTSpice (Version 4.14h) 
aufgebaut und simuliert.

Als OPV verwende ich einen TL071. Das Modell habe ich von 
TexasInstrument.
(http://www.ti.com/product/tl071#simulationmodels)

Laut Datenblatt hat jeder Verstärker einen Versorgungsstrom von Typ 
1,4mA Max 2,5mA. Also in der Schaltung mit 3 OPVs maximal 7.5mA.

Die Messung der Versorgungsstroms (der OPVs) I_vcc1 ergibt einen Strom 
von 35mA ??? Also viel zu viel.

Ich kann mir kaum vorstellen, dass das Modell von TI fehlerhaft ist. 
Aber was könnte das Problem sein?

Hat vielleicht jemand ein anderes LTSpice-Modell des TL071?

Vielen Dank im Voraus!

von Helmut S. (helmuts)


Lesenswert?

Hallo,
in dem von dir angehängten Modell ist ein Widerstand mit 2,14kOhm 
zwischen den Versorgungspins. Das gibt 11mA Versorgungsstrom. Ändere 
diesen Widerstand auf den Wert deiner Wahl.

RP    3  4 2.143E3





* TL071 OPERATIONAL AMPLIFIER "MACROMODEL" SUBCIRCUIT
* CREATED USING PARTS RELEASE 4.01 ON 06/16/89 AT 13:08
* (REV N/A)      SUPPLY VOLTAGE: +/-15V
* CONNECTIONS:   NON-INVERTING INPUT
*                | INVERTING INPUT
*                | | POSITIVE POWER SUPPLY
*                | | | NEGATIVE POWER SUPPLY
*                | | | | OUTPUT
*                | | | | |
.SUBCKT TL071    1 2 3 4 5
*
  C1   11 12 3.498E-12
  C2    6  7 15.00E-12
  DC    5 53 DX
  DE   54  5 DX
  DLP  90 91 DX
  DLN  92 90 DX
  DP    4  3 DX
  EGND 99  0 POLY(2) (3,0) (4,0) 0 .5 .5
  FB    7 99 POLY(5) VB VC VE VLP VLN 0 4.715E6 -5E6 5E6 5E6 -5E6
  GA    6  0 11 12 282.8E-6
  GCM   0  6 10 99 8.942E-9
  ISS   3 10 DC 195.0E-6
  HLIM 90  0 VLIM 1K
  J1   11  2 10 JX
  J2   12  1 10 JX
  R2    6  9 100.0E3
  RD1   4 11 3.536E3
  RD2   4 12 3.536E3
  RO1   8  5 150
  RO2   7 99 150
  RP    3  4 2.143E3
  RSS  10 99 1.026E6
  VB    9  0 DC 0
  VC    3 53 DC 2.200
  VE   54  4 DC 2.200
  VLIM  7  8 DC 0
  VLP  91  0 DC 25
  VLN   0 92 DC 25
.MODEL DX D(IS=800.0E-18)
.MODEL JX PJF(IS=15.00E-12 BETA=270.1E-6 VTO=-1)
.ENDS

von Spicer (Gast)


Lesenswert?

Hallo Helmut,

vielen Dank für die schnelle Antwort. Dein Lösungsvorschlag funktioniert 
sehr gut.

Ich habe jetzt durch Variation des Widerstands Rp den Versorgungsstrom 
auf den im Datenblatt angegebenen Wert gestellt.

Vcc     = +-15V
Icc_max(pro Amp, no load) = 2.5mA

-> Rp = 12kOhm

Dennoch ziemlich merkwürdig... Ich hätte erwartet das mir Texas 
Instruments ein Modell liefert, welches ich nicht noch per Hand 
editieren muss.

Ist denn der Versorgungsstrom nicht auch noch von anderen Faktoren 
abhängig? Last, Ausgangsspannung. Das wird ja dann anscheinend gar nicht 
berücksichtigt.

Viele Grüße.

von Kai K. (klaas)


Lesenswert?

>Ist denn der Versorgungsstrom nicht auch noch von anderen Faktoren
>abhängig? Last, Ausgangsspannung. Das wird ja dann anscheinend gar nicht
>berücksichtigt.

Richtig.

Ganz viele Feinheiten werden übrigens nicht modelliert, zum Beispiel, 
wie sich der OPamp verhält, wenn die Eingangsspannung die 
Versorgungsspannung übersteigt.

Wie die Erfahrung lehrt, liegen Simulationen oft völlig daneben. Eine 
Simulation kann ein echtes Prototyping also niemals ersetzen. Ich kann 
nur davor warnen, eine Simulation immer als "genügend real" 
einzuschätzen.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.