Forum: PC Hard- und Software Ubuntu: Bildschirmauflösung "gewaltsam" einstellbar?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Jochen (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Linuxer

Habe "Surfix" (http://www.heise.de/download/ct-surfix-1185970.html)
Ubuntu auf einen bootfähigen USB- Stick geladen.

Funktioniert auf meinen beiden Nootebooks mit unterschiedlichen 
Bildschirm-
auflösungen einwandfrei.

Auf meinen 3 Desktop PCs läuft der Stick nur mit VGA- Auflösung.

Unter Systemeinstellung- Anzeigegeräte erscheint nur "Laptop" und im
Drop- Down Menü ist nur die VGA- Auflösung eingetragen d.h. keine höhere 
Auflösung wählbar.

Als Newbie in Linux haben mir die Empfehlungen in den einschlägigen 
Foren nicht geholfen bzw. waren für mich nicht nachvollziebar.

Gibt es unter Linux evt. eine editierbare Datei, in der man die 
Auflösung einstellen kann?

von Mathias B. (mbr)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

probiers mal in der Shell mit
xrandr --output <Dein Bildschirm, z.B. VGA2> --mode <welche Auflösung 
möchtest Du 1280x1024>
für mögliche Optionen auch

xrandr --help

viele Grüße

von Jochen (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke Mathias, mit dem xrandr- Befehl habe ich schon erfolglos 
rumlaboriert.

Wo finde ich unter Linux, wie mein Ausgabebildschirm ("Dein Bildschirm") 
heißt?

von linuxianer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Jochen schrieb:
> Wo finde ich unter Linux, wie mein Ausgabebildschirm ("Dein Bildschirm")
> heißt?

xrandr verrät dir das, einfach mal, wie bereits empfohlen, die Hilfe zu 
dem Tool lesen...

von +/-5% (Gast)


Bewertung
0 lesenswert
nicht lesenswert
linuxianer schrieb:
> Jochen schrieb:
>> Wo finde ich unter Linux, wie mein Ausgabebildschirm ("Dein Bildschirm")
>> heißt?
>
> xrandr verrät dir das, einfach mal, wie bereits empfohlen, die Hilfe zu
> dem Tool lesen...

Sicher? klar man kann den X! screen waehlen und manip., aber Infos zum 
Geraet gibt es nicht.

Mit ddcprobe gibt es mehr zur Hardware

ddcprobe ->

(Beispiel, meiner alten Gurke)
------------------------

snipp

Standard timing 0: 60 Hz, 1280x1024
Standard timing 1: 72 Hz, 1024x768
Standard timing 2: 75 Hz, 1152x864
Detailed timing 0:
        Pixel clock: 108000000
        Horizontal active time (pixel width): 256
        Horizontal blank time (pixel width): 1432
        Vertical active time (pixel height): 0
        Vertical blank time (pixel height): 1066
        Horizontal sync offset: 48
        Horizontal sync pulse width: 112
        Vertical sync offset: 3
        Vertical sync pulse width: 1
        Dimensions: 376x301
Monitor details 2:
        Timing ranges: horizontal = 31 - 83, vertical = 56 - 75
Monitor details 3:
        Name: Belinea1975S


-----------------------


Evtl. hilft es dir weiter.

von +/-5% (Gast)


Bewertung
0 lesenswert
nicht lesenswert
+/-5% schrieb Zeugs so.

Satz vergessen, Gedanken ueber das was er machen soll kann ich mir ja 
erst machen wenn ich weiss was das Ding kann, oder?

In der Xorg.conf Version-XY gibt es bestimmt eine DDC-irgendwas option.
man xorg.conf

von linuxianer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
+/-5% schrieb:
> Sicher?

ganz sicher!

von +/-5% (Gast)


Bewertung
0 lesenswert
nicht lesenswert
linuxianer schrieb:
> +/-5% schrieb:
>> Sicher?
>
> ganz sicher!

Muss mal bei Gelegenheit schauen.

Aber gerade wieder eingefallen. EDID, Extended Display Identification 
Data heisst das. Bei manchen Karten bzw. deren Treibern, jdf. vor ein 
paar Jahren, musste man das zu Fuss aktivieren.

Denn eigentlich will er ja nicht "gewaltsam einstellen", waere doch 
schoener wenn das automatisch ...

von Jochen (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Tja, das wird halt wieder ebenso kryptisch wie die Hilfen in anderen 
Foren.
Ein eingefleischter Linuxer kann sich wahrscheinlich in die Gedankenwelt 
eines Linux Newbie nicht mehr hineindenken....

Ich kriege nur das:

ctsurfix@ctsurfix:~$ ddcprobe
bash: ddcprobe: Kommando nicht gefunden.

von Εrnst B. (ernst)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Jochen schrieb:
> Tja, das wird halt wieder ebenso kryptisch wie die Hilfen in anderen
> Foren.

Sag das doch gleich, dass du eine nicht-kryptische Hilfe willst....

Systemeinstellungen - Bildschirm - Auflösung wählen - Speichern.

Mag aber je nach ubuntu-"Geschmacksrichtung" anders aussehen.

von ein Gast (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich vermute eher dass die Grafikkarte nicht korrekt erkannt wurde, und X 
das vga Modul nutzt, was dann auch nur VGA Auflösung kann.

Poste doch mal die Ausgabe von:

sudo grep LoadModule /var/log/Xorg.0.log

von Thomas K. (rlyeh_drifter) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Also wenn du etwas gewaltsames willst fällt mir sofort manuelles 
editieren der xorg.conf ein ;-)

Du kannst versuchen dir eine ModeLine zu schreiben, das sieht dann in 
etwa so aus:
Section "Monitor"
        Identifier   "0-CRT1"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1280x1024"
        Modeline "1280x1024@75" 156.43 1280 1312 1904 1936 1024 1043 1056 1076
EndSection

Da kann man die timings genau angeben, wo du die für deinen Monitor 
herkriegst weiß ich jedoch auch nicht. Probier doch mal nur die Option 
PreferredMode

Aber poste doch mal deine Xorg.0.log aus /var/log

: Bearbeitet durch User
von foobar (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ein Gast schrieb:
> Ich vermute eher dass die Grafikkarte nicht korrekt erkannt wurde, und X
> das vga Modul nutzt, was dann auch nur VGA Auflösung kann.
>
> Poste doch mal die Ausgabe von:
>
> sudo grep LoadModule /var/log/Xorg.0.log

Auch meine Vermutung

von +/-5% (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> Also wenn du etwas gewaltsames willst fällt mir sofort manuelles
> editieren der xorg.conf ein ;-)

Ist doch nicht gewaltsam, ganz natuerlicher Vorgang :)

> Auf meinen 3 Desktop PCs läuft der Stick nur mit VGA- Auflösung

Es fehlen 10 Angaben, wenigstens.
Welche Karten, Monitore, Treiber und welcher X-Server.

a) vesa-treiber in xorg.conf festlegen, als Aufloesung die kleinste 
Gemeinsame.
b) richtig machen, entsprechend die Treiber vorhalten und EDID Daten der 
Monitore lesen. wenn ddcprobe nicht funktioniert fehlt eben ein 
entsprechendes Paket.

Gibt es ein "Surfix"-Forum oder Homepage?

von Arno (Gast)


Bewertung
0 lesenswert
nicht lesenswert
...und wenn die Grafikkarte zwar korrekt erkannt wird, der Monitor aber 
nicht (auch das gibts) helfen Einträge für den Monitor in der xorg.conf. 
Alternativ kann man mit xrandr auch ModeLines festlegen. Generieren kann 
man diese ModeLines übrigens wunderbar mit 
http://xtiming.sourceforge.net

Hilft auch, wenn man (z.B. damit Flash nicht so weit hochskalieren muss) 
den schicken Full-HD-Bildschirm gerne mit 960x540 fahren möchte, der 
Bildschirm der Grafikkarte aber nicht mitteilt, dass er das kann.

MfG, Arno

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
linuxianer schrieb:
> +/-5% schrieb:
>> Sicher?
>
> ganz sicher!

Z. B. hier, ein Schleppi mit angeschlossenem VGA-Monitor:
% xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
LVDS connected 1280x1024+0+0 (normal left inverted right x axis y axis) 305mm x 228mm
   1400x1050      60.0 +
   1280x1024      59.9* 
   1280x960       59.9  
   1280x854       59.9  
   1280x800       59.8  
   1280x720       59.9  
   1152x768       59.8  
   1024x768       59.9  
   800x600        59.9  
   848x480        59.7  
   720x480        59.7  
   640x480        59.4  
S-video disconnected (normal left inverted right x axis y axis)

Wenn dort aber nur 640x480 drin steht, dann wird es wohl so sein wie
befürchtet, dass auf irgendeine Art Standardtreiber für die Grafik
zurückgefallen worden ist.

von Jochen (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ja Ernst, wie gleich eingangs geschrieben, funktioniert die grafische 
Einstellung nicht: Keine andere Auflösung als VGA aufgführt in der Drop- 
Down Liste.

Gast: Hier mal das Ergebni:

ctsurfix@ctsurfix:~$ sudo grep LoadModule /var/log/Xorg.0.log
[    39.711] (II) LoadModule: "extmod"
[    39.776] (II) LoadModule: "dbe"
[    39.802] (II) LoadModule: "glx"
[    39.841] (II) LoadModule: "record"
[    39.850] (II) LoadModule: "dri"
[    39.872] (II) LoadModule: "dri2"
[    39.885] (II) LoadModule: "intel"
[    39.918] (II) LoadModule: "vesa"
[    39.934] (II) LoadModule: "fbdev"
[    39.972] (II) LoadModule: "fbdevhw"
[    39.988] (II) LoadModule: "fb"
[    40.025] (II) LoadModule: "shadow"
[    41.245] (II) LoadModule: "evdev"
ctsurfix@ctsurfix:~$

von Albrecht H. (alieninside)


Bewertung
0 lesenswert
nicht lesenswert
Also "xrandr" ist schon der richtige Weg, bei mir wird der Monitor auch 
nicht richtig erkannt weil bei meinen VGA-Kabel nicht alle Pins belegt 
sind.

Mit xrandr kann ich aber trotzdem die gewünschte Auflösung und 
Bildwiederholfrequenz einstellen indem ich im Terminal folgende 
Kommandos nacheinander ausführe:

xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA1 "1280x1024_60.00"
xrandr --output VGA1 --mode "1280x1024_60.00"


Der Text zwischen den Anführungszeichen "1280x1024_60.00" ist der Name 
für meine neue Auflösung, die dafür erforderlichen Daten in der ersten 
Zeile habe ich von einem "Modeline-Generator" aus dem Internet, wobei 
diese Konfiguration jetzt schon seit Ewigkeiten an jedem Monitor 
funktioniert der 1280x1024 mit 60Hz kann.

"VGA1" passt jetzt halt gerade für meinen Computer, bei einem anderen 
Gerät bzw.einer anderen Grafikkarte muss da eventuell auch "VGA2", 
"VGA-1", "VGA-2", "HDMI-1", "HDMI-2", "HDMI1" oder irgendetwas ganz 
anderes stehen.

Braucht man eine andere Auflösung, bzw. Bildwiederholfrequenz, so ist 
eine neue "Modeline" in der ersten Zeile erforderlich, es reicht also 
nicht aus einfach nur den Namen der Auflösung in z.B. "1920x1080_70.00" 
zu ändern!

Wenn die Umschaltung der Auflösung funktioniert hat, kann man das auch 
dauerhaft abspeichern, indem man die obigen Zeilen in einer Text-Datei 
namens ".xprofile" im jeweiligen Benutzerorder abspeichert.

Natürlich lassen sich diese Zeilen auch in einer ausführbaren 
Batch-Datei abspeichern, ich persönlich bevorzuge aber die 
".xprofile"-Methode.

: Bearbeitet durch User
von Jochen (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Albrecht

Schon nach Eingabe der 1. Befehlszeile bekomme ich Fehlermeldungen:

ctsurfix@ctsurfix:~$ xrandr --newmode "1280x1024_60.00"  109.00  1280 
1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  19
  Current serial number in output stream:  19
ctsurfix@ctsurfix:~$

von ein Gast (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Also die LoadModule Zeilen sagen dass er versucht das intel Modul zu 
laden.
Das schlägt dann aber wahrscheinlich fehl.
Guck doch mal was um diese LoadModule Zeile drum herum steht, da wird 
wahrscheinlich ein Fehler auftreten. (Fehler erkennt man am (EE))

von Jay W. (jayway)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe einen etwas älteren TFT-Monitor (nativ 1280×1024 Pixel) der 
unter (*)ubuntu und anderen neueren Linuxen nur mit einer Auflösung von 
1024×768 oder 1152x??? unterstützt wird. Unter Windows (da funktioniert 
er einwandfrei) habe ich mir deshalb die Daten für eine 
Modeline-Änderung geholt und diese mittels xrandr eingebunden. Beim 
Aktivieren der geänderten Modeline wird aber ein CRTC 0 – Fehler vom 
X-Server zurückgeschickt. Recherchen haben ergeben, dass das fehlerhafte 
Auslesen der Monitordaten durch den X-Server die Ursache dafür ist. 
Abhilfe schafft man, in dem man auf einer funktionierenden Installation, 
die RAW-Monitordaten ausliest und diese dann als Custom-EDID an den 
X-Server verfüttert.
Kurzablauf

1.   Unter einer laufenden Konfiguration eine RAW-Datei mit den 
Monitordaten erzeugen. (Windows: moninfo oder powerstrip; Linux: 
read-edid-tools)

2.    Mittels X -configure eine xorg.conf.new erzeugen. (XServer darf 
nicht laufen: Alt + F1 und dann sudo stop (g/x/k)dm)

3.    Die im home-Verzeichnis erzeugt xorg.conf.new editieren und in der 
Device Section: „Option „CustomEDID“ „CRT-1:/pfad/zur/custom.edid“ und 
in der „Screen“ Section: „DefaultDepth 16“ eintragen. Danach als 
xorg.conf nach /etc/X11 kopieren.

4.    Mittels „sudo start (g/x/k)dm“ den XServer wieder starten.

5.    Falls es gar nicht läuft, die xorg.conf löschen, schon werden die 
Standardskripte wieder genutzt.

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
ein Gast schrieb:
> Guck doch mal was um diese LoadModule Zeile drum herum steht

Oder einfach mal das komplette X-Server-Log hier als Anhang hochladen.
Da sollten doch eigentlich keine sensitiven Informationen drin stehen.

von Jochen (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke, danke für Eure Mühe! Bleibe wohl doch noch eine Weile Linux Dau 
und muß mich erst mal weiter in die Grundlagen einarbeiten, damit ich 
Eure Vorschläge verstehen und auch ausführen kann. Hoffentlich werde ich 
so alt, daß mir das noch gelingt...

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Jochen schrieb:
> damit ich Eure Vorschläge verstehen und auch ausführen kann.

Naja, /var/log/Xorg.0.log hier als Anhang zu posten, sollte dir aber
auch ohne weitere Einarbeitung relativ schnell gelingen. ;-)

von +/-5% (Gast)


Bewertung
0 lesenswert
nicht lesenswert
> Hoffentlich werde ich so alt, daß mir das noch gelingt...

Das keiner deine Hard&Software kennt ist dir aber klar?
Anfangen, dranbleiben.

> bash: ddcprobe: Kommando nicht gefunden.

Das stammt aus dem Paket xresprobe. ->
(sudo) apt-get install <package_name>
Eigentlich super einfach. Aaaber wie immer Tuecke im Details.

(Zb. auf deinem -modifizierten surfix Ubuntu- weiss keiner wie die 
Rechte verteilt sind, CT sollte man annehmen wird das irgendwo 
dokumentiert haben)



------------------------------

(x)randr liest seit Vers. 1.2 EDID (Treiberunbhaengig)
Aber nicht alle aelteren Treiber, bes. wohl Invidias unterstuetzen halt 
randr ...





have fun

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.