Forum: Analoge Elektronik und Schaltungstechnik Step-Down Leistung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Elektor (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich habe bei Texas Instruments über den webench designer einen Step-Down 
Konverter dimensioniert. Habe das ganze jetzt auf dem Steckbrett 
aufgebaut leider passt aber der Strom nicht ich kann ca. max. 100mA 
rausziehen, wobei laut dem Datenblatt und dem Dimensionierungsvorschlag 
von TI ca. 1A bei 3,3V sein sollte.


Habe ich irgendwas übersehen?  Hat einer ne Idee ?

: Verschoben durch Admin
von Manateemoo (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Aufbau auf Steckbrett ist nicht optimal?
Speicherdrossel sättigt?

von (prx) A. K. (prx)


Bewertung
0 lesenswert
nicht lesenswert
Switcher auf Steckbrett ist keine gute Idee. Erst recht kein 260kHz 
Switcher. Datasheet lesen, da steht hinten was übers Layout drin.

: Bearbeitet durch User
von Elektor (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Manateemoo schrieb:
> Aufbau auf Steckbrett ist nicht optimal?
> Speicherdrossel sättigt?

Steckbrett Aufbau ist natürlich nicht mit dem aufbau auf einer Platine 
zu vergleichen, aber ich möchte halt ganz sicher gehen das ich dann auch 
ca. 1 A ziehen kann.


Ist die Schaltung den soweit korrekt bzw. das IC ist doch bis 1A 
ausgelegt.

Oder hat es damit was zutun das meine Eingangspannung relativ hoch ist 
24V DC.


als Spule verwende ich diese 
http://de.farnell.com/jsp/search/productdetail.jsp?SKU=2061674 Isat 
liegt bei 1,5A das dürfte reichen oder?


Was könnte ich noch überprüfen bzw. messen?

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Elektor schrieb:
> auf dem Steckbrett
Hat schon ein einzelner Steckkontakt viel mehr Übergangswiderstand als 
deine Spule Innenwiderstand... :-o

Zum Aufbau eines Schaltreglers mit einem viertel Megahertz:
sieh dir das mal an und denk drüber nach...
http://www.lothar-miller.de/s9y/categories/40-Layout-Schaltregler

Elektor schrieb:
> Ist die Schaltung den soweit korrekt bzw. das IC ist doch bis 1A
> ausgelegt.
Du hast doch die Webbench. Das passt schon, was die ausrechnet...
Aber 1A auf Dauer macht das Ding sicher hübsch heiß.

: Bearbeitet durch Moderator
von mknoelke (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Selbst mit einem sorgfältigen Lochrasteraufbau hätte man seine liebe Not 
das halbwegs zum laufen zu bringen.
Doch Du kannst das wirklich glauben: Steckbrett geht nicht.

Bei schnellen Schaltern ist alles R+L+C in unterschiedlichen 
Gewichtungen.
2 cm Draht werden zur Spule, 2 Steckreihen zum Kondensator.

Schau Dir das mit einem Oszi an, dann wirst Du es sehen.

Wenn Du Dich halbwegs an die Layoutvorschriften hältst und den 
Bauteilempfehlungen folgst kannst Du nicht viel falsch machen.
1A ist wirklich noch kein Aufriss.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
mknoelke schrieb:
> 2 cm Draht werden zur Spule
Wie heißt es so schön im angelsächsischen Sprachraum: Each mm has its 
nH.

von Elektor (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> Elektor schrieb:
>> auf dem Steckbrett
> Hat schon ein einzelner Steckkontakt viel mehr Übergangswiderstand als
> deine Spule Innenwiderstand... :-o
>
> Zum Aufbau eines Schaltreglers mit einem viertel Megahertz:
> sieh dir das mal an und denk drüber nach...
> http://www.lothar-miller.de/s9y/categories/40-Layo...
>
> Elektor schrieb:
>> Ist die Schaltung den soweit korrekt bzw. das IC ist doch bis 1A
>> ausgelegt.
> Du hast doch die Webbench. Das passt schon, was die ausrechnet...
> Aber 1A auf Dauer macht das Ding sicher hübsch heiß.

Vielen Dank für die Tipps bzw. Erklärung.


Also der Schaltplan ist zu 100% aus dem Webbench übernommen die Bauteile 
sind von den spezifikationen identisch nur die Bauform wurde von mir 
angepasst z.B. statt R 0805 R 0603.

Auf dem Steckbrett bekomme ich nur knapp 100 mA bei 24V DC 
Eingangsspannung raus wenn ich die Eingangspannung auf z.B. 5V reduziere 
dann bekomme ich ca. 680mA raus bei 3.3V. (war nur ein Test Steckbrett 
funktioniert ja sowieso nicht und auf der Platine habe ich 24V DC 
Eingangsspannung).


Mir geht es nur darum das wenn ich das so auf meine Platine übernehme 
sollte es stabil 3.3V liefern bei max. 1A.


Ich habe mal das Layout erstellt mit den Hinweisen vom Datenblatt und 
http://www.lothar-miller.de/s9y/categories/40-Layout-Schaltregler.


Was meint ihr wird es so funktionieren? Gibt es noch was zu verbessern ?

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Elektor schrieb:
> Ich habe mal das Layout erstellt mit den Hinweisen vom ...
> http://www.lothar-miller.de/s9y/categories/40-Layout-Schaltregler.
Warum hast du die Regeln nicht beachtet?
Zeichne die Stromkreise ein und beachte dabei, dass sich der Strom 
auch über die Masse erst mal einen Weg suchen muss!
Da hat sogar jemand ein Video dazu gemacht:
http://www.youtube.com/watch?v=WMMNxUSTw4E

> das Layout
Hast du da mal den Schaltplan dazu (Bauteilnamen)?

: Bearbeitet durch Moderator
von (prx) A. K. (prx)


Bewertung
0 lesenswert
nicht lesenswert
Im Datasheet gibts ein fertiges Layout.

von Helge A. (besupreme)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Mir scheint auf den ersten Blick, der Strompfad für die Diode ist stark 
verbesserungsfähig.

Ich halte auch 10mil Leiterbahnen für 1A etwas dünne.

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
mknoelke schrieb:

> Selbst mit einem sorgfältigen Lochrasteraufbau hätte man seine liebe Not
> das halbwegs zum laufen zu bringen.

Wenn man den Layoutvorschlag im Datenblatt mit passend gebogenen
Drähten nachbildet, sollte das eigentlich keinen Unterschied machen.

> Wenn Du den Bauteilempfehlungen folgst...

Die meisten Fehler werden da bei der Wahl der richtigen Drossel gemacht.
Gruss
Harald

von Elektor (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> Elektor schrieb:
>> Ich habe mal das Layout erstellt mit den Hinweisen vom ...
>> http://www.lothar-miller.de/s9y/categories/40-Layo....
> Warum hast du die Regeln nicht beachtet?
> Zeichne die Stromkreise ein und beachte dabei, dass sich der Strom
> auch über die Masse erst mal einen Weg suchen muss!
> Da hat sogar jemand ein Video dazu gemacht:
> Youtube-Video "Aufgeschraubt #13: Schaltregler-Layout mit Stromschleifen
> optimieren [HD]"
>
>> das Layout
> Hast du da mal den Schaltplan dazu (Bauteilnamen)?

Hier ist der Schaltplan.


Aber sehe ich das richtig das mein Layout so funktionieren würde bei 24V 
DC Eingang und 3.3V Ausgang bei ca. 1A? Das wäre für mich fatal wenn ich 
die Platine bestelle und stelle dann fest das ich nur 100mA aus dem 
Regler ziehen kann (wie ich es auf dem steckboard gehabt habe)


Wäre super wenn einer noch mal drüber schauen kann.


Danke!

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Elektor schrieb:
> Das wäre für mich fatal wenn ich
> die Platine bestelle und stelle dann fest das ich nur 100mA aus dem
> Regler ziehen kann

Deine Kondensatoren sind von der Bauformk her sehr klein, denk dran daß 
diese Kondensatoren auch Verluste haben und diese Verlustleistung in 
Wärme abgeführt werden muss.

Suche also Kondensatoren die auch für 1A bei 250kHz ausgelegt sind. Ja, 
auch Kondensatoren haben Datenblätter.

Die Masseführung könnte man verbessern.

von Frank M. (frank_m35)


Bewertung
0 lesenswert
nicht lesenswert
Wenn du dir so unsicher bist, warum baust du es dann nicht auf einer 
Lochrasterplatine bzw. SMD Platine auf? Halt nicht auf einem Steckbrett 
^^

Der Schaltplan sieht ok aus.

Was jedoch viel wichtiger ist, ist der spätere Aufbau, d.h. wo sind die 
Bauteile platziert, wie sind sie miteinander verbunden und welche 
Bauteile verwendest du überhaupt.
Auch wenn du es auf einer Lochrasterplatine aufbaust musst du das 
unbedingt beachten und kannst nicht 5cm lange Kabel verwenden!

Im Datenblatt ein ein Beispiellayout, halte dich da dran. Dein 
gepostetes Leiterplattenlayout ist unbrauchbar.
Du verwendest die SOIC Bauform, die hat keine Kühlfläche unterhalb des 
Gehäuses, sondern wird über Pin 2 und 3 gekühlt, wie im Beispiellayout 
ersichtlich. Bei dir sind sie nicht angeschlossen, der IC wird 
überhitzen und runterregeln.

Cout muss ein Low ESR Kondensator sein!
An den Eingang solltest du auch noch parallel zu den 
Keramik-Kondenatoren einen gewöhnlichen Elektrolyt-Kondensator setzen 
(kein Low ESR).

von Elektor (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Frank M. schrieb:
> Wenn du dir so unsicher bist, warum baust du es dann nicht auf
> einer
> Lochrasterplatine bzw. SMD Platine auf? Halt nicht auf einem Steckbrett
> ^^
>
> Der Schaltplan sieht ok aus.
>
> Was jedoch viel wichtiger ist, ist der spätere Aufbau, d.h. wo sind die
> Bauteile platziert, wie sind sie miteinander verbunden und welche
> Bauteile verwendest du überhaupt.
> Auch wenn du es auf einer Lochrasterplatine aufbaust musst du das
> unbedingt beachten und kannst nicht 5cm lange Kabel verwenden!
>
> Im Datenblatt ein ein Beispiellayout, halte dich da dran. Dein
> gepostetes Leiterplattenlayout ist unbrauchbar.
> Du verwendest die SOIC Bauform, die hat keine Kühlfläche unterhalb des
> Gehäuses, sondern wird über Pin 2 und 3 gekühlt, wie im Beispiellayout
> ersichtlich. Bei dir sind sie nicht angeschlossen, der IC wird
> überhitzen und runterregeln.
>
> Cout muss ein Low ESR Kondensator sein!
> An den Eingang solltest du auch noch parallel zu den
> Keramik-Kondenatoren einen gewöhnlichen Elektrolyt-Kondensator setzen
> (kein Low ESR).

Habe jetzt das Layout nochmal angepasst. Wird es so funktionieren wenn 
ich 24 V DC einspeise und am Ausgang 3.3V bei ca. 1A entnehme.


Oder sieht Jemand noch einen Fehler mich wundert es nur das ich bei 
meinem Aufbau auf dem Steckbrett nur 100mA entnehmen kann?! Liegt es 
wirklich am Aufbau oder ist vllt das IC nur bis 100mA ausgelegt?

Zudem wie kann ich die Brummspannung am besten reduzieren?

von Frank M. (frank_m35)


Bewertung
0 lesenswert
nicht lesenswert
Elektor schrieb:
> Habe jetzt das Layout nochmal angepasst. Wird es so funktionieren wenn
> ich 24 V DC einspeise und am Ausgang 3.3V bei ca. 1A entnehme.
Nein, funktioniert nicht. Viel geändert hast du ebenfalls nicht. Die 
Spule ist immer noch an der falschen Stelle, genauso wie so ziemlich 
alle anderen Bauteile.
Die Bauformen von C49 und C50 können niemals geeignet sein. Viel zu 
klein für diese Spannung und Werte.
Den Elektrolyt hast du auch weg gelassen. Kannst du zwar, aber vor allem 
wenn die 24 V Steckbar sind brauchst du ihn.

> Zudem wie kann ich die Brummspannung am besten reduzieren?
Ein gescheiter Aufbau. Deine Platine wird so niemals effizient arbeiten 
können.

Nochmal:
Datenblatt Seit 20. Übernimm 1:1 die Bauteilplatzierung. Dann route es 
und verschiebe die Bauteile ein bisschen bis alles passt.
Nimm Polygone, deaktivere Thermals. Das Layout sollte so aussehen wie im 
Datenblatt, fette flächige Verbindungen. Vor allem im Eck 
Spule-Diode-IC.

Mach auch mal eine Stückliste. Spule, Diode und IC wissen wir nun schon. 
Aber die Kondensatoren sehen einfach ungeeignet aus. Gib mal genaue 
Typen an!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.