Forum: Analoge Elektronik und Schaltungstechnik Störungen im Verstärker LM386


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Gerdchen03 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hi,

zunächst möchte ich vorausschicken, dass ich noch am Anfang meiner 
Elektronikerkarriere stehe, und daher noch nicht soooo viel Erfahrung 
habe. Also bitte die leichenhaften Formulierungen entschuldigen, ich bin 
noch am Lernen!

Was möchte ich bauen?
Ich möchte eine Platine für einen Raspberry Pi bauen, auf der ein 
kleiner Verstärker mit Poti für die Lautstärkenregelung und ein 
Spannungswandler sitzen. Der Spannungswandler soll die 12 V 
Versorgungsspannung auf 5 V für den Raspberry reduzieren, und der 
Verstärker soll das Audiosignal aus dem Klinkenstecker verstärken, so 
dass ein Lautsprecher angeschlossen werden kann. Als Verstärker dient 
ein LM386 und als Spannungsregler ein LM2575.

Wenn ich die Platine auf dem Raspberry aufsetze und den Klinkenstecker 
einstecke, höre ich quasi den Prozessor (vielleicht ist es auch was 
anderes) im Lautsprecher. Ziehe ich den Klinkenstecker heraus, höre ich 
nichts. Mit dem Oszi habe ich festgestellt, dass die Versorgungsspannung 
des LM386 „zittert“ und dieses „Zittern“ höre ich wahrscheinlich im 
Lautsprecher. Das „Zittern“ messe ich, egal ob der Klinkenstecker 
eingesteckt ist oder nicht. Wenn ich alle Kabel entferne, die ggf. als 
Antenne wirken könnten, und auch denn LM386 entferne, sehe ich im Oszi 
dennoch das „Zittern“ der Spannung. Also vermute ich mal, dass die 
Geräusche, die ich höre, von der Versorgungsspannung kommen. Ich 
vermute, ich muss den LM2575 stabilisieren. Ein Freund schlug mir vor, 
in die Versorgungsspannung des LM2575 eine 10mH Spule zu setzen, und 
anschließend von +5V zu Masse zwei Kondensatoren parallel zu schalten: 
KeKo 100nF und Tantal 100µF.

Das Resultat ist bescheiden. Ich bemerke keine Verbesserung. Hat jemand 
einen Tip für mich?
Sollten noch Angaben fehlen, bitte Bescheid geben, ich liefere sie dann 
nach!

Danke
Gerd

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Nun, du hast vermutlich richtig analysiert, daß der Schaltregler LM2575 
den Audioverstärker LM386 stört und diese Störung über die 
Versorgungspsannung kommt, übrigens sind das immer Plus und Masse.

Ich nehme an, der LM386 nutzt die 12V die auch in den LM2575 gehen, 
obwohl so ein LM386 ja auch die 5V nutzen könnte.

Woher kommt deine Versorgungspannung? Aus einem Steckernetzteil oder 
Bleiakku ?

Dann solltest du die Quelle besser puffern. Gleich an der Stelle der 
Platine an der das Kabel mit den 12V ankommt, setzt du einen LowESR Elko 
von sagen wir 100uF.

Dahinter verzweigen sich sowohl Masseleitung als auch Plusleitung zum 
LM386 und LM2575. Da LEIDER die Masseletung wieder über das RPi-Board 
verbunden wird, darfst du dir keine Spannungsdifferenz auf der 
Masseleitung einfangen, also nimmst du eine extrem breite Leiterbahn, 
eine ganze Massefläche, zwischen beiden Schaltungsteilen, wie ein 
grosser Kupferfleck an den von Süd der Elko der Eingangsspannung liegt, 
nach Ost je eine Masseleitung zu jedem Anschluss des LM386 geht der 
Masse braucht, nach Nord die Masseleitung zum RPi und im Westen für 
jeden Anschluss an Masse des LM2575 auch eine Leitung geht.

Plus führst du zum LM386 in der Standardschaltung aussen von Süd nach 
Ost, eine Plusleitung von Süd aussenrum zum Schaltregler nach West. In 
diese beiden Leitungen kannst du Drosselspulen einbauen, aber eine 
"grosse" muss nicht unbedingt eine gute sein, die Drossel muss vor allem 
die Freqeunz des Schaltreglers dämpfen, dafür können grosse Spulen zu 
langsam sein. Du hast glücklicherweise ein Oszilloskop, kannst also die 
Wirkung unterschiedlicher Spulen überprüfen. Hinter der Drossel gehört 
direkt am Schaltregler und direkt am Verstärker noch ein Elko, beim 
LM386 nicht kleiner als der Ausgangselko.


Der Kupferfelck sorgt gleichzeitg noch für einen möglichst grossen 
räumlichen Abstand zwischen verstärker und Schaltreghler, die 
Schaltreglerspule sollte nicht in die Verstärkershaltung reinstreuen. Um 
deren Empfindlichkeit zu verringern, sorge in den beiden Teilschaltungen 
selbst für möglichst kurze Leiterbahnen, vor allem keine grösseren 
eingereiten Stellen.

Ja richtig, das geht nicht auf Lochraster, man braucht eine geätzte 
Leiterplatte. Aber durch edn grossen Massefleck nicht unbedingt eine 
zweiseitige.

von Gerdchen03 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo MaWin,

ich bin nicht sicher, ob ich alles korrekt verstanden habe. Daher hab 
ich es so, wie ich es verstanden habe, mal kurz skizziert. Ist es 
wirklich wichtig, dass zum LM2575 und zum LM386 zwei getrennte 
Masseleitungen führen? Wie groß sollte der ElKo am LM2575 in etwa sein? 
In welchem Bereich sollte ich mir Spulen besorgen, um zu testen?

Danke,
Gerd

von Gerdchen03 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
In der Skizze oben ist ein Fehler. 12V gehen an PIN 1 vom LM2575.

von Roland E. (roland0815)


Bewertung
0 lesenswert
nicht lesenswert
Ein Low-Res-Elko am Versorgungeingang ist völlig übertrieben. Der 
Induktive Belag der Leiterzüge macht des ESR total zu Nichte. Dort 
reicht ein StiNo-Elko mit 100...1000uF (jenachdem was das Netzteil 
abkann).

Auf jeden Fall trennt man die Versorgung (hier 12V) für den 
Audioverstärker mit einem (C)LC-Tiefpass vom digitalen Teil ab, und 
verbindet auch die Massen nur an einem Punkt.
Bei dem LC-Tiefpass macht man dann direkt an der Induktivität (darf auch 
ein Ferrit mit ordentlich Induktivität sein) 10+100 nF KerKo. Wer gern 
Hosenträger zum Gürtel trägt kann dahinter noch 1uF Keramik machen.
Wenn SMD die nF in 0805 und das uF in 1206.
Danach noch 100...330uF Elko aus der Bastelkiste. Halt mal nachrechnen, 
dass man nicht gerade einen LC-Schwinger in der Frequenz des Verstärkers 
baut. Fertig.

LoResElkos sind viel zu empfindlich gegen Alterung und Misshandlungen. 
Ausserdem hat die kaum einer in der Bastelkiste rumfliegen.

PS: Die Kapazität hinter dem LC-Tiefpass sollte auf jeden Fall groß 
genug sein, um bei Maximal zu erwartendem Strom die Spannung im 
erwarteten Zeitfenster der Belastung nicht weiter als 1V einbrechen 
lässt.

: Bearbeitet durch User
von MaWin (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Gerdchen03 schrieb:
> Daher hab ich es so, wie ich es verstanden habe, mal kurz skizziert.

So ähnlich dachte ich das.

> LoResElkos sind viel zu empfindlich gegen Alterung und Misshandlungen.

Aber gut darin einen Schaltreglereingang zu beruhigen.
Da ist ESR wichtiger als Kapazität.

von Gerdchen03 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Roland,

ich bin mir nicht sicher, ob ich die Anordnung richtig verstanden habe. 
Meinst du das so, wie ich es grob skizziert habe?

Danke

von Roland E. (roland0815)


Bewertung
0 lesenswert
nicht lesenswert
Genau.

Und auch physikalisch die Masse tatsächlich nur an einem Punkt zwischen 
"vor der Spule" und "nach der Spule" zusammenführen. Das sollte reichen, 
um den Verstärker richtig ruhig zu stellen.

von Gerdchen03 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Was ist denn der Unterschied, ob man als Induktivität eine Spule oder 
einen Ferrit nimmt? Wie hoch sollte denn die Induktivität sein, bzw. in 
welchem Bereich sollte ich beginnen auszuprobieren?

von Stefan M. (derwisch)


Bewertung
0 lesenswert
nicht lesenswert
Der LM 386 hat selbst eine starke Schwingneigung.
Mittlerweile verwende ich lieber andere ICs zur NF Verstärkung ( die zum 
Teil sogar noch einfacher in der Beschaltung sind ).
TDA 2822 oder TDA 7050 z.B.

Versuch mal deinen LM386 separat mit einer Batterie zu versorgen.
Wenn die Probleme weiterhin bestehen, dann solltest du in der 
Beschaltung des LM386 genauer nachschauen.

Der LM386 kann mit einem "Boost" Kondensator beschaltet werden ( 10µF 
zwischen Pin 1 und Pin 8 ). dann steigt die Verstärkung nochmal kräftig 
an, aber auch die Schwingneigung.
Wichtig ist beim LM386. dass man sich genau an die Beschaltung wie im 
Datenblatt hält.

Oft schwingen die LM386 ohne dass es direkt bemerkt wird.
Auch mit Boostkondensator darf im Lautsprecher / Kopfhörer kaum Rauschen 
vorhanden sein, wenn am Input kein Signal anliegt.
Wenn doch, schwingt er.
Wenn man den Input auf Masse legt, und sich dann im Rauschen eine 
Änderung ergibt, ist dies der Beweis.

: Bearbeitet durch User
von Roland E. (roland0815)


Bewertung
0 lesenswert
nicht lesenswert
Das Ferrit stellt sich durch die Umladeverluste (zu)steilen Anstiegen 
des Stroms entgegen. Innen drin oder aussen drumrum (je nach Bauform) 
ist eine "normale" Induktivität.

Das Ferrit frisst unangenehme Spitzen raus und mindert richtig 
eingesetzt die EMV-relevanten Abstrahlungen und andere Nebenwirkungen.

von Gerdchen03 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und die Spule macht das weniger effektiv?
In welcher Größenordnung sollte ich die Induktivität wählen, um meine 
Versuche zu starten?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.