Forum: Analoge Elektronik und Schaltungstechnik Problem mit MOC3041


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Jens (Gast)


Angehängte Dateien:

Lesenswert?

Hallo,
ich habe ein Verständnisproblem mit der Schaltung im Anhang. Wenn ich 
das 24V Relais ohne Optokoppler (MOC3041) an 230V anschließe, dann 
funktioniert die Schaltung. Am Relais messe ich dann ca. 18V. Wenn ich 
nun aber den Optokoppler dazwischen schalte, dann zieht das Relais nicht 
mehr an (gemessen 0V). Warum läst sich das Relais mit Optokoppler nicht 
mehr einschalten?

von MaWin (Gast)


Lesenswert?

Der Kondensator begrenzt nicht nur den Strom, er bewirkt auch eine 
deftige Phasenverschiebung.
Ein MOC3041 mit 400V ist sowieso nicht zum Einsatz an 230V Netzen 
geeignet, dafür gibt es 600V MOC3061.
Ein MOC ist sowieso nicht zum direkten Schalten von Lasten gedacht
http://www.fairchildsemi.com/ds/MO/MOC3061M.pdf
"The optoisolator should not be used to drive a load directly"
dafür gibt es SolidStateRelais wie S201D02

von Jens (Gast)


Lesenswert?

Hallo MaWin!

Danke für die Erklärung. Würde mit dem S201D02 dann nicht auch das 
gleiche Problem bestehen (im Bezug auf meine Schaltung)? Das ganze ist 
nun schon auf einer Leiterplatte aufgebaut und ich würde die Schaltung 
auch gerne „retten“. Könnte es mit einem MOC3010 funktionieren (der hat 
keine Zero-Crossing)? Wenn nein, wie könnte ich hier noch vorgehen (ohne 
alles neu auf zu bauen)?

von MaWin (Gast)


Lesenswert?

Jens schrieb:
> Könnte es mit einem MOC3010 funktionieren

Natürlich nicht, der platzt bei 230V, lest ihr eigentlich niemals 
Datebblätter, wenn schon, dann MOC3052, bei dem steht nichts von "should 
not be used".

von Jens (Gast)


Lesenswert?

> Natürlich nicht, der platzt bei 230V, lest ihr eigentlich niemals Datebblätter,

Doch schon, nur ist Englisch nicht wirklich verständlich für mich. Und 
im Datenblatt stand als erstes gleich „250 V Phototriac Driver Output“ 
und das heißt für mich dass er an 230V angeschlossen werden kann. Aber 
trotzdem Danke für den Tipp mit dem MOC3052, den werde ich dann mal 
ausprobieren.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Jens schrieb:
> und das heißt für mich dass er an 230V angeschlossen werden kann

Mach dir bitte den Unterschied von Effektivwert und Spitzenwert klar, 
bevor du den MOC3010 tötest.
Eine Sinusspannung von effektiv 230V hat eine Vss (Spitze-Spitze) von 
etwa 325V. Spitze-Spitze misst du z.B. mit einem Oszilloskop, 
Effektivwerte mit z.B. einem DMM.
Deine obige Schaltung ist recht einfach zu retten, indem du z.B. einen 
Kleinleistungstriac wie den Z0402 o.ä. mit dem MOC durchschaltest.

: Bearbeitet durch User
von Harald W. (wilhelms)


Lesenswert?

Jens schrieb:

> ich habe ein Verständnisproblem mit der Schaltung im Anhang. Wenn ich
> das 24V Relais ohne Optokoppler (MOC3041) an 230V anschließe, dann
> funktioniert die Schaltung.

Wieso muss man eigentlich ein Relais über einen MOC ansteuern?
Die Potentialtrennung macht doch schon das Relais.
Gruss
Harald
PS: Der Hund ist tot. Besser ist, wir binden ihn an.

von Michael (Gast)


Lesenswert?

Jens schrieb:
> und das heißt für mich dass er an 230V angeschlossen werden kann

Spätestens die Angabe vier Zeilen später ("Output Driver Designed for 
115 Vac") hätte dich stutzig machen sollen.

von Jens (Gast)


Lesenswert?

@Matthias Sch.

> Deine obige Schaltung ist recht einfach zu retten, indem du z.B.
> einen Kleinleistungstriac wie den Z0402 o.ä. mit dem MOC durchschaltest.

Die Phasenverschiebung durch den Kondensator besteht doch dann nach wie 
vor. Warum schaltet der MOC3041 denn dann durch? Wenn er ohne den 
zusätzlichen Z0402 nicht schaltet, warum sollte er es denn mit dem Z0402 
machen?

@Harald Wilhelms

> Wieso muss man eigentlich ein Relais über einen MOC ansteuern?

Ich brauche eine Schaltung die im ausgeschalteten Zustand kein Strom 
verbraucht und die mit einer Spannung von 3V bis 4V eingeschaltet werden 
kann. Sonst habe ich dafür ein 230V Relais mit dem Optokoppler 
geschaltet, das hat immer gut funktioniert. Keine Ahnung was mich hier 
geritten hat etwas anderes aus zu probieren.

> Der Hund ist tot. Besser ist, wir binden ihn an.

Das ist zwar ein Cooler Spruch, der Vergleich hinkt aber etwas. Viel 
mehr ist es hier eine Niere die versagt und wenn man die retten kann, 
dann darf der Hund auch weiter leben...

@Michael

> Spätestens die Angabe vier Zeilen später ("Output Driver Designed for
> 115 Vac") hätte dich stutzig machen sollen.

Ja, die hat mich dann auch Stutzig gemacht, aber erst als mich MaWin 
darauf hingewiesen hat.

von Harald W. (wilhelms)


Lesenswert?

Jens schrieb:

> Ich brauche eine Schaltung die im ausgeschalteten Zustand kein Strom
> verbraucht und die mit einer Spannung von 3V bis 4V eingeschaltet werden
> kann. Sonst habe ich dafür ein 230V Relais mit dem Optokoppler
> geschaltet, das hat immer gut funktioniert. Keine Ahnung was mich hier
> geritten hat etwas anderes aus zu probieren.

Grundsätzlich ist es schon sinnvoll, für grössere Relais 12...24V
Versorgungsspannung zu haben. Es gibt aber auch 5V-Relais, die 230V
schalten können. Den dafür sinnvollen Transistortreiber kann man mit
0,7V ansteuern. Es gibt aber auch FETs, die man mit 3...4V ansteuern
kann.
Gruss
Harald

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Jens schrieb:
> Wenn er ohne den
> zusätzlichen Z0402 nicht schaltet, warum sollte er es denn mit dem Z0402
> machen?

Weil die Ausgangsschaltung des MOC für die Ansteuerung des Triac Gates 
gemacht worden ist. An diesem liegt keine Phasenverschiebung und vor 
allem keine induktive/kapazitive Last, die für den MOC alleine das 
Problem verursacht. Du kannst evtl. sogar feststellen, das es dir 
gelingt, den MOC zwar einzuschalten, das er dann aber im 'Ein' Zustand 
'klebt'. Mit einem Triac am Ausgang passiert das nicht.
Ich schalte mit dem Z0402 z.B. einen dicken alten Metalllüfter von Pabst 
mit 100V AC, und mit einem anderen MOC und BT137 drei EVG für 
Leuchtstofflampen.

: Bearbeitet durch User
von Jens (Gast)


Lesenswert?

@Matthias Sch.

> Weil die Ausgangsschaltung des MOC für die Ansteuerung des
> Triac Gates gemacht worden ist. An diesem liegt keine
> Phasenverschiebung und vor allem keine induktive/kapazitive
> Last, die für den MOC alleine das Problem verursacht.

Danke für die Erklärung.

Ich habe jetzt den Optokoppler gegen einen MOC3052 ausgetauscht, damit 
funktioniert die Schaltung erst einmal.

Danke...
LG Jens

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.