Forum: PC Hard- und Software Daten löschen auf NAS


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Günter R. (galileo14)


Bewertung
0 lesenswert
nicht lesenswert
Gibt es eine Möglichkeit, beim Löschen von Daten auf einem NAS (hier: 
Pollin LogiLink NS0045) den Papierkorb zu umgehen? Denn die Daten werden 
ja erst freigegeben, wenn auch wieder der Papierkorb(inhalt) gelöscht 
wird (doppelte Zeit und Plattenabnutzung).

Im NAS-Menü finde ich keine Einstellung, um den Papierkorb zu umgehen 
(im Gegensatz zu einem Buffalo-Server; dort gibt es das).

Vielen Dank für Hinweise.

Günter

von Test (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Kleiner Hinweis am Rande... Dateien verschieben bedeutet nicht! Das 
diese auch im Dateisystem kopiert werden, es werden nur die iNode 
Einträge im Filesystem geändert.
Evtl gibt es für dein noname NAS ja eine alternative Firmware die du 
benutzen kannst

von HP (Gast)


Bewertung
0 lesenswert
nicht lesenswert
also ich hab noch nie davon gehört dass sich eine Festplatte durch 
Schreib-/Lesezyklen abnutzt. Außer SSD natürlich. Also da würd ich mir 
mal keine sorgen machen dass durch "drauf rum schreiben" die Platte 
kaputt geht.
Der Zeitfaktor ist da schon eher ein Argument. Das kann nerven

von Michael_ (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Eigentlich geht das doch mit gedrückter Shift-Taste.
Oder ist das neuerdings nicht mehr so?

von kopfkratzer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
kopfkratz
Also bei Un*x und rm ist der iNode weg und damit auch die Daten.
Unter Windows kann man für jedes Laufwerk einzeln einstellen ob beim 
löschen in den Papierkorb geschoben wird oder es direkt gelöscht wird, 
wobei das nur den Eintrag in der FAT bzw. MFT betrifft.
Wenn die Daten 100% gelöscht werden sollen muß man erst die Datei 
überschreiben und dann löschen.

von Günter R. (galileo14)


Bewertung
0 lesenswert
nicht lesenswert
Test schrieb:
> Kleiner Hinweis am Rande... Dateien verschieben bedeutet nicht! Das
> diese auch im Dateisystem kopiert werden, es werden nur die iNode
> Einträge im Filesystem geändert.

Ja, so sollte es sein, und auf dem PC ist es beim "Verschieben" auch so. 
Aber bei diesem NAS werden wohl beim Löschen die Daten tatsächlich 
kopiert, mit gleichem Zeitaufwand wie beim Datensichern. Das ist mir 
auch völlig unverständlich (weiß nicht, was sich die Konstrukteure dabei 
gedacht haben, oder ob sie ihr eigenes Gerät jemals selbst verwendet 
haben ...).

von Günter R. (galileo14)


Bewertung
0 lesenswert
nicht lesenswert
HP schrieb:
> also ich hab noch nie davon gehört dass sich eine Festplatte durch
> Schreib-/Lesezyklen abnutzt.

Nun, wenn der Kopf-Arm sich ständig bewegt, nutzen sich die Kopfarmlager 
schon (äußerst geringfügig) ab; das hatte ich gemeint. Natürlich 
schleifen die Köpfe nicht auf der Magnetoberfläche ...

von Günter R. (galileo14)


Bewertung
0 lesenswert
nicht lesenswert
Michael_ schrieb:
> Eigentlich geht das doch mit gedrückter Shift-Taste.
> Oder ist das neuerdings nicht mehr so?

Das dachte ich so - Shift-F8 löscht ohne Papierkorb. Auf dem PC ist das 
so, aber nicht bei diesem NAS.

von Günter R. (galileo14)


Bewertung
0 lesenswert
nicht lesenswert
Günter R. schrieb:
> Test schrieb:
>> Kleiner Hinweis am Rande... Dateien verschieben bedeutet nicht! Das
>> diese auch im Dateisystem kopiert werden, es werden nur die iNode
>> Einträge im Filesystem geändert.
>
> Ja, so sollte es sein, und auf dem PC ist es beim "Verschieben" auch so.
> Aber bei diesem NAS werden wohl beim Löschen die Daten tatsächlich
> kopiert, mit gleichem Zeitaufwand wie beim Datensichern. Das ist mir
> auch völlig unverständlich (weiß nicht, was sich die Konstrukteure dabei
> gedacht haben, oder ob sie ihr eigenes Gerät jemals selbst verwendet
> haben ...).

Naja, okay, ich muß mich ein wenig korrigierten - so lange dauert es 
tatsächlich nicht, wie ich schrieb. Wahrscheinlich werden tatsächlich 
nur die Nodes umgehängt; ich habe sehr viele Dateien zu löschen, daran 
mags auch liegen, daß es lange dauert.

von Delf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ja, der Beitrag ist älter, aber die Problemlösung fehlte.

Beim beschriebenen Gerät geht das DAUERHAFTE Entfernen von "Recycle Bin" 
so:

-> Menüseite http://ns0045/share.htm aufrufen (Ordner gemeinsam 
benutzen)
-> Bei "Archivoptionen" die Option "deaktivieren" auswählen und mit 
"übernehmen" bestätigen.

Dann werden gelöschte Dateien auch wirklich gelöscht, statt einfach nur 
"umgehängt". Ein temporäres Umgehen scheint es nicht zu geben, also 
entweder gar nichts oder damit leben, unerwünschte "Sicherheitskopien" 
immer manuell löschen zu müssen.

von Günter R. (galileo14)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Delf,

ja, der Beitrag ist älter, das Problem bestand aber immer noch, jedoch 
hast Du mir eine gute Hilfe gegeben; dort hatte ich nicht nachgeschaut; 
habe die Archivoption jetzt erfolgreich deaktiviert. Das ist jetzt 
super.

Herzlichen Dank.

Günter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.