Forum: Mikrocontroller und Digitale Elektronik Temperatur des ENC28J60


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Friedrich R. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hey Leute,

ich habe gerade ein kleines Problem. Ich möchte einen ATMega ins Netz 
bringen. Hierfür habe ich mir bei unseren Freunden aus Fernost ein 
Breakout Board mit ENC28J60 bestellt, ist offensichtlich so ein 
Standard-Teil. Ich habe mal etwas gegoogelt, wie ich es anzuschließen 
habe, damit die Arduino Ethernet Library funktioniert. Was mir dabei 
aufgefallen ist, war dass das Modul eine Spannung von 3,3V braucht. In 
diversen Anleitungen wird deshalb empfohlen, einfach Quick&Dirty zwei 
Dioden vor die Versorgungsspannung zu schalten, damit ich etwa 3,3V 
bekomme.

Wozu ich so etwas brauche, wusste ich nicht, da auf meinem Board sich 
ein 3.3V Voltage Regulator befindet. Da der AVR aber auch sehr gut mit 
3.3V läuft, habe ich die Spannung einfach mal draufgegeben. AVR lief, 
das Ethernet Board nicht. Ich habe dann die Spannung erhöht. Erst ab 
4,5V lief das Modul.

Ethernet funktioniert jetzt bei mir. Das Demo-Projekt mit dem Webserver 
läuft und ich kann aus dem Netzwerk darauf zugreifen - ein Erfolg.

Nur bin ich jemand, der Chips gerne mal berührt um zu schauen, wie warm 
die werden. Nun, der ENC28J60 wird schon relativ heiß. Ich habe das Ding 
gestern gemessen, es kommt auf ca. 46°C Temperatur am Gehäuse.

Zuerst dachte ich, dass die Spannung tatsächlich zu hoch sei. Allerdings 
liegt am Pin 28 (VDD) eine Spannung von 3.3V an. Also voll im Rahmen.

Ich habe den AVR jetzt über Nacht am Netz gelassen, er läuft ohne 
Probleme bei den ca. 46°C, die ich gemessen habe. Jetzt frage ich mich, 
ob es okay ist oder ob diese Temperatur auf Dauer nicht zu viel ist. 
Denn ich möchte eine Art Sensor-Netzwerk aufbauen und der AVR mit der 
Ethernet Schnittstelle soll die Schnittstelle Wireless <=> LAN sein.

von Stampede (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Nein das ist normal. Der nimmt sich bis zu 120mA bei 3,3V.

von Max D. (max_d)


Bewertung
0 lesenswert
nicht lesenswert
Friedrich R. schrieb:
> Erst ab
> 4,5V lief das Modul.

Das klingt so als ob da noch ein 3,3 V Regler irgendwo unterwegs ist, 
vlt. direkt auf dem ENC-Modul-PCB....

Die 45° sind normal, gerade bei kleineren SMD-Packages, kein Grund zur 
Sorge.

Da der ENC (anscheinend) direkte 5V am I/O verträgt kannst du also 
problemlos deinen AVR mit 5V füttern und so die vollen 16/20 MHz aus ihm 
rausholen....

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.