mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD Display Hintergrundbeleuchtung defekt


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich bin ein Neuling im Forum und hoffe hier aus Tips und 
Anregungen.
Die Hintergrundbeleuchtung meines Displays der Heizungsteuerung 
(Holzvergaser Guntamatic , Elektronik Fa. Hainz in Linz) ist defekt.
Anfangs kam es zu kurzen Aussetzern, die immer häufiger wurden, dann mal 
einige Tage komplett dunkel, tzwischendurch immer mal wieder kurzes 
aufleuchten, doch jetzt ist alles dunkel.
Bei Reichelt habe ich nicht vergleichbares gefunden, daher dieser 
Beitag.
Vielleicht weiss jedand mehr oder Details zur Reperatur.
Die LCD-Platine sitzt Huckepak auf der Reglerplanine ( 20 pins)

Siehe Foto im Anhang

Platine = 78 * 70 mm
Display mit Rahmen = 76*64 mm
Sichtfeld = 61,8 * 44 mm

Für Anregerungen jeglicher Art dankbar

Thomas

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf dem Bild erkennt man nicht, wie die Hintergrundbeleuchtung aufgebaut 
ist. Die Abmessungen der Platinen hingegen sind eher irrelevant.

Verwendet das Ding LEDs zur Beleuchtung? Verwendet es eine 
Elektrolumineszenzfolie? Oder verwendet es CCFL-Röhren?

Ein Bild der Platinenrückseite könnte hier Aufklärung bringen, weil man 
dort die Hochspannugnserzeugung für EL-Folien und CCFL-Röhren erkennen 
könnte.

Zum Bild selbst:

Das ist ein Foto. Kein Gif für Fotos.

Deine Schreibtischplatte interessiert niemanden, Dein Foto ist aber zu 
gut 70% damit gefüllt, daher bitte Fotos vor dem Hochladen sinnvoll 
beschneiden.

Außerdem hast Du das Foto bei zu wenig Licht aufgenommen, deswegen ist 
es verrauscht und man kann nicht sehr viel erkennen. Mehr Licht; aber 
keinen Blitz verwenden, und die Platine/das Display auch nicht direkt 
anleuchten, sondern indirekt (weil sonst, wie auch in Deinem Bild zu 
erkennen ist, einige Teile des Bildes die Lichtquelle reflektieren bzw. 
zu hell werden).

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok ich werde das Bild nocheinmal neu hochladen.

Autor: Karl H. (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Ok ich werde das Bild nocheinmal neu hochladen.

Aber bitte nicht wieder 3Mb!

: Bearbeitet durch Moderator
Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Ok ich werde das Bild nocheinmal neu hochladen.

Das gleiche? Besser nicht.

Und mach ein neues Bild von der Rückseite der Platine.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So sollte es besser sein ... sorry

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ein zweites "kleines" Bild ...

Autor: aha (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Display ablöten und mal von hinten anschauen, da steht vielleicht drauf 
wie das heissen tut...

Autor: Blinky (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Löte mal die Kontakte unten am Display nach. Vieleicht ist es ja nur 
eine kalte Lötstelle...

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Auf dem Frontalbild erkennt man etwas, was aussieht, wie zwei von links 
unter das Display führende Drähte. Bei einer Schrägansicht von der 
linken Seite müsste man die besser erkennen können.

Diese Drähte jedenfalls könnten ein erstes Indiz für eine 
Elektrolumineszenzfolie sein.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke erst einmal ...
ich werde
1. Nachlöten
              wenn das keinen Erfolg bringt

2. Auslöten und Fotos (von unten, links und rechts) machen
         und melde mich dann zurück
Thomas

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Das ist ein Standardgrafikmodul mit LED-Backlight, 128*64 Pixel. Die 
Backlightanschlüsse sind Pin 19+20.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo hinz , kannst Du mir auch sagen wo ich das Teil bekomme.
Bei Reichelt konnte ich mit diesen Abmessungen nichts finden.

Electonic Assembly scheint ja ein führender Hersteller zu sein?

Gruß Thomas

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe eins gefunden ....
das kommt der Sache schon Nahe.  Aber die Maße stimmen nicht ...

http://www.reichelt.de/LCD-64128A-LED/3/index.html?&ACTION=3&LA=446&ARTICLE=31672&artnr=LCD+64128A+LED&SEARCH=Standardgrafikmodul

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Electonic Assembly scheint ja ein führender Hersteller zu sein?

Die stellen keine Displays her. Aber ein, von den Abmessungen passendes 
ist im Sortiment:

http://www.lcd-module.de/pdf/grafik/j128-6n6.pdf

MfG Spess

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Volltreffer     spess53

SUPER   vielen Dank

Gruß Thomas

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider beim genauen hinschauen hier nur 16 Pins  ....  statt 20

Ich werde wohl doch erst einmal auslöten

Gruß
Thomas

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Hallo hinz , kannst Du mir auch sagen wo ich das Teil bekomme.

z.B. Schukat, DEM128064HSYH-PY

Autor: Ronny S. (phoenix-0815)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also wenn ich mir deine Bilder so ansehe sollte es sich um ein Display 
mit T6963C Controller handeln.

Falls es so sein sollte und Du keins auf die schnelle findest was passt 
kannst ja eine PN an mich senden.

Gruß Ronny

Autor: oder so (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: oder so (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Ronny S. (phoenix-0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oder so schrieb:
> sorry:
>
> http://www.elpro.org/shop/shop.php?p=DEM128064BSYH-PY
>
> oder so


Hallo,
schönes Display aber leider wissen wir ja nun noch nicht was da nun 
verbaut ist.

Gruß Ronny

Autor: oder so (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Thomas Müller schrieb:
>> Hallo hinz , kannst Du mir auch sagen wo ich das Teil bekomme.
>
> z.B. Schukat, DEM128064HSYH-PY

der hat es erkannt
oder so

Autor: Ronny S. (phoenix-0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oder so schrieb:
> hinz schrieb:
>> Thomas Müller schrieb:
>>> Hallo hinz , kannst Du mir auch sagen wo ich das Teil bekomme.
>>
>> z.B. Schukat, DEM128064HSYH-PY
>
> der hat es erkannt
> oder so

Oh da hatte ich dann wohl was überlesen,oder so.

Gruß
Ronny

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Hintergrundbeleuchtung kann man doch reparieren?

Rufus Τ. Firefly schrieb:
> Auf dem Frontalbild erkennt man etwas, was aussieht, wie zwei von links
> unter das Display führende Drähte. Bei einer Schrägansicht von der
> linken Seite müsste man die besser erkennen können.
>
> Diese Drähte jedenfalls könnten ein erstes Indiz für eine
> Elektrolumineszenzfolie sein.

An dieser Stelle würde ich mal mit messen anfangen.

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Diese Drähte jedenfalls könnten ein erstes Indiz für eine
> Elektrolumineszenzfolie sein.

Diese meine Vermutung scheint sich nicht zu bestätigen.

Interessant aber, gerade bei einer LED-Hintergrundbeleuchtung, ist es, 
herauszufinden, was da jetzt ausgefallen ist. Daß die LEDs selbst 
ausfallen, ist eher unwahrscheinlich. Defekte LEDs sind wirklich sehr 
selten, außer bei zu Raumbeleuchtungszwecken verwendeten weißen LEDs.
Hier geht es zwar auch um Beleuchtung, aber nur um die eines banalen 
Displays, und daher bezweifle ich arg, daß die Hintergrundbeleuchtung im 
LED-tötenden Flakscheinwerferbetrieb operiert haben wird.

Also ist es interessant, herauszufinden, woher die Versorgungsspannung 
der LEDs kommt, und wie diese Versorgungsspannung aussieht. Letzteres 
könnte man sich mit einem Oszilloskop näher ansehen --- für ersteres 
benötigen wir das bereits mehrfach angeforderte Bild der 
Platinenrückseite.

Autor: michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen Oszi braucht man erst in der zweiten Runde.
Es sind doch nur zwei Leitungen und ein MM reicht da erst mal.
Und wenn man guckt, wo die zwei Leitungen herkommen, ist doch klar 
welchen Typ die Beleuchtung hat.

Autor: Nikolaus (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Ronny S. schrieb:
> also wenn ich mir deine Bilder so ansehe sollte es sich um ein Display
> mit T6963C Controller handeln.

Naja, also auf den Controller würde ich mich mal nicht so vorschnell 
festlegen.

Ich sag das nur, damit der Thomas nicht spontan ein solches Display als 
Ersatz für sein eigenes beschafft und dann feststellen muß, daß es 
leider doch ein KS0108/7B oder SED... oder sonstwas war. Denn dann 
stünde er ziemlich bedröppelt da.

Autor: Harald W. (wilhelms)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Rufus Τ. Firefly schrieb:

> Defekte LEDs sind wirklich sehr selten,

...kalte Lötstellen o.ä. dagegen deutlich häufiger.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo   ....  vielen vielen Dank für die zahlreichen Anmerkungen

         Ronny, oder so, rufus und alle anderen.

Es ist nicht ganz einfach, denn das Teil ist in meiner Heizungsanlage 
verbaut.
Wenn ich irgendeinen Fehler beim Löten oder Ausbau / Einbau mache, dann 
wirds richtig kalt in meiner Bude.

Aber Fotos der Rückseite sind erforderlich, das sehe ich auch so.
Also Heizungsanlage runterfahren, sauber auslöten, fotografieren, sauber 
einlöten, Heizungsanlage wieder hochfahren und ... beeeeeten.

Ich werde für diese Aktion einen geeigneten Termin aussuchen um im 
Notfall nicht ganz dumm dazustehen.
Gruß Thomas

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Aber Fotos der Rückseite sind erforderlich, das sehe ich auch so.
> Also Heizungsanlage runterfahren, sauber auslöten, fotografieren, sauber
> einlöten, Heizungsanlage wieder hochfahren und ... beeeeeten.

Ich meine nicht ein Bild der Rückseite des Displays, sondern der 
Rückseite der Platine, die Du da weiter oben abgebildet hast. Um dieses 
Bild zu machen, hast Du doch nicht etwa auch schon irgendwo 
herumgelötet?

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja Rufus, aber diese grössere Planine ist die Einheit des 
Heizungsreglers mit dem EEPROM der Kesselparameter und dem ganzen Zeug 
was so einen Regler in der Heizungstechnik braucht.  Das Display sitzt 
auf einer kleinen eigenständigen Platine "Huckepak" auf der 
Heizungsreglerplatine und ich nehme an: All die Komponenten ob CAN Bus / 
8 oder 4 Bit Datenbus mit den entsprechenden Bausteinen haben ihren 
Platz auf der kleinen Platine.
Meinst Du es ist sinnvoll dann die große Platine von unten zu sehen?

Gruß Thomas

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich werde das Haus richtig aufheizen, danach Heizungs aus und zum 
Schrauben in den Heizraum um ein paar bessere Bilder einzustellen. 
(kleines Dateiformat *.jpg)
Thomas

Autor: oder so (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
"Meinst Du es ist sinnvoll dann die große Platine von unten zu sehen?"


bevor du da rumlötest auf jeden Fall...

oder so

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oder so DANKE oder so

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Das Display sitzt auf einer kleinen eigenständigen Platine "Huckepak"
> auf der Heizungsreglerplatine

Das war Deinem Bild schon zu entnehmen.

Und ja, ich möchte die Unterseite der anderen Platine sehen. Daß das 
Display selbst ausfällt, daß die LEDs der Hintergrundbeleuchtung ein 
Kontaktierungsproblem haben, das halte ich für recht unwahrscheinlich.

Deswegen möchte ich erahnen können, wie Deine andere Platine die 
Hintergrundbeleuchtung des Displays ansteuert -- das wird ja wohl 
vermutlich nicht dauernd an sein, sondern nur nach Tastendruck, für 'ne 
Weile -- und also ist da irgendeine steuernde Elektronik drauf.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau Rufus, so ist es das Ding leutete ab Ativität auf den 
Bedienungselementen mit ca. 60 sec. Haltezeit.
Der Kessel brennt gerade.  Es wird ca. 4 Stunden dauern danach sind alle 
Pufferspeicher geladen und ich werde aktiv.
Gruß aus Niedersachsen
Thomas

Autor: isidor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> ..... und ich werde aktiv.

Wenn die Steuerung geschickt programmiert ist läuft sie
auch ohne angeschlossenes Display.

Aber wehe wenn der Controller auf das Busy des LCDs wartet !!

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das waren Österreicher, die Fa. Hainzl in LINZ.
        Toller Internetauftritt!

Jedoch ich möchte kein Risiko eingehen ....
also lieber 4 Stunden warten

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am Rande
  4 Std a. 30KW  =  120 KWh

das sollte für eine Weile reichen.

   Holzvergasertechnik

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:
  • preview image for 3.jpg
    3.jpg
    350 KB, 539 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen ...
hier ein Bild der Unterseite.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:
  • preview image for 1.jpg
    1.jpg
    60,1 KB, 469 Downloads

Bewertung
0 lesenswert
nicht lesenswert
und die Steckerleiste

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:
  • preview image for 2.jpg
    2.jpg
    600 KB, 500 Downloads

Bewertung
0 lesenswert
nicht lesenswert
und größere Detailansicht

Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> und größere Detailansicht

Größe ist nicht alles - mehr Schärfe wäre hilfreich.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke diese Bilder sind viel besser als die ersten.
Nach dem  Ausbau der Platine, habe ich die Pins 19 und 20 kurz 
nachgelötet.
Nach dem Einbau ein Freudenschrei, denn das Display leuchtete ....
jedoch nach einiger Zeit flackerte die Beleuchtung und wurde immer 
dunkler ... und jetzt ist es wieder komplett dunkel.

Vielleicht kann dieser Hinweis hilfreich sein, denn die LEDs scheinen ja 
so OK zu sein. Dann müsste der Fehler wirklich eine kalte Lötstelle oder 
die ansteuernde Logik für die LEDs sein.

Könnte es sich bei dieser Logik um ein RC Zeitglied handeln. Oft sind ja 
Kondensatoren das Verschleißteil und schwächeln nach einigen Jahren.

Die Umgebungsbedingungen für diese Platine sind auch nicht ganz ohne ...
denn im Kesselbetrieb ist natürlich Wärme da. Und entspechende Gase 
durch die Verbrennung von Holz sind auch nicht wegzudenken.

Vielleicht hat jemand Erfahrung auf diesem Gebiet.

Für alle Antworten bin ich sehr dakbar.
Klasse das es solch ein Forum gibt. Danke Rufus!

Thomas Müller (nicht aus München)

Autor: Wegstaben V. (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
je schärfer das Bild (von der Unterseite), desto mehr Tips kann man 
geben.

Das muß so scharf sein, daß man dei Bauteile-Beschriftung lesen kann

PS: Falls du keine geeignete Kamera hast, dann leg die Platine mit einem 
Handtuch abgedeckt auf einen ALTEN Scanner, der noch mit 
Leuchtstoff-Röhren arbeitet. Diese Scanner haben gelegentlich eine 
beeindruckende Tiefenschärfe....

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja danke für Hinweis , Handtuch ist vorhanden jedoch diesen Scannertyp 
hab ich nicht.
Leider habe ich hier nur diese Medion DigCam die auch Schwierigkeiten 
mit dem Focus hat.
Für bessere Bilder muß ich erst was anderes organisieren.
Thomas

Autor: Axel S. (a-za-z0-9)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Für bessere Bilder muß ich erst was anderes organisieren.

Vor allem mehr Licht. 2 Schreibtischlampen, die von links und rechts 
jeweils im 45° Winkel auf die Platine leuchten, wären ideal.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Diese Bilder sollten gut sein.
Beim Einschalten nach dem Wiedereinbau leuchtete das Display für ca. 
2sec.
Gruß Thomas Müller

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Diese Bilder sollten gut sein.

Die Anpassung an die Farbtemperatur der Lampe könnte man noch 
verbessern, z.B. durch einen sauberen Weißabgleich ;-)

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Beim Einschalten nach dem Wiedereinbau leuchtete das Display für ca.
> 2sec.

Dann dürfte das Display selbst und die im Display verbaute 
Hintergrundbeleuchtung nicht die Ursache des Problems sein, sondern die 
Ansteuerung der Hintergrundbeleuchtung durch diese Platine.

Such Dir doch mal die Pinbelegung des Displays raus, dann kannst Du 
'rausfinden, was auf der Platine mit der Hintergrundbeleuchtung 
verbunden ist.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch ein Bild der Vorderseite!

Pin 19 &  Pin 20 ist für die Beleuchtung!

Gruß Thomas

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Pin 19 &  Pin 20 ist für die Beleuchtung!

Das ist schön. Welche sind das? (Wo ist Pin 1?)

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf dem xxxxx54.jpg sind das die beide Pins rechts unten. Ich habe sie 
schon  mit Reiniger sauber gemacht. In der Nähe ist ein Baustein (mit 3 
Anschlüssen)und dieses kleine goldfarbene Teil. Kann das für die 
Hintergrundbeleuchtung zuständig sein?
Ich könnte beim "nächsten Ausbau" auch die Leiterbahnen verfolgen und 
durchmessen.

Gruß Thomas

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pinbelegung ist :  links=1   ......  rechts=20

im Bild xxxx54.jpg ganz unten .... jetzt gut zu erkennen.
Auch die gesäuberten Stellen um 19/20 erkenne ich auf dem Bild.

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> dieses kleine goldfarbene Teil

Das ist ein Quarz, der scheint an dem 8-Beiner rechts oberhalb 
angeschlossen zu sein. Die Bauform gibt es bei Uhrenquarzen (also 
welchen mit recht geringen Frequenzen, wie z.B. 32 kHz).
Die Beschriftung des ICs ist nicht lesbar, aber vielleicht ist das ja 
'ne RTC?

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:
Angehängte Dateien:
  • preview image for z1.jpg
    z1.jpg
    11,1 KB, 426 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Das steht AD P5n drauf.

Autor: hinz (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Das steht AD P5n drauf.

BCX51-16

Ist dessen Kollektor mit Anode(+) des BL verbunden?

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hinz
Der AD P5n ist also ein BCX51-16 ein Transistor?  Was ist BL?

Autor: test (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
BL = Backlight

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Ist dessen Kollektor mit Anode(+) des BL verbunden?

Kann ich so nicht sagen, anhand der Bilder kann ich das nicht erkennen.
Ich werde wohl messen müssen, dazu wieder die Heizung aus.
Dieses ist erst morgen oder heute spät in der Nacht möglich.

Danke für alle Hinweise ... Rufus , Hinz und test

Autor: Nikolaus (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Was ist BL?

Backlight, zu deutsch: Hintergrundbeleuchtung

Ist die Beleuchtung jetzt also immer (also reproduzierbar) für 2 
Seklunden an und geht dann aus? Und wie ist eigentlich der Sollzustand? 
Gab es früher auch ein Ausschalten nach einer gewissen Zeit oder ist die 
Beleuchtung ständig an gewesen? Oder war sie schaltbar?

Wie benimmt sich denn die Spannung an Pin 19/20? Ändert die sich auch 
nach diesen 2 Sekunden?

Wenn ja - > Fehler liegt vor dem Display.
Wenn nein -> Fehler am Display selbst suchen. Bringt leichtes 
Herumdrücken auf dem Display einen Effekt?

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Nikolaus

Nikolaus schrieb:
> Ist die Beleuchtung jetzt also immer (also reproduzierbar) für 2
> Seklunden an und geht dann aus? Und wie ist eigentlich der Sollzustand?
> Gab es früher auch ein Ausschalten nach einer gewissen Zeit oder ist die
> Beleuchtung ständig an gewesen? Oder war sie schaltbar?

Nur nach dem Einbau war das BL kurz da.
Beim vorletzten Einbau (ich hatte die Pins 19/20 nachgelötet) war das BL 
ca. 60 sec. da.

Früher ging es an wenn ich an Bediehnungstastern war und erlosch nach 
ca. 60sec.


Die Spannungen an pin 19/20 habe ich noch nicht gemessen, werde ich aber 
nachholen.

Autor: Nikolaus (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Die Spannungen an pin 19/20 habe ich noch nicht gemessen, werde ich aber
> nachholen.

Ja, das wäre gut, denn wie hier schon gesagt

Nikolaus schrieb:
> Wie benimmt sich denn die Spannung an Pin 19/20? Ändert die sich auch
> nach diesen 2 Sekunden?
>
> Wenn ja - > Fehler liegt vor dem Display.
> Wenn nein -> Fehler am Display selbst suchen. Bringt leichtes
> Herumdrücken auf dem Display einen Effekt?

solltest Du damit ruckzuck herausbekommen, ob das Display selbst mitsamt 
seinem BL im Eimer ist, oder doch die Ansteuerung.

Zum Testen könntest Du übrigens auch einfach eine LED (mit 
Vorwiderstand) an diese Pins hängen. Sollte die LED in gewünschter Weise 
weiterbrennen, dann wüsstest Du, das im Display selbst irgendetwas 
korrodiert ist. Das kann im klammen Keller nach längerer Zeit schon mal 
vorkommen.

Noch was:

die Platine macht (bsonders auf den ersten Bildern) einen versifften 
Eindruck, mutmaßlich spielen dabei Verbrennungsrückstände eine Rolle.

Solche kohlenstoffhaltigen Plaques sind eigentlich Gift für das sichere 
Funktionieren von Steuerplatinen. Ich würde deshalb ernsthaft überlegen, 
die Platine mit reichlich Isopropanol abzureinigen. Danach gut 
abtrocknen lassen. Das Trocknen geht bei Isopropanol ja schnell.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nikolaus schrieb:
> Solche kohlenstoffhaltigen Plaques sind eigentlich Gift für das sichere
> Funktionieren von Steuerplatinen. Ich würde deshalb ernsthaft überlegen,
> die Platine mit reichlich Isopropanol abzureinigen. Danach gut
> abtrocknen lassen. Das Trocknen geht bei Isopropanol ja schnell.

Guter Hinweis

Danke!

Autor: Nikolaus (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Und noch was vergessen, sorry:

wenn Du ohnehin schon am Machen bist, solltest Du auch noch die 
aufgelötete Stützbatterie prüfen.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nikolaus schrieb:
> solltest Du damit ruckzuck herausbekommen, ob das Display selbst mitsamt
> seinem BL im Eimer ist, oder doch die Ansteuerung.
>
> Zum Testen könntest Du übrigens auch einfach eine LED (mit
> Vorwiderstand) an diese Pins hängen. Sollte die LED in gewünschter Weise
> weiterbrennen, dann wüsstest Du, das im Display selbst irgendetwas
> korrodiert ist. Das kann im klammen Keller nach längerer Zeit schon mal
> vorkommen.


Ja das klingt sehr logisch  .....

NOCHMAL  DANKE   dem Nikolaus (6.12)

Thomas

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja Nikolaus du denkst an alles ...

Die hatte ich schon gewechselt, irgendwie auch in der Hoffnung das das 
BL wieder geht.

Autor: Nikolaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du jetzt noch versprichst, mit dem Isopropanol im Überschwang nicht 
ausgerechnet im Raum des Brenners herumzuhantieren, dann gehe ich 
beruhigt zu Bett ;-)

Andernfalls kommen morgen der Krampus und der Knecht Ruprecht und 
stecken Dich in den Sack :-)

... oder die Feuerwehr :-(

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versprochen .... nichts von dem ist geplant.
Zwar rauche ich ab und zu beim Befüllen meiner Motorsäge, aber das ist 
eine andere Geschichte.

Ich warte lieber auf den Nikolaus ... am 6.12.

Gute Nacht

Autor: optional (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hätte noch eine Idee. In der Nähe der BL-Pins sitzt auf der Platine 
ein Trimmpoti. Evtl. hängt das mit dem BL zusammen (Helligkeit). 
Vielleicht ist das auch durch, wegen Dreck, etc.

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
optional schrieb:
> sitzt auf der Platine ein Trimmpoti.

Das dürfte eher für den Kontrast des Displays zuständig sein.

Autor: Dietrich L. (dietrichl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. Firefly schrieb:
> optional schrieb:
>> In der Nähe der BL-Pins sitzt auf der Platine ein Trimmpoti.
>
> Das dürfte eher für den Kontrast des Displays zuständig sein.

... denn es sitzt nicht bei den BL-Pins, sondern auf der 
gegenüberliegenden Seite, wo üblicherweise der Kontrastanschluss ist.

Autor: dummy (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Man könnte mal den Transistor brücken und schauen
ob das Licht an bleibt.

Autor: Seppi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dummy schrieb:
> Man könnte mal den Transistor brücken und schauen
> ob das Licht an bleibt.

Würde ich auch versuchen.

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für all die weiteren Ideen.

Mit einer LED mit Vorwiderstand werde ich anfangen.
Das grenzt den Fehler ein ...  DISPLAY oder Ansteuerungelektronik.

Danach könnten die anderen Ideen zu Einsatz kommen.

Ich berichte weiter ...

Gruß Thomas

Autor: Thomas Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
------------ FREUDENSCHREII -----------

Ich habe eine LED mit Rv=220 an Pin 19= +   20= - und gleichzeitig ein 
Multimeter zur Spannungskontrolle.  4,68V  ....
und die LED und das Display leuchten beide 1A.
Jetzt faellt es mir auf ... nicht so schwach wie beim letzten Mal die 2 
Sec nach dem Einschalten. Ich hatte schon vergessen wie schön hell es 
doch sein kann.

Alles weist auf eine kalte Lötstelle am Pin 19 oder 20 hin.

Ich habe eine Minute gewartet  und ....   das Display und die LED ging 
wie gewohnt aus. Spannung = 0V.  Beim ersten Tastendruck war es sofort 
wieder da. So sollte es sein.

Danach die LED "abgeknippst" und den Kessel zusammengebaut.

Volle Funktion. Ich bin zufrieden.

Wie einen doch Kleinigkeiten im Leben glücklich machen können  ... 
smile.

PS: Der Kesselhersteller wollte 580€ für ein neues Modul oder ca. 300€ 
im Austausch.

Als letzten Satz:
Nocheinmal vielen Dank an alle die mein Anliegen mitverfolgt haben und 
mit ihren Anregungen geholfen haben.

Thomas      ... und jetzt kann der 6.12. auch mit Minusgraden kommen !

Autor: Thomas M. (Firma: ostfalia) (tommyta)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles ok siehe oben.

Autor: Rufus Τ. F. (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na, herzlichen Glückwunsch!

Autor: zuio (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas Müller schrieb:
> Alles weist auf eine kalte Lötstelle am Pin 19 oder 20 hin.

Glückwunsch, das wurde dir schon !68 Beiträge weiter oben gesagt. Ich 
würde die Lötstellen der THT Bauteile mal pauschal alle nachlöten, die 
sehen echt scheiße aus.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.