mikrocontroller.net

Forum: Platinen Kicad, Probleme mit der lokalen Einrichtung der Footprintlibs.


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bin unter Windows vom letzten Stable-Release von Kicad von 2013 auf 
die aktuellste Version BZR 5376 umgestiegen. Diese wird als fertiges 
Kompilat angeboten.

Kicad hat zwischenzeitlich die Libraries umgebaut, so dass die 
Footprint-Bibliotheken nicht mehr in der Installationsdatei enthalten 
sind. Die *.pretty-Verzeichnisse liegen als Git-Repo im Netz vor. Das 
dürfte den meisten hier auch bekannt sein.

Ich will Kicad nun aber ausschließlich offline nutzen. Also müsste ich 
die Footprint-Libraries lokal einbinden, will ich nicht alle bisher 
verwendeten Footprints portieren oder neu zeichnen. Aber wie geht das? 
Die entsprechenden *.pretty Verzeichnisse mit Inhalten konnte ich mit 
einem Helper-Script bereits lokal spiegeln.

Kicad verwanltet seine Footprints nun wohl über die Datei fp-lib-table. 
Unter PCBnew kann unter Einstellungen ein Dialog "PCB 
Bibliothekstabelle" hierfür geöffnet werden, der aber keine 
nennenswerten Veränderungen zulässt. Insbesondere können keine 
Pfadabschnitte eingegeben werden. Ebeso liegt die fp-lib-table-Datei, 
auf die sich der Dialog bezieht, lediglich im Templateverzeichnis von 
Kicad vor \Kicad\share\template\, nicht aber in dem von diesem Dialog 
verlangten Verzeichnis .\Dokumente und 
Einstellungen\xyz\Anwendungsdaten\kicad\fp-lib-table. Dieses Verzeichnis 
existiert erst gar nicht.

Der Inhalt der Datei fp-lib-table selbst bezieht sich mit allen 
Einträgen auf den Pfad $KISYSMOD, den ich nirgends definiert finde, 
außer in dem obigen Dialog und den ich nicht ändern kann.

In der Registry hingegen finden sich die unterschiedlichen fp-lib-table 
wiederum brav aufgeführt in dem entsprechenden 
Kicad-template-Verzeichnis.

Hat einer von euch einen Tip, wie ich die gespiegelten Modules unter 
Windows mit Kicad lokal verwenden kann? Wass muss ich wie einstellen?

Ich bin für jeden Tipp dankbar.

Mit Gruß

Mike

Autor: Bernd W. (berndwiebus) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mike.

Die Bibliothelstabellenverwaltung ist leider noch eine zimliche 
Baustelle.

Wie Du die ftp-lib-tab unter Windows behandelst, kann ich Dir Leider 
nicht sagen.

Trozdem solltest Du mal Probieren, die Bibliorhekstabelle in BCPnew 
direkt zu bearbeiten. Das ist vermutlich unter Windows so ähnlich wie 
unter Linux.

Betrachte bitte aus dem Anhang das Bild 
"PCBnew_Bibliothekstabelle_Nickname-Pfad.jpg"

Du legst mit dem Button eine neue leere Zeile an.
Als "Nickname" trägst Du irgendeine Bezeichnung ein, an der Du die 
Bibliothek später wiedererkennst, wenn Du sie irgendwo brauchst.
Unter "Pfad" kannst Du den Pfad direkt eingeben. Das ist entweder eine 
".mod" Datei aus älteren KiCad Versionen, oder aktuell ein Ordner, 
dessen Name idealerweise mit ".pretty" endet, und der einzelne Dateien 
mit einer ".kicad_mod" Endung enthält.

Die Eingabe dort ist etwas unfertig. Du bekommst KEINE Auswahlbox für 
Pfade und Dateien, sondern musst den Pfad direkt eintragen. Das get 
manuell oder mit Copy und Paste über <str>-v. Rechtsklick und Menue mit 
Kopieren und Einfügen funktioniert nur in den alllerallerneuesten 
Versionen!

Betrachte nun  "PCBnew_Bibliothekstabelle_Bibliothekstyp.jpg"
Dort trägst Du in der Spalte "Plugintyp" die Art der Bibliothek ein.
Ein Auswahlmenue erhältst Du, wenn Du ZWEIMAL LINKS in das Feld klickst.
KiCad ist für aktuelle Bibliotheken, Legacy für Bibliotheken im alten 
Format und Github halt für das Github Repository.

Anschliessend unten rechts mit ok bestätigen.

Das ältere Bibliotheksformat ist eine Datei, die auf ".mod" endet. Diese 
Datei enthält alle Footprints dieser Bibliothek.
Das aktuelle Format ist ein Ordner, der idealerweise auf ".pretty" 
endet, und der Dateien enthält, die auf ".kicad_mod" enden. Diese Datein 
representieren jeweils einen einzigen Footpreint der durch den Ordner 
spezifizierten Datei.

Alternativ kannst Du mit der Desktopsuche Deine ftp-lib-table suchen und 
mit einem Editor bearbeiten. Sie enthält S-Expressions. Wenn Du 
hineinschaust, wirst Du sofort erkennen, wie das aufgebaut ist.
Dort kannst Du dann Name, Pfad und Typ auch eingeben.
Lege Dir aber vom Original eine Sicherheitskopie an!

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das Problem ist gelöst. Die notwendige fp-lib-table ist unter XP in 
einem versteckten Verzeichnis abgelegt. Nachdem ich dieses gefunden 
hatte, konnten alle Einstellungen vorgenommen werden, so dass die 
Footprints nun verfügbar sind.

Mit Gruß

Mike

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich muss mich leider noch einmal zur Fortsetzung des alten Problems 
melden:

Ich habe mir mittlerweile die *.pretty Repos in meine aktuelle 
KiCad-Installation eingebunden. Sehr schön, das Einbinden funktioniert. 
Mit der obigen Anleitung habe ich auch meine alten Bibliotheken 
eingebunden. Sie werden auch gefunden.

Nun bestehen aber zwei sehr ärgerliche Probleme, mit denen ich einfach 
nicht sinnvoll mit KiCad weiter arbeiten kann:

1. Auch wenn die alten "Legacy" Footprints nun erkannt werden, geladen 
werden können nur etwa 1/3. Bei 2/3 der Bibliotheken kommt der Hinweis:

"Beim Laden der Footprints sind Fehler aufgetreten. IO_ERROR: Konnt 
Datei <foo.bar.mod> nicht öffnen from 
C:\dev\kicad-winbuilder-3.4\src\kicad\common\richio.cpp: 
FILE_LINE_READER(): line 193".

Sieht nach einem Bug aus.

Nun gut, dann verwende ich halt die neuen *.pretty's. Habe keine Lust 
alles neu zu zeichnen. Und dann nehme ich auch gleich die neuen Symbole.

Hier wird es noch konfuser. Nicht nur, dass es ein einziges Symbol für 
einen normalen N-Fet gibt, es aber keine Passende Konfiguration zwischen 
Symbol und Footprint gibt, so dass ich einen D-Pak N-Fet (1G 2D(nv) 3S 
4D) verbinden kann... ???

Aber das ist verkraftbar... es gibt ja Standardkomponenten...

Die Bibliothek SMD_Packages wird im Footprinteditor gefunden und 
geöffnet. Super.
Im Programm Cvpbb wird sie aber nur gefunden; die einzelnen Footprints 
werden nicht angezeit und können auch nicht zugewiesen werden. Sehr 
ärgerlich. Sackgasse. Also neues Symbol zeichnen.

Noch besser: Ich habe für einige Transistoren das Package SOT32 aus 
"Transiostors_SMD" verwendet. Dieses wird geladen, bei der Zuweisung 
gefunden und zugewiesen. Klasse. Das klappt ja. ABER: Der Footprint 
erscheint in PCBNew nur als Doppelstrich mit Bauteilbezeichner!

Und so geht es weiter...

Nach dem ich meinem Entwicklungsrechner eine schnellere Grafikkarte 
spendiert habe, weil ich mich so auf Push&Shove gefreut habe, bin ich 
nun kurz davor, wieder auf die Windowsversion von 2013 zurück zu gehen.

Hat einer von euch einen Tipp für mich?

Mit Gruß

Mike

Autor: Bernd W. (berndwiebus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mike.

Mike schrieb:

> 1. Auch wenn die alten "Legacy" Footprints nun erkannt werden, geladen
> werden können nur etwa 1/3. Bei 2/3 der Bibliotheken kommt der Hinweis:
>
> "Beim Laden der Footprints sind Fehler aufgetreten. IO_ERROR: Konnt
> Datei <foo.bar.mod> nicht öffnen from
> C:\dev\kicad-winbuilder-3.4\src\kicad\common\richio.cpp:
> FILE_LINE_READER(): line 193".

Könntest Du eventuell einmal eine der defekten Bibliotheken hier 
einstellen? Oder mir per E-Mail zukommen lassen?
Wenn Du Dir Sie mit einem Text Editor ansiehst, und das in der Syntax 
mit einem funktionierenden Legacy-Footprint vergleichst, ist da 
irgendwas auffällig?

> Hier wird es noch konfuser. Nicht nur, dass es ein einziges Symbol für
> einen normalen N-Fet gibt, es aber keine Passende Konfiguration zwischen
> Symbol und Footprint gibt, so dass ich einen D-Pak N-Fet (1G 2D(nv) 3S
> 4D) verbinden kann... ???


Sinnvolle Nummerierung im Footprint: 1G 2D 3S und Deine vier wieder als 
zwei Nummerieren. Du hast ja zwei Drain Anschlüsse. Gleiche Pad Nummern 
werden verbunden.
Damit hast Du dann 3 Pinne im Symbol, die auf drei Pads im Footprint 
passen. Falls die Reihenfolge nicht passt: Jetzt besser im Symbol 
umnummerieren.



> Noch besser: Ich habe für einige Transistoren das Package SOT32 aus
> "Transiostors_SMD" verwendet. Dieses wird geladen, bei der Zuweisung
> gefunden und zugewiesen. Klasse. Das klappt ja. ABER: Der Footprint
> erscheint in PCBNew nur als Doppelstrich mit Bauteilbezeichner!
>

Schau Dir das Bauteil mal im Footprinteditor an, und auch einmal mit 
einem normalen Texteditor.
Ist da irgendetwas auffälliges? Insbesondere beim Vergleich mit 
"funktionierenden"?

Ansonsten, schau mal ob Du mit dem Kram aus dem Anhang was Anfangen 
kannst.

> Hat einer von euch einen Tipp für mich?

Der Ärger muss nicht zwangsläufig aus der aktuellen Version bzw. von 
KiCad selber stammen.....
Ich habe gerade festgestellt, das die Version von Ende Dezember 2014, 
die ich bis gestern verwendet habe, in den Schaltplänen die Symbolnamen 
"Upper-Case" speicherte. Eine Option, die eigentlich defaultmäßig seit 
über einem Jahr abgeschaltet ist. Das Build Script hat die wohl wieder 
eingeschaltet gehabt.....die aktuelle Version funktioniert.
Aber mit der vorhergehenden Version gespeicherte Schaltpläne machen nur 
Fragezeichen Kästchen.


Glücklicherweise existiert ein Skript, das ich mir vor einem Jahr 
geschrieben habe, um meine eigenen alten "Upper Case" Schaltpläne zu 
konvertieren: 
http://www.mikrocontroller.net/wikifiles/3/33/PyKiCad-CaseSensitiveLibCure_RevC_21Mar2014.zip 
Das funktioniert auch jetzt.
Anleitung ist im Liesmich File. Zusatz: Es ist ein Python-3 Skript. Und 
es verwendet tkinter!

Allerdings sind die Linux-Build Skripte etwas ganz anderes als der 
Winbuilder....da kann ich Dir jetzt nichts zu agen.

Ab Sommer/Herbst soll es wieder offizielle vorkompilierte "stable" 
Releases geben.

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

Autor: Bernd W. (berndwiebus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:

Bernd Wiebus schrieb:

> Der Ärger muss nicht zwangsläufig aus der aktuellen Version bzw. von
> KiCad selber stammen.....
> Ich habe gerade festgestellt, das die Version von Ende Dezember 2014,
> die ich bis gestern verwendet habe, in den Schaltplänen die Symbolnamen
> "Upper-Case" speicherte. Eine Option, die eigentlich defaultmäßig seit
> über einem Jahr abgeschaltet ist. Das Build Script hat die wohl wieder
> eingeschaltet gehabt.....die aktuelle Version funktioniert.
> Aber mit der vorhergehenden Version gespeicherte Schaltpläne machen nur
> Fragezeichen Kästchen.

Konkret handelte es sich um (2014-12-28 BZR 5339). Näheres kann ich 
nicht mehr dazu feststellen, die Version ist schon gelöscht.

Mit freundlichem Gruß: Bernd Wiebus alias dl1eic
http://www.dl0dg.de

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.