Forum: Mikrocontroller und Digitale Elektronik IRF520N Raspberry Pi 3-6V Motor betreiben


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Thorsten Schwonbeck (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte mit meinem Raspberry Pi per GPIO eine Pumpe betreiben.

Pumpe:
3-6V
max. 2.2 - 4.5 A


GPIO:
3.3V

Ich habe IRF520N Mosfets liegen. Aber das ganze wird nichts liege ich 
richtig das ich Logic Mosfets brauche? Falls ja kann mir jemand sagen 
welcher Sinnvoll wäre?

Danke für eure Hilfe :)

Liebe Grüße
Thorsten

von Helge A. (besupreme)


Bewertung
0 lesenswert
nicht lesenswert
Die IRF520 werden höchstens warm. Du brauchst sowas wie z.B. IRLZ34.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Ich würde dir sogar empfehlen, den RPi nur die LED eines Optokopplers 
antreiben zu lassen und den Leistungskreis komplett galvanisch vom 
Rechnerchen zu trennen. Der kleine Kerl mag keine Spitzen von Motoren, 
selbst wenn sie nur auf der GND Schiene liegen.

: Bearbeitet durch User
von Lothar (Gast)


Bewertung
0 lesenswert
nicht lesenswert

von Thorsten Schwonbeck (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Resonanz.

Ich werde mir mal einige IRLZ34 besorgen und mir Gedanken über die 
Trennung der Kreise machen. Das Problem dabei ist nur das ich keinen 
Platz für 2 Netzteile habe.

Hat jemand vielleicht erfahrungen hiermit gemacht?
Ebay-Artikel Nr. 390966068761

Laut Beschreibung tuhen die Dinger ja was ich möchte.

von Alexander S. (esko) Benutzerseite


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die IRLZ34 sind ausgesprochen knapp für 3,3 Volt Gatespannung.
Bei 4,5 Ampere fallen am Mosfet schon 0,6 Volt ab. Das ergibt:
P = U * I = 4,5 A * 0,6 V = 2,7 Watt
Ohne Kühlkörper ist das schon etwas viel.

Schau dir mal diese an: IRF3708, IRF7607, IRLIZ44N, MOSFET-Übersicht


Matthias Sch. schrieb:
> Ich würde dir sogar empfehlen, ... den Leistungskreis komplett galvanisch > vom 
Rechnerchen zu trennen.

Dies ist bestimmt eine gute Idee.

von Thorsten Schwonbeck (Gast)


Bewertung
0 lesenswert
nicht lesenswert
So ich hab das ganze mal mit dem IRLZ34 getestet und das ganze lief auch 
für einen Moment bis der Pi sich verabschiedet hat also doch irgendwie 
galvanisch trennen.
Jemand ne Idee bezüglich eine Optokopplers? Ich werd aus den Dingern 
nicht ganz schlau. Was für einen benötige ich dafür?

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Thorsten Schwonbeck schrieb:
> Jemand ne Idee bezüglich eine Optokopplers?

AQZ102

von Thorsten Schwonbeck (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So diese Module sind angekommen und besitzen auch einen Optokoppler, 
wenn ich das richtig sehe.
Ebay-Artikel Nr. 390966068761

Wenn ich das richtig verstanden habe muss ich damit der IRF520 voll 
durchschaltet minimum 10V anlegen und die müsste ich dann ja an Vcc 
anlegen richtig?

Leider funktioniert dies nicht egal welche Spannung ich bei Vcc anlege 
ob 0V, 3.3V, 5V, 12V ich habe am Mosfet immer nur die 3,3V vom Raspberry 
Pi und dementsprechend nicht genug Spannung zum durch schalten.

Kann mir vielleicht jemand sagen was ich falsch mache?

Danke schon mal für eure Hilfe

von Alexander S. (esko) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Thorsten Schwonbeck schrieb:
> So diese Module sind angekommen und besitzen auch einen Optokoppler,
> wenn ich das richtig sehe.
> Ebay-Artikel Nr. 390966068761

Nein, haben sie nicht. Nur eine LED.

Dieses Modul ist untauglich, um direkt am RaspberryPi angeschlossen zu 
werden, denn der dort verwendete IRF520 braucht mehr als die 3,3 Volt, 
die der RaspberryPi liefern kann.


Wenn du löten kannst, dann nimm einfach einen Mosfet den ich oben 
vorgeschlagen habe und löte den ein.

von Thorsten Schwonbeck (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke Alexander, ich werde mich aber nochmal mit den Optokopplern 
auseinander setzen, ich will lieber auf nummer sicher gehen.
 Ich muss nicht noch einen Raspberry schrotten :D

von Alexander S. (esko) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Wenn du den Motor nur ein- und ausschalten willst, dann kannst du ein 
Relais(shield) nehmen.

von Thorsten Schwonbeck (Gast)


Bewertung
0 lesenswert
nicht lesenswert
An Relais hab ich auch schon gedacht aber spätestens ab Version 2 muss 
ich die Pumpen regeln können dann mache ich das lieber gleich.

Danke :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.