Forum: Analoge Elektronik und Schaltungstechnik Brummen in der Klangregelschaltung für einen Audio-Verstärker


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von M. G. (ixil96)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen Audio-Verstärker mit 2x LM4780 als Endstufe gebaut.

Versorgt wird die Schaltung über einen 300VA Ringkerntrafo mit 2x25V 
sekundär. Die gleichgerichtete Spannung am Eingang der beiden 
Linearregler 7812 und 7912 beträgt 36V.

Der untere Teil der Schaltung (2x NE5532 Operationsverstärker) ist für 
die Variation der Höhen/Bässe und Volume.

Links kommt das Audiosignal vom PC rein und rechts geht es raus auf den 
Eingang des Endverstärkers LM4780.

Soweit funktioniert der Verstärker sehr gut, wenn nicht das störende 
Brummen an den Lautsprechern (nur bei ganz kleiner Lautstärke bzw. 
Volume OFF wahrnehmbar) wäre.

Es dürfte sich hier um ein 100Hz Brummen handeln.
Wenn ich das Eingangssignal direkt auf den Eingang des Endverstärkers 
gebe ist das Brummen weg. Somit muss das Problem in der 
Klangregelschaltung zu suchen sein.

Kann mir jemand einen Tip geben, was ich hier machen soll?

von Stefan S. (mexakin)


Bewertung
0 lesenswert
nicht lesenswert
ich habe sone Schaltung noch nie Aufgebaut, aber was mir auffällt:

von 36V auf 12V linear regeln würde mir zuviele Verluste machen, aber 
zum testen geht das keine Frage.

Wieso ist der Ausgang DC entkoppelt, der Eingang aber nicht, macht man 
das im Audio nicht auch DC entkoppelt am Eingang?

von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
stefan schmitt schrieb:
> ich habe sone Schaltung noch nie Aufgebaut, aber was mir auffällt:

> Wieso ist der Ausgang DC entkoppelt, der Eingang aber nicht, macht man
> das im Audio nicht auch DC entkoppelt am Eingang?

Hmmmm, jetzt wo du das sagst - ich werd mal am Eingang einen Kondensator 
zur DC Entkopplung reinbauen. Mal schauen, was passiert.

von TomA (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo m. g.

brummen rührt oft von einer "Erdschleife" her. Überprüfe mal die Masse 
deiner Geräte, ob du irgendwie einen Massering herstellst? Vergiss dabei 
auch die Schutzleiter der Geräte nicht, sie sind über die Steckdose 
miteinander verbunden.

Und sag bescheid, wenn die Würstchen fertig sind - dein Netzteil ist ein 
prima Grill geworden. Die Spannungsregler verbraten mehr Leistung als 
die Endstufe. :)

Gruß. Tom

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
TomA schrieb:

> Die Spannungsregler verbraten mehr Leistung als
> die Endstufe. :)

Die Frage ist, was alles an den 12V angeschlossen ist.
Allerdings sind die Regler spannungsmäßig überfordert,
was früher oder später zum Durchschlag führen kann.

von moeb (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die 7812 werden außerhalb der Absolute Maximum Ratings betrieben:
http://www.ti.com/lit/ds/symlink/lm7805c.pdf
Input Voltage (VO=5V,12V and 15V) = 35V

von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
Harald Wilhelms schrieb:
> TomA schrieb:
>
>> Die Spannungsregler verbraten mehr Leistung als
>> die Endstufe. :)
>
> Die Frage ist, was alles an den 12V angeschlossen ist.
> Allerdings sind die Regler spannungsmäßig überfordert,
> was früher oder später zum Durchschlag führen kann.

an den 12V hängen nur die OPs. Die Linearregler sind gut gekühlt und 
erreichen im Betrieb ca. 45°C. Die Eingangsspannung ist an der Grenze, 
aber nicht überschritten. Das sollte also kein Problem werden.

Ich weis, es gäbe hier feinere Lösungen, aber ich möchte auch meine 
lagernden Bauteile verwenden. Und auf die paar hundert mW was die beiden 
Linearregler verbraten kommts mir dann auch nicht drauf an.

von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
TomA schrieb:
> Hallo m. g.
>
> brummen rührt oft von einer "Erdschleife" her. Überprüfe mal die Masse
> deiner Geräte, ob du irgendwie einen Massering herstellst? Vergiss dabei
> auch die Schutzleiter der Geräte nicht, sie sind über die Steckdose
> miteinander verbunden.

Hallo Tom,

Masse nehme ich zentral zwischen den beiden großen Elkos ab. Den Trafo 
habe ich zum Test auch mit Kupferband abgeschirmt und den Schirm mit 
Erde verbunden. Hier war aber kein Unterschied zum Verhalten ohne 
Abschirmung zu erkennen.

von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
moeb schrieb:
> Die 7812 werden außerhalb der Absolute Maximum Ratings betrieben:
> http://www.ti.com/lit/ds/symlink/lm7805c.pdf
> Input Voltage (VO=5V,12V and 15V) = 35V

Wenn ich ganz genau messe, dann habe ich am Eingang der Regler 35,4V. 
Also die 0,4V mehr sind sicher nicht das Problem.

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
m. g. schrieb:
> Somit muss das Problem in der Klangregelschaltung zu suchen sein.

Nicht unbedingt. Die ist ja aus "wenn nicht das störende
Brummen an den Lautsprechern (nur bei ganz kleiner Lautstärke bzw.
Volume OFF wahrnehmbar) wäre."

Meist entsteht Brummen durch falsche Masseführung, und dein PC als 
Quelle hängt am Schutzleiter. Über die korrekte 
Masse-Sternpunktverlegung zeichnest du nichts.

Desweiteren ist deine Schaltung recht fehlerhaft:

1k Eingangswiderstand und 50k Ausgangswiderstand sind irgendwie 
"falschrum". 47k als Quellwiderstand für NE5532 ist auch zu hoch da 
rauscht der, er will lieber niederohmigere Quellen sehen, für so 
hochohmigen Aufbau wäre der TL072 besser geeignet.

Auch vermisse ich mindestens einen Kondensator im Bassregelzweig
http://sound.westhost.com/dwopa2.htm

7812/7912 an gleichgerichteten 36V~ aus der Trafoangabe im Schaltplan 
dürfen platzen, du schreibst allerdings im Text 2x25V, was 
gleichgerichtete 36V= ergäbe, auch knapp zu viel für die Regler aber 
damit werden sie wohl nicht gleich platzen, allerdings wird die 
Leerlaufspannung so 3V höher liegen.

von moeb (Gast)


Bewertung
0 lesenswert
nicht lesenswert
m. g. schrieb:
> moeb schrieb:
>> Die 7812 werden außerhalb der Absolute Maximum Ratings betrieben:
>> http://www.ti.com/lit/ds/symlink/lm7805c.pdf
>> Input Voltage (VO=5V,12V and 15V) = 35V
>
> Wenn ich ganz genau messe, dann habe ich am Eingang der Regler 35,4V.
> Also die 0,4V mehr sind sicher nicht das Problem.

Absolute Maximum Ratings bedeuten nicht, wenn innerhalb => "funktioniert 
auf jeden Fall"

sondern:
Wenn außerhalb => Geht auf jeden Fall 
kaputt/explodiert/schmilzt/magischer Rauch raus

Du solltest eine Verlustleistungsberechnung anstellen und insgesamt 
immer DEUTLICH unter den absolute maximum ratings bleiben, es sei denn, 
deine Schaltung muss nur 5min funktionieren ;)

von TomA (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo  m. g.

wenn die Störung aus dem Trafo kommt, dann hilft Kupfer als Abschirmung 
wenig. Dann ist die Störung das Magnetfeld des Trafo und das durchdringt 
Kupfer. Probiere versuchsweise mal eisenhaltiges Blech 
(Konservendosenblech) als Schirm oder trenne, falls möglich, das 
Netzteil räumlich vom Verstärker. Beides kann dir zeigen, ob der Trafo 
bzw. sein Magnetfeld die Ursache des Brummen ist.

Viel Erfolg. Tom

von Peter D. (peda)


Bewertung
0 lesenswert
nicht lesenswert
Sind die Leitungen zu allen Potis geschirmt?
Sind alle Poti-Gehäuse geerdet?

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
TomA schrieb:

> wenn die Störung aus dem Trafo kommt,

Das ist bei Ringkerntrafos eher unwahrscheinlich.
Es sei denn, der TE meint merchanisches Brummen durch
falsche Montage.

von TomA (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Harald Wilhelms,

habe es jetzt auch gelesen. Ja, bei Ringkerntrafo ist der als 
magnetische Störquelle eher unwahrscheinlich - danke für den Hinweis.

Zu überprüfen ob er nicht vielleicht die Störquelle ist, kann trotzdem 
nicht schaden. Im Grunde können wir nur raten.

Als kleine Hilfe vielleicht noch etwas Allgemeines zur 
Störungbeseitigung:

Bei Störgeschehen gibt es drei Beteiligte - Die Störquelle, die 
Störsenke und den Übertragungsweg. Die beste Art eine Störung zu 
beseitigen ist das beseitigen der Störquelle, das geht meist aber nicht. 
Deshalb kann man versuchen der Übertragungsweg zu unterbrechen (z.B: 
geeignet abschirmen). Als Letztes bleibt die Schaltung gegen die Störung 
unempfindlich zu machen (z.B: Filter). Da man die örtlichen 
Gegebenheiten vorher nicht kennt, wird man vorsorglich bereits Maßnahmen 
(Schirme und Filter) in den Geräten verbauen.

Gruß. Tom

von Stefan S. (mexakin)


Bewertung
0 lesenswert
nicht lesenswert
Also wenn das brummen von der netzgebunden Spannungsversorgung kommen 
sollte, ganz einfach Testweg:

Spannung diretk aus Netzteilen versorgen oder den Netzspg Trafo, wenns 
dann nicht mehr da ist, muss es das gewesen sein.

Und wenn das ein 100Hz signal sein sollte muss das ja ggf am Ausgang mit 
Oszi nachweisbar sein, auch einfach MEssung.

von dolf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
für die vorstufen nimmt man immer nen separaten kleinen trafo oder man 
sieht ne passend dimensionierte wicklung auf dem leistungstrafo vor.
ein printtrafo von der "stange" mit 2*15v/100 ... 200ma sollten reichen.
dann hat man auch das problem mit den hohen spannungen/verlustleistungen 
am regler nicht.
hab grad nen sub in betrieb genommen.
da ist für das filter auch n eigenes nt mit +-12v zuständig.
hier brummt nicht´s!
sternerdung beachten, schirme nur einseitig an gnd legen, 
schirmen/geschirmte signalleitung verwenden, verstärkung auf das 
notwendige begrenzen, die schaltung nicht zu hochohmig auslegen.
mfg

von ixil96 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Peter Dannegger schrieb:
> Sind die Leitungen zu allen Potis geschirmt?
> Sind alle Poti-Gehäuse geerdet?

Potis sind direkt auf der Platine
Poti-Gehäuse sind nicht geerdet, aber eine Erdung der Gehäuse hat keine 
Veränderung gebracht.

von dolf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ixil96 schrieb:
> Potis sind direkt auf der Platine
> Poti-Gehäuse sind nicht geerdet, aber eine Erdung der Gehäuse hat keine
> Veränderung gebracht.

sind die schirme der signalleitungen einseitig geerdet?
wenn die beidseitig geerdet sind bekommst ne brummschleife rein.
masse  wird exrea verlegt.
mfg

von dolf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ixil96 schrieb:
> Potis sind direkt auf der Platine
> Poti-Gehäuse sind nicht geerdet, aber eine Erdung der Gehäuse hat keine
> Veränderung gebracht.

sind die schirme der signalleitungen einseitig an gnd?
wenn die beidseitig an gnd sind bekommst ne brummschleife rein.
gnd der einzelnen stufen kommen am den sternpunkt im nt.
und das die gnd seite der lautsprecher auch am sternpunkt enden ist 
bekannt.
kleiner tip ne dc überwachung mit einschaltverzögerung kostet net viel.
der basslautsprecher kostet schon.
mfg

von M. G. (ixil96)


Bewertung
0 lesenswert
nicht lesenswert
dolf schrieb:
> ixil96 schrieb:
>> Potis sind direkt auf der Platine
>> Poti-Gehäuse sind nicht geerdet, aber eine Erdung der Gehäuse hat keine
>> Veränderung gebracht.
>
> sind die schirme der signalleitungen einseitig geerdet?
> wenn die beidseitig geerdet sind bekommst ne brummschleife rein.
> masse  wird exrea verlegt.
> mfg

Ich habe hier ein Kabel von einem Chinch Stecker genommen. 2 
Drahtleitung (Schirm ist beidseitig (am Ausgang des Klangreglers und am 
Eingang der Endstufe) mit Masse verbunden)

von M. G. (ixil96)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier die Messung des Brumms auf der V+ Leitung direkt nach dem 10000uF 
Kondesator. Die 100HZ Brummspannung beträgt ca. 160mV Spitze-Spitze.

von Kai K. (klaas)


Bewertung
0 lesenswert
nicht lesenswert
Der 7912 ist falsch entkoppelt! 100n reichen nicht!!!

von Kai K. (klaas)


Bewertung
0 lesenswert
nicht lesenswert
>Wenn ich ganz genau messe, dann habe ich am Eingang der Regler 35,4V.
>Also die 0,4V mehr sind sicher nicht das Problem.

Eieiei! Aber vielleicht sind 5...10% Netzüberspannung ein Problem??

Die Regler so knapp an der Grenze zu betreiben ist völlig unsinnig! Nur 
ein blutiger Anfänger tut so etwas.

von Thomas O. (kosmos)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Den Gleichrichterdioden jeweils einen spannungsfesten Kerko spendieren. 
Viele Spannungsregler brauch 1-10uF Elko manchmal sogar Low ESR am 
Ausgang. Die Versorgung der NE5532 würde ich nochmal extra Filtern und 
Puffern 100uH und 100uF direkt am NE5532. Ansonsten einfach mit dem 
Tastkopf der Schaltung entlang messen um den Punkt zu finden wo die 
Störung rein kommt bevor sie verstärkt wird.

Anbei nochmal ein Bild eines Gleichrichter aus einer PA-Endstufe mit 
besagten Kerkos, da hat es einen zerlegt gehabt.

von dolf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
m. g. schrieb:
> Ich habe hier ein Kabel von einem Chinch Stecker genommen. 2
> Drahtleitung (Schirm ist beidseitig (am Ausgang des Klangreglers und am
> Eingang der Endstufe) mit Masse verbunden)

falsch

die klangregler platine bekommt nen separaten anschluß zum sternpunkt.
die endstufe natürlich auch.
die schirme werden ebenfalls separat an gnd geführt.
über den schirm darf kein signalstrom fließen was durch den einseitigen 
anschluß an gnd erfolgt.
wobei auszuprobieren ist was den geringsten brumm ergibt.
gnd sternpunkt, gnd am endverstärker oder gnd an der klangreglung.

von MaWin (Gast)


Bewertung
1 lesenswert
nicht lesenswert
m. g. schrieb:
> Hier die Messung des Brumms auf der V+ Leitung direkt nach dem 10000uF
> Kondesator. Die 100HZ Brummspannung beträgt ca. 160mV Spitze-Spitze.

Also für die Entladekurve der 10000 uF zwischen den Sinushalbwellen ist 
sie falschrum.

von meinereiner (Gast)


Bewertung
0 lesenswert
nicht lesenswert
m. g. schrieb:
> an den 12V hängen nur die OPs. Die Linearregler sind gut gekühlt und
> erreichen im Betrieb ca. 45°C. Die Eingangsspannung ist an der Grenze,

In meinem AER Bingo sind auch 7815er an 36Volt eingebaut. Und der Amp 
zählt zu der Oberklasse.

von Thomas O. (kosmos)


Bewertung
0 lesenswert
nicht lesenswert
Dieser Brumm wie auf dem Bild ist ein schwingen des Spannungsregler.

von WolframR_ (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Du könntest folgendes versuchen:

zwischen Gleichrichterausgang und Elkos jeweils einen R von ca. 100 Ohm 
einsetzen (also jeweils in die Plus- und Minus-Leitung).


Das hat bei mir bei einer ähnlichen Schaltung den Brumm vollständig 
eliminiert.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.