Forum: Mikrocontroller und Digitale Elektronik Newhaven Display flackert


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Thomas M. (tom_holzwurm)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Kollegen,
ich bin gerade dabei, mich in de Thematik Grafikdisplays einzuarbeiten:
Ich habe mir zwei Newhaven displays beschafft ( 240x64 & 240x128 Pixel ) 
Controller T6963.
Angesteuert von einem ATXMega über Parallelinterface mit den bekannten 
Bibliotheksfunktionen laufen die Displays auch, aber:
Im Grafikmodus z.B. bei Darstellung von externen Fonts oder Bitmaps 
flackern beide Display sehr stark, das große noch mehr als das kleine.
Die Daten werden zum Test nur einmal geladen, danach hält der Prozessor 
an.
Es sieht aus wie Interferenzen, die wellenartig vertikal über Display 
laufen.
Im Textmodus ist die Darstellung völlig ruhig !
Geschätzte Flackerfrequenz so um die 10Hz.
Da ich mehrere Exemplare besitze, kann es kein Defekt des Displays sein 
und grundsätzlich muss es funktionieren, der Hersteller wirbt ja auch 
damit.

Hat jemand eine Idee, wo ich suchen sollte ?
Danke für Eunre Hilfe,
Gruß Thomas

von google (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gut ausgeleuchtetes, scharfes, detailreiches Foto vom Aufbau? 
Bildformate beachten

von holger (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>Es sieht aus wie Interferenzen, die wellenartig vertikal über Display
>laufen.

Halt mal ne Taschenlampe drauf. Wird der Effekt dann weniger?

von spess53 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hi

>Es sieht aus wie Interferenzen, die wellenartig vertikal über Display
>laufen.
>Im Textmodus ist die Darstellung völlig ruhig !
>Geschätzte Flackerfrequenz so um die 10Hz.

Mit welcher Spannung laufen die Displays?

MfG Spess

von Stephan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Glaubst du, dass die Timings richtig sind?
Wird das Display vernünftig versorgt?
Ich hatte selber vor ein paar Monaten Newhaven Displays verbaut und 
programmiert und besonders mit der Hintergrundbeleuchtung Probleme 
gehabt.
Hab dann den Versorgungspin für die Hintergrundbeleuchtung einfach offen 
gelassen.
Hmm, mir fällt gerade ein, dass es auch der Pin für den Kontrast gewesen 
sein könnte.

von Thomas M. (tom_holzwurm)


Bewertung
0 lesenswert
nicht lesenswert
Aaaalso :-)
Wie bescheuert muss man ( ich ) denn sein ......
Problem war, dass ich den Screenrefresh, also Update des Inhalts nicht 
mit dem PWM Signal für das Dimmen der Hintergrundbeleuchtung 
synchronisert hatte.
Wenn ich die Helligkeit auf 100% stelle ist das Problem genauso weg, wie 
wenn ich den Refresh abschalte.
Lösung: Update des Displayinhalts in den Dunkelphasen der 
Hintergrundbeleuchtung und gut ist es !

Im Übrigen, weder die 3,3V zu 5V Logik macht Probleme noch irgendwelche 
Versorgungsprobleme liegen vor, sieht alles gut aus.

Trotzdem danke für die Hilfe
Gruß Thomas

von spess53 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hi

>Wie bescheuert muss man ( ich ) denn sein ......
>Problem war, dass ich den Screenrefresh, also Update des Inhalts nicht
>mit dem PWM Signal für das Dimmen der Hintergrundbeleuchtung
>synchronisert hatte.

Wie passt das zu der Aussage:

>Die Daten werden zum Test nur einmal geladen, danach hält der Prozessor
>an.

?

MfG Spess

von Peter D. (peda)


Bewertung
0 lesenswert
nicht lesenswert
Thomas M. schrieb:
> Problem war, dass ich den Screenrefresh, also Update des Inhalts nicht
> mit dem PWM Signal für das Dimmen der Hintergrundbeleuchtung
> synchronisert hatte.

Sollte aber nur dann ein Problem sein, wenn man die Pixel immer wieder 
löscht. Wenn man die Pixel mit dem neuen Wert überschreibt, aber nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.