Forum: Mikrocontroller und Digitale Elektronik Tauchlampe mit Reedkontakten schalten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich bräuchte Eure Hilfe da ich leider nicht viel Ahnung von der Sache 
habe mit Schaltungen erstellen. Löten wäre aber kein Problem. Und zwar 
habe ich eine Tauchlampe wo die aktuelle Schaltung nicht mehr richtig 
funktioniert. Daher würde ich gerne einen neuen Schaltkreis bauen oder 
Bausatz kaufen.
Geschaltet wird mit einem Reedkontakt für Ein 100% noch mal drücken des 
Taster Leistung. 50%
Per 2. Reedkontakt bei gedrückthalten 2-3 sek Tauchlampe Aus. Eventuell 
noch Tiefentladeschutz und Softstart?
So war die alte Schaltung.
Spannung wär 12 V max. 14.4 V mit Überlast. 4.5 A haben die Akkus.

Ich hoffe Ihr könnt mir da helfen.

MfG Sven

von oszi40 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sven schrieb:
> eine Tauchlampe wo die aktuelle Schaltung nicht mehr richtig
> funktioniert

Dann suche den Fehler und tausche die defekten Teile oder mache 
wenigstens ein Foto von dem Ding. Zu 90% besteht mein Verdacht, daß 
Deine Akkus tiefentladen wurden und nun krank sein könnTEN.

von Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Danke für die schnelle Antwort.
Aber Akku wurde schon getauscht. Daran liegt es nicht. Auf der Lampe ist 
dauerhaft Strom. Sobald man den Halogenstrahler einsetzt in die Fassung 
leuchtet er.
Bilder muss ich mal schauen. Kann ich eventuell morgen machen.

von Sebastian S. (amateur)


Bewertung
-1 lesenswert
nicht lesenswert
Reed-Kontakte haben es nicht so mit Schalten (rastend).

Ist der Magnet in der Nähe, so sind sie geschlossen, andernfalls tappst 
Du im Dunkeln.

Eine 50%-Stellung ist nur mit einem Vorwiderstand (verschwenderisch) 
oder mit Elektronik machbar.

Denk mal beim Ausschlachten daran, eine LED, anstelle der Glühbirne, für 
deine Erleuchtung vorzusehen. Die leben viel länger, können härtere 
Stöße ab und die Akkus freuen sich ebenfalls.

von oszi40 (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sebastian S. schrieb:
> Reed-Kontakte haben es nicht so mit Schalten

Sie könnten auch kleben und deshalb nicht klicken?

von H.Joachim S. (crazyhorse)


Bewertung
0 lesenswert
nicht lesenswert
Vermutung: das Ding läuft mit PWM und der Mosfet ist durch.

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Hab mich jetzt mal angemeldet. Also bin der Ersteller.
Bei der Lampe handelt es sich um die Oceanic OP 504 ex. Leider bekommt 
man keine Schaltpläne von der Lampe. Die Lampe hat noch eine SOS 
funktion mit einer kleinen Led auf der Rückseite. Funkioniert noch. Auch 
die Led dass die Lampe an ist. Nur auf dem Halogenstrahler ist dauerhaft 
saft bis der Akku leer ist.
Beim Ein und Ausschalter handelt es sich um so drucktaster die innen 
drinnenReedkontakte schalten.
Die Lampe hat vermutlich beim Akkutausch einen Kurzschluss bekommen. Ein 
Bauteil hatte ein Loch (verschmort). Habe es getauscht, hat aber nichts 
gebracht. Gleicher fehler immer noch vorhanden.
Umbau auf Led hört sich auch gut an. Ist das sehr kompliziert/teuer?

Dieses Bauteil wurde getauscht da es durchgebrannt war: 
PMIC-L6902D013TR-SOIC-8-STMicroelectronics

Den Lampenkopf bekommtmanaber vermutlich nicht auf bezüglich Led 
umbau...

Wie wäre es mit einer neuen Schaltung zu versuchen? Bräuchte dabei aber 
hilfe da ich davon nicht wirklich viel Ahnung habe.

: Bearbeitet durch User
von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Sven Haß schrieb:
> Dieses Bauteil wurde getauscht da es durchgebrannt war:
> PMIC-L6902D013TR-SOIC-8-STMicroelectronics

Hmm, das ist aber nur der Laderegler. Da muss es noch irgendwo einen 
Leistungshalbleiter (mit min. 3 Beinen oder Pins) geben, der vermutlich 
einen Kurzschluss hat, weswegen die Lampe dauernd leuchtet.

Sven Haß schrieb:
> Wie wäre es mit einer neuen Schaltung zu versuchen?

Schwierig, wenn du keinen Spezi in der Nähe hast. Es bedarf einer 
Auswertung eines Reedkontaktes, denn damit kannst du nicht direkt die 
Lampe schalten. Dann braucht es noch eine PWM Schaltung, die für die 50% 
Stellung sorgt.
So etwas macht man heute meistens mit einem Mikrocontroller, der aber 
etwas ausserhalb deiner Reichweite ist.

: Bearbeitet durch User
von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Danke mal bisher an alle.

Ich werde heute mal Bilder von den 2 Platinen machen und die mal 
reinstellen. Vielleicht hilft das euch weiter.
Wenn jemand vielleicht dabei Vor Ort helfen kann, komme von
Pforzheim / Baden Würrtemberg.

von SonicHazard (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Was wir jetzt wissen ist dass der Schaltregler der Lampe (wieder) 
funktioniert. Kannst Du die Reedkontakte überprüfen? Was sitzt noch auf 
der Steuerplatine?

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Die Reedkontakte müssten ja funktionieren, da die Lampe sich schalten 
lässt. Nur an der Leuchtkraft/ Aus funktioniert nicht. Sie ist dauerhaft 
auf 100%
Das funktionierte aber auch schon vor dem Tausch des Bauteils.
SOS blinklicht funktioniert ja auch. Nur das Leuchtmittel lässt sich 
nicht steuern.

von stefan (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sven Haß schrieb:
> Die Reedkontakte müssten ja funktionieren, da die Lampe sich schalten
> lässt.

Versteh ich nicht. Wenn sie nicht aus geht und du die Helligkeit nicht 
ändern kannst, was kannst du dann schalten? Mach doch einfach mal eine 
Durchgangsprüfung. Ohne Magnet in der Nähe sollten sie offen sein.

Die Reedkontakte werden ganz sicher nicht den Lampenstrom schalten. Für 
die großen Ströme sind sie meist nicht geeignet. Auch das du mit einem 
Kontakt die Helligkeit einstellen kannst, spricht dafür, dass da noch 
ein Stück Elektronik dahinter sitzt, dass die Lampe z.B. per PWM 
steuert. Da kann alles mögliche defekt sein. Ohne Bilder kommen wir da 
nicht weiter.

von DerDaniel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
stefan schrieb:
> Versteh ich nicht. Wenn sie nicht aus geht und du die Helligkeit nicht
> ändern kannst, was kannst du dann schalten? Mach doch einfach mal eine
> Durchgangsprüfung. Ohne Magnet in der Nähe sollten sie offen sein.
Er hat hinten dran eine LED die den aktuellen Zustand anzeigt, und die 
tut was sie soll.

Daher mein 99,9%er Tipp auf Leistungs-Mosfet durch.
Bitte Bilder Posten, dann kann man sagen welches Bauteil getauscht 
werden muss.

von Sven H. (sven22)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Led dient nur als Licht wenn man aus dem Wasser geht. Kann man auch 
durchschalten durch den Einknopf, und halt SOS bei gedrückthalten glaube 
ich.

Hier mal ein Bild wo ich noch auf dem Handy habe. Weitere Bilder erst 
heute abend.

von Sven H. (sven22)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So hier sind ein paar Bilder. Falls weiter Bilder benötigt werden oder 
frage zu Beschriftung einfach schreiben :) Was mir gerade noch auf viel 
war bei IMG 7427 die dunkle Stelle um die Lötstelle. Verbrannt?
DANKE schon mal.

: Bearbeitet durch User
von DerDaniel (Gast)


Angehängte Dateien:
  • 15136 (600 KB, 448 Downloads)

Bewertung
0 lesenswert
nicht lesenswert
Das Ding ist  höchstwahrscheinlich kaputt.
Schreib bitte mal die Bezeichnung drauf raus, dann kann man dir sagen 
sie du es testen kannst.

von DerDaniel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sorry, Probleme mit dem Handy.
Bild 7426 das groß fette schwarze Teil in der Mitte mit 3 Anschlüssen 
und einer fetten Metall Fahne.

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
P36NF06L
6K052 V3
CHN 532
von ST

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
DerDaniel schrieb:

> Das Ding ist  höchstwahrscheinlich kaputt.

Ja, ich tippe auch auf defekten Leistungstransistor. Es könnte natürlich
auch ein Folgefehler auf Grund defekter Ansteuerung sein.
Mein Firefox zeigt das Bild übrigens auch ohne Endung an.
Gruss
Harald

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert

von Falk B. (falk)


Bewertung
0 lesenswert
nicht lesenswert
@ Sven H. (sven22)

>    IMG_7420.JPG
>    6,48 MB, 20 Downloads
>    IMG_7424.JPG
>    5,11 MB, 10 Downloads
>    IMG_7426.JPG
>    6,69 MB, 18 Downloads
>    IMG_7427.JPG
>    7,21 MB, 15 Downloads

AUA!!! Siehe Bildformate!!!

von Arni (Gast)


Bewertung
0 lesenswert
nicht lesenswert
nimm mal ein glasfaserpinsel und alkohol und feh damit mal zwischen die 
pins des ICs...da sieht es sehr nach durch feuchtigkeit verursachte 
Schäden aus...

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Sorry wegen der Dateigröße... war nicht beabsichtigt. Soll ich sie noch 
mal verkleinert hochladen?

@Arni mache ich Danke :)

Wie wäre es mit dem hier?

Ebay-Artikel Nr. 361244332526

Müsste doch der richtige sein?

Darf man Links überhaupt posten? Falls nicht bitte löschen.

: Bearbeitet durch User
von Rote T. (tomate)


Bewertung
0 lesenswert
nicht lesenswert
Haste zufällig ein Oszi oder zur not ein Voltmeter mit Frequenzmessung.
Falls ja, löte mal den STP36NF06 aus und miss, was am 1. Pin (von links) 
passiert, wenn die Lampe im 50%-Modus ist (auf der Platine ohne den 
MOSFET)

Dann auch noch den Widerstand von Pin1 nach Pin2 & Pin3 messen. 
Hochohmig ist gut/schlecht, dann ist der MOSFET vermutlich OK und was 
anderes ist kaputt

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Nein habe ich leider nicht da.Ich werde morgen mal auf der Arbeit 
schauen ob ich was finde :)

von Meckerziege (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sven H. schrieb:
> IMG_7420.JPG
> 6,48 MB
>
> ...
>
> IMG_7424.JPG
> 5,11 MB, 27 Downloads
>
> IMG_7426.JPG
> 6,69 MB, 33 Downloads
>
> IMG_7427.JPG
> 7,21 MB, 33 Downloads

Schei.e sind die Dinger groß. Keine Ahnung von Elektronik und von 
Bildformaten und angemessenen Bildgrößen noch viel weniger.

von Michael U. (amiga)


Bewertung
1 lesenswert
nicht lesenswert
Nicht Meckerziege, nur Papagei...

Gruß aus Berlin
Michael

von DerDaniel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Es reicht meist ein einfaches Multimeter.

Mess mal ohne Batterien den Widerstand zwischen den drei Beinchen und 
poste ihn hier.
Und mit Batterie drinnen die Spannung zwischen dem Minus Pol der 
Batterie und den drei Beinchen.

Wenn du Geld übrig hast, kannst du das Teil auch einfach auf Verdacht 
ersetzen. Mit hoher  Wahrscheinlichkeit geht die Lampe dann wieder.

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Alles klar ich dank mal. Im Geschäfft sollte eigentlich ein Multimeter 
sein. Werde dann mal durchmessen. Also nur den Widerstand messen, sonst 
noch was?
Muss der Mosfet dabei ausgebaut sein?

: Bearbeitet durch User
von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Sven H. schrieb:
> Muss der Mosfet dabei ausgebaut sein?

Nicht unbedingt, es ist aber hilfreich (wenn es geht), die Halogenlampe 
so lange zu ziehen und die Batterie zu entfernen. Wenn du auf die 
Schrift des Teiles schaust und die Beinchen nach unten zeigen, sollte 
zwischen dem mittleren Pin (Drain) und dem rechten Pin (Source) kein 
niedriger Widerstand zu messen sein. Falls das doch der Fall ist, hat 
der MOSFet einen Kurzschluss und ist defekt.

Sven H. schrieb:
> Darf man Links überhaupt posten?

Sischer dat. So kann man sich doch langwierige Erklärungen sparen. Ja, 
wäre der richtige.

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Alles klar. Werde ich dann mal testen. Woran erkenneich eig. genau ob 
der IC den ich getauscht habe richtig oder falsch herum eingelötet 
wurde?
Markierung oder der gleichen habe ich nichts gefunden.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Sven H. schrieb:
> Woran erkenneich eig. genau ob
> der IC den ich getauscht habe richtig oder falsch herum eingelötet
> wurde?

Am besten schaut man natürlich, wie der alte eingebaut war :-P

Wenn das nicht mehr geht, kann man mit Hilfe des Datenblattes mal ein 
paar relevante Leitungen verfolgen, wie z.B. Masse oder die 
Betriebsspannung. Die Schrift auf solchen IC wird eigentlich immer so 
angebracht, das, wenn sie lesbar ist, Pin 1 unten links ist. Bei SOIC 8 
ist auch oft die Seite abgeschrägt, auf der Pin 1 und Pin 8 ist.

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Schräge oder abgeflacht war nichts zu erkennen. Habe dann die 
Beschriftung in gleicher richtung wie beim alten verbaut.
Danke :)

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
Also hab gemessen. So gut wie kein Widerstand. Müsste ja dann defekt 
sein?
Werde ihn dann mal tauschen und berichten ob es geklappt hat.
Danke an alle wo dabei geholfen haben.
?

: Bearbeitet durch User
von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Sven H. schrieb:
> So gut wie kein Widerstand. Müsste ja dann defekt
> sein?

Jo, wenns nahe bei null Ohm ist, ist das der typische Fall eines 
durchlegierten MOSFet.

: Bearbeitet durch User
von Andrew T. (marsufant)


Bewertung
0 lesenswert
nicht lesenswert
Sven H. schrieb:
> Danke mal bisher an alle.
>
> Ich werde heute mal Bilder von den 2 Platinen machen und die mal
> reinstellen. Vielleicht hilft das euch weiter.
> Wenn jemand vielleicht dabei Vor Ort helfen kann, komme von
> Pforzheim / Baden Würrtemberg.


Komm hierhin am 18., bring das Teil nebst Akku und neuer Glühbirne mit. 
Ich bzw. Axel kümmern sich dann um Deine Lampe (Axel und ich sind da für 
derartige Themen vor Ort):

https://repaircafe.lauchaecker.de/

von Sven H. (sven22)


Bewertung
0 lesenswert
nicht lesenswert
@Andrew  Ich werd jetzt erst mal den MOSFET tauschen und dann hoffen 
dass sie wieder funktioniert. Falls nicht melde ich mich noch mal.
Trotzdem Danke für die Info

von Sven22 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hey,
also hat alles geklappt. Lag am MOSFET.
Funktioniert wieder komplett :)
VIELEN DANK an alle

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.