Forum: Analoge Elektronik und Schaltungstechnik Messung von Sensor, Werte echt oder von Schaltung?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Gerald M. (gerald_m17)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich messe einen resistiven Sensor, welcher mit etwa 150kHz angeregt 
wird.
Zur Auswertung wird dieser in einer Brückenschaltung betrieben.
Bei der Messung erhalte ich zwar einen Sinus, aber keine gleichmäßige 
Amplitude.
Zwei Bilder davon sind angehängt, einmal nur das Signal, und einmal das 
Signal mit Kreuzen dargestellt mit einem Fit.
Die Spannung wird über eine Referenzquelle bereitgestellt (ADR8520) und 
mit einem Instrumentenverstärker (AD8425, fixed gain of 2000, 3,5Mhz 
Bandwidth) verstärkt. (Danach noch einmal um Faktor 3 und -3)
Beim Layout habe ich die GND-Plane ausgeblendet, diese ist aber 
durchgängig oben und unten, und wurde mit Vias gespickt. Unten sind 
sowieso nur wenige Leiterbahnen.

Dieses Problem mit der variablen Amplitude gab es allerdings auch schon 
mit der vorherigen Schaltung und ich hoffte es mit der neuen Platine 
ausräumen zu können. Doch dem scheint nicht so.
Kann das vomn der Platine kommen, oder ist das wahrscheinlich der 
Sensor?

Danke schonmal
Gerald

von Pandur S. (jetztnicht)


Bewertung
0 lesenswert
nicht lesenswert
Da ist eben noch eine Modulation drauf. Eine Ahnung was kommen sollte 
muesst ihr schon haben. Der Sensor sollte ja auch irgendwie kalibriert 
werden koennen.

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Gerald M. schrieb:
> keine gleichmäßige Amplitude.
Brumm eingekoppelt. Ist da irgendwas irgendwie abgeschirmt?

> Unten sind sowieso nur wenige Leiterbahnen.
Eine einzige reicht aus, um eine Massefläche in 2 Masseschnipsel zu 
teilen. Und du hast da schon 2 davon quer über die gesamte Platine...

> Kann das vomn der Platine kommen, oder ist das wahrscheinlich der
> Sensor?
Was kommt heraus, wenn du nicht den Sensor, sondern eine 
"Sensorsimulation" mit möglichst kurzen Leitungen anschließt?

> wurde mit Vias gespickt.
Sieht man: Schrotflintentechnik. Besser wäre es, dort "Treffer" 
anzubringen, wo sie sinnvoll und nötig sind.

> einen AD8425
gibts nicht. Ist vermutlich ein AD8428...

: Bearbeitet durch Moderator
von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
Also das kabel vom Sensor zum Verstärker ist knapp 10cm lang. Über der 
Platine ist ein alublech.

Eine Simulation für den Widerstand fällt mir nicht ein (der Widerstand 
hat etwa 150 Ohm und schwankt um wenige Prozent) jedoch sollte der 
Brumm, wenn es denn einer ist, unabhängig von der Messspannung sein. So 
sollte ich das testen können :)

Zur Schrotflintentechnik, natürlich habe ich dort Vias platziert wo ich 
sie auf den ersten Blick für sinnvoll erachtet, nur eben noch zusätzlich 
ein paar, da diese ja nichts kosten und schaden sollten sie auf keinen 
Fall.
Und ja, es ist ein AD8428, bin da wohl verrutscht.

von Jens G. (jensig)


Bewertung
0 lesenswert
nicht lesenswert
Vielleicht habt Ihr einen starken Langwellensender in der Nähe stehen, 
der sich dem Sinus überlagert.

von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
Eine bestimmte Frequenz sollte es nicht sein, die Fourier-Transformation 
zeigt zumindest keine einzelne Frequenz.
Von außen sollte auch nicht viel kommen, die Messung findet in einem 
Reinraum mit etwa 1,5m dicken Stahlbetonwänden statt (früher wurde darin 
was mit Strahlung gemacht)
Ich wickle auch mal dick Alufolie um alles. Aber wie gesagt, wenn es 
nicht vom Sensor ist, sollte der Brumm ja unabhängig von der 
Messspannung sein.

von lightninglord (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gerald M. schrieb:
> Eine bestimmte Frequenz sollte es nicht sein, die Fourier-Transformation
> zeigt zumindest keine einzelne Frequenz.

Was hast du den der FFT unterzogen? Beim Messsignal liegt ja definitif 
eine dominierende Frequenz drauf, das siehste ja schon an dem hübschen 
Sinus ;-) Liegt ja recht genau 150kHz, die müsstest du in jedem Fall in 
der FFT sehen, an sonsten ist deine FFT und/oder dein Fenster falsch.

von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
Natürlich rede ich von Frequenzen die nicht den 150kHz entsprechen ;)

von Ein Fragender (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mal ne doofe Frage dazwischen: Wenn ich das Datenblatt richtig verstehe 
hat der AD8428 ein GBP von 3.5 MHz. Bei einem Gain von 2000 entpricht 
das dann noch einer Nutzbandbreite von 1.75kHz. Wenn man mit 150 kHz so 
weit außerhalb des GBP ist, kann ich mir schon vorstellen, dass das Teil 
komische Sachen macht. Welchen Gain machter der in der realen Anwendung 
denn bei den 150kHz noch?

Grüße,

Ein Fragender

von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
Ja, das liegt daran, dass du es nicht richtig verstanden hast ;)
Darin steht sogar das entsprechende GBP

von Jens G. (jensig)


Bewertung
0 lesenswert
nicht lesenswert
@ Ein Fragender (Gast)

>mal ne doofe Frage dazwischen: Wenn ich das Datenblatt richtig verstehe
>hat der AD8428 ein GBP von 3.5 MHz. Bei einem Gain von 2000 entpricht
>das dann noch einer Nutzbandbreite von 1.75kHz. Wenn man mit 150 kHz so

Wirklich gute Frage, aber trotzdem falsch gedacht. Denn das DB sagt:

"... amplifier stage of 10. This architecture results in a 3.5 MHz
bandwidth at a gain of 2000 for an equivalent gain bandwidth
product of 7 GHz. ..."

Das ist also intern nicht nur ein Langwellenempfänger ... ;-)

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gerald M. schrieb:
> Instrumentenverstärker (AD8425...

Sicher?

Gibt es dazu auch ein Datenblatt?

von Jens G. (jensig)


Bewertung
0 lesenswert
nicht lesenswert
@Wolfgang (Gast)
>> Instrumentenverstärker (AD8425...

>Sicher?

>Gibt es dazu auch ein Datenblatt?

Wieso - hat sich doch schon geklärt ...

von Ein Fragender (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Danke für die Antwort, klarer Fall von Datenblatt nicht richtig gelesen. 
In dem Fall ist der AD8428 schon ein interessantes Teil. Die 
Eingangsstufe hat dann ja ein GBP von 700Mhz, respekt.

Noch mal zur Ursprungsfrage zurück: Sich nacheinander die Teile 
anschauen.
Datenerfassungssystem am Eingang kurzschließen (OSZI, ADC Karte,...?), 
schauen ob das Signal stabil ist (DC Wert).
Instrumentenverstärker am Eingang kurzschließend, schauen ob das Signal 
stabil ist (DC Wert).
Nur Signalquelle an das Datenerfassungssystem anschließend (zu dem 
ADR8520(??) konnte ich nichts finden), schauen ob die Anregungsspannung 
stabil ist.
Ganzes System ohne den Sensor (mit einem Dummy) vermessen -> Stabilität 
bestimmen
Andere AC Quelle testen, schauen ob es dann stabiler wird.

Grüße,

Ein Fragender

von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
Hi,
danke für deine Anregungen.
So langsam frage ich mich ob ich beim abtippen der Bauteile betrunken 
war. Als Referenzspannungsquelle habe ich einen ADR4520 genutzt.
Das Messsystem ist einwandfrei, aber einfach mal das rauschen des 
Verstärkers aufnehmen macht natürlich auch Sinn ^^
Wobei ein rauschen von ~100mV schon heftig wäre :D
Aber ich kann den Sensor auch messen wenn er nicht angeregt ist (er 
misst die Biegung eines mechanischen Oszillators, sollte also 
gleichmäßig sein).
Dann habe ich ja einen Plan was ich morgen alles machen muss :)
Ich werde mich melden.

von Ein Fragender (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

jetzt wird es langsam licht. Du versogst Deinen Sensor mit einer DC 
Spannung. Die Anregung kommt von Deinem Teil, das zu vermessen willst. 
Ich hatte erst die Vermutung, dass Deine Anregung schon DC moduliert ist 
(mit 150kHz) und Du ein Messsignal (durch Bewegung/Stauchung,... des 
resistiven Sensors) auf die 150kHz aufmodulieren willst und das ganze 
dann später wieder runtermischst.

In dem Fall würde ich das System mal ohne Anregung ruhig und hoffentlich 
stabil stehen lassen und an dem Jumper SV1 aus einem Funktionsgenerator 
(evt. Funktionsgeneratorsignal nehmen und mit Spannungsteiler 1/1000 
runterteilen) einen 150 kHz Sinus in das System einspeisen.
Damit kannst Du dann unterscheiden ob die Abweichungen aus Deiner 
"Mechanik" oder aus der Elektronik kommen.

Grüße,

Ein Fragender

von lrep (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gerald M. schrieb:
> ich messe einen resistiven Sensor

Womit?
Vielleicht ist es ja bloss aliasing vom Scope...

von Lothar M. (lkmiller) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
lrep schrieb:
> Vielleicht ist es ja bloss aliasing vom Scope...
Angesichts der Zahl der Abtastpunkte und der niedrigen Frequenz kann man 
das vemutlich ausschließen.

Gerald M. schrieb:
> Aber ich kann den Sensor auch messen wenn er nicht angeregt ist
Mein Vorschlag zielte darauf ab, überhaupt nicht den Sensor zu messen, 
sondern den Verstärker. Und dazu einfach eine DifferenzGLEICHspannung 
aus einem möglichst kompakt aufgebauten und angeschlossenen 
Spannungsteiler vorne einzispeisen.

> (er misst die Biegung eines mechanischen Oszillators, sollte also
> gleichmäßig sein).
Auch mechanische Oszillatoren können Überlagerungen haben. Eine 
Gitarrensaite wäre z.B. ein langweiliger Tongenerator, wenn da nur ein 
Sinus herauskäme...

von thomas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sensorspeisespannung entfernen und dann das Signal angucken!

von Simpel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gerald M. schrieb:

"...die Messung findet in einem
Reinraum mit etwa 1,5m dicken Stahlbetonwänden statt (früher wurde darin
was mit Strahlung gemacht)"

Da "Strahlung" ein weiter Begriff ist und 1,5m dicke Wände darauf 
schliessen lassen, dass da entweder von aussen nach innen, oder... von 
innen nach aussen(!) eine sehr gute Schirmung vonnöten war.... mal 
spekulativ gefragt:

Wurde der Raum mal mit einem professionellen Strahlenmeßgerät auf 
nuklear aktive Altlasten untersucht? Besonders auch im Nahbereich 
(Beta).

Mach deine Messungen mal ausserhalb deines "strahlensicheren" 
Ex-Strahlungslabors....

von Stefan S. (mexakin)


Bewertung
0 lesenswert
nicht lesenswert
Dein Ausgangsverstärker der invertierende Teil, die Eingangsimpedanz 
beträgt dort 430 Ohm, das würde ich mla höher wählen, wer weiß ob dein 
Ausgang das bereitstellt.

Glaube zwar nicht das es was ändert, aber das ändern kann meiner Meinung 
nicht schaden.

von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
Also es ist amtlich, Pfusch am Bau.

Selbst ohne Sensor oder mit kurzgeschlossenem Sensor (da wird praktisch 
nur die Messspannung über die Brückenwiderstande gemessen), egal ob 
interne oder externe Messspannung (haben da ein riesen Teil, extra für 
so etwas) ich habe Schwingungen mit ca. 44kHz und 22kHz und einer 
Amplitude von etwa 10mV, aufm Oszi sieht das eher nach rauschen aus, am 
PC mit dem ADC (eigentlich digitaler Lockin) sieht man die Schwingungen 
deutlich.
Die Schwingungen sind auch schon direkt am Ausgang des 
Instrumentenverstärkers zu sehen.

Jetzt heißt es Schaltung zerlegen und schauen wo das herkommt -_-"

von lrep (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> lrep schrieb:
>> Vielleicht ist es ja bloss aliasing vom Scope...
> Angesichts der Zahl der Abtastpunkte und der niedrigen Frequenz kann man
> das vemutlich ausschließen.

Na ja, ich habe mit einem 1GS/s Tek auch schon etliche Stunden lang eine 
Schwingung bei 10MHz oder so gejagt, die sich dann als schnöder 
50Hz-Brumm herausstellte...


Gerald M. schrieb:
> Jetzt heißt es Schaltung zerlegen und schauen wo das herkommt -_-"

Oder doch mit einem analogen Scope mal nachschauen, ob das echt ist.

von Gerald M. (gerald_m17)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte das Thema noch einmal aufgreifen.
Bei kurzgeschlossenen Eingängen am Instrumentenverstärker erhalte ich 
angehängtes Bild.
Erst dachte ich dass es ziemlich viel rauschen ist, doch sowohl beim 
nachrechnen als auch simulieren mit LTSpice bekomme ich bei 2.5MHz ein 
RMS rauschen von 11mV. Da passt das mit dem Peak2Peak Wert aus dem Bild 
mit ca 100mV ziemlich gut rein.
Liegt einfach an dem rauschen des Verstärkers, obwohl 1.3nv/(Hz)^1/2 
ziemlich wenig ist, wird das ziemlich viel bei 6000-facher verstärkung 
und 2.5MHz -_-"

Gibt es eine alternative Methode, einen resisitven Sensor auszulesen? 
Ich dachte schon an Transimpedanzverstärker oder Stromspiegel, bei denen 
dann der Strom durch einen deutlich größeren Widerstand fließen soll. 
Doch irgendwie komme ich auf keinen grünen Zweig

von thomas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
1. Wie sieht die Sensorspeisespannung aus? Symmetrisch? Störpegel?

2. Was sollen R1 und R2 und das Poti? Das belastet die 
Brückenausgangsspannung, sonst nichts.

3. Wo wird der Instrumentenverstärker für Ubrücke =0 abgeglichen? Der 
Ref-Pin bietet sich an. Du misst doch hoffentlich nicht mit dem Oszi mit 
AC-Kopplung und der Ausgang ist DC-mässig am Anschlag?

von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
1.: +-15 Volt. Sind sehr sauber (ist die Spannung aus dem Controller, in 
dem auch der Lockin und ADCs und DACs sind)
2.: Die beiden Widerstände sind Teil der Messbrücke. Das Poti ersetzt im 
Moment noch R1 um die Brücke abzugleichen. Anmerken möchte ich hier dass 
das Oszibild bei kurzgeschlossenen Ad8428 entstanden ist. Es sollte also 
keine Differenz anliegen, weshalb die Messspannung auch relativ egal 
sein sollte.
3.: Siehe 1. DC Signal lag bei etwa 2mV. In Sättigung sieht die Spannung 
super aus (hatte mich kurz gefreut, bevor ich das bemerkte)

von thomas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
In der Tat seltsam. Ich würde mal einen anderen Instrumentenverstärker, 
vielleicht einen mit deutlich weniger Verstärkung, probieren.

von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
Wie gesagt, bei 1.3nV(Hz)^-1/2 rauschen sind wir bei 2.5Mhz und 
Gain=6000 schon bei 12mV RMS rauschen. Für peak2peak kann man das locker 
mal 6 rechnen. Also 72mV p2p
Da bin ich schon recht nahe am Wert dran, zumal das nur das rauschen des 
Amps ist.
Deswegen ja doch eine andere Möglichkeit der Verstärkung.
Ich denke ich mache ein neues passendes Thema auf.

von Possetitjel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
thomas schrieb:

> In der Tat seltsam.

Nö, eigentlich nicht.
So sieht es aus, wenn man an der Rauschgrenze arbeitet.

von Possetitjel (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gerald M. schrieb:

> Wie gesagt, bei 1.3nV(Hz)^-1/2 rauschen sind wir bei
> 2.5Mhz und Gain=6000 schon bei 12mV RMS rauschen.

Ja. - Wobei unter 1nV/sqrt(Hz) machbar sein sollte; AD797
zum Beispiel, oder AD8099. Was netto in Deiner Schaltung
an Rauschen rumkommt, müsstest Du natürlich nachrechnen.

> Für peak2peak kann man das locker mal 6 rechnen. Also
> 72mV p2p

Ey sag mal... das ist doch ein kleiner Tek. Warum lässt Du
nicht einfach Effektivwert anzeigen?

> Deswegen [suche ich] ja doch eine andere Möglichkeit der
> Verstärkung.

Naja. Mal rechnen.

Dein Sensor hat, wenn ich mich nicht irre, ungefähr 100 Ohm
Innenwiderstand. Sein eigenes Rauschen liegt also in derselben
Größenordnung wie das Rauschen des Verstärkers.

Sensor und (realer) Verstärker zusammen haben (wegen der
vektoriellen Addition) ungefähr 2nV/sqrt(Hz) Rauschen.

Sensor und (idealer = rauschfreier) Verstärker zusammen
hätten etwas über 1nV/sqrt(Hz) Rauschen. Die im besten Falle
erreichbare Verbesserung ist also Faktor 2 (6dB); real wird
es weniger sein. - Lohnt sich das?

Jetzt weisst Du auch, warum kapazitive Sensoren so beliebt
sind: Sie rauschen nicht.

von Gerald M. (gerald_m17)


Bewertung
0 lesenswert
nicht lesenswert
Possetitjel schrieb:
> Ey sag mal... das ist doch ein kleiner Tek. Warum lässt Du nicht einfach
> Effektivwert anzeigen?

Dafür habe ich mich durch das Menü geklickt, aber leider nicht gefunden. 
Habe die Daten aber auf Speicherkarte, sobald ich einen PC habe wo ich 
die rein bekomme rechne ich das aber nach :)

Possetitjel schrieb:
> Sein eigenes Rauschen liegt also in derselben Größenordnung wie das
> Rauschen des Verstärkers.

Das stimmt allerdings. Was mich aber gewundert hat war, dass das 
optische auslesen mit laser und Vierquadrantenphotodiode ein deutlich 
schöneres Signal liefert, obwohl dort nur ca 1/3 des Stromes fließt wie 
beim resistiven Sensor.
Deshalb dachte ich es muss etwas besseres geben, was ja aber nicht 
(wirklich) sein kann.

Da das Signal eh durch einen Lockin gejagt wird ist es sowieso nicht so 
schlimm, aber trotzdem Schade. Danke dir

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.