mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LED Balkenanzeige mit NE555 & CD4018 geht nicht


Autor: Flohoo (Gast)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Hallo,
ich bin gerade dabei eine Balkenanzeige nachzubauen die ich in folgendem 
Video gesehen hab:
Youtube-Video "regelbares Lauflicht mit 555 + 4018 // inkl. Schaltplan zum Nachbauen"

(ich hoffe ich darf den Link hier posten)

Aufgebaut ist die Schaltung 1:1, die Test LED am Ausgang des NE555 
blinkt (Frequenz einstellbar).

Jedoch leuchten alle LED´s an den Ausgängen des CD4018 auf ohne zu 
blinken oder -wie erhofft- der Reihe nach hochzuzählen.

Der Aufbau ist auf einem Breedboard gemacht, eventuell hat ja jemand ne 
Ahnung wo mein Fehler liegen könnte. (Verdrahtungsfehler schließ ich aus 
und getestet hab ich auch mit mehreren CD4018)

Eventuell hab ich was übersehen, aber der Aufbau ist wirklich 1:1

Danke schonmal

Grüße
Flo

Autor: Teo D. (teoderix)
Datum:

Bewertung
6 lesenswert
nicht lesenswert
Schaltplan auf VIDEO!
Sorry, ich tu mir das nicht an.

Autor: Route 6. (route_66)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flohoo schrieb:
> Eventuell hab ich was übersehen, aber der Aufbau ist wirklich 1:1

Entspricht dein Aufbau dem Video oder der Zeichnung im Video?

Autor: Flohoo (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Hey,
ja sorry... ich find leider nirgends nen alternativen Schaltplan.

Ich hab beides getestet, also das Video pausiert und aufgebaut.

Ebenso hab ich den folgenden Aufbau getestet, jedoch nur mit einem 
CD4018 (DD1 im Plan) und Ausgang Q5 auf Data um alle zurückzusetzen.

http://zpostbox.ru/digital_sine_wave_generator_wit...

Der NE555 hat als R1 2.2kOhm und als R2 nen Poti das bis 5kOhm geht.

Braucht der CD4018 ne gewisse Eingangsfrequenz?
Find darüber leider nichts.

Danke :)

Autor: Route 6. (route_66)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Route 6. schrieb:
> Entspricht dein Aufbau dem Video oder der Zeichnung im Video?

Nochmal, beantworte die Frage!
Der Breadbordaufbau entspricht nicht der Zeichnung.

: Bearbeitet durch User
Autor: Kurt A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aufbau und Schaltplan im Video sind nicht identisch. Im Schaltplan sind 
Pin 2+3 mit GND verbunden. Im Aufbau sind nur Pin 2+3 miteinander 
verbunden und haben keine Verbindung zu GND. Die Widerstände für die LED 
sind im Aufbau zwischen IC und LED geschaltet. Im Plan jedoch nach der 
LED zu GND gezeichnet.

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeichne doch einfach mal auf was Du da zusammengestöpselt hast.
Event. fällt Dir dabei auch gleich ein Fehler auf.

Autor: Flohoo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beides getestet! Da ich das auch gemerkt hab.

Bei dem oben genannten Sinus Generator Link leuchten auch nur alle 
LED´s, als würden sie nicht zurückgesetzt werden.

Ich kann mir aber auch irgendwie nicht vorstellen dass alle 10 China 
IC´s Müll sind :/

Autor: Der Andere (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Flohoo schrieb:
> ja sorry... ich find leider nirgends nen alternativen Schaltplan.

Oh mein Gott, wenn man nix aus dem Internet kopieren/klauen kann ist die 
Smartphone Generation inzwischen völlig aufgeschmissen.

Kleiner Tipp von mir, am Besten bastelst du auch nur noch virtuell 
ELektronik in einer App

SCNR

Autor: Flohoo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine Sache hab ich anders:

Ich benutz bei den LED´s keine Vorwiderstände. Was die Schaltung aber 
nicht beeinflussen sollte, oder irre ich mich?
Die sind doch nur für den Schutz der LED´s?

Pin 2 und 3 hab ich auf GND. Aufbau aktuell wie beim Sinus Generator, 
nur dass die Ausgänge auf LED´s gehen und Q5 zusätzlich auf den DATA 
Eingang.

Autor: fireheart (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem 4018er hab ich auch noch nie was gebaut, aber das Ding ist ganz 
interessant.
Wenn ich einen Blick auf das Datenblatt vom 4018er werfe, fällt mir aber 
schon mal auf, dass Du auf jeden Fall Pin15 (RESET) und Pin10 (PRESET) 
auf Masse legen musst, was im Schaltplan für PRESET schon mal nicht der 
Fall ist. Wenn dein Clock-Signal in Ordnung ist und du Pin16 (Vcc) an 
Plus hängst (was im Schaltplan etwas seltsam gezeichnet ist), dann wird 
das Ding wohl auch funktionieren.

Mein erstes "ernsthaftes" Projekt vor 35 Jahren war auch ein Lauflicht 
mit einem 4017er. Grade vor einem Monat hab ich ein Lauflicht mit 16 
COB-LEDs (5W) mit Mikroprozessorsteuerung (alle möglichen Muster und 
Bedienung über Pulsdrehgeber und LCD-Display) gebaut ... somit schließt 
sich der Kreis wieder.

Autor: Flohoo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
fireheart schrieb:
> Wenn ich einen Blick auf das Datenblatt vom 4018er werfe, fällt mir aber
> schon mal auf, dass Du auf jeden Fall Pin15 (RESET) und Pin10 (PRESET)
> auf Masse legen musst, was im Schaltplan für PRESET schon mal nicht der
> Fall ist. Wenn dein Clock-Signal in Ordnung ist und du Pin16 (Vcc) an
> Plus hängst (was im Schaltplan etwas seltsam gezeichnet ist), dann wird
> das Ding wohl auch funktionieren.

Genau das dachte ich auch, und hab nach Datenblatt, bzw jetzt gerade 
nach Sinus Generator verdrahtet. Jedoch leuchten die LED´s konstant.


Hab gerade aber festgestellt, wenn ich die LED an Ausgang 5 abstöpsel, 
zählt der IC auf 4 hoch und wieder der Reihe nach runter, also:

1 an, 2 an, 3 an, 4 an, 1 aus, 2 aus, 3 aus, 4 aus...

Eigentlich sollte pin 5 ja das ganze auf Reset setzen und von 1 bis 5 
wieder hochgezählt werden.

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann gib zumindest der LED am Ausgang 5 einen Vorwiderstand, wenn du 
schon glaubst das es genügt wenn die Innenbeschaltung des IC als 
Strombegrenzung tätig ist.

Autor: Kurt A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flohoo schrieb:
> Die sind doch nur für den Schutz der LED´s?

Nicht nur. Auch zum Schutz des IC vor Überlastung.

Autor: Flohoo (Gast)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
Oh man! D

Hubert G. schrieb:
> Dann gib zumindest der LED am Ausgang 5 einen Vorwiderstand, wenn
> du
> schon glaubst das es genügt wenn die Innenbeschaltung des IC als
> Strombegrenzung tätig ist.

Du bist mein Held!

Ich hab eigentlich keine Widerstände verbaut, da ich auf den Schutz der 
billig test LED´s verzichten wollte, ich wusste nicht dass das eine 
Auswirkung auf die Funktion der Schaltung hat!

Vielen vielen Dank!

Eine Frage noch:
Wäre es möglich dass, wenn LED 5 an ist, alle LED´s resettet werden und 
von vorne gezählt wird?

Danke! :)

Autor: Ralf D. (doeblitz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flohoo schrieb:
> Eine Frage noch:
> Wäre es möglich dass, wenn LED 5 an ist, alle LED´s resettet werden und
> von vorne gezählt wird?

Nicht wirklich, denk mal nach: wenn du Ausgang 5 zum Reset zurückführst, 
dann wird der Zähler genau dann zurückgesetzt, wenn Ausgang 5 High wird. 
Die LED 5 leuchtet dann nur solange wie der Zähler für den Reset 
braucht, und das wirst du kaum noch sehen können.

Wenn du ein D-Flipflop (z.B. 4013) an Q5 hängst (gleicher Takt wie für 
den Zähler), dann kannst du das Signal um einen weiteren Takt verzögern 
(Q an Reset des Zählers und des D-Flipflops) und solltest das gewünschte 
Leuchtverhalten bekommen.

Autor: Flohoo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ralf D. schrieb:
> Flohoo schrieb:
>> Eine Frage noch:
>> Wäre es möglich dass, wenn LED 5 an ist, alle LED´s resettet werden und
>> von vorne gezählt wird?
>
> Nicht wirklich, denk mal nach: wenn du Ausgang 5 zum Reset zurückführst,
> dann wird der Zähler genau dann zurückgesetzt, wenn Ausgang 5 High wird.
> Die LED 5 leuchtet dann nur solange wie der Zähler für den Reset
> braucht, und das wirst du kaum noch sehen können.
>
> Wenn du ein D-Flipflop (z.B. 4013) an Q5 hängst (gleicher Takt wie für
> den Zähler), dann kannst du das Signal um einen weiteren Takt verzögern
> (Q an Reset des Zählers und des D-Flipflops) und solltest das gewünschte
> Leuchtverhalten bekommen.

Das würde nichts ausmachen, 4 Outputs langen für mein Vorhaben, wenn der 
5te die ersten 4 reseten könnte wäre dies optimal.

Ich kriegs nur nicht hin..

Irgend ein Vorschlag?

Aufbau: Reset auf Q5 geht nicht, mit Pulldown Widerstand an Q5 ebenfalls 
nicht..

Autor: Flohoo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch ne Frage: gibts ne Möglichkeit dass nachdem die Schaltung aus und 
wieder eingeschaltet wurde das Lauflicht von 0 an anfängt zu zählen?

Konkret: Der Audi Blinker soll für nen Modellauto nachgebaut werden, als 
einschaltbare "Warnblinkanlage".

Nehm ich aber die Spannung weg und geb gleich wieder welche drauf, 
startet das Lauflicht an nem Random Punkt..

Autor: Jobst M. (jobstens-de)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flohoo schrieb:
> aber der Aufbau ist wirklich 1:1

YMMD! :-D


Gruß

Jobst

Autor: Gerald B. (gerald_b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flohoo schrieb:
> Nehm ich aber die Spannung weg und geb gleich wieder welche drauf,
> startet das Lauflicht an nem Random Punkt..

Was du willst, ist ein Power on Reset. Na, klingelt's bei Reset? Du mußt 
den Reset Pin nicht fest auf Masse legen, sondern mit einem 10K 
Widerstand auf Masse und andererseits den Reset Pin mit 10 nF, oder was 
du gerade in der Bastelkiste rumschwirren hast, auf + Ub. Beim 
Einschalten zieht der Kondensator den Reset Pin kurz nach High, das IC 
resettet, wenn der Kondensator geladen ist, wird der Pin über den 
Widerstand auf Masse gezogen und der Zähler kann loszählen :-)
Baue das Ganze doch auf einem Breadboard mit Steckbrücken auf.
Hier ist sogar in deutsch beschrieben, was das IC macht: 
http://www.cmos4000.de/cmos/4018.html
Dort ist auch ein ausführliches englischsparachiges Datenblatt verlinkt. 
So ein Zähler ist kein Mikrocontroller mit 500 seitigem Datenblatt, den 
kann man auch so begreifen, wenn man sich denn damit auseinandersetzt.
Es ist doch heute quasi das Paradies für Bastler:
- es gibt Steckbretter - wir mußten löten
- die Datenblätter sind im Internet sofort und frei verfügbar und nur 
einen Klick entfernt - wir mußten dicke Bücher kaufen oder darauf 
hoffen, das ein IC mal in einer Elektronikzeitschrift vorgestellt wurde
- die IC's kosten wenige Cent, LEDs, Widerstände usw. ebenfalls - damals 
war Fakor 10-100 zu entrichten!
- es gibt für 1-2€ Steckernetzteile mit stabilisierter Ausgangsspannung 
und ausreichenden Strömen - wir mußten erst ein Netzteil mit einem 
Eisentrafo dazu aufbauen

Autor: Flohoo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gerald B. schrieb:
> Was du willst, ist ein Power on Reset. Na, klingelt's bei Reset? Du mußt
> den Reset Pin nicht fest auf Masse legen, sondern mit einem 10K
> Widerstand auf Masse und andererseits den Reset Pin mit 10 nF, oder was
> du gerade in der Bastelkiste rumschwirren hast, auf + Ub. Beim
> Einschalten zieht der Kondensator den Reset Pin kurz nach High, das IC
> resettet, wenn der Kondensator geladen ist, wird der Pin über den
> Widerstand auf Masse gezogen und der Zähler kann loszählen :-)

Danke!
Das Problem nun ist das Power ON, alle LEDs leuchten am Anfang, ich such 
genau das Gegenteil, die sollen alle aus sein beim Start.


Ich hatte mit Elektronik bisher extrem wenig zu tun. Für euch ist dieses 
Thema wahrscheinlich Kindergarten..

Autor: Flowhow (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Push,
falls jemand nen letzten Tipp hätte wäre ich sehr dankbar... ich komm 
einfach nicht vorwärts. :/

Autor: Gerald B. (gerald_b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Drehe die LED einfach um und schalte sie statt gegen + gegen Masse. CMOS 
Ausgänge sind symmetrisch aufgebaut.
Es leitet immer einer der beiden FETs. Entweder der Obere gegen +, 
Ausgang hat High Pegel oder der Untere gegen Masse, Ausgang hat Low 
Pegel. Somit leuchtet die LED dann beim jeweils anderen Pegel.

Autor: svep (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mithilfe des "Preset Enable" und den "JAM 1" bis "JAM 5" Eingängen 
kannst du einen beliebigen Startwert in den Zähler laden.

Ändere folgendes:

Alle JAM Eingänge auf Plus legen. (Pin 2, 3, 7, 9, 12)

Entferne die Widerstand-Kondensator Beschaltung und lege den "Reset" 
(Pin 15) wieder auf Minus.

Baue die Widerstand-Kondensator beschaltung an "Preset Enable" (Pin 10) 
wieder auf.

Autor: Flowhow (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Funktioniert!

Vielen Vielen Dank!!!
Ich hätte nicht erwartet dass ich das noch gelöst bekomme :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.