mikrocontroller.net

Forum: FPGA, VHDL & Co. Webpack 8.1


Autor: Axel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi.
Was ist denn mit Xilinx los. Die ballern ja eine Version nach der
anderen momentan auf den Markt. Was ist denn nu wieder neu im ISE
WEBPACK 8.1! Welche Devices wurden denn bei 7.1 nicht unterstützt? hat
es sich schon jemand runtergeladen und kann berichten, ob sich der
wechsel lohnt? Vielleicht sind ja wieder einige neue Nettigkeiten dazu
gekommen.

Axel

Autor: Antti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
7.1SP4 hat bugs und mangel und es gibt keine service packs mehr furs 7.1
so das man eventuell auf 8.1 umsetzen MUSS

8.1 hat coregen und fpga editor und unterstutzt alles das was fruher in
kostenpflichtiger BaseX drinne war.

8.1 sieht SEHR BUNT aus, hervorragendes graphisches design :)

letztendlich ist Spartan 3E support wirklcih drinne, impact 7.1SP4 kann
ja nicht alle s3e programmieren :(

aber ganz genau ubers webpack 8.1 weiss ich nicht da ich nur das volle
version habe

Antti

Autor: Christoph Kessler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab heute versucht es herunterzuladen, zuerst gabs nur den Link zur
7.1i, später war die 8.1i-Seite da, aber der Link zum Download führte
ins Leere, anscheinend arbeiten die bei Xilinx noch dran. In USA ist es
ja noch früh am Tag.

Autor: Christoph Kessler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, das alte 7.1i war 375 MB groß,das neue soll 848 MB groß sein,
wenn der Link mal funktioniert

Autor: AxelM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da haben die bestimmt noch bugs entdeckt und schnell wieder vom Server
genommen. Damn.
Aber dann sollten die den Link von der startseite nehmen ....


Axel

Autor: Xenu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Download geht jetzt.

Autor: A. N. (netbandit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wer weiß vielleicht ahebn die auch ca. 500 MB mehr Bugs drinne ;)

Autor: T.M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir hört der Download immer nach ca. 250 MB auf und meldet er wäre
fertig. Ist er aber natürlich nicht. Naja, will jetzt mitten in einem
Projekt eh nicht umstellen, gibt nur wieder vermeidbare Probleme dabei.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich will Euch nicht zum downloaden bei Emule anstacheln. Aber dort gibt
ess eine 8.1 Version (1,6GB groß)zum saugen. Hat bei mir 1 Tag
gedauert. Zum ausprobieren ist das ganz toll. Wenns gefällt sollte dann
aber doch die Version kaufen, damit die Entwicklung der Software auch
weiter finanziert werden kann.

Grüsse Michael

Autor: Marco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habs gerade mal ausprobiert. Der Download bei Xilinx hat nicht lange
gedauert, der Server läuft wohl ganz gut.

Aber: das Editorfenster zeigt nichts an bis auf einen Teil der Regler
zum Verschieben der Fenster, alles andere ist grau. Mit Ultra-Edit als
Editor geht wenigstens das editieren der Quell Dateien, aber das kanns
ja eigentlich nicht sein. Das WebPack 7.1i funktioniert natürlich, aber
da fehlt ja der (interessante) Coregen. Hat vielleicht jemand den selben
Effekt und eine Lösung ?

Grüsse Marco

Autor: Antti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
keien ahnung - die ISE 8.1 geht einwandfrei bei mir mit default editor

antti

Autor: Xenu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wenns gefällt sollte dann aber doch die Version kaufen, damit die
>Entwicklung der Software auch weiter finanziert werden kann.

Mit der ISE-Software macht Xilinx kein Geschäft, sondern mit FPGAs.

Die Vollversion kostet nur was, um den Support zu decken und
Hobbybastler davon abzuhalten, sie mit Supportanfragen zu
bombardieren...

Autor: lehmi (Marco) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter Linux läufts natürlich ohne Probleme... Gibt es eigentlich
kostenfreie Simulatoren, die ich mit dem WebPack unter Linux benutzen
kann ? Modelsim xe gibt es ja für Linux nicht.

Autor: Stefan R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lehmi: So wie es scheint, haben die in der 8.1-Version auch unter Linux
den Simulator dazugepackt:

http://www.xilinx.com/prs_rls/software/0610webpack81i.htm

Dort heisst es. u.a.:
"...WebPACK 8.1i includes ISE Simulator; for both PC and Linux
platforms.."
Was jetzt allerdings der Unterschied zwischen dem ISE-Simulator und
Modelsim ist hat sich mir bis jetzt noch nicht erschlossen. Werde den
neuen Webpack auch mal demnächst testen, abgeblich haben die ja auch
auf diese Win-Emulationsschicht verzichtet ("Windu") und benutzen was
natives (gtk?), womit der Webpack wohl erstmalig unter Linux richtig
benutzbar wird.

Gruß,
Stefan

Autor: Christoph Kessler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das Webpack6.weißnichwas hat unter Linux/Wine eine Seriennummer
verlangt, die nirgends zu finden war. Unter Windows XP ( 98 ging nicht,
hab mir deshalb extra ein XP geleistet) war keine Seriennummer nötig

Autor: Xenu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was jetzt allerdings der Unterschied zwischen dem ISE-Simulator und
>Modelsim ist hat sich mir bis jetzt noch nicht erschlossen.

Der ISE-Simulator ist ein Xilinx-eigene Software, und Modelsim ist,
naja, eben Modelsim von Mentor.

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
-Unter Linux läufts natürlich ohne Probleme... Gibt es eigentlich
-kostenfreie Simulatoren, die ich mit dem WebPack unter Linux benutzen
-kann ? Modelsim xe gibt es ja für Linux nicht.

Es gibbet simili von www.symphonyeda.com Die freie Version funzt gut,
is aber etws beschränkt.

FPGAküchle

Autor: Axel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kurze warnung meinerseits. Wenn ihr aufwendige Projekte mit dem neuen
Webpack öffnen wollt modifiziert er die Dateien zu beginn auf den
Standart für 8.1.
Ich habe bereits bei 2 Projekten einen Absturz der Software und damit
auch einen zerstörten Quelltext gehabt. Projekt konnte ich dananch
nicht mehr öffnen. Hatte zwar Sicherheitskopien, aber ich denke das
interessiert euch auch. Selbes habe ich von einem bekannten auch
gehört. anscheinend passeirt teilweise bei Projekten, die viele
Snapshots enthalten. Ansonsten habe ich aber ausser viel
grafikschnickschnack noch keine wichtigen neuerungen entdecken können.
Somit kann man wohl auch getrost auf das ServicePack 2 oder 3 warten.

Axel

Autor: hschwedne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein netter Zusatz ist z.B. das Warnung maskiert werden können und man
ihnen Kommentare geben kann

Autor: Axel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit maskieren meinst du das man bestimmte Warnings ausblenden kann? Das
ging allerdings bei der vorherigen Version 7.1 auch schon.

Autor: Antti Lukats (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt mehrere neue bugs mit ISE 8.1, ich werde alles bugs was
ich find in der bugtracker reintragen wo man die acuh dann nach
sehen kann

http://bugs.xilant.com/view.php?id=1

Antti
die bugtracker is offen, jeder kann bugs die gefunden sind eintragen
oder wenn kein lust dan mir ein kurzer email, dann trage ich die
rein.

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab an einem kleinen deisgn Spartan3-400; ca 1300 slices genutzt, die
ISE 8.1SP1 Tools getestet. Verglichen wird mit USE 6.3SP3. Die ISE
Oberfläche wird nicht genutzt, der flow basiert auf make.
Erste Erfahrungen

-ngdbuild wollte erst nicht, im ucf gabs Instanznamen die er nicht
gefunden hat. Problem war wohl eine Änderung in der Defaulteinstellung
wegen Preserve Hierarchie. Nachdem im ucf die Instanznamen mit /
getrennt worden, liefs auch wieder.
(also; 6.3 INST toplevel_instanzname ->
       8.1 INST toplevel/instanzname

-an den projektfiles haben die Tools nix gedreht (Klar, werden im
makefile flow ach nicht gebraucht)
-die Größen und max Takt Angaben vom XST sind noch mehr "falscher"
-Durchlaufzeit ist konstant geblieben (ca 3 min)
-Fläche ist bei gleichen Einstellungen ca 5% kleiner, timing im krit.
Pfad (80 MHz) ist um ca 100 ps besser -> der Umstieg lohnt.
-Impact zeigt im Filebrowser keine *.cdf an (obwohl angewählt)
-impact hat neues Fileformat, und konvertiert das alte CDF
-der Place+Route report ist informativer und die Angabe Logic Level
scheint zu stimmen.


-> gegenüber der letzten 6er version lohnt der Umstieg, da flow nicht
langsamer und dennoch design kleiner (5%) und etwas schneller.

Autor: ope (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich hätte wohl nur XST updaten sollen, nicht auf MXE 6.0d. Jedenfalls
bekomme ich diese hilfreiche Error Meldung und mxe beendet sich dann
(nack OK klick).

Habe schon im Temp.dir alles gelöscht, unter eigene Datein das hte
Verz. - es half alles nichts. Im Progamme/xilinx.... habe ich keine
Schreibrechte (arbeite als non-admin), darin kann er sich also nichts
gemerkt haben.

Das Problem begann, als ein TCL Error kam und ich mxe per Taskmanager
abschiessen musste.

Zwischendurch ein anderes Projekt File öffnen klappt, ist aber keine
Lösung, da bei neuen Projekten ein anderer TCL Error kommt.

Irgendwelche Ideen, wie ich mxe wieder bändigen kann?

Viele Grüße
Olaf

Autor: lehmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielen Dank für die Hinweise zum Ise-Simulator, funktioniert recht gut.
Schöner wäre natürlich Modelsim (free) für Linux, aber man kann wohl
nicht alles haben.
Da ich Linux 64-bittig betreibe, funktionieren die JTAG-Treiber des
Webpacks nicht und zurück zu 32-bit möchte ich unter Linux nicht mehr.
(Bitte jetzt keine Flames über die Sinnigkeit von 64 bit ;-)

Naja, also wohl doch Windows. Durch "Abtrennen" des Editorfensters
funktioniert dann auch bei mir die Darstellung.

Viele Grüße
lehmi

Autor: Stephan Schuler (emtrion)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bin nun auch von 7.1 auf 8.1 um gestiegen. hab mir auch gleich das
ServicePack 1 aufgespielt.

Wie oben schon zu lesen hatte ich auch Probleme ein 7.1-Projekt in 8.1
zu konvertieren. Stürzte jedes mal ab. Habe dann mit den Sourcefiles
ein neues Projekt anglegen müssen. Aber vielleicht liegt es ja wirklich
wie oben erwähnt an den Snapshots. Hatte nämlich auch 2 angelegt. Werd
ich mal noch ausprobieren.

Ich habe allerdings noch ein ganz anderes Problem:
Also ich mein Projekt endlich wieder am laufen hatte, wollte ich eine
Änderung vornehmen. Als ich allerdings eine ODER-Verknüpfung mit dem
"|"-Zeichen einfügen wollte ging das nicht. Ich habe dann
festgestellt, dass die ALT-GR-Taste nicht mehr funktioniert in dem
ISE-Editor. In anderen Programmen funktioniert es problemlos, wie auch
bei ISE 7.1!
Bin ich der einzige mit dem Problem? oder gibt es ne Lösung dafür?

Gruß,
Stephan

Autor: Antti Lukats (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
neín das ist ein BUG !!

|

kann man in ISE 8.1 mit deutschen keyboard nicht benutzen
siehe bugtracker

http://bugs.xilant.com/view.php?id=11

Antti

Autor: torsten buschka (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann es sein das ich zu dumm bin das runterzuladen? ich habe
mittleiweile 4 browser versucht, aber keine ahhte mir es ermoeglicht,
nachdem ich mir registriert hatte, das webpack runterzuladen.... hat
jemand nen directlink?

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Wenn man ein Projekt von 7.1 auf 8.1 updated, wird die alte
Projektdatei abgespeichert unter .old.
Das alte Projekt kann also wiederhergestellt werden.

Was mir aber in der neuen Version sehr negativ aufgefallen ist:
Wenn ich das Programm-File generieren möchte, dann
läuft die ganze Prozedur ab wie: Synthesize, Translate, usw.
Dieses Durchlaufen durch alle Punkte benötigt in der neuen Version um
eine Minute länger. Schade.

Tschüss

Martin

Autor: Uwe Bonnes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@lehmi
Zum Programmieren unter Linux kann man die xc3sprog verwenden
(www.rogerstech.force9.co.uk/xc3sprog/).

Als VERILOG SIMULATOR wird cver http://www.pragmatic-c.com/gpl-cver/
immer besser.

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
<Wenn ich das Programm-File generieren möchte, dann
<läuft die ganze Prozedur ab wie: Synthesize, Translate, usw.
<Dieses Durchlaufen durch alle Punkte benötigt in der neuen Version um
<eine Minute länger.

Nach meinem Beobachtungen braucht der par länger weil er mehr
optimiert. Mal den Effortlevel runtersetzten.

Das immer alle tools durchlaufen habe ich noch nicht gesehen. Die
Überprüfung der Abhängigkeiten (bitgen optionen geändert, nur der
bitgen wird gestartet, VHDL files werden geändert, alles muss gestartet
werden) ist zwar in der ISE nicht perfekt, aber ausreichend.
Da ist es schon besser ein makefile für den FPGA aufzusetzen und auf
die ISE zu verzichten.

Autor: A. N. (netbandit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit dem Atl GR ist mir auch aufgefallen, wenigstens kann man die
zeichen ja reinkopieren. Das ist zumindest eine Übergangslösung.
Was meint ihr wann dieser Fehler behoben wird?

Was mich an der ISE ärgert ist, daß die Windows Standard
Tastenkombinationen nicht funktionieren (z.B. Paste = Cntl+Enfg.)

Autor: Antti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die hot keay gehen wenn ISE editor fenster 'float' ist ! :)

ALT-GR aber auch dann nicht


Antti

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
<die hot keay gehen wenn ISE editor fenster 'float' ist ! :)

float fenster? Was'n des?

Autor: A. N. (netbandit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>die hot keay gehen wenn ISE editor fenster 'float' ist ! :)
auch nicht ganz, zwar kann ich nun mit CNTL+Enfg. die Pastefunktion
ausüben aber mit Cntl+Entf. nicht die Cut Funktion :(

Außerdem ist Fenster float irgendwie Bockmist.

Meine Güte was denken sich die Programmierer dabei ein Editor zu
programmieren, wo diese Standard Hotkeys umfunktioniert werden? Soll
ich mich jetzt bei jedem neuen Editor an neue Hotkeys gewöhnen?

Eagl, vielleicht kommt da ja ein Lösungsansatz für raus.

Autor: Stephan Schuler (emtrion)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also ich hatte mit den Copy- und Paste-Funktionen bis jetzt keine
Probleme. Sowohl bei 'float' und 'nicht float' des Editorfensters.
ich nutze allerdings auch die Tastenkombinationen Ctrl+C, Ctrl+V und
Ctrl+X.

Gruß,
Stephan

Autor: Antti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja die sind ok, aber manche altere leute benutzten die ur-alten hotkeys
noch und die sind teilweise kaputt

antti

Autor: A. N. (netbandit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie Uralte Hotkeys?

Ctrl+Entf. und Ctrl+Einf. funktioniert in JEDEM Programm bei mir,
selbst auf meinem Linuxrechner habe ich mit diesen Kombinationen kien
problem. Nur das Webpack von Xilinx springt da gewaltig aus der Reihe.

Ständig versaue ich mir während des arbeitens den Programmcode, nur
weil ich aus instinkt immer wieder diese Tastenkombination benutze.

Also bevor man mich hier als Altmodisch abstempelt frage ich mich,
warum es denn nötig sei für diese Funktionen völlig neue
Tastenkombinationen zu erfinden, wenn es schon seit Jahrzehnten gute
und ausreichende Funktionen dafür gibt?

Soll ich mir für jedes Programm neue Standardhotkeys angewöhnen und die
alten abgewöhnen? Also irgendwie hat da ein Softwareing. wohl seinen
schlechten Tag gehabt.

Autor: ope (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ohne irgendwie Flames wegen des Editors zu beziehen: Ich nehme den
(X)Emacs. Urpsrünglich nur, da ich ihn noch aus meinen C++ Zeiten her
gut kannte und ich mir nicht noch weitere Bedienung einprägen wollte,
Später stellte ich fest, dass die Verhalten des Editor von Modellsim
und dem ISE auch noch verschieden sind, so dass erst wieder eine grosse
Einstellorgie (Tabs u.a.) durchgeführt werden müsste. Konkret bei mir
waren diese auch nur temporär (arbeite als non-admin, entsprechend
fehlen die Schreibrechte und die kommen damit nicht so recht klar -
sehr eigenartig für vom unix Konzept abstammende Programme). Das
Einzige, was ich mir aus dem ISE gemopst habe sind die Templates -
diese sind nun per menu zu erreichen. ISE und Modelsim bekommen mit,
wenn die Dateien geändert werden.

Es kann aber jeder andere beliebige Ed. sein, UltraEdit etc.

Immerhin halten solche "Sachen" von der eigentlich Arbeit/Ziel ab und
wer weiss, was als nächstes gefixed wird und isch dann wieder geändert
hat. Irgendwann hat man keine Lust mehr, sich ständig an neue
Philosophien/Bedienungen/Darstellungen zu gewöhnen, wenn man doch nur
proggen will ...

Viele Grüße
Olaf

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
<ohne irgendwie Flames wegen des Editors zu beziehen: Ich nehme den
<(X)Emacs.

Zustimmung, emacs passt mit ISE. Und ganz grosses Vorteil ist der
VHDL-Mode:
  -beautify
  -automatisches einfügen von component dekl und Instanz aus Entity
beschreibung
  -automat. signalnamenergänzung
  -etc.

Die VHDL-mode ergänzung zu Emacs findet sich hier:
  http://opensource.ethz.ch/emacs/vhdl-mode.html

Autor: Michael Günther (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frage:

Ist der ISE-Simulator nun in der Windows-version mit drin oder nicht?
In Linux scheint er ja wohl drin zu sein...

Danke,
MG.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
kann es sein dass das Webpack Probeleme macht wenn man Gehäusepins in
der UCF-Datei zuweisen möchte? Wenn ich im Schematic zb ein Flip flop
habe dann sehe ich unter Assign package pins nur noch die pins des FF
und nicht die Xilinx_xx kann es sein dass ich beim Setzen der I/O-Pads
was falsch mache? Oder ist das ein fehler im Webpack?

Autor: Axel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LEdier kann ich dir dazu nichts sagen, aber ich habe mitbekommen, das
die Firmen, die Hardwareentwicklung mit den Xilinxbausteinen auch zur
Zeit noh auf 7.1 bauen. Selbst mit dem aktuellen Update ist es ihnen
noch mit zu vielen Fehlern behaftet. Ich denke also das man in den
nächsten 1-2 Monaten noch mit 7.1 arbeiten sollte.

Axel

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, nach meiner Sicht haben die wenigsten Firmen in D (eigentlich fast
alle)
keine Updatestrategie hinsichtlich Xilinx-tools. Jedes Update ist mit
Einarbeitung
verbunden, da Xilinx immer mal wieder z.B. Defaulteinstellungen ändert
und der VHDL-Code (geringfügig) angepasst werden muss. Am besten
gelingt es immer noch ein neues Projekt mit einer neuen Webpackversion
zu starten, als im laufenden Projekt die Tools zu aktuallisieren. Das
liegt aber meist an dem Zeitdruck im laufenden Projekt und der
Verweigerung gewohnheiten abzulegen.

IMHO ist die die 8.1 ein Bug-arme Variante, eigentlich ein Bugfix zur
7.1. Die Siebener Variante steht im Ruf größere Designs zu produzieren
(was ich für meine Projekte nicht bestätigen kann). Wahrscheinlich sind
die aktuellen Speedfiles (garantierte Laufzeiten und timings des
Siliziums) Ursache für größere designs bei Chipauslastungen > 90%. Dann
war das design eh knapp am Limit und reif für manuelle Optimierung
(meist Placementconstraints für BUFG's etc, der Placer ist doof).
Daher habe ich die 7er varianten übersprungen und bin von der 8er
schwer überzeugt (wobei ich aber kein PACE oder schematic entry nutze).


Wer noch warten möchte, lt. lokalen Xilinx-FAE kommt die 8.2 Ende März.

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
<kann es sein dass das Webpack Probeleme macht wenn man Gehäusepins in
<der UCF-Datei zuweisen möchte? Wenn ich im Schematic zb ein Flip flop
<habe dann sehe ich unter Assign package pins nur noch die pins des FF
<und nicht die Xilinx_xx kann es sein dass ich beim Setzen der
I/O-Pads
<was falsch mache? Oder ist das ein fehler im Webpack?

Ich versteh die Frage nicht? Was ist Xilinx_xx ? welches schematic
(RTL-view, PACE, schematic entry?)? Wills du PADS placieren oder Pins
zuweisen (also im ucf-file:
NET "toplevelsignal" LOC = "A13";
?

Screenshot, designauszug?

Autor: Axel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Probleme mit dem Webpack 7.1 im bezug auf größere Spartanbausteine
kann ich leider auch nur bestätigen. :-(

Autor: Markus (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@FPGAküchle:
sorry das waren nicht xilinx_xx sondern diese Pads mit XLXN_1...
wenn nur Logik in einer Schaltung verwendet wird (und, oder usw.) dann
erscheinen im "assign Package pins" diese Anschlüsse XLXN_1 usw.
warum nicht wenn ich ein FF einfüge?

Na ja wenn, dann muss ich das so machen wie du oben beschrieben hast,
so mit tippen mein ich...

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, ich bin eingefleichter Makefile Nutzer und Quelltexthacker, mit den
ISO tools zur grafischen Designeingabe kenn ich mich nicht aus.

Autor: Mighty (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Icarus Verilog funtzte für Synthese und Simulation und gibt
edif Dateien aus.

Webpack sorgte dann für den Rest.

Hab das nur mit einem einfachen Beispiel probiert.

Autor: Stephan Hochberger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welcher Nutzername und Kennwort müssen beim Download angegeben werden?
Mein Xilinx-Account klappt nicht.

Hat jemand nen Tipp?

Autor: Michael Günther (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

wie sieht's nun aus mit dem ISE-Simulator in der 8.1i????
Ich bekomme dauernd einen Fehler 222 zurück...

Danke!

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

für den ISE-Simualtor mußt du auch einen Simulator einbinden. D.h.,
hast Du einen Simulator(zB ModelSim) auch bei Xilinx gezogen?!?
Wenn ja, mußt Du diesen noch in der ISE einbinden. Unter Properties ->
Simulator wird dann der Pfad für die Simu.exe Datei angegeben....

Gruß
Tom

Autor: Michael Günther (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die neue WebPack installiert. Modelsim ist nochvon der früheren
7.1i drauf. Aber in der Auswahl des Simulations-Tools kann man
auswählen, welchen Simulator man nutzen will. Mit Modelsim klappts
problemlos - aber das ist ja auch nicht der Sinn!! Ich will mal den
integrierten ISE-Simulator verwenden! Der wird als Simulator auch
angezeigt. Nach dem Starten kommt jedoch der Fehler-Code 222.
Das ist das Problem...

Autor: antti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm. dann ist das ein bug, mit 7.1 hat es mit internen simulator noch
geklappt, mit 8.1 habe nicht probiert

Autor: Michael Günther (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In der 7.1 war der Simulator in der freien version nicht enthalten. In
der 8.1er ist ers 'anscheinend'. das ist auch der Grund, warum ich
die 8.1er drauf habe.

Autor: Ines (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist eigentlich der Unterschied zwischen ISE Foundation und ISE
WebPACK? Außer dem fehlenden Support beim WebPACK habe ich auf den
ersten Blick nichts gefunden. Habe ich da was übersehen?

Autor: Ines (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, ich hab was gefunden. Bei den größeren FPGAs gibt es wohl
Einschränkungen - da werden nicht alle unterstützt.

Gruß
Ines

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der ISE Simulator im Webpack ist abgespeckt

Autor: Ines (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@FPGAküchle: Danke für die Info.

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nach einem Danke schau ich gleich nochmal nach (Comparsion sheet):
Foundation gibts auch f. Solaris und Linux 64bit, Webpack nur
für Win und Linux32bit.

Und eine kleine Präzesierung zum ISE Simulator: fur Webpack gibst nur
den Lite, für Foundation gibts Optional (noch mal draufzahlen?) den
vollen.

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, da habe ich grad ein kleines schmankerl gefunden:

 http://www.xilinx.com/ise_eval/index.htm

Wenn ichs recht verstehe kann man über diese kostenlose DVD 60 tage
lang die ISE Foundation, Chipscope, vollen ISE Simulator und EDK
testen. Wer hats probiert?

Autor: Michael O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe Probleme beim Umstieg von ISE6.3i auf die neue ISE8.1 .
Habe ein etwas älteres FPGA Projekt das mal ursprünglich für ORCAs von
Lattice geschrieben wurde und dann auf Spartan2E angepasst wurde.
Zunächst habe ich mit der ISE5.2 programmiert bis das FPGA so voll war
(99% Slices, > 50%Tbuf..) dass der Placer nicht mehr funktionierte und
nicht in der Lage war die TBufs vernünftig zu mappen. Ein Update auf
ISE6.3 und häufiges hin und her mit Xilinx brachte genau dieses Design
wieder zum Laufen. Aber genau dieses Projekt kann unter ISE8.1i schon
wieder nicht mehr kompiliert werden, da offensichtlich die struktur der
TBufs schärfer geprüft wird. Laut Xilinx sollten alle bidirektionalen
Buffer ausschließlich in der TopLevel platziert werden, mindestens
jedoch einer. Alle PortMaps die z.B. nur ein open collector Signal
ausgeben (mal 'Z' oder '1' oder '0') müssen als 'inout'
definiert sein.

Vermutlich ist es besser ich programmiere die ganzen 20,000 Zeilen code
nochmal neu, damit auch die ISE8.1i funktioniert....
Wer weiß welche Fehlermeldung nach dem umbau der port maps noch so
auftauchen.

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wärs mit gemischten Toolflow? Ich nehme an, es ist der XST der wegen
dem Toplevel meckert. Dann mach doch die Synthese (XST) mit 6.3 und den
Rest
(z.B. map, par) mit 8.1. Zumindest mit 7 und 8 geht das recht gut. Weil
der map aus der 8 unter Linux streikt. Nache ich die Synthese mit der 8
und den Rest mit der 7.
Da ich make statt projektnavigator benutzt kann ich einfach zwischen
den Tools wechseln. Und es gibt andere Synthesetools statt dem XST, die
kosten aber richtig Taler.

Neugier: was hat den Xilinx empfohlen um den par ans Durchlaufen zu
kriegen?

Autor: Breti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht das bei Euch mit dem "Generate Desing Report" aus?

Bei meinen eigenen IPs sagt der mir in 8.1:
"Device utilization information is not available for this IP. Run
platgen to generate synthesis information. "

Und das obwohl Platgen korrekt aufgerufen wurde. Es ändert auch nichts,
wenn ich es noch einmal von Hand auf der Konsole probiere.
Kennt jemand eine Lösung?

Gruß,
       Thomas

PS: Ich weiß, dass ich das auch in den .log Dateien zu Fuß nachlesen
kann - aber ich finde das mit einem Knopfdruck in der grafischen
Oberfläche so praktisch und übersichtlich.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.