Forum: Analoge Elektronik und Schaltungstechnik Netzteilfrage


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Bernd B. (gorkde)


Lesenswert?

Hallo,

ich möchte ein kleines Netzteil als Spannungsversorgung für meine 
Aktuelle Schaltung benutzen.

Der Microcontroller braucht 3,3V und ein Sensor braucht 5V,dafür habe 
ich Spannungsregler.

Dann werden Pumpen angesteuert, die ca. 1,8A ziehen. Und mit 3-9V 
laufen, optimal 7V konstant (Pumpe RS-360-SH).

Aktuell habe ich das testweise mit einem einstellbaren Netzteil 
realisiert.

Mein Problem ist jetzt, wenn ich das Netzteil auf 7V stelle, hat es 
unbelastet 10V.
Wenn ich es dann durch die Pumpe belaste bricht die Spannung stark ein.

Momentan habe ich leider zum Testen nur ein zu kleines Netzteil, aber 
ich befürchte, dass ich dieses Problem auch habe, wenn ich später ein 
Netzteil mit mehr Ampere benutze.

Optimal wäre für mein Gerät ein kleines Steckernetzteil mit wirklich 
stabilen 5V bis 3A, dann kann ich nämlich den Sensor und die Pumpen 
direkt dran hängen ohne noch nen 5V Spannungsregler zu brauchen.

Da ich lange raus bin aus der Elektronik hier meine Fragen:

1)
Stimmt meine Vermutung, dass die normalen Steckernetzteile ne höhere 
Spannung haben und dann auch zusammenbrechen, wenn ich beispielsweise 
eins mit 5A nehme?

2)
Kann man die Pumpen irgendwie einfach abkoppeln, damit der Rest der 
Schaltung wirklich stabile 5V hat?

3)
Was für ein Netzteil würdet Ihr mir empfehlen? Vielleicht hat ja sogar 
jemand einen Link?

von MaWin (Gast)


Lesenswert?

Bernd B. schrieb:
> 1)
> Stimmt meine Vermutung, dass die normalen Steckernetzteile ne höhere
> Spannung haben und dann auch zusammenbrechen, wenn ich beispielsweise
                                               ^
> eins mit 5A nehme?                          als ?

Ja, kleine konventionelle (Eisenkerntrafo) Netzteile haben eine höhere 
Leerlaufspannungsüberhöhung als dickere Netzteile. Teilweise gilt das 
sogar bei Schaltnetzteilen (ungeregetlte bzw. primär geregelte).

> 2)
> Kann man die Pumpen irgendwie einfach abkoppeln, damit der Rest der
> Schaltung wirklich stabile 5V hat?

Schwer. Zumal deine Pumpen 1.8A Nennstromaufnahme haben werden aber im 
Anlaufmoment deutlich mehr braucht, nämlich 8.6A. Guckt eigentlich kein 
Schwein vorher mal in Datenblätter von dem Müll den ihr verbaut ?
http://www.robotstorehk.com/motors/doc/rs_360sh.pdf

> 3)
> Was für ein Netzteil würdet Ihr mir empfehlen? Vielleicht hat ja sogar
> jemand einen Link?

Kommt drauf an, die oft/lange die Pumpen laufen. Wenn das die absolute 
Seltenheit ist, könnte es sich lohnen, nur uC und Sensor aus einem 
winzigen Netzteil wie
http://de.aliexpress.com/store/product/Hi-Link-ac-dc-5v-3w-power-supply-module-220v-isolated-ac-dc-converter/345286_32610637345.html
zu versorgen und die Pumpe mit eigenem Nezteil (ggf. 6V~ 10VA 
Eisenkerntrafo mit Gleichrichter ohne Siebung) zu betreiben.

Läuft die Pumpe häufig, ist der Stromverbrauch im ausgeschalteten Moment 
nicht so wichtig, da kann es ENTWEDER ein 14VA 6V~ Trafo sein ODER ein 
10A/5V Schaltnetzteil (denn Schaltnetzteile müssen auf die 
Maximalstromaufnahme ausgelegt sein, Eisenkerntrafos nur auf die 
Dauerleistung).

An den 6V~ Trafo kommt dann 1 Brückengleichrichter für die per MOSFET 
ausgeschaltete Pumpe und ein zweiter Kleinleistungsbrückengleichrichter 
(eventuell Schottky) für die Elektronik, ein Siebelko an die Elektronik 
und ein low drop 5V Spannungsregler (LP2951-5) und parallel dazu ein 
3.3V Regler (LP2951-3.3), in der Hoffnung, daß die 5V Spannung nicht 
stabil sein muss wenn die Pumpe anläuft, denn da wurde wohl vorher per 
Sensoer entschieden, daß sie anlaufen soll.

von Bernd B. (gorkde)


Lesenswert?

Danke.

wieso Müll? Ist das ein schlechter Wert für solche Pumpen?
Ich habe da ja keinen Vergleich, dachte das sei normal.

Die Idee einen Trafo zu nehmen und ein Netzteil aufzubauen hatte ich 
auch, das wollte ich aber vermeiden. Erstens damit keine 220V im Gehäuse 
sind, zweitens da das sehr viel Platz kostet den ich eigentlich nicht 
habe. Daher würde ich gerne ein fertiges nehmen.

Die 5V brauche ich im Anlaufmoment der Pumpe nicht unbedingt, damit 
messe ich den Wasserstand im Tank, die kann ich aber ja auch mit dickem 
Elko stützen.

Die Pumpen laufen sehr selten, aber wenn, dann vielleicht  für bis zu 5 
Minuten.

Sollte ich eher ein Schaltnetzteil oder eines mit Trafo nehmen, oder 
macht das nicht viel Unterschied?

Wenn ich ein 5A (falls erhältlich 10A)  Schaltnetzteil nehme und es mit 
Kondensatoren stütze, sollte das nicht gehen?

von Elektrofan (Gast)


Lesenswert?

> Die Pumpen laufen sehr selten, aber wenn, dann vielleicht für bis zu 5
> Minuten.

Egal, wie oft.
Beim Anlaufen müssen sie das Losbrech-Drehmoment aufbringen.

> Sollte ich eher ein Schaltnetzteil oder eines mit Trafo nehmen, oder
> macht das nicht viel Unterschied?

Wenig relevant, solange es 'läuft'.

von Bernd B. (gorkde)


Lesenswert?

Das ist ja gerade die Frage mit welchem es besser läuft, also weniger 
Überspannung ohne Last und weniger Einbruch beim Start der Pumpe.

Leider findet man nämlich bei den üblichen Netzteilen (Wandwarzen) 
nirgends ne Angabe ob die 5V auch genau 5V sind und ebensowenig 
ob/wieviel sie bei Belastung einbrechen. Ebenso bekam ich auf  Nachfrage 
von einem Händler die Antwort: "Fragen Sie mich mal was leichteres, 
keine Ahnung".

Eigentlich soll ein Netzteil ja Stabil die angegebene Spannung liefern, 
aber bei dem China Gammel ist das relativ...

Bei denen die ich testweise gemessen habe, sind  genug bei mit deutlich 
höherer Leerlaufspannung, die dann auf "irgendwas" einbrechen.

Meint ihr ein Netzteil ohne Spannungsregler ist stabil genug als 
Versorgung für einem Sensor (5V Versorgungsspannung), oder empfiehlt es 
sich lieber ein 7V (statt 5V) Netzteil zu nehmen und es auf 5V zu 
regeln? Wenn ich die 5V direkt nehmen kann würde es einiges 
vereinfachen.

Allerdings jetzt auf gut Glück ein Netzteil bestellen, nur um danach ein 
zweites zu bestellen, ist auch blöd.

von Stefan ⛄ F. (stefanus)


Lesenswert?

> Leider findet man nämlich bei den üblichen Netzteilen (Wandwarzen)
> nirgends ne Angabe ob die 5V auch genau 5V sind und ebensowenig
> ob/wieviel sie bei Belastung einbrechen.

Beim manchen schon. Das ist eine Frage des Preises. Bei Geräten ab 30 
Euro aufwärts stehen die Chancen recht gut, dass der Hersteller auch ein 
Datenlatt dazu liefert.

Wie stabil die Spannung ist, sollte einer gewöhnlichen Pumpe völlig egal 
sein.

> Eigentlich soll ein Netzteil ja Stabil die angegebene Spannung liefern

Nein, das gilt noch lange nicht für alle Netzteile. Gerade in deinem 
Fall. Ersten benötigt ein normaler Motor keine konstante Spannung. 
Zweitens kann es für die Lebensdauer der Materialien durchaus 
vorteilhaft sein, wenn beim Anlaufen die Spannung etwa einbricht, was 
wiederum den Anlaufstrom senkt und für einen sanfteren Anlauf sorgt.

Stabile Spannung kannst du nur erwarten, wenn das Netzteil ausdrücklich 
stabilisiert ist UND es nicht überlastet wird.

Mein Laptop Netzteil ist mit 19V beschriftet, liefert jedoch je nach 
Belastung 18-21 Volt. Das heisst, es ist ein bisschen stabil, aber nicht 
absolut. Und das ist überhaupt nicht schlecht. Denn im Laptop befindet 
sich kein einziges Bauteil, das genaue 19V benötigt. Im Laptop befinden 
sich mehrere Spannungsregler, die für die jeweiligen Bauteile die nötige 
stabile Versorgungsspannung erzeugt.

> Bei denen die ich testweise gemessen habe, sind  genug bei mit
> deutlich höherer Leerlaufspannung

Beinahe alle Netzteile benötigen eine gewisse Mindest-Last, damit die 
Regelung funktioniert, wie sie soll. Oft genügt dazu schon die 
Stromaufnahme der Power-LED. Aber manche Netzteile benötigen erheblich 
mehr Laststrom (z.B. PC Netzteile).

> Meint ihr ein Netzteil ohne Spannungsregler ist stabil
> genug als Versorgung für einem Sensor

Kommt auf deinen Sensor an.

Nimm am besten zwei getrennte Netzteile. Eins dickes für die Pumpe und 
ein kleines für die Elektronik.

: Bearbeitet durch User
von MaWin (Gast)


Lesenswert?

Bernd B. schrieb:
> wieso Müll? Ist das ein schlechter Wert für solche Pumpen?
> Ich habe da ja keinen Vergleich, dachte das sei normal.

Du hast gar nicht verglichen, sondern schlicht kein Interesse 
nachzudenken was denn der Maximalstrom sein mag, den deine Pumpe zieht, 
Hauptsache billig sollte sie sein. Ist sie auch. Du soltest unbedingt 
eine Überwachung reinbaun, ob die Pumpe auch läuft, denn solche Pumpen 
(Welle im Wasser mit Durchgangsbuchse zum Motor) fallen gerne mal aus. 
verstopfung wäre auch noch möglich.

> Die Idee einen Trafo zu nehmen und ein Netzteil aufzubauen hatte ich
> auch, das wollte ich aber vermeiden. Erstens damit keine 220V im Gehäuse
> sind, zweitens da das sehr viel Platz kostet den ich eigentlich nicht
> habe. Daher würde ich gerne ein fertiges nehmen.

Kannst du ja.
Nur eine Quelle für fertige Eisenkerntrafos in Gehäuse:
http://www.hsgm.com/hsgm/Katalog_Trafos.pdf

> Die Pumpen laufen sehr selten, aber wenn, dann vielleicht für bis zu 5
> Minuten.

Das spricht für 2 Netzteile. Sagte ich schon, wenn du meinen Beitrag 
gelesen hättest.

> Sollte ich eher ein Schaltnetzteil oder eines mit Trafo nehmen, oder
> macht das nicht viel Unterschied?

Steht da auch alles zu drin, wenn du ihn gelesen hättest.

> Wenn ich ein 5A (falls erhältlich 10A)  Schaltnetzteil nehme und es mit
> Kondensatoren stütze, sollte das nicht gehen?

Nein. Schon Kondensatoren, die so gross sind, daß sie stützen, würden 
bei Einschalten durch ihren Aufladestrom dazu führen, daß das 
Schaltnetzteil einen Kurzschluss am Ausgang annimmt und abschaltet.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.