mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik N-Mosfet verrücktes Verhalten


Autor: Analog (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich verstehe die Welt nicht mehr.

Ich habe eine Schaltung die mit 12V versorgt wird. Daraus werden 3V mit 
einem Linearegler erzeugt diese Versorgen den Schaltungsteil den ich mit 
R1 dargestellt habe. Ich habe noch ein IC welches ich nur versorgen will 
wenn die 12V anliegen, in der Schaltung ist das R2. Das habe ich dann 
alles aufgebaut. Soweit so gut.

In der Schaltung messe ich nun aber an Source und Drain vom Mosfet ca. 
4,5V.
die auch die Schaltung versorgen können also nichts hochohmig 
angebundenes. Der Linearregler wird wohl zumachen, da die Istspannung 
über der Sollspannung liegt. Um irgendwelche anderen Effekte 
auszuschliessen habe ich die Schaltung mal, wie Im Anhang mit den beiden 
Widerständen und nur den 12V aufgebaut, also auch ohne die 3V. Der 
Effekt ist der Gleiche, an Source und Drain stellen sich ca. 5V ein, und 
es fliesst ein Strom von den 12V über das Gate(Verrückt) und versorgt 
die beiden Widerstände mit Strom. Kann mir das jemand erklären?

Autor: Falk B. (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Analog (Gast)

>In der Schaltung messe ich nun aber an Source und Drain vom Mosfet ca.
>4,5V.

Gegen GND? Niemals. Pins falsch angeschlossen? Falsch gemessen? MOSFET 
mit ESD geschädigt?

>Effekt ist der Gleiche, an Source und Drain stellen sich ca. 5V ein, und
>es fliesst ein Strom von den 12V über das Gate(Verrückt) und versorgt
>die beiden Widerstände mit Strom. Kann mir das jemand erklären?

Siehe oben.

Ausserdem ist deine Schaltung falsch. Wenn du die 3V schalten willst, 
muss dort ein P-Kanal MOSFET rein, der wird dannn aber mit negativer 
Spannung realtiv zu den 3V geschaltet (Gate auf GND). Denn beim N-Kanal 
leitet in der Schaltung die parasitäre Bodydiode, auch wenn die 12V 
nicht anliegen. Wenn es mit einem N-Kanal MOSFET funktionieren soll, 
musst du DRAIN an die 3V anschließen und Source wird dann zum 
geschalteten Ausgang.

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doch, deshalb frage ich doch. Ich habe es mit mehreren Mosfets 
ausprobiert.

Die Schaltung ist richtig.
Die Bodydiode benutze ich mit Absicht mit. Auf der Rechten seite sitzt 
noch ein Akku und ich möchte die Rückspeisung von Schaltung R2 nach 
Schaltung R1 verhindern, wenn die 12V abgeschaltet werden. Das tut aber 
nichts zur Sache, deshalb habe ich das ganze so einfach wie Möglich 
aufgebaut. Ich kann es mir aber nicht erklären?
Ich habe gerade noch einen Gate-Widerstand eingefügt, dann funktioniert 
es wie gewünscht, ich suche aber nach einer Erklärung.

Autor: Simpel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht nach Phantomspeisung aus. Die Schaltungen die an R1 bzw. R2 
hängen, scheinen irgendwie zurückzuspeisen. Das würde ich als erstes 
prüfen. Falls von da keine Spannung kommt, ist der Fet zwischen Gate und 
DS irgendwie faul.

Autor: Falk B. (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Analog (Gast)

>Die Schaltung ist richtig.
>Die Bodydiode benutze ich mit Absicht mit. Auf der Rechten seite sitzt
>noch ein Akku und ich möchte die Rückspeisung von Schaltung R2 nach
>Schaltung R1 verhindern, wenn die 12V abgeschaltet werden.

Dann kannst du aber nicht abschalten!

>Ich habe gerade noch einen Gate-Widerstand eingefügt,

Wo denn GENAU?

Autor: Teo D. (teoderix)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Was soll das?
Ist das dass Samstag Voprmittags-Trollrätsel, gibt's was zu gewinnen?

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung kann nie die 3V abschalten (falls 3V die Quelle ist) wegen 
der internen Diode zwischen Source und Drain. Diese Diode sieht man 
gleich ganz oben im Datenblatt.

http://www.infineon.com/dgdl/Infineon-BSP89-DS-v02_02-en.pdf?fileId=db3a30433b47825b013b4b8a07f90d55

: Bearbeitet durch User
Autor: Mark S. (voltwide)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Die Schaltung kann nie die 3V abschalten (falls 3V die Quelle ist) wegen
> der internen Diode zwischen Source und Drain. Diese Diode sieht man
> gleich ganz oben im Datenblatt.
>
> 
http://www.infineon.com/dgdl/Infineon-BSP89-DS-v02_02-en.pdf?fileId=db3a30433b47825b013b4b8a07f90d55

Korrekt. Du mußt 2 N-Kanal-MOSFETs in Serie schalten (source mit source 
verbunden) sonst wird das nix.

Autor: Analog (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also nochmal etwas ausführlicher, ich habe nochmal ein Bild angehängt.
Ich hatte das ganze etwas abstrahiert, nun etwas genauer. Die Body Diode 
habe ich mal mit eingezeichnet.

Ich hatte das Problem, das der µC Teil, hier dargestellt durch R1, Strom 
aus dem Akku der RTC zieht, wenn die 3V bzw. 12V ausfallen. Also wollte 
ich abschalten, ja ich weiß eine Diode hätte auch gereicht. Ich habe es 
aber so gelöst.

Ist die 12V Versorgung vorhanden wird der RTC Teil über den Mosfet und 
die Bodydiode versorgt. Wird die 12V abgeschaltet, sperrt der Mosfet 
sofort. So der Plan. Das funktioniert auch soweit. Doch dann entdeckte 
ich den Spannungsanhub und dachte mir "verrückt". Konnte ich mir nicht 
erklären und habe eine Schaltung nur mit Mosfet 12V und zwei 
Widerständen aufgebaut(Bild im ersten Posting, die 3V waren nur 
Informativ). Das Ergebnis ist gleiche.

So, also kein Troll einfach nur jemand sich etwas nicht erklären kann 
und auf Hilfe vom Forum hofft.

@Falk
Der Widerstand ist in Serie zum Gate. 12V-R-Gate.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://cds.linear.com/docs/en/datasheet/1083ffe.pdf

For input/output voltage differentials greater than
15V, a minimum external load of 5mA is required to maintain regulation.

Du hast zwar keine 15V Differenz, aber wer weiß ob da nicht auch bei 
kleinerer Differenz bereits ein Mindestlaststrom benötigt wird. Ersetze 
mal den 10KOhm Widerstand durch 470Ohm.

Autor: Jens (Gast)
Datum:
Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Mosfets haben interne Schutzdioden, siehe Bild. Vielleicht wird da 
irgendwas leitend wenn du die 12V direkt ohne Vorwiderstand auf das Gate 
schaltest. Der Eingangswiderstand wird dadurch geringer.

http://elektroniktutor.de/bauteilkunde/mosfet.html

Autor: Helmut S. (helmuts)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
> Mosfets haben interne Schutzdioden

Ich behaupte mal, dass 99% der Power-Mosfets keine eingebauten 
Schutzdioden haben.

: Bearbeitet durch User
Autor: Andreas F. (andgset)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Ersetze mal den 10KOhm Widerstand durch 470Ohm.

Das Verhalten tritt laut OP auch auf wenn die 3V direkt am Drain hängen.

Jens schrieb:
> Vielleicht wird da irgendwas leitend wenn du die 12V direkt ohne
> Vorwiderstand auf das Gate schaltest.

Auch ein Vorwiderstand ändert laut OP nichts am Verhalten.

OP welchen MOSFET verwendest du denn?

Autor: Homo Habilis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens schrieb:
> Mosfets haben interne Schutzdioden, siehe Bild.

Die wenigsten. Steht aber so auch nicht auf der verlinkten Seite.

Helmut S. schrieb:
> Ich behaupte mal, dass 99% der Power-Mosfets keine eingebauten
> Schutzdioden haben.

...und hast damit völlig recht. Genaugenommen ist Jens´ obige Behauptung 
(zumindest so formuliert, ohne ein "manche/könnten ... haben") extrem 
irreführend.

Hoffentlich prägt sich das kein wissenssuchender Leser zufällig ein - 
ist ja schon fast Beihilfe zum Halbleitermord.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich gehe inzwischen davon aus, dass die Schaltung auf einem Steckbrett 
ist. Da gibt es oft Kontaktprobleme und dann wundert man sich über 
komische Ergebnisse.

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also als Mosfet hatte ich den NDS351AN. Alles auf Lochraster aufgelötet.
Vielleicht kann das auch nochmal jemand nachbauen einfach Source und 
Drain mit zwei Widerständen 10k und 1Mega nach Masse und 12V direkt auf 
das Gate geben.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Glaub mir. Das liegt bestimmt an den 10Kohm. Nimm 470Ohm.

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Glaub mir. Das liegt bestimmt an den 10Kohm. Nimm 470Ohm.

Nur wenn der Regler ne Macke hat! Laut Specs, bei dem Betrieb und 0mA 
Last, hat er ein völlig "normales" Regelverhalten.

Apropos Macke.
Hab hier auch einen N-Mos mit merkwürdigen Verhalten, zB: ~100x 
Leckstrom. Eine merkwürdig glänzende Oberfläche hat er auch (SOT23).
Mag wohl daran liegen das der enthaltene Magic-Somke, bei einem 
Kurzschluss, mit aller Gewalt flüchten wollte :)

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vergesst doch mal den Regler. Der ist doch dafür gar nicht nötig.

Autor: Nico B. (saint1234)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

kannst du mal Strom und Spannung am Drain messen, wenn du das Simulierst 
und dabei deine Gatespannung sweepst (0-12V in 1V) und hier hochladen?

Gruß

: Bearbeitet durch User
Autor: uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Restladung an der Gatekapazität?! mach doch mal nen Entladewiderstand 
ans Gate.

Autor: Teo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
uwe schrieb:
> Restladung an der Gatekapazität?! mach doch mal nen Entladewiderstand
> ans Gate.

Willst du die 12V Stromquelle entladen?
Gut dann liegt nirgends wo mehr Spannung an. Problem gelöst, gratuliere 
;)

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bezogen auf die Schaltung ohne Regler:
Der MOSFET wird wohl kaputt sein. Wenn du mit bloßen Händen hantierst, 
kann das durchaus vorkommen; durch ESD-Effekte.
Zum Prüfen MOSFET ausbauen und mal D und S zusammenschalten und dann mit 
einem Ohmmeter von G nach D parallel S in beiden Polaritäten Widerstand 
messen. Der muß jenseits 10Megaohm sein. Notfalls einen neuen einbauen 
und nochmal Verhalten checken.

Und wie Helmut bereits schrieb:
Die Steuerwiderstände für MOSFETs dürfen nicht zu hochohmig sein. Der 
könnte im KHz bis MHz-Bereich schwingen oder der andere dann auftretende 
unangenehme Effekt ist eine thermische Überlastung beim Durchlaufen des 
linnearen Bereichs bei Ansteuerung. OK, das wird deine Schaltung mangels 
Leistung nicht zum Problem machen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.