mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik [MPLAB X] Programmiervorgang abbrechen wenn kein Target VDD erkannt


Autor: Test (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe folgendes Problem mit MPLAB X v3.35:

Wenn ich vergesse die Spannungsversorgung meines PICs anzuschalten bevor 
ich programmiere bekomme ich logischer Weise den Fehler "Target VDD not 
detected". Nur leider denkt MPLAB dann nicht daran den 
Programmiervorgang abzubrechen. Unten läuft die Progressbar endlos 
weiter und die "Make and Programm" Buttons und Konsorten bleiben 
augegraut. Da bleibt mir nichts anderes übrig als MPLAB zu beenden und 
neu zu starten (zeitaufwendig).

Das Target über das PICkit3 zu versorgen ist nicht möglich.

Irgendwelche Ideen / Lösungsansätze? Kann man die Vorgänge "von Hand" 
abbrechen?

Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Test schrieb:
> Wenn ich vergesse die Spannungsversorgung meines PICs anzuschalten bevor
> ich programmiere

Test schrieb:
> Das Target über das PICkit3 zu versorgen ist nicht möglich.

Passt irgend wie nich. Is da was in der Infokette verlorengegangen?

Autor: Test (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Teo D. schrieb:
> Test schrieb:
>> Wenn ich vergesse die Spannungsversorgung meines PICs anzuschalten bevor
>> ich programmiere
>
> Test schrieb:
>> Das Target über das PICkit3 zu versorgen ist nicht möglich.
>
> Passt irgend wie nich. Is da was in der Infokette verlorengegangen?

Ich versorge das Target über ein Labornetzteil weil das PicKit nicht 
genügend Strom zur Verfügung stellen kann um die Schaltung incl. PIC zu 
versorgen.

Autor: TK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich hab zwar den PICKit3 noch nicht im Einsatz gehabt - allerdings 
behelfe ich mir immer mit einem "Establish Connection" oder "Connect" 
bei meinem ICD2 / PICSTART+ bevor ich programmiere. Spätestens damit 
wird Dir auch angezeigt, dass Deine Spannung fehlt.

Gruß
TK

Autor: Volker S. (vloki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Test schrieb:
> Nur leider denkt MPLAB dann nicht daran den
> Programmiervorgang abzubrechen. Unten läuft die Progressbar endlos
> weiter...

Bei mir ist das nicht so. Was hast du den für eine Version von MPLAB-X?

<edit< Ähhh, sorry du hat ja geschrieben v3.35. Der trau ich irgendwie 
nicht.

: Bearbeitet durch User
Autor: Teo D. (teoderix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Test schrieb:
>>> Wenn ich vergesse die Spannungsversorgung meines PICs anzuschalten bevor
>>> ich programmiere

Oh, ein kleiner Scherz meine alterndem Gehirns :}
Da wurde aus "PICs", "PICkit3". Naja, wenigstens fehlt mir noch auf das 
da was nich stimmen kann :)


Das passiert mir eigentlich auch regelmäßig, nur bricht da MPLABX 3.35 
ab.
Bin mir nicht sicher aber es könnte dir eine Einstellung für den PicKit 
Querschießen.
Eventuell die Firmware mal neu aufspielen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.