mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STM32F407 WakeUp von Stop Mode


Autor: Sandro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute

Ich habe ein Problem, an welchem ich mir schon seit Stunden die Zähne 
ausbeisse.

Ich habe einen STM32F407 auf meiner Hardware und versetze ihn in den 
Stop Mode mit:
    PWR_EnterSTOPMode(PWR_Regulator_LowPower, PWR_STOPEntry_WFI);

Der uC läuft mit dem HSI Clock und hat ein HCLK von 2MHz.

Aufwecken tue ich ihn mittels einem externen Interrupt (Button).

Das Problem ist nun das der Prozessor ganz normal bei 1.8V startet und 
sich in de Stop Mode versetzt. Um korrekt aufzuwachen braucht er jedoch 
ca. 2.1V. Bei Spannungen darunter wird ein kompletter Reset ausgelöst 
beim drücken des Buttons. BOR ist nicht eingeschaltet.

Hat jemand eine Idee, an was das liegen könnte? Habe ich da etwas 
übersehen?

Vielen Dank! :)
MFG

Autor: Jim M. (turboj)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan. Dein Problem klingt nach fehlender Pufferkapazität auf VCC, 
da beim Aufwachen sehr kurz ein hoher Strom fließt.

Bei 2,1V hast Du halt 0.3 V mehr Headroom.

Autor: Sandro (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Jim M. schrieb:
> Schaltplan. Dein Problem klingt nach fehlender Pufferkapazität auf
> VCC,
> da beim Aufwachen sehr kurz ein hoher Strom fließt.
>
> Bei 2,1V hast Du halt 0.3 V mehr Headroom.

Danke für deine Antwort. Den Schaltplan habe ich 1zu1 übernommen vom 
STM32F4 Discovery DevBoard von ST. Ich denke daher eher nicht, dass das 
ein Problem sein könnte. Starten kann er ja auch mit 1.8V am Anfang...

Autor: Sandro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na toll... Sorry für den Mehrfachupload!

Autor: Little B. (lil-b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sandro schrieb:
> Den Schaltplan habe ich 1zu1 übernommen vom
> STM32F4 Discovery DevBoard von ST.

Sandro schrieb:
> Starten kann er ja auch mit 1.8V am Anfang

Das STM32F4 Discovery arbeitet mit 3 Volt, nicht mit 1.8V

Autor: Sandro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es geht jedoch nicht um die gesamte Schaltung. Mir ist klar, dass ich 
beim Discovery 3V benötige.
Es geht darum, wieso ich 2.1V Input Voltage benötige, um den Prozessor 
wieder zu wecken wenn alles auf 1.8V läuft (Also während dem Betrieb 
kann ich diverse Pins mit 1.8V einlesen). Und wieso der Prozessor bei 
<2.1V sogar einen Reset macht...

Es scheint als wäre irgendwas per default falsch konfiguriert...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.