mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik RasberryPi: It keeps crashing.


Autor: Michael H. (Gast)
Datum:

Bewertung
-6 lesenswert
nicht lesenswert
Hallo,

ich habe mir ein Rasberry Pi gekauft. Das ganze funktioniert aber 
garnicht. Wenn man die SD-Karte programmiert hat, und klemmt zum 
Beispiel die Tastatur an, restartet das ganze. Was ist das ein 
Systemdesign bitte?
Und nein, es ist kein schrott-Netzteil.

Wenn man jetzt Pech hat, dann crashed das einem die SD Karte - und gute 
Nacht, SD Karte Formatieren und neu Programmieren.
Ein Stromausfall kann doch immer mal passieren, sowas darf doch einem 
Computersystem nix anhaben!!!

Also ich persönlich sehe keine Möglichkeit das zuverlässig zu betreiben. 
Habt ihr änliche Erfahrungen gemacht? Gelöst oder RasPi in die tonne 
getreten?

-Michael

: Verschoben durch Moderator
Autor: Franklin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H. schrieb:
> Das ganze funktioniert aber
> garnicht.

Bei mir schon.

Michael H. schrieb:
> Wenn man die SD-Karte programmiert hat, und klemmt zum
> Beispiel die Tastatur an, restartet das ganze.

Bei mir nicht.

Michael H. schrieb:
> Also ich persönlich sehe keine Möglichkeit das zuverlässig zu betreiben.

Ich schon.

Michael H. schrieb:
> Habt ihr änliche Erfahrungen gemacht?

Nö. Ich hab zwei Raspi1 als Internetradios und einen Raspi2 als 
Mediacenter am laufen. Beide 24/7 in Betrieb. Keine Abstürze, keine 
Resets. Alles perfekt.

Autor: Thomas Z. (thomas_z41)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
Also das klingt sehr nach zu wenig Strom. Was ist es denn für ein 
Netzteil, und was für ein Kabel verwendest du? Ich habe ähnliche 
Probleme mit billigen China USB Kabeln gehabt, die haben einfach zu 
geringe Leiterquerschnitte.

Dass die Daten auf der SD Karte durch einen Stromausfall beschädigt 
werden können ist bekannt, aber so ein Raspi ist nun mal nicht als 
Computer sondern als Lernsystem entwickelt worden. Wenn man ihn für 
etwas anderes verwendet muss man mit Kompromissen leben.

Autor: holger (Gast)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
>Und nein, es ist kein schrott-Netzteil.

Aber vieleicht eine Schrott-Tastatur?

Autor: Michael H. (overthere)
Datum:

Bewertung
-3 lesenswert
nicht lesenswert
Also ich habe folgendes Netzteil:
https://www.amazon.de/Goobay-44008-Travel-Schwarz/dp/B0089R9QOC

+Kurzes Kabel (ca. 30cm). Spannungsabfall kann da ja nicht so hoch sein.

Autor: Timm T. (Gast)
Datum:

Bewertung
3 lesenswert
nicht lesenswert
Michael H. schrieb:
> Also ich habe folgendes Netzteil:
> https://www.amazon.de/Goobay-44008-Travel-Schwarz/dp/B0089R9QOC

Zu schwach.

Ich habe den Pi3 mit meinem Samsung Netzteil, welches 2A liefert, 
betrieben, und es gab immer Spannungseinbrüche. Vor allem mit einem 
Ladekabel an der Mikro-USB-Buchse.

Jetzt betrieben mit einem 5V 3A Netzteil über die Stiftleiste und keine 
Einbrüche mehr.

Michael H. schrieb:
> +Kurzes Kabel (ca. 30cm). Spannungsabfall kann da ja nicht so hoch sein.

Bei zu dünnen Drähten kann auch ein kurzes Kabel hohen Spannungsabfall 
verursachen. Ich hab hier auch eins aussortiert, welches bei 50cm gut 
0.2V Abfall hatte.

Der Pi zieht halt kurzzeitig mal hohe Ströme.

Außerdem kann es sein, daß in Deiner Tastatur ein Elko sitzt, der beim 
Anstecken erstmal geladen werden will und dabei die Spannung einbrechen 
läßt.

Autor: Joachim B. (jar)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Michael H. schrieb:
> Also ich habe folgendes Netzteil:
> https://www.amazon.de/Goobay-44008-Travel-Schwarz/dp/B0089R9QOC

und warum steht dort:
Reiseladeadapter (schwarz)

Ein Ladeadapter ist kein Netzteil!

Ein Netzteil, optimal ein geregeltes sorgt für stabile Spannung mit 
ausreichend Strom!

Ein Ladeadapter erwartet einen Akku der genügend puffert und einen Akku 
hat der PI nicht!

Autor: Johannes O. (jojo_2)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Michael H. schrieb:
> ich habe mir ein Rasberry Pi gekauft. Das ganze funktioniert aber
> garnicht. Wenn man die SD-Karte programmiert hat, und klemmt zum
> Beispiel die Tastatur an, restartet das ganze.
Bei mir nicht. Auch bei Kollegen nicht. Probiere doch mal eine andere 
Tastatur.

> Was ist das ein
> Systemdesign bitte?
> Und nein, es ist kein schrott-Netzteil.
DOCH! Das "Netzteil", das du gepostet hast ist dafür wohl nicht 
geeignet. Ich betreibe mein Raspi an einem RICHTIGEN Netzteil, welches 
auch für den Dauerbetrieb ausgelegt ist.
http://www.reichelt.de/Schaltnetzteile-fuer-Hut-Schiene/MW-DR-15-5/3/index.html?ACTION=3&LA=2&ARTICLE=148095&GROUPID=4961&artnr=MW+DR-15-5

Damit hatte ich bisher noch nie Probleme, das Raspi läuft 24/7 durch. 
Steht fest verkabelt in einem Netzwerkschrank.

Ich hab schon von (Handy)"Netzteilen" gehört, die die Dauerlast nicht 
ausgehalten haben oder deren Spannung zu instabil war. So einen 
potentiellen Brandherd würde ich mir nicht ins Haus holen. Dann schon 
lieber ein paar Euro mehr für ein gutes Netzteil ausgeben.

> Wenn man jetzt Pech hat, dann crashed das einem die SD Karte - und gute
> Nacht, SD Karte Formatieren und neu Programmieren.
> Ein Stromausfall kann doch immer mal passieren, sowas darf doch einem
> Computersystem nix anhaben!!!
Das ist aber stark von der SD-Karte abhängig. Hatte ich bisher nie das 
Problem, andere Leute schon teils.

> Also ich persönlich sehe keine Möglichkeit das zuverlässig zu betreiben.
Also meins hat eine Uptime von 102 Tagen aktuell. Letzter Reboot wegen 
Stromausfall, nie Probleme gehabt seit einigen Jahren. Zuverlässig 
genug?

> Habt ihr änliche Erfahrungen gemacht?
Nein.

> Gelöst oder RasPi in die tonne
> getreten?
Da gabs nichts zu lösen. Mit anständiger Hardware gibt es auch keine 
Probleme.

Autor: PittyJ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte auch mal Probleme, als ich einen Raspi an einem USB-Hub oder 
direkt am USB eines Rechners betrieben hatte. Da kamen gleich am Anfang 
schon die Farbmuster, dass die Versorgungsspannung zu niedrig ist.
Abhilfe brachte nur ein Netzteil. Ich habe von Reichelt eines im Bundle 
gekauft, das geht prima.

Autor: Mikro 7. (mikro77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H. schrieb:
> Gelöst oder RasPi in die tonne getreten?

Oha.

Erstmal Fehler eingrenzen. Hier wurde ja bereits einiges genannt: 
Anderes NT probieren (auf Spannungsanzeige beim Start/Desktop achten), 
besseres Kabel, andere Tastatur, Reboot auch beim Anstecken anderer USB 
Geräte (?), Anstecken über Powered HUB.

Das Problem scheint wohl auch vom RPi Modell abzuhängen (Spannungsregler 
im Eingang, USB-Strombegrenzung). Mein RPi Zero kommt bspw. nicht mit 
einem bestimmten WLAN Stick zurecht. Mein RPi-2 schon (bei gleichem NT).

Und letztlich, vielleicht nicht optimal, aber grundsätzlich machbar: 
Anstecken der Tastatur vor dem Einschalten?

Autor: Draco (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Jep, dein "Netzteil" ist völlig ungeeignet!

Solange du nicht mit nem Xenon Blitz vor dem Pi rumtöftelst, ist das 
Ding äußerst stabil. Siehst du beim booten denn schon dies Farbmuster 
oben rechts? Btw... ich gehe mal von aus du Raspbian aufm dem Pi oder?

Also bei mir laufen zu Hause drei Stück (2x Kodi und einmal Mediaserver) 
ohne jegliche Mucken.

Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Draco schrieb:
> Solange du nicht mit nem Xenon Blitz vor dem Pi rumtöftelst, ist das
> Ding äußerst stabil.
"Äußerst stabil"?
Das Ding bringt man mit einem in die Nähe gehaltenen Blitz zum 
Abstürzen?
Zum Vergleich: ich zünde bei meinen Steuerungen mit einem Funken auf die 
Masseanschlüsse und mache mir Sorgen, wenn dann was aussetzt...

Michael H. schrieb:
> Also ich habe folgendes Netzteil:
> https://www.amazon.de/Goobay-44008-Travel-Schwarz/dp/B0089R9QOC
Mach in das USB-Kabel mal einen 1000uF Kondensator zum Puffern der 
stärksten Stromspitzen. Denn wenn du am USB eine Tastatur einsteckst, 
dann braucht die mal kurz einiges an Strom, um ihre Elkos zu laden.

Autor: Mikro 7. (mikro77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Draco schrieb:
> Jep, dein "Netzteil" ist völlig ungeeignet!

Der RPi-2 mit Spannungsregler kommt bspw. mit vielen NT zurecht. Nicht 
dass ich das NT nicht auch als einen möglichen Verursacher sehe. Wo aber 
gibt es denn die Kristallkugel zu kaufen, die dein "völlig ungeeignet" 
stützt? ;-) Du garantierst damit quasi, dass ein Austausch sein 
Problem löst. Mutig.

> Also bei mir laufen zu Hause drei Stück (2x Kodi und einmal Mediaserver)
> ohne jegliche Mucken.

Und da steckst du dauernd USB Geräte an und ab?

: Bearbeitet durch User
Autor: Patrick S. (pad)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann will ich da auch mal was zu sagen´.

Wenn alles normal läuft, ist es kein Problem USB-Geräte im Betrieb an- 
und abzustecken. Weder bei meinem Kodi-Mediacenter noch bei meinem 
HausautomatisierungsPi. Sonst würde der USB-Anschluss ja auch irgendwie 
seinen Sinn verfehlen.
Ich würde auch erstmal auf das Netzteil tippen. Das ist sehr häufig das 
Problem. Einfach mal ein anderes ausprobieren.

lg

Autor: ● J-A V. (Firma: FULL PALATINSK) (desinfector) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Michael H. schrieb:
> Wenn man jetzt Pech hat, dann crashed das einem die SD Karte - und gute
> Nacht, SD Karte Formatieren und neu Programmieren.

ein Image kann man davon nicht erstellen?

Autor: Toni Tester (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Lothar M. schrieb:
> "Äußerst stabil"?
> Das Ding bringt man mit einem in die Nähe gehaltenen Blitz zum
> Abstürzen?
> Zum Vergleich: ich zünde bei meinen Steuerungen mit einem Funken auf die
> Masseanschlüsse und mache mir Sorgen, wenn dann was aussetzt...

Naja, das muss man eben im Kontext sehen...
Für ein Consumerdingens, das ursprünglich zu Lehrzwecken entwickelt 
wurde und dementsprechend besonders auf den Parameter "günstiger Preis" 
optimiert wurde, ist das Ding schon bockstabil.
Klar, kein Vergleich mit einem "richtigen" Server oder "echter" 
industrial grade, automotive grade o. ä. Hardware.
Erschreckend finde ich in dem Zusammenhang eigentlich eher, dass es z. 
B. Lieferanten von/für Add-Ons gibt, die dieses Ding zum 
"Industrierechner" machen sollen - und/oder Industriekunden, die das 
Ding so verwenden bzw. dazu vergewaltigen (gab m. W. hier mal einen 
Thread, in welchem jemand behauptete, RPis in den Werkzeugmaschinen 
seiner Firma zu verbauen - konnte damals nicht antworten, weil sich 
meine Finger durch extreme Anspannung zu sehr verkrümmten, als ich das 
las)...

Autor: soul e. (souleye)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H. schrieb:

> (...) Was ist das ein
> Systemdesign bitte?
> Und nein, es ist kein schrott-Netzteil.

Der Raspi ist für Schul- und Ausbildungszwecke gedacht. Daher ist er vor 
allem eins: billig. Man hat quasi das Beagleboard genommen und alles 
weggelassen, was für die Funktion nicht unbedingt nötig war. Damit sind 
auch sämtliche EMV-Bauteile entfallen.

Man kann Raspis durchaus 24/7 als Router, Server oder in Steuerungen 
betreiben. Dafür gibt es genug Beispiele im Netz. Die Zuverlässigkeit 
einer Simatic S7, eines Intel NUC oder eines Beaglebone Black darf man 
zu dem Preis aber nicht erwarten.

Autor: Timm T. (Gast)
Datum:

Bewertung
-2 lesenswert
nicht lesenswert
soul e. schrieb:
> Damit sind
> auch sämtliche EMV-Bauteile entfallen.

Erstens stimmt das nicht, es sind durchaus einige Schutzdioden drauf.

Und Zweitens haben wir doch schon festgestellt, daß das Netzteil 
ungeeignet ist. Da nützen Dir keine EMV Bauteile, wenn die Netzspannung 
zusammenbricht.

Autor: Timm T. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> Das Ding bringt man mit einem in die Nähe gehaltenen Blitz zum
> Abstürzen?

Hachja, da ist halt eine Diode oder was, bei der ein starker Blitz 
optisch durchs Gehäuse dringt und die dann asl Photodiode wirkt.

Ist jetzt nur sehr entfernt ein EMV Problem.

Autor: Erwin D. (Gast)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Timm T. schrieb:
> Da nützen Dir keine EMV Bauteile, wenn die Netzspannung
> zusammenbricht.

Na wenn wegen einem Raspi schon die Netzspannung zusammenbricht, sollte 
man mal ein Wörtchen mit dem EVU reden :-)
(Nicht daß am Ende noch die Generatoren im Kraftwerk stehenbleiben.)

scnr :-)))

Autor: Draco (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Mikro 7. schrieb:
> Und da steckst du dauernd USB Geräte an und ab?

Ähm nicht ich, aber meine Tochter. USB Pad und / oder Tastatur ja. Warum 
die Frage?!

Autor: Draco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> "Äußerst stabil"?
> Das Ding bringt man mit einem in die Nähe gehaltenen Blitz zum
> Abstürzen?

Ja aus dem einfachen Grund weil das Silizium des Reglers offen liegt. 
Mit nem Stückchen schwarzem Klebeband oder schwarzem Lack ist das aber 
erledigt.

Mikro 7. schrieb:
> Nicht
> dass ich das NT nicht auch als einen möglichen Verursacher sehe. Wo aber
> gibt es denn die Kristallkugel zu kaufen, die dein "völlig ungeeignet"
> stützt?

Jup, weil ich genau das gleiche Steckergerät hatte! Mit angeschlossener 
Tastatur, nem Edmiax Stick und nem USB Flash Stick bootete er nichtmal 
richtig hoch. Ich habe nie gemessen wieviel Spannung wirklich 
rausgekommen ist. Aber nach einem Wechsel zu einer anderen 2A Wandwarze, 
lief es dann anstandslos.

Autor: Michael U. (amiga)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Hallo,

daß die Versorgung der RasPi-USB-Buchsen etwas wacklig sein kann, ist 
bekannt seit es den Pi gibt. USB-Geräte, die auch nur kurzzeitig beim 
Anstecken mehr Strom ziehen oder im Betrieb starke Änderungen haben, 
sorgen gern mal für einen Absturz oder Neustart.
DVB-Sticks waren mit Aufkommen der Medianutzung am Pi die ersten 
Anwärter. Mein RasPi startet generell neu, wenn ich einen älteren 
WLAN-Stick im Betrieb anstecken. Die Empfehlung, einen aktiven USB-Hub 
dazwischen zu stecken, ist nicht neu.

Andererseits läuft hier ein RasPi3 mit FHEM 24/7, da stürzt definitiv 
nichts ab, genau eine RasPi als Streamplayer oder einer als 
OpenVPN-Endpunkt.
Netzteile sind 5V/2A und 2,5A aus der Pollin-Sammlung.

Gruß aus Berlin
Michael

Autor: Dirk K. (dekoepi)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Wir reden davon, dass er da mit einem 750mA-Netzteil rumhampelt:
http://www.lygte-info.dk/info/usbPowerSupplyTest%20UK.html#9

Also - anständiges Netzteil, und es sollte klappen. Wobei da noch 
offensichtlich PEBCAC mit reinspielt. Also an seiner Stelle: Wegwerfen, 
Apple-Kram kaufen und weiter laut rumtönen.

Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Draco schrieb:
> Ja aus dem einfachen Grund weil das Silizium des Reglers offen liegt.
> Mit nem Stückchen schwarzem Klebeband oder schwarzem Lack ist das aber
> erledigt.
Aha, gutes Chipdesign.
Dann ist das halb so schlimm, das hat mit EMV nicht direkt was zu tun...

Autor: Draco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar M. schrieb:
> Aha, gutes Chipdesign.
> Dann ist das halb so schlimm, das hat mit EMV nicht direkt was zu tun...

Nein, gutes Platinendesign und Kostenpunkt. Das war der Grund das Die 
direkt auf die Platine zu werfen statt im Gehäuse.

Aaaaber: Sie haben eine CE Konformität. Also, muss es ja was taugen ;-)

Autor: Joachim B. (jar)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Michael U. schrieb:
> daß die Versorgung der RasPi-USB-Buchsen etwas wacklig sein kann, ist
> bekannt seit es den Pi gibt. USB-Geräte, die auch nur kurzzeitig beim
> Anstecken mehr Strom ziehen oder im Betrieb starke Änderungen haben,
> sorgen gern mal für einen Absturz oder Neustart.

ich hatte meinen alten PI B einen 1000µF/6,3V Al Elko über den USB 
Tantal gelötet damit hörten alle PowerProbleme beim Anschluß an USB auf!

: Bearbeitet durch User
Autor: Mikro 7. (mikro77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dirk K. schrieb:
> Wir reden davon, dass er da mit einem 750mA-Netzteil rumhampelt:
> http://www.lygte-info.dk/info/usbPowerSupplyTest%20UK.html#9

Ist nicht das gleiche.

Btw: Mein 700 mA NT funzt problemlos mit meinem RPi-2. Ich käme aber 
nicht auf die Idee zu behaupten, dass alle NTs mit jedem RPi in jeder 
Situation funktionieren. Umgekehrte Verallgemeinerungen sind ebenso 
Unsinn.

Autor: mo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da du ihn scheinbar neu gekauft hast ist es hoffentlich ein RPI 3. Dann 
kannst du auf USB Boot umstellen und hast das SD Karten Problem nicht 
mehr. Ich hatte mit der SD Karten Lösung auch nur Probleme. Alternativ 
kannst du bei dem RPI1-2 BerryBoot nutzen welches das Image aus dem 
Netzwerk lädt, so wird die SD Karte nicht kaputt geschrieben wenn was 
schiefgeht.

Autor: Huh (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Heinzz schrieb im Beitrag #4701449:
> Schon mal so ein jurzes Kabel vom Netzteil probiert?

Nein, meins ist nicht so jurz :-)

Autor: Mikro 7. (mikro77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joachim B. schrieb:
> ich hatte meinen alten PI B einen 1000µF/6,3V Al Elko über den USB
> Tantal gelötet damit hörten alle PowerProbleme beim Anschluß an USB auf!

Ich habe grade mal testweise für meinen WLAN Stick ein 3m (nicht gerade 
niederohmiges) Verlängerungskabel zwischengeschaltet... und siehe da, 
kein Reset. Verbindung läuft. Dann wieder ohne Verlängerungskabel: 
Reset. (Das gleiche übrigens bei einem meiner Notebooks.)

Zusätzliche Kapazität oder Widerstand im USB Zweig ist also ein (im 
Nachhinein offensichtlicher) Workaround (wenn denn der Einschaltstrom 
das Problem ist.)

Autor: Timm T. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erwin D. schrieb:
> Na wenn wegen einem Raspi schon die Netzspannung zusammenbricht, sollte
> man mal ein Wörtchen mit dem EVU reden :-)

Was weißt Du denn, wo die Raspis überall eingesetzt werden.

Autor: Zeno (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Habe derzeit 3 Pi's im Einsatz. Der Pi meiner Wetterstation läuft seit 
seit 3 Jahren fehlerfrei ohne Absturz. Wird mit 1A Steckernetzteil 
betrieben
Der Pi für meine 2.Eigenbauwetterstation ist jetzt 1,5 Jahre ohne 
Probleme gelaufen, jetzt hat die SD-Card den Geist aufgegeben, da ich 
offensichtlich zu viel darauf geschrieben habe (Auslesen der 
1-Wiresensoren alle 3 Minuten). Bin grad dabei das System neu 
aufzusetzen und da werde ich es so machen, daß er die Daten auf meine 
NAS schreibt oder ich spendiere ihm eine kleine HD. Wahrscheinlich werde 
ich mich für letzteres entscheiden und die SD nur noch für das Booten 
benutzen. Ach ja der Pi ist im Freien (IP65 Verteiler) installiert, 
arbeitet also schon unter extremen Bedingungen zumindest 
temperaturtechnisch. Stromversorgung über ein kleines 
Meanwellhutschienennetzteil.
Der 3.Pi ist in meiner HA, die habe ich aber grad erst in Betrieb 
genommen.

Ich kann nicht sagen das der Pi unzuverlässig ist man muß halt nur ein 
paar Sachen beachten, z.B. so wenig wie möglich Schreibvorgänge auf die 
SD-Card. Ich habe eben mal nicht daran gedacht und jetzt die Quittung 
bekommen. Der arme Pi kann da aber nichts dazu.

Zeno

Autor: Timm T. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeno schrieb:
> Bin grad dabei das System neu
> aufzusetzen und da werde ich es so machen, daß er die Daten auf meine
> NAS schreibt oder ich spendiere ihm eine kleine HD.

Kann man das nicht so machen, das man die Daten auf eine Ramdisk 
schreibt und die Daten dann nochmal komprimiert (Mittelwertbildung) und 
jede Stunde oder einmal täglich auf der SD Karte ablegt?

Autor: mo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum so ein Aufwand? Das Image per ISCSi vom Nas laden. Die SD ist nur 
für BerryBoot da. Damit gibt es eher keine Probleme mit sterbenden SD 
Karten durch zuvieles schreiben.

So betreibe ich mein FHEM auf dem RPI1 und so hat der jetzt schon viele 
Hard Offs überstanden.

Der RPI3 braucht dafür scheinbar auch keine SD Karte mehr.

Autor: Jobst Q. (joquis)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Timm T. schrieb:
> Kann man das nicht so machen, das man die Daten auf eine Ramdisk
> schreibt und die Daten dann nochmal komprimiert (Mittelwertbildung) und
> jede Stunde oder einmal täglich auf der SD Karte ablegt?

So ähnlich mache ich das auch bei einer Messwertaufzeichnung. Alle 30 
Sekunden eine Messreihe, die in die Ramdisk geschrieben wird und alle 15 
Min wird es auf SD-Karte kopiert. Läuft jetzt ohne Probleme etwa seit 
einem halben Jahr.

Wenn bei Stromausfall evt fehlende Daten keine große Rolle spielen kann 
man natürlich auch größere Zeitabstände wählen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.