mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Offsetproblem bei hoher OPV Verstärkung


Autor: Matthias (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

bin an meiner Verstärkerschaltung zugange und bräuchte mal Rat.
Habe den TL084 um ein Wechsespannungssignal ca 60-80 fach zu verstärken.
Den TL084 versorge ich mit 2 stk in Reihe geschalteter 9V Batterien.

Jetzt habe ich leider das Problem, dass ich bei der hohen Verstärkung 
zur Wechselspannung noch ca 2 V Gleichspannung am Ausgang bekomme.

Ich habe mir Schaltungen zum Abgleich angeschaut, aber in Anbetracht, 
dass ich die Versorgungs - Batterien unsymmetrisch entlade, da ich Teile 
der Schaltung nur mit einer Batterie betreibe ist das alles nicht so 
dolle und würde mit Temperaturveränderungen sicher einen ständigen 
Abgleich erfordern.

Da habe ich im Datenblatt eines anderen OPV eine alternative Schaltung 
mit "einfacher" Versorgungsspannung gefunden. Hier wird die 
Gleichspannung bewusst genutzt und das Wechselspannungssignal 
überlagert.

Jetzt würde mich mal folgendes interessieren, wie sich das dort mit den 
Offsetproblem verhält. Muss man dort ebenfalls befürchten, plötzlich 
statt 4,5 V Grund-Gleichspannung plötzlich 6,5 V zu haben ?

Grüße

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias schrieb:
> statt 4,5 V Grund-Gleichspannung plötzlich 6,5 V

Radio Eriwan sagt: es kommt ganz darauf an. Nicht jeder Schaltkreis hat 
die selben Eigenschaften. Bei ungünstigen Aufbau könnte auch was 
schwingen? 
https://www.mikrocontroller.net/articles/Operationsverst%C3%A4rker-Grundschaltungen 
http://www.elektronik-kompendium.de/public/schaerer/opa1.htm

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
2 lesenswert
nicht lesenswert
Schalte einen Kondensator (ca. 10 µF) zwischen R1 und GND. Der sorgt
dafür, dass für DC-Spannungen der Verstärkungsfaktor auf 1 zurückgeht.

Edit: Ich habe mir erst jetzt das zweite Bild angeschaut. Dort wird es
ja genau so gemacht.

Allerdings erscheinen mir die 2V am Ausgang etwas heftig. Der TL084 hat
laut Datenblatt in seiner schlechtesten Ausführung über den gesamten
Temperaturbereich einen maximalen Offsetfehler von 20 mV. Verstärkt um
den Faktor 80 ergibt das immerhin 1,6 V, aber noch keine 2 V. Unter
normalen Bedingungen sollte der Offsetfehler aber nicht höher als 5 mV
sein, was am Ausgang maximal 400 mV ergibt.

: Bearbeitet durch Moderator
Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich jetzt C5 mit 100µF am Eingang sehe, dann ist schon der 
Reststrom eine Frage wert.

Autor: Sebastian S. (amateur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Operationsverstärker sind in mancher Beziehung ganz demokratisch: Sie 
verstärken alles.
Wenn Du bei 80-facher Verstärkung ein Gleichspannungssignal von 2V 
bekommst, so bedeutet das u.a., dass Deine 25mV Eingangsoffset ebenfalls 
mitverstärkt wurden.

Autor: Dieter W. (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> Wenn ich jetzt C5 mit 100µF am Eingang sehe, dann ist schon der
> Reststrom eine Frage wert.

Ja, weil der sich ja auch noch durch den 1MOhm Widerstand quälen muss.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vor allem der 100uF Kondensator(Elko) am Eingang hat einen hohen 
Leckstrom. Zusammen mit 1MegOhm gibt das eine unerwünschte 
Gleichspannung.  Bau da einen 0,1uF bis 1uF Folienkondesator ein.

: Bearbeitet durch User
Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

vielen Dank für Eure Antworten.
Ich werde morgen Nachmittag den Kondensator tauschen und zwischen R3 und 
Ground noch einen weiteren einsetzen.
Ich berichte dann gegen Abend nochmal ausführlich.


Yalu X. schrieb:
> Allerdings erscheinen mir die 2V am Ausgang etwas heftig.

Ich messe auch nochmal mit den Oszi nach, ob es wircklich 2 V waren.

Welche Werte sollte den R6 so haben ? Hatte einfach in die Kiste 
gegriffen.
Ich meine kleiner machen geht ja nur bis zu einen gewissen Punkt, sonst 
löscht man das Signal.

Grüße und euch schonmal vielen Dank !

Autor: Possetitjel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:

> Vor allem der 100uF Kondensator(Elko) am Eingang hat
> einen hohen Leckstrom. Zusammen mit 1MegOhm gibt das
> eine unerwünschte Gleichspannung.

Ja. -- Zumal sich die Frage stellt, ob man eine
Zeitkonstante 100s (!!) wirklich haben will.

> Bau da einen 0,1uF bis 1uF Folienkondesator ein.

Dem Rat schließe ich mich an.

Autor: Possetitjel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias schrieb:

> Yalu X. schrieb:
>> Allerdings erscheinen mir die 2V am Ausgang etwas heftig.
>
> Ich messe auch nochmal mit den Oszi nach, ob es wircklich
> 2 V waren.

Ja, also 2V ist verdächtig viel. Bis zu 1V können bei
Deiner Verstärkung schon auftreten, wenn Du Pech hast.

> Welche Werte sollte den R6 so haben ? Hatte einfach in
> die Kiste gegriffen. Ich meine kleiner machen geht ja
> nur bis zu einen gewissen Punkt, sonst löscht man das
> Signal.

Nö, den kannst Du lassen; 1MOhm passt schon. Aber den
Elko von 100µF solltest Du ersetzen; eine untere Grenz-
frequenz von 1.6mHz (=Milli-Hertz!) ist sicher weder
notwendig noch sinnvoll.

Autor: Klaus R. (klara)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yalu X. schrieb:
> Schalte einen Kondensator (ca. 10 µF) zwischen R1 und GND. Der sorgt
> dafür, dass für DC-Spannungen der Verstärkungsfaktor auf 1 zurückgeht.

Das würde ich zuerst durchführen.
mfg klaus

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Upsala, wollte den 100 uF Kondensator tauschen, da habe ich gesehen, 
dass ich einen 100 nF verbaut hatte. So sorgt ein Doppelfehler unwissend 
zur Richtigkeit.

Die Ausgangsspannung ist bei einer Verstärkung von 100 = 0,25 V, muss 
mich da wohl vertan/vermessen haben.

Zieht man bei der Berechnung der unteren Grenzfrequenz nur den 1 MOhm 
Widerstand in Betracht ? Dann könnte ich theoretisch ganz streng 
genommen sogar 10 nF nehmen, da ich den Audiobereich ab 16 Hz verstärken 
möchte.

Yalu X. schrieb:
> Schalte einen Kondensator (ca. 10 µF) zwischen R1 und GND. Der sorgt
> dafür, dass für DC-Spannungen der Verstärkungsfaktor auf 1 zurückgeht.

Hierzu eine Frage:

Hatte keinen 10uF da und einfach mal den R1 von Ground losgemacht.
Jetzt müsste ja theoretisch für Gleichspannungen derselbe Fall 
existieren, als wenn ein Kondensator eingebaut ist (unendlich hoher 
Widerstand)?
Die Ausgangsspannung war trotzdem 0,25 V.
Also bringt dieser Widerstand ja auch nur etwas, wenn das 
Wechselspannungssignal noch eine Gleichspannung enthält ?
Der Offset bleibt davon unberührt ?

Autor: Sebastian S. (amateur)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
>Upsala, wollte den 100 uF Kondensator tauschen, da habe ich gesehen,
>dass ich einen 100 nF verbaut hatte. So sorgt ein Doppelfehler unwissend
>zur Richtigkeit.
Ich schätze mal: Deine Augenmaßleere muss mal wieder gerichtet werden.
Trotz Miniaturisierung ist der Größenunterschied doch "gut sichtbar".

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias schrieb:
> Hatte keinen 10uF da

Der muss auch nicht exakt 10 µF haben, das ist nur so eine grobe
Größenordnung, die passen würde. Wenn du R2 und R1 um einen Faktor
vergrößerst (für die Verstärkung ist ja nur ihr Verhältnis maßgeblich),
darf die Kondensator um denselben Faktor kleiner werden. Der Kondenstor
gibt dem Verstärker Hochpassverhalten, d.h. wenn du ihn bei gleichen
Widerständen kleiner machst, steigt die Grenzfrequenz (sie liegt etwa
bei 1/(2π·R1·C)), die Schaltung sollte aber immer noch funktionieren.

> und einfach mal den R1 von Ground losgemacht. Jetzt müsste ja
> theoretisch für Gleichspannungen derselbe Fall existieren, als wenn
> ein Kondensator eingebaut ist (unendlich hoher Widerstand)?

Ja, richtig, so kannst du das testen. Der Verstärker ist jetzt ein
gewöhnlicher Spannungsfolger und hat damit die Verstärkung 1.

> Die Ausgangsspannung war trotzdem 0,25 V.

Die sollte jetzt deutlich kleiner sein.

Miss mal am invertierenden Eingang (Pin 2), da sollte ebenfalls die
Ausgangsspannung anliegen. Und auch die Spannung am nichtinvertierenden
Eingang (Pin 3) sollte nur minimal (ein paar mV) davon abweichen. Wenn
zwischen den drei Spannungen größere Abweichungen bestehen, schwingt die
Schaltung (wüsste zwar nicht, warum sie das tun solle), oder mit der
Versorgungsspannung stimmt etwas nicht, oder der Opamp ist defekt, oder
du hast irgendwo Kontaktprobleme, oder ...

Autor: Possetitjel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yalu X. schrieb:

> Wenn zwischen den drei Spannungen größere Abweichungen
> bestehen, schwingt die Schaltung (wüsste zwar nicht,
> warum sie das tun solle),

Na, weil wie üblich keine Abblockkondensatoren eingebaut
sind.
Zumindest sind im Schaltplan oben keine eingezeichnet.

Autor: Possetitjel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias schrieb:

> Die Ausgangsspannung ist bei einer Verstärkung von
> 100 = 0,25 V, muss mich da wohl vertan/vermessen
> haben.

250mV kommt hin; das wäre 2.5mV eingangsbezogener
Offset. Für die TL08x kommt das hin.

> Zieht man bei der Berechnung der unteren Grenzfrequenz
> nur den 1 MOhm Widerstand in Betracht ?

Ja - denn der Eingangswiderstand dieses FET-OPV ist um
so vieles größer als 1MOhm, dass die Parallelschaltung
von 1MOhm und OPV-Eingang immer noch 1MOhm ergibt - im
Rahmen der üblichen Toleranzen.

> Dann könnte ich theoretisch ganz streng genommen sogar
> 10 nF nehmen, da ich den Audiobereich ab 16 Hz verstärken
> möchte.

Ja, rechnerisch richtig.

Beachte aber, dass bei der Grenzfrequenz schon ein Abfall
von 3dB gegeben ist.

> Also bringt dieser Widerstand ja auch nur etwas, wenn das
> Wechselspannungssignal noch eine Gleichspannung enthält ?

Nein!

R1 ist für das definierte Einstellen der Verstärkung notwendig.
Wenn R1 über einen Kondensator auf GND liegt, wird die
Gleichspannungsverstärkung gleich Eins -- die Verstärkung
vor Wechselspannung bleibt aber R2/R1.

> Der Offset bleibt davon unberührt ?

Der eingangsbezogene Offset bleibt unberührt.

Am OPV- AUSGANG misst Du aber ohne Kondenstor (also R1
direkt an GND) 100*U_offset, mit Kondensator aber nur 1*U_offset.

Dass sich bei Dir nix ändert, ist sehr komisch und spricht
für einen Fehler.

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Possetitjel schrieb:
> Matthias schrieb:
>
>> Der Offset bleibt davon unberührt ?
>
> Der eingangsbezogene Offset bleibt unberührt.
>
> Am OPV- AUSGANG misst Du aber ohne Kondenstor (also R1
> direkt an GND) 100*U_offset, mit Kondensator aber nur 1*U_offset.
>
> Dass sich bei Dir nix ändert, ist sehr komisch und spricht
> für einen Fehler.

Ok Danke, jetzt habe ich es verstanden.

Yalu X. schrieb:
>> Die Ausgangsspannung war trotzdem 0,25 V.
>
> Die sollte jetzt deutlich kleiner sein.
>
> Miss mal am invertierenden Eingang (Pin 2), da sollte ebenfalls die
> Ausgangsspannung anliegen. Und auch die Spannung am nichtinvertierenden
> Eingang (Pin 3) sollte nur minimal (ein paar mV) davon abweichen. Wenn
> zwischen den drei Spannungen größere Abweichungen bestehen, schwingt die
> Schaltung (wüsste zwar nicht, warum sie das tun solle), oder mit der
> Versorgungsspannung stimmt etwas nicht, oder der Opamp ist defekt, oder
> du hast irgendwo Kontaktprobleme, oder ...

Ach menno. Ja das passt jetzt, nachdem ich den Fehler gefunden habe.
Ist mir sehr peinlich das zu sagen, aber habe den Kondensator gestern 
Abend immer zwischen R6 und GND eingebaut.
Tut mir leid, dadurch unnötig falsch zum Nachdenken angeregt zu haben.

Also mit Kondensator zwischen R1 und GND habe ich jetzt eine 
AusgangsGleichspannung von ca 2 mV, also für meine Zwecke komplett zu 
vernachlässigen. :-)

Ohne Kondensator ca 200-250 mV. Also ziemlich genau meine eingestellte 
Verstärkung von 100.

Habe jetzt einen 100 nF zwischen R1 und GND eingebaut. Jetzt wird nur 
noch die Wechselspannung verstärkt. Laut Berechnung ist die 
Grenzfrequenz jetzt dort 1591,55 Hz. Das passt auch mit meinen 
Beobachtungen. Tiefe Töne werden auf den Oszi nicht mehr angezeigt.

Werde mir also einen Kondensator größerer Kapazität zulegen.

Möchte mich nochmal bei euch für die Hilfe bedanken.

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias schrieb:
> Also mit Kondensator zwischen R1 und GND habe ich jetzt eine
> AusgangsGleichspannung von ca 2 mV, also für meine Zwecke komplett zu
> vernachlässigen. :-)

Ja, die 2 mV sind plausibel. Laut Datenblatt liegt der typische Wert
sogar bei 3 mV, also hast du wohl eines der besseren Exemplare des TL084
erwischt :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.