mikrocontroller.net

Forum: Compiler & IDEs Grbl mit ARDUINO 1.6.11 kompilieren -> ERRROR


Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin.

Ich muss mir die Grbl 9J Version mit einer Besonderheit bauen Spindel 
PWM mit Enable (nicht Richtung).
Aber ARDUINO 1.6.11 wirft beim kompilieren nur Fehler.
Ist eine Standard Installation mit einbinden von GRBL.

Bin nicht der grosser Software Typ darum habt Rücksicht!

Kann die Meldungen gerade nicht kopieren!

Mal abgesehen von den ganzen redefined (bit max min true false) Kram, 
was schon mal nicht gerade positiv auf mich wirkt, kommt am Ende so was 
wie
"collect2.exe: error: ld returned 5 exit status"

Dieser Fehler spuken die Suchmaschinen ja mehr als einmal aus, aber 
irgendwie lese ich da nie die Lösung.
Bitte helft dem blinden der nur seine Fräse zum laufen bringen will.

Peter

Autor: NA (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Winavr installieren und dann (nach dem Neustart) im GRBL Verzeichnis 
einfach make ausführen (in der Kommandozeile/Eingabeaufforderungen).

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gut auch eine Lösung, werde ich versuchen auch wenn ich den Rechner 
nicht mit so vielen Programmen zu müllen wollte.

Aber warum geht das nicht mit der ARDUINO IDE?

Damit soll es angeblich ja am einfachsten gehen.
Das wäre jetzt auch das schnellste und damit sollte ich das ganze ja 
auch auf das Board kommen.
Aber da habe ich gesehen das es dafür auch ein Programm gibt.

Probleme die kein Mensch braucht, Peter

Autor: Jan L. (ranzcopter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...wenn im GRBL-Wiki steht "tested with Arduino IDE v1.65" (= 1.6.5), 
dann würde ich das im ersten Ansatz einfach mal wörtlich - und *nicht 
die 1.6.11 nehmen...
(da hat sich zwischendrin der gcc-Unterbau deutlich geändert)

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das würde alles erklären auch wenn es schon recht blöd ist.

Welcher IDIOT zerlegt den GCC unterbau so das nichts mehr geht?
Bei mir an der Arbeit, so wie ich den Chef kenne, würden die Software 
Jungs dafür vor die Tür gesetzt werden.
Aber so ist es halt in der freien Welt.

Lade mir heute Abend die alte Version und probiere mein Glück mit den 2 
Lösungen.

Peter

Autor: Bernd K. (prof7bit)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Peter schrieb:
> Welcher IDIOT zerlegt den GCC unterbau so das nichts mehr geht?

Du weißt doch weder wer noch was er zerlegt hat, also spar Dir lieber 
erstmal pauschal mit Idioten um Dich zu werfen, am Ende könnte sich 
vielleicht sogar rausstellen daß Du derjenige bist.

Autor: Liam Z. (liz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Arduino baut noch den Millis Timer ein, welcher Probleme bei hohen 
Taktraten macht. Ein neueres .ino sollte das Problem beheben.

Autor: JB (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Na klar wenn man nicht schwimmen kann ist die Badehose schuld...

Gruß J

Autor: Kaj (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> Aber warum geht das nicht mit der ARDUINO IDE?
Weil das Ding keine IDE sondern eine Krankheit ist.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Bernd K.
In einer frischen Instalation genau nach Anleitung gibt es nur:
geht oder geht nicht.
Wenn es nicht geht dann hat jemand Mist gebaut, aber wie soll der Dumme 
User (ICH) dann schuld sein?

@JB
Ich habe gleich gesagt das ich kein experte bin sonder ein dummer 
Anwender.

@Liam Zeno
Keine Ahnung was das bedeutet!
Habe keine neue Datei und keine Ahung was man da machen müsste.

@Kaj
Ist auch schon wieder runter vom Rechner, dein Kommentat trift es gut.

@NA
Habe mir von ATMEL den Compiler gezogen und damit geht es genau so wie 
man es erwartet. Meine Karte läuft jetzt und wird vorläufig nicht mehr 
angefast.

Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.