mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Frage zu IXTN550N055T2 Power Mosfet


Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte mit einem IXTN550N055T2 eine PWM Steuerung für einen
Gleichstrommotor 24V / 2,5kW aufbauen.

Der Nennstrom beträgt etwa 104A, der Kurzschlussstrom etwa 200A (R= 
0,12Ohm).

lt. Datenblatt kann der IXTN550N055T25 550A schalten, die Anschlüsse 
begrenzen das ganze jedoch dann auf 200A.

Reicht für meine Anwendung 1 Stück (kommt von den Werten ja hin) oder 
soll ich doch lieber 2 Stück parallel betreiben?
Als zusätzlicher Freilaufdiode wird ein DSS 2x101-015A Block verwendet.
Das ganze wird mit CU-Schienen verbunden.

Als GateTreiber würde ich für jeden FET einen TC4420 verwenden, der 
sollte das ganze leicht Treiben können.

eine Überstrombegrenzung ist vorhanden, der maximale Strom kann also nur 
kurze Zeit fließen, (und kurze Zeit werden auch die Anschlüsse etwas 
mehr vertragen..),

sind meine Überlegungen so richtig?

Vielen Dank und noch ein schönes Wochenende!

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und noch vergessen,

Gate Widerstand im Bereich 1-2,2Ohm,
die PWM beträgt 300Hz

Autor: Ben B. (Firma: Funkenflug Industries) (stromkraft)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würd zwei Stück parallelschalten, da dies
die Verlustleistung stark reduziert.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan schrieb:
> Der Nennstrom beträgt etwa 104A, der Kurzschlussstrom etwa 200A (R=
> 0,12Ohm).

Das wäre ein übelst schlechter Motor.

Autor: Stefan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@hinz:
die Ströme wurden mit einem Zangenamperemeter (auch für DC) gemessen,
die 200A fließen wenn der Antrieb blockiert ist/wird. Im Normalbetrieb 
unter Volllast fließen etwa die 100-110A..

Der Wirkungsgrad des Motors ist sicher nicht der Beste.. naja der Motor
ist ja auch schon ca. 25-30Jahre alt, genau kann man es nicht sagen, des 
gibt keine Typenschild mehr..
Es handelt sich bei dem "Gefährt" um eine Art Mini-Schleppfahrzeug, man 
kann auf dem Teil gerade sitzen und mehrere kleine Anhänger ziehen.

Ich hab mir das Teil vor Jahren mal günstig gekauft, fast geschenkt 
bekommen, jetzt könnte ich es verwenden und deshalb möchte ich es 
reparieren. Die Batterie ist noch OK.

defekt an der Karre ist der "Fahrregler". Da ist kein elektronischer 
Regler drin, sondern eine Art "Monsterpoti" welches den Feldstrom des 
Motors regelt. In dem "Poti" sind jede Menge dicker Widerstandsdraht mit 
unzähligen Abgriffen, welche mittels eines massiven Kohlegleiters 
entsprechend des Drehwinkels kurz geschlossen werden. Das ganze ist mit 
Öl gefüllt. Bei Vollgas sind alle Widerstände kurzgeschlossen.
Das Teil ist mechanisch am Ende, der Kohlegleiter ist vermutlich schon 
seit Jahren defekt gewesen und dann hat die Stahlaufhängung an den 
Drähten geschliffen, welche jetzt stark beschädigt sind..

Nun möchte ich eine kleine PWM Steuerung aufbauen und damit das Gefährt 
wieder in gang bringen. Der Steuerteil mittels µC ist bereits fertig, es 
fehlt jetzt nur noch der Leistungsteil inkl. Treiberstufe.

In der Anlage mal mein geplanter Leistungsteil, jedem FET hab ich jetzt 
eine 100A MidiFuse spendiert, ob dies sinnvoll ist weis ich nicht.

und wegen Sicherheitsbedenken:
ich bin mir bewusst, dass es gefährlich ist solche Sachen selbst zu 
bauen,
aber es gibt nichts erwerbbares. Habe schon mit Curtis zwecks eines 
fertigen Reglers telefoniert, die sagen aber das kann man nicht 
umbauen.. die waren auch nicht gerade freundlich am Telefon......

ich bin Elektroniker, jedoch arbeitete ich bislang nur mit Strömen bis 
20A, eher im mA-Bereich. Der µC überwacht die FET's ob diese auch machen 
was das Gate vorgibt.
Wird ein defekt (Kurzschluss) erkannt, schaltet ein Hauptschütz sowie 
sie Wendeschütze sofort aus. Die Schütze schalten auch nur ein wenn 
jemand auf dem Sitzt sitz und das Gaspedal betätigt wird.

... und das Gefährt ist kein Rennwagen, es fährt wenn überhaupt ca. 6 
km/h, und wes wird nur von mir privat genutzt..

Danke für weitere Antworten
Gruß Stefan

Autor: Sicherheitsbedenken (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
es ist doch egal ob privat genutzt oder nicht,
wenn es zu einem Unfall kommt, kommt der Staatsanwalt und
schaut sich das ganze an,
dann kommen:
Wo ist CE Kennzeichen, wer hat das gebaut usw...
ich würd das lieber lassen..

und ob die beiden Fets den Strom aushalten glaub ich fast nicht.
bei diesen Strömen würd ich die Finger davon lassen!!

Autor: Zitronen F. (jetztnicht)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich wuerd's auch sein lassen. Allenfalls den Motor als Anker, oder so 
verwenden.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan schrieb:
> Da ist kein elektronischer
> Regler drin, sondern eine Art "Monsterpoti" welches den Feldstrom des
> Motors regelt.

Ah, deshalb ist das so eine Gurke.


Mach das mit den zwei parallelen MOSFETs, das klappt schon.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hab die beiden Fets und die Diode bereits bestellt.
Werde es am Wochenende fertig zusammenbauen und mal testen.

Wegen der Sicherheit mach ich mir jetzt nicht gerade so große
Gedanken, die Endstufe wird vom µC überwacht, die Fahrschütze ziehen nur 
an wenn FET OK ist, und das Fahrpedal betätigt ist, da ist noch ein 
Schalter drin. Diese Überwachung funktioniert, hab ich schon mehrmals 
getestet.
Das Hauptschütz zieht nur an wenn man auch auf dem Sitzt sitze.

Und sollte alle obigen Maßnahmen versagen, gibt es noch einen NotAus
der die Batterie direkt abtrennt (Laststrom), der Batteriestecker ist 
auch direkt neben dem Fahrersitz.
Ich denk noch sicherer geht es bald nicht mehr.

Irgendwo muss man auch etwas vertrauen in Technik und Programmierung
haben.

Trotzdem Danke für die Antworten!!

Autor: Achim S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da du es nicht explizit erwähnt hast, sicherheitshalber der Hinweis: 
denk dran, dass dein FET Treiber nicht direkt aus den 24V laufen darf 
sondern eine niedrigere Spannung braucht. Und auch daran, dass die 
Freilaufdiode mindestens so eine gute Kühlung braucht wie die FETs (im 
Teillastbereich wird sie stärker heizen als die FETs bei Vollast).

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die FET Treiber laufen mit 15V, Gate Widerstand wird 1 Ohm werden.

FET's und Dioden sind auf einem massiven Alu Kühlkörper montiert,
der mit Lüftern gekühlt wird. Wärme sollte ich leicht wegbringen.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan schrieb:
> Die FET Treiber laufen mit 15V, Gate Widerstand wird 1 Ohm werden.

Schalte die MOSFETs nicht zu hart, das gibt nur  unerwünschte 
Funkstörungen. Auch der Einbauplatz der Freilaufdiode will richtig 
gewählt sein. Einfach die Designregeln für Schaltregler beachten.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hätte die Freilaufdioden jetzt direkt als erstes an die CU-Schienen 
gebaut die den Motor versorgen, dahinter die FETS. So wie ichs weiter 
oben gezeichnet hab, links gehen 24V rein, rechts die zwei 
Motorleitungen raus.

Autor: Homo Habilis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Stefan schrieb:
>> Die FET Treiber laufen mit 15V, Gate Widerstand wird 1 Ohm werden.
>
> Schalte die MOSFETs nicht zu hart, das gibt nur  unerwünschte
> Funkstörungen. Auch der Einbauplatz der Freilaufdiode will richtig
> gewählt sein. Einfach die Designregeln für Schaltregler beachten.

Das sehe ich ähnlich. Scheinbar möchtest Du trotz der nur 300Hz im 
100nS-Bereich schalten (grob überschlagen aus der Kombination an 
Angaben), das muß doch gar nicht sein.

Auch, wenn Du im 10µS-Bereich schalten würdest (also mit um die hundert 
mal größerem Gate-Widerstand - nur mal als "Gegenbeispiel", etwas in 
Richtung des anderen Extrems), wäre das von den Schaltverlusten her 
sogar noch "akzeptabel".

Ist aber natürlich Quark, Treiber mit potentiell bis zu 6A dann mit 
solchen Gatewiderständen auszubremsen. Treiber auch schon bestellt?

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, die Treiber sind schon bestellt,
kann aber jederzeit noch andere verwenden
wenn diese zu stark sind.

Ich dachte immer man muss schnell schalten, um die Schaltverluste
niedrig zu halten.
Naja, wie gesagt, ich eher im mA Bereich zu Hause...

also danke für die Tipps!

Autor: Harald W. (wilhelms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan schrieb:

> Ich dachte immer man muss schnell schalten, um die Schaltverluste
> niedrig zu halten.

Das stimmt zwar im Prinzip, da Du aber nur selten schaltest,
(alle 3ms) sind die Schaltverluste eher vernachlässigbar.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.