mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega 644PA mit 16MHz


Autor: HansWerner (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Hallo zusammen,

ich möchte von einen ATMEGA 32 auf einen ATMEGA 644PA umsteigen.
Nun meine Frage: Kann ich den ATMEGA 644PA mit 16MHz betreiben bei 5V 
Betriebsspannung, leider bin ich mir nach dem lesen des Datenblattes 
nicht sicher.

Autor: Tim W. (werwolf92)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
ja

Autor: S. Landolt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bis 20 MHz

> leider bin ich mir nach dem lesen des Datenblattes nicht sicher
Dann war es wohl die falsche Stelle, nochmal unter "28.2 Speed grades" 
versuchen.

Autor: Stefan S. (sschultewolter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du überhaupt einen Blick ins Datenblatt gesetzt? Da hätten bereits 
die ersten zwei Seiten dir eindeutig den Hinweis geben müssen!!

Speed Grades
– 0 - 4MHz @ 1.8V - 5.5V
– 0 - 10MHz @ 2.7V - 5.5V
– 0 - 20MHz @ 4.5 - 5.5V

Autor: HansWerner (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja genau dass habe ich auch gelesen, war aber dann verunsichert weil ich 
keine eindeutige Auswahl in meinen Compiler habe. Ich bin mir bei der 
Auswahl nicht sicher.

Autor: Georg G. (df2au)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HansWerner schrieb:
> keine eindeutige Auswahl

Was ist bei 8MHz bis XXMHz uneindeutig?

Aber was anderes: Bei 16MHz braucht dein Protz mindestens 4.5V. Da ist 
ein BOD Level von 2.7V kontraproduktiv.

: Bearbeitet durch User
Autor: Carl D. (jcw2)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Georg G. schrieb:
> HansWerner schrieb:
>> keine eindeutige Auswahl
>
> Was ist bei 8MHz bis XXMHz uneindeutig?
>

Vermutlich das MHz, das man beim genauen hinsehen nicht erkennt.
;-)

Autor: S. Landolt (Gast)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
> Bei 16MHz braucht dein Protz mindestens 4.5V
Sind es nicht eher rund 3.8 V bei 16 MHz, die dieser uC benötigt?

Autor: Paul B. (paul_baumann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Er hat doch 5 Volt zur Verfügung -da ist doch Alles in Ordnung.

MfG Paul

Autor: Georg G. (df2au)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
S. Landolt schrieb:
> rund 3.8 V bei 16 MHz

OK, ich hatte einfach den Wert von 20MHz übernommen, nicht das 
Datenblatt rausgesucht. Aber auch bei 3.8V ist BOD bei 2.7V suboptimal.

Autor: Mike J. (linuxmint_user)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein ATmega644PV läuft bei 12MHz noch ohne Probleme mit 1.9 Volt und 
wenn du ihn mit 3.3V betreibst kannst du auch locker bis auf 16MHz 
gehen.

Wenn du ihn bei 4,5V betreibst bist du laut Datenblatt auf der sicheren 
Seite.

Autor: HansWerner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann leider nirgends 16MHz auswählen das ist mein Problem mit dem 
Auswahlfenster.

Autor: Paul B. (paul_baumann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HansWerner schrieb:
> Kann leider nirgends 16MHz auswählen das ist mein Problem mit dem
> Auswahlfenster.

Das "8MHZ_XX" soll "von 8 MHz bis zur maximal zulässigen Taktrate" 
bedeuten.

Diese Symbolik ist wirklich saublöde gewählt.

MfG Paul

Autor: Dieter F. (jim_quakenbush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HansWerner schrieb:
> Kann leider nirgends 16MHz auswählen das ist mein Problem mit dem
> Auswahlfenster.

Suche mal nach "ATMEGA" "FUSES" ...

Das ist voll doof gemacht und ich muss auch immer wieder nachlesen 
(beginnender Alzheimer oder so)

Autor: Stefan S. (sschultewolter)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Paul B. schrieb:
> HansWerner schrieb:
>> Kann leider nirgends 16MHz auswählen das ist mein Problem mit dem
>> Auswahlfenster.
>
> Das "8MHZ_XX" soll "von 8 MHz bis zur maximal zulässigen Taktrate"
> bedeuten.
>
> Diese Symbolik ist wirklich saublöde gewählt.
>
> MfG Paul

Hallo Paul, verstehe nicht, was hier "saublöd" gewählt wurde! Wenn man 
sich einmal damit auseinander gesetzt hat, sollte doch alles klar sein.

Autor: Paul B. (paul_baumann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan S. schrieb:
> verstehe nicht, was hier "saublöd" gewählt wurde! Wenn man
> sich einmal damit auseinander gesetzt hat, sollte doch alles klar sein.

Gut, dann erklär ich es Dir: Solche prägnanten Bezeichnungen wie diese 
hier:

"0MHz9_3MHz" sind ja auch völlig einleuchtend, oder nicht?

Setz Dich mal damit auseinander...

MfG Paul

Autor: Dieter F. (jim_quakenbush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan S. schrieb:
> Wenn man
> sich einmal damit auseinander gesetzt hat, sollte doch alles klar sein

Na, dann bist Du doch DER Mann, der mal alle aufklärt. Erkläre doch 
bitte am die zu Grunde liegende Semantik

https://www.mikrocontroller.net/attachment/305523/...

dafür :-) en detail ...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.