mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Mit positiver Spannung ein anderes Signal unterbrechen


Autor: Nicola Staub (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo miteinander

ich stehe echt gerade ein wenig auf dem Schlauch, vielleicht kann mir 
hier jemand helfen.

Ich habe einen Modellbaudecoder mit zwei Ausgängen, wobei diese gegen 
Masse schalten, will heissen: An beiden Ausgängen sind via Vorwiderstand 
die Kathoden von LEDs angeschlossen, die Anoden sind direkt an ~19V.

Jeder Ausgang schaltet somit seine LED(s). Was ich nun möchte und leider 
nur elektronisch und nicht in der Programmierung des Decoders 
realisieren kann: Wenn einer der Ausgänge eingeschaltet ist, möchte ich 
dass dieser den anderen unterbricht. Dazu anbei eine Zeichnung (man 
entschuldige meine tollen Paint Fähigkeiten).

Jemand dazu eine brauchbare Idee ? Relais sollen keine zum Einsatz 
kommen.

: Verschoben durch Moderator
Autor: Lothar M. (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nicola Staub schrieb:
> Relais sollen keine zum Einsatz kommen.
Darf man fragen, warum? Nur keine mechanischen Relais oder auch keine 
Halbleiterrelais/Optomos-Relais?

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nicola Staub schrieb:
> Wenn einer der Ausgänge eingeschaltet ist, möchte ich
> dass dieser den anderen unterbricht.

Das macht wenig Sinn.
Entweder ist immer nur einer von beiden Ausgängen auf 0V, dann brauchst 
du ja auch den anderen Ausgang nicht unterbrechen, da die andere LED ja 
sowieso aus ist.
Wenn beide auf 0 sind, würden sich beide unterbrechen, also keine LED 
leuchten.
Oder ist es das, was du willst (also wenn beide Ausgänge auf 0 sind, 
soll keine LED leuchten)?

: Bearbeitet durch User
Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Relais kommen auf Grund der Grösse nicht in Frage, zudem wäre das 
Klicken störend (Modelleisenbahn halt...).

Was das "gegenseitige" Unterbrechen anbelangt: Ich weiss, dass dies auf 
den ersten Blick keinerlei Sinn ergibt, die Schaltung beinhaltet aber 
pro Ausgang noch weitere LEDs, die ich der Einfachheit halber nicht 
gezeichnet habe. Die Logik ist somit folgende:

Out 1 ein, Out 2 aus: Alle LEDs am Out 1 leuchten
Out 1 ein, Out 2 ein: Ein Teil der LEDs an Out 1 und Out 2 leuchten 
(diejenigen die ich nicht eingezeichnet habe).
Out 1 aus, Out 2 ein: Alle LEDs am Out 2 leuchten

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eigentlich brauche ich das:
http://www.tech-ecke.de/index_quereinstieg.htm?/el...

Aber so, dass ich die Masseseite schalten kann.

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nicola Staub schrieb:
> Ich weiss, dass dies auf
> den ersten Blick keinerlei Sinn ergibt, die Schaltung beinhaltet aber
> pro Ausgang noch weitere LEDs, die ich der Einfachheit halber nicht
> gezeichnet habe.

Dann zeichne sie bitte, der Verständlichkeit halber.

Autor: Nicola Staub (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dürfte dann etwa so aussehen.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du brauchst eine EXOR-Verknüpfung für die LEDs, die in der mittleren 
Bedingung nicht leuchten sollen.

Autor: Günter Lenz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm zwei, zwei Eingangs-NAND und mach daraus ein
RS-Flip-Flop. An den Ausgängen dieses Flip-Flop
noch je ein Negator dann hast du genau die
gewünschte Funktion.

Autor: Joe F. (easylife)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das geht mit N-Channel Mosfets, die am Gate min. deine Betriebsspannung 
aushalten.
Wenn deine LED Spannung unter 30V bleibt, kannst du z.B. 2N7002 oder 
2N7000 nehmen.
Drain an den Vorwiderstand der abzuschaltenden LED.
Source an OUT (der abzugschaltenden LED)
Gate an den anderen OUT (der die LED abschalten soll).

Siehe Anhang.

Im Grunde ist es genau umgekehrt, wie im Titel des Threads beschrieben.
Du unterbrichst das Signal, wenn am anderen Ausgang keine Spannung 
anliegt (0V -> LED leuchtet).

: Bearbeitet durch User
Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Besten Dank für den Vorschlag, werde ich gerne so testen :)
Stimmt übrigens: Die Überschrift ist nicht wirklich korrekt getroffen.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, habe die Schaltung mal kurz aufgebaut und funktioniert so :)
Nur habe ich einen unschönen Nebeneffekt: Die GS Spannung kann ja nun 
bis gegen die 19V gehen, was dann doch an der Grenze vieler MOSFETs 
liegt, wie kann ich diese sinnvoll reduzieren ?

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am besten nimmst du eben einen FET, der 30V am Gate okay findet (z.B. 
2n7000).
Spannungsteiler ist hier schwierig, da man ja keinen Strom durch die 
ausgeschaltete LED fließen lassen möchte. Kannst es aber z.B. mit 
100K/100K versuchen, da dürfte die LED nicht wirklich leuchten.

: Bearbeitet durch User
Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Hinweis, da werde ich aber wohl suchen müssen.
Ich finde hier leider nur 2N7000 die eine Rds von 10V haben oder einen 
maximalen DI von 200mA (sollte das doppelte vertragen können).

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was wäre damit ? Wäre auch gleich dual:
http://www.mouser.com/ds/2/389/sts1dnc45-956706.pdf

Autor: Joe F. (easylife)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Könnte gehen. Du hast recht, die 2n700x gehen in der Regel nur bis 20V 
GS.

Du könntest aber auch die Gate Spannung mit einer kleinen 
Transistorschaltung heruntersetzen (s. Anhang, die andere Hälfte der 
Schaltung, um auch D1 abzuschalten, habe ich mal der Übersichtlichkeit 
halber weggelassen). Dann ist die FET Auswahl einfacher.
Welcher NPN ist total egal. BC857, oder BC847 (SMD)...

: Bearbeitet durch User
Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lieben Dank für das Schema, werde ich gerne so testen :)

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joe F. schrieb:
> Welcher NPN ist total egal. BC857, oder BC847 (SMD)...

äh, Unsinn. Ein PNP Transistor muss es sein, also z.B. ein BC857, gibs 
auch in SMT (BC857C,215). BC847 ist falsch.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sehe da leider gerade ein kleines Problem: Mir steht Masse nicht zur 
Verfügung :(

Falls sich jemand wundert was das Ganze soll: Es geht um einen 
Modellbahnzug. Dieser hat zuvorderst in der "Lok" einen 
Funktionsdecoder, welcher die beiden Ausgänge sowie die 19V zur 
Verfügung stellt.
Von dort aus besteht eine Verdrahtung durch den ganzen Zug, welche über 
8polige Kupplungen geführt wird, dort sind leider alle Pins belegt und 
notwendig.
Normalerweise schaltet man nur die Stirnbeleuchtung rot/weiss über die 
beiden Ausgänge um. Ich möchte diese Funktion aber um weitere 
"Lichtbilder" erweitern, was auf Grund der Verdrahtung bzw. der 
Kupplungen nicht ohne gröberes Gebastel geht, daher mein Ansatz einer 
elektronischen Lösung.
Da aber in den Wagen keine Komponente Masse braucht (Masse wird bei den 
Verbrauchern immer geschaltet und 19V steht dauernd zur Verfügung), habe 
ich diese nicht.

Autor: Joe F. (easylife)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
geht auch so.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wow, danke vielmals für die tolle Unterstützung :)

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doch noch eine kurze Freage am Rand: Habe leider gerade keine BC857C da, 
was eignet sich besser: BC327 oder BC557 (das sind diejenigen, die ich 
gerade zur Hand habe).

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
egalo.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sodele, habs nun auf dem Steckbrett gebaut, leider funktionert es aber 
nicht wie gewollt :(

Bau ich die Schaltung wie gezeichnet nur für eine Seite auf, dann läuft 
alles normal. Sobald ich aber beide habe, geht es leider nicht mehr und 
zwar ab dann, wenn ich von beiden PNPs die Basis angeschlossen habe.

Hänge ich jeweils eine ab, funktioniert der eine Teil für sich, 
gemeinsam aber leider nicht.
Ich habe sowohl versucht die Basis am Drain wie auch an der Source 
anzuschliessen (auf dem Schema leider nicht ersichtlich).

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hängt denn noch mind.
je 1 nicht abgeschaltete led an den ausgängen? notwendig.

: Bearbeitet durch User
Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jeweils eine ist dran ja.
Folgendes passiert, wenn die gesamte Schaltung aufgebaut ist:
Egal, welchen Ausgang ich schalte (auch beide zusammen): Es leuchten 
immer beide "nicht unterbrochenen" LED, die anderen tun gar nichts.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mist, ich merke gerade, dass das auch der Fall ist, wenn nur eine Seite 
die "Ausschaltung" besitzt :( habe ich falsch beobachtet.

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
drain und source verwechselt? drain ist bei mir 'oben'. welchen fet 
benutzt du?

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab leider nur IRFD220 hier aktuell, hab es noch einmal kontrolliert und 
ist soweit korrekt. Drain ist sehr gut erkennbar an den beiden 
verbundenen Füssen: http://www.vishay.com/docs/91131/sihfd220.pdf

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nimm mal testweise den pnp transistor weg. nur spannungsteiler am gate 
des fet. die led muss sich dann so verhalten, wie die ohne fet.

: Bearbeitet durch User
Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Funktioniert nun :)
Habs einfach nur nochmal neu aufgebaut und dabei bemerkt, dass mein 
Steckboard wohl eher für die Tonne taugt... hatte einen Wackelkontakt.

Nun funktionierts einwandfrei ! Vielen lieben Dank !!!

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok. dann kannste ja jetzt etwas passendere fets besorgen ;-)
aber deine vorgehensweise gefällt mir: erst mal testaufbau machen mit 
dem was da ist.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dankeschön :)

Eine Frage trotzdem noch:

Joe F. schrieb:
> hängt denn noch mind.
> je 1 nicht abgeschaltete led an den ausgängen? notwendig.

Habs mal rein Interesse halber ohne dauernd leuchtende LED getestet und 
funktioniert trotzdem (war halt neugierig), was wäre denn normalerweise 
zu erwarten ?

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Korrektur: Die nicht-leuchtende LED ist nur auf einer Seite entfernt und 
nicht auf beiden.

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kannst du die led vorwiderstände eigentlich auch durch 2 in serie 
geschaltete widerstände mit halbem wert ersetzen? dann gäbe es noch eine 
möglichkeit, wieder nur mit den 2 fets, aber weniger spannung am gate...

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dazu müsste ich die Platine in der Lok noch genau studieren, ganz 
ausschliessen würde ich es aber nicht.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe gerade die Gate-Source Spannung an der neuen Schaltung 
gemessen, die scheint aber mit dem Multimeter komischerweise immernoch 
gleich hoch zu sein wie ohne die beiden Transistoren ? Komisch.

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hast du das multimeter wirklich zw g-s oder gate-gnd? zu gnd kann die 
spannung 19v sein. zu source nicht.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mist: Ich hatte die Verbindung vom Kollektor der beiden Transistoren zum 
OUTx vergessen... nur leider ist jetzt der von mir oben beschriebene 
Effekt zurück, also doch kein Wackelkontakt :(

(ich sollte wohl schlafen gehen, die Fehler häufen sich).

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab nun den empfohlenen Test noch gemacht und die Transistoren entfernt: 
Die geschalteten LEDs verhalten sich dann korrekt (bzw. auch die nicht 
geschalteten).

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na ich gucke morgen mal
in der simulation mit der kompletten schaltung.
sind deine ausgänge eigentlich 'push-pull' oder 'open-drain'?

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dankeschön (sollte echt langsam unter die Decke...).

Das mit den Ausgängen weiss ich leider nicht, der verbaute 
Digitaldecoder ist von einem Dritthersteller und die geben solche Infos 
nicht Preis. Muss evtl. mal schauen was auf dem Ding verbaut ist.

Autor: Joe F. (easylife)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das mit den PNP Transistoren war keine gute Lösung.
Versuche es mal einfach so, wie im Anhang gezeigt. Es fließt zwar ein 
ganz kleiner Strom von Ausgang 1 zu 2 und umgekehrt, das dürfte eine LED 
aber nicht sichtbar zum Leuchten bringen. Die Gatespannung ist jetzt 
immer im Bereich +/-9.5V

Wenn eine der 'äußeren' (nicht durch den anderen Ausgang abschaltbaren) 
LEDs entfallen soll, dann ist stattdessen ein Pullup des Ausgangs zu 19V 
nötig (47K sollten reichen).

: Bearbeitet durch User
Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Vorschlag, funktioniert soweit einwandfrei, nur leider 
sieht man diesen kleinen Strom tatsächlich: Die andere LED leuchtet ganz 
schwach :(

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kannst ja mal 1M oder sogar 2.2M ausprobieren.

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habs gerade mit 4.7M probiert und sehe das sogar dann noch ?! Wahnsinn.

Ich bin aber heute noch über was anderes gestolpert: Ein Panasonic 
photoMOS in NC Konfiguration, das würde mein Problem doch theoretisch 
auch lösen: 
http://www.farnell.com/datasheets/1972647.pdf?_ga=...

War recht erstaunt, als ich sah, dass es sowas als Normally Closed gibt.

Autor: Tommi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie waers mit Dioden? Vier Stueck reichen aus, einfach von jeder 
mittleren LED je eine Diode zum eigenen Ausgang und eine zum Anderen.
Wenn ich die Funktion richtig verstanden hab...

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das wird leider nicht gehen ;) ich will LEDs ausschalten, wenn der 
andere Ausgang eingeschaltet und leider nicht umgekehrt.

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
photomos: naaaaa, viel zu teuer. und 50ma werden nicht durch deine leds 
fliessen, wenn die schon mit astronomisch grossen vorwiderständen 
sichtbar leuchten. mach dich mal auf die suche nach einem GND punkt. es 
gibt noch eine gute lösung nur mit fet, spannungsteiler und diode. man 
braucht aber GND dafür:
spannungsteiler von 19v zu GND (zB 330k/330k).
9.5V an fet gate. diode vom gate zum anderen ausgang, so dass der andere 
ausgang bei 0V das gate auf 0.6-0.7V zieht, bei LED aus aber die 19V 
nicht zum gate können.
nimm am besten keine schottky, die haben wieder relativ hohen reverse 
current. 1N4148 ist gut (ca 10nA).

: Bearbeitet durch User
Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 50mA bringe ich natürlich nicht durch die LEDs, somit würde ich die 
Input LED vom photoMOS über einen separaten Vorwiderstand zwischen 19V 
und OUTx. Wobei unter Recommended Operating Conditions ein Strom von 5 
mA angegeben ist, 50mA steht unter Absolute Maximum Ratings.

Der Preis ist "unschön" ja, zumal ich vier von den Dingern pro Zug 
benötigen würde.

GND wird sich definitiv nicht finden lassen, wie ich mal erwähnte hat es 
eine 8polige Verbindung zwischen den Wagen:
- 2x Schienensignal (DCC Digitalsignal mit alternierender Polarität ohne 
feste Masse)
- 2x Motorsignal, PWM, wechselt Polarität je nach Fahrtrichtung
- 19V+
- 3x OUT (wir haben immer nur von Out1 und 2 gesprochen, Nummer 3 wird 
für die Innenbeleuchtung verwendet und fällt somit auch weg).

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nicola Staub schrieb:
> GND wird sich definitiv nicht finden lassen

OK. Auch die Lösung mit dem Spannungsteiler und Dioden ist nix. Da 
können dann trotzdem -20V am Gate vorkommen.

Die einfachste Lösung wäre nach wie vor, einen FET zu finden, der 30V am 
Gate aushält. Das vereinfacht die Schaltung auch sehr (einfach nur den 
FET in die Leitung legen, genau wie im allerersten Vorschlag).
Von diesen FETs gibt es dann doch noch einige.

z.B:

ZVN4525E6TA (bis 40V V_gs)
z.B. bei mouser, digikey, rs-components

NTR5103N
z.B. bei Digikey.de
http://www.digikey.de/product-detail/de/on-semicon...
http://www.onsemi.com/pub_link/Collateral/NTR5103N-D.PDF

2N7002E,215
z.B. bei rs-components.de
http://de.rs-online.com/web/p/transistoren-mosfet/7258307/
http://docs-europe.electrocomponents.com/webdocs/0...

2N7002F,215
z.B. bei rs-components.de
http://de.rs-online.com/web/p/transistoren-mosfet/7258300/
http://docs-europe.electrocomponents.com/webdocs/0...

Autor: Nicola Staub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Vorschläge, wird wohl die einfachste Lösung sein :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.