mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Kein GPS Verbindung mit Arduino


Autor: Markus (Gast)
Datum:
Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Hallo,

ich habe das folgende GPS Modul an meinen Arduino Nano angeschlossen.
Ebay-Artikel Nr. 222174677508

leider bekomme ich keine Daten, auch nach 5 minütiger Laufzeit.

Kann mir jemand sagen wieso es nicht funktioniert

Autor: Andreas B. (bitverdreher)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weil ein GPS im Gebäuden nicht funktioniert?

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe es natürlich draußen versucht...

Autor: Dieter S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
RX und TX vom GPS vertausch ?
Solltest du auch im Sketch dokumentieren.

Autor: das Einhorn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daten kommen sowieso. Sie sind einfach ungueltig. Was waren denn die 
Kommunikationsparameter ?

Autor: Jim M. (turboj)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wundert mich nicht.
Laut http://arduiniana.org/libraries/tinygps/

muss man die GPS Daten manuell da reinpfriemeln, bevor es Lat und Long 
Koordinaten ausspucken kann. Findet hier überhaupt nicht statt.

Autor: Wolfgang (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Markus schrieb:
> Kann mir jemand sagen wieso es nicht funktioniert

Du hast eine "Black Box" aufgebaut und erwartest, dass sie beim 
Einschalten auf anhieb funktioniert. Das nenne ich Optimismus.

Wie wäre es mit einer systematischen Fehlersuche, indem du die Daten von 
der Quelle (serielle Schnittstelle des GPS Moduls) bist zum Ziel 
(serielle Ausgabe des Arduino) Schritt für Schritt verfolgst.

Du könntest z.B. das GPS-Modul über ein USB-Seriell Wandler "TTL" an 
deinen PC hängen und erstmal den NMEA-Daten in einen Terminalprogramm 
o.ä. direkt lauschen. Dann weißt du schon mal, ob das Modul tut was es 
soll und ob die in deinem Programm gewählten 38400Bd auch tatsächlich 
der vom Modul aktuell verwendeten Geschwindigkeit entsprechen.

Autor: Crazy H. (crazy_h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut dem Verkäufer:
> The default baud rate: 9600 or 38400
Ich hatte bisher noch kein GPS-Modul das mit 38400 ausgeliefert wurde.

Autor: --- (Gast)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
> Du hast eine "Black Box" aufgebaut und erwartest, dass sie beim
> Einschalten auf anhieb funktioniert. Das nenne ich Optimismus.

Einen mehr als einstelliger IQ wird bei Adruino ja auch nicht
vorrausgesetzt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.