mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LD33v richtig einlöten


Autor: LötNoob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe scheinbar nun schon 2 3.3V Spannungsregler beim Löten zerstört:

Ich wollte einen LD33v von ST in eine Lochrasterplatine löten. Per 
Kupferlackdraht führe ich 5V von meinem STM32F4Discovery Board (das über 
Buchsenleisten auf der Lochrasterplatine angesteckt ist) zum LD33v. Vom 
LD33v soll die Spannung weiter an einen SD-Karten Slot.

Als ich vor dem Einlöten, den LD33v durchgemessen habe, sind die 
erwarteten 3.3V aus dem Ausgang gekommen. Nachdem ich ihn eingelötet 
habe, nur noch beim ersten 1.5V beim zweiten 0.7V.

Was mache ich falsch? Der Lötkolben ist auf ca. 320 °C eingestellt, und 
ich habe versucht, den Lötkolben nicht länger als 1 - 2 Sekunden an das 
Bauteil zu halten.

Wie lötet man so ein (scheinbar) empfindliches Bauteil, dass es nicht 
gleich kaputt geht?

Vielen Dank schon mal für eure Hilfe
LötNoob

Datenblatt:
https://www.sparkfun.com/datasheets/Components/LD1117V33.pdf

: Verschoben durch Moderator
Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Zeig' doch bitte mal ein Photo von Deinem gelöteten Aufbau.

So einen Spannungsregler bekommt man beim Löten eigentlich nicht kaputt.

Autor: Joe F. (easylife)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Hat denn dein LDO auch Kondensatoren am Eingang und am Ausgang?

Autor: LötNoob (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Man kann zwar nicht viel erkennen, weil ich gerade angefangen hatte, die 
Schaltung aufzubauen.

Zum Messen habe ich übrigens mal die 5V vom µC direkt über Jumperwire an 
den LD33v gehängt..

Autor: LötNoob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kondensatoren habe ich noch keine dran. Sind die zwingend nötig? Bevor 
ich sie eingelötet habe, hatte ich den LD33v mal direkt per Jumperwire 
mit den 5V versorgt, und da hat er auch so die 3.3V geliefert.

Autor: Joe F. (easylife)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
LötNoob schrieb:
> Kondensatoren habe ich noch keine dran. Sind die zwingend nötig?

Ja.

PS: der mittlere Pin deines LDO ist doch überhaupt nicht angelötet.
Übe löten.
Der Rest ist auch nur so "angeklebt".
Kupferlackdraht braucht besonders viel Übung, da der Lack nicht immer 
zuverlässig wegschmilzt.
Nimm lieber einen normalen isolierten Draht, und isoliere die Stellen 
ab, die du verlöten möchtest.

PPS: Ausserdem braucht der Regler eine minimale Belastung am Ausgang.
2-5mA.
Du solltest also einen Widerstand von OUT zu GND einfügen (irgendwas 
zwischen 680 Ohm und 1.5 K).

: Bearbeitet durch User
Autor: LötNoob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dass der mittlere Pin noch nicht angelötet ist, liegt daran, dass die 
ersten beiden angelötet habe, und dann messen wollte, ob er wieder die 
falschen Werte liefert, nachdem ich das gleiche Problem schon mit dem 
ersten Spannungsregler hatte.

Aber danke für eure Hilfe. Ich werde mir die entsprechenden 
Kondensatoren besorgen, und dann nochmal messen.

Autor: Axel Schwenke (a-za-z0-9)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
LötNoob schrieb:
> Dass der mittlere Pin noch nicht angelötet ist, liegt daran, dass die
> ersten beiden angelötet habe, und dann messen wollte, ob er wieder die
> falschen Werte liefert

Wie überaus albern. Ohne den mittleren Pin angeschlossen zu haben, macht 
der Regler gar nichts. Insbesondere regelt er nicht.

Das ist gefähr so, wie an ein Auto erst mal nur zwei Räder anzuschrauben 
und dann zu versuchen, ob es schon fährt ...

Autor: Andreas Schweigstill (Firma: Schweigstill IT) (schweigstill) Benutzerseite
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Axel S. schrieb:
> Wie überaus albern. Ohne den mittleren Pin angeschlossen zu haben, macht
> der Regler gar nichts. Insbesondere regelt er nicht.

Doch.

> Das ist gefähr so, wie an ein Auto erst mal nur zwei Räder anzuschrauben
> und dann zu versuchen, ob es schon fährt ...

Es ist eher damit vergleichbar, den Motor laufen zu lassen, aber keinen 
Gang einzulegen.

Autor: Axel Schwenke (a-za-z0-9)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas S. schrieb:
> Axel S. schrieb:
>> Wie überaus albern. Ohne den mittleren Pin angeschlossen zu haben, macht
>> der Regler gar nichts. Insbesondere regelt er nicht.
>
> Doch.

Hmm. Ich hätte doch vorher die Pinbelegung des LD33 nachsehen sollen. 
War ich doch davon ausgegangen, daß der nicht angeschlossene Pin der für 
GND ist. Es ist aber die Ausgangsspannung und der TE hat dann wohl an 
diesem, nicht angeschlossenen Pin gemessen. Ich nehme also alles zurück 
und behaupte das Gegenteil ;)

Allerdings sollte am Reglerausgang definitiv ein Kondensator hin. Die 
Lötstellen sehen nicht vertrauenswürdig aus. Und der Draht wirkt auch 
reichlich dünn. Wenn man soviel Platz hat wie auf dieser Platine, dann 
nimmt man verzinnten Kupferdraht (oder abgeschnittene Bauelemente- 
Beinchen) und lötet den flach auf. Gerade bei Versorgungsspannungen und 
GND will man ja auch eine niederohmige Verbindung haben.

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LötNoob schrieb:
> Per
> Kupferlackdraht führe ich 5V von meinem STM32F4Discovery Board (das über
> Buchsenleisten auf der Lochrasterplatine angesteckt ist) zum LD33v. Vom
> LD33v soll die Spannung weiter an einen SD-Karten Slot.

Das Discovery Board liefert dir bereits die internen ~3,0V, mit dem das 
Board alle Onboard Komponenten versorgt. Die liegen auch auf den 
Pfostenfeld Pins, direkt neben den 5V.
Man darf nicht unendlich viel Strom daraus ziehen, aber für eine SD 
Karte reicht das immer.

: Bearbeitet durch User
Autor: LötNoob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Das Discovery Board liefert dir bereits die internen ~3,0V, mit dem das
> Board alle Onboard Komponenten versorgt. Die liegen auch auf den
> Pfostenfeld Pins, direkt neben den 5V.
> Man darf nicht unendlich viel Strom daraus ziehen, aber für eine SD
> Karte reicht das immer.

Ich dachte mir auch, dass die 3V bestimmt reichen würden. Wollte aber 
auf Nummer Sicher gehen, weil ich noch nicht so viel Erfahrung mit 
SD-Karten habe...

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LötNoob schrieb:
> Vom
> LD33v soll die Spannung weiter an einen SD-Karten Slot.

Nimmst Du fertige Platte, z.B.:
https://www.aliexpress.com/item/Hot-Sale-Reading-a...

Da ist der 5V-LD-Regler schon drauf!

Autor: Matthias S. (Firma: matzetronics) (mschoeldgen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LötNoob schrieb:
> Wollte aber
> auf Nummer Sicher gehen, weil ich noch nicht so viel Erfahrung mit
> SD-Karten habe

Eben, die Frage ist, was heisst 'Nummer sicher'? Sicherlich ist die 
Stromversorgung des Disco Boards besser als das, was du da bisher gebaut 
hast und sie liegt auch noch auf dem gleichen Potenzial wie die SD Karte 
- vorausgesetzt, du willst die Karte mit dem Disco Board lesen.

Da ausserdem diese 3V genau der Logikpegel sind, der innerhalb des Disco 
Boards überall verwendet wird, ist 'Nummer sicher' die Verwendung der 3V 
vom Board - dafür sind sie da.

Wenn man ausserdem darauf verzichtet, das Board je über diese 3V von 
extern zu speisen, kann man noch eine Diode brücken und die nominellen 
3,3V benutzen, die der Disco Regler eigentlich bereitstellt.

: Bearbeitet durch User
Autor: LötNoob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Eben, die Frage ist, was heisst 'Nummer sicher'?

Mit 'Nummer sicher' meinte ich, dass das Board, das ich verwende einen 
3.3V Eingang erwartet. Und ich deswegen auch versucht habe diese 3.3V zu 
erzeugen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.