Forum: Analoge Elektronik und Schaltungstechnik Komparator richtig beschalten?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Sepp (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

habe folgendes Problem. Habe eine Schaltung mit welcher ich eine analoge 
Eingangsspannung anhand des Komparators überprüfen will. Hier ist einer 
der Vergleiche mit dem invertierenden Eingang aufgezeigt und da liegt 
das Problem.
Selbige Schaltung auf Basis des Nicht-Invertierenden Eingangs gibt ein 
sauberes Schaltsignal, das obige auf dem invertierenden leider nicht. 
Der scheint dor zu "schwingen", also er hat dort einen Bereich der nicht 
definiert ist. Habe ich heruasgefunden als ich den Schaltpegel durch das 
Poti verändert hab bei konstanter Referenzspannung. Habe auch schon 
einen Pull-Up versucht was ja bei dieser Art OP herzunehmen ist, 
allerdings ändert das nichts an dem Problem. Spannungsversorgung kommt 
direkt aus einem fertigen Netzteil. Analoges Signal wird direkt auf OP 
gelegt.

Kann mir jemand helfen? Ich weiß echt nicht weiter -.-

Danke

: Verschoben durch Moderator
von Christoph db1uq K. (christoph_kessler)


Bewertung
0 lesenswert
nicht lesenswert
Der 1MOhm-Widerstand sieht so aus, als ob das einen Schmitt-Trigger 
geben sollte (der nicht so leicht schwingt). Nur hängt der am falschen 
Eingang, der müsste auf den nichtinvertierenden zurückgeführt sein.

von Sepp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Also ich hab die gesamte Schaltung schon aufgebaut und mal getestet. Der 
einzige Unterschied zu der obigen ist, dass die beiden Eingänge 
vertauscht sind und da läuft alles rund. lediglich hier nicht. Ich hab 
heute lange nach Fehlern gesucht aber keine gefunden. Hab leider kein 
Bild vom Oszi, lässt sich aber so beschreiben, dass im Kippzustand der 
OP zwischen zwei Pegel hin und herspringt und das rasant. Das geht so 
schnell dass das Oszi das selbst nur als Punkte anzeigt. Ich hab aber 
keine Ahnung wie ich das beheben soll um einen konkreten Zustandswechsel 
zu erhalten. Habe nach den beiden OPs ein UND geschalten und das hängt 
dann natürlich auch in der Luft -.-

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sepp schrieb:
> Ich hab heute lange nach Fehlern gesucht aber keine gefunden.

Wo hast du denn den Fehler gesucht?
Es liegt höchstwahrscheinlich nicht an deinem Aufbau, sondern an der 
Schaltung. Du brauchst einen Schmitt-Trigger mit einer Hysterese, die 
größer als das Rauschen/Störungen auf deinem Signal ist.

von Wolfgang (Gast)


Bewertung
0 lesenswert
nicht lesenswert
p.s.
Woher bekommst du überhaupt einen High-Pegel am Ausgang, i.e. was hast 
du da als Pull-Up dran hängen. Der LM393 besitzt einen 
Open-Kollektor-Ausgang und kann ohne nicht als linearer Verstärker 
arbeiten.

von Sepp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das analoge Signal hat ja an sich keine Störungen oder Rauschen, das 
taucht erst aum Ausgang des OPs auf. Ich kann dafür leider keinen 
Schmitt-Trigger einsetzen, da ich die zwei Potis für 
Einstellmöglichkeiten benötige und die unabdinglich sind :/

von Sepp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Als Pull-Up derzeit einen 47kOhm, hatte auch schon 4,7k dran aber ändert 
nix am Ausganssignal. Hat das vll was damit zu tun, dass am 
invertierenden Eingang die Referenzspannung anliegt? Muss man dann was 
ändern als wenn es am nicht-invertierenden wäre?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Wolfgang schrieb:
> Der LM393 besitzt einen
> Open-Kollektor-Ausgang und kann ohne nicht als linearer Verstärker
> arbeiten.

Richtig, aber linear arbeitet der LM393 nie. Das bleibt immer ein 
digitaler Ausgang, an dem high steht, wenn der + Eingang höher liegt als 
der - Eingang und umgekehrt.
Aber ohne Pullup geht es nicht und Christophs Einwand sollte der TE auch 
mal lesen, im Moment hat er da ein selbstschwingendes System gebaut.

von Sepp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Auf gut deutsch ich kann das nicht beheben? Derzeit ist die Schaltung so 
wie oben gezeigt nur es ist noch ein Pull-Up auf 5V mit 47kOhm 
abgehängt. das Ausgangssingla führt auf ein UND-Gatter... Muss ich was 
ändern oder einfach einen anderen Komparator suchen? Ich brauch da 
dringend ein eindeutiges Signal und kein geschwimme ^^

von Joe F. (easylife)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Lesen, was dir geraten wird...

Christoph K. schrieb:
> Der 1MOhm-Widerstand sieht so aus, als ob das einen Schmitt-Trigger
> geben sollte (der nicht so leicht schwingt). Nur hängt der am falschen
> Eingang, der müsste auf den nichtinvertierenden zurückgeführt sein.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Sepp schrieb:
> Muss ich was
> ändern oder einfach einen anderen Komparator suchen? Ich brauch da
> dringend ein eindeutiges Signal und kein geschwimme ^^

Du musst, wie Christoph sagte, den Sch..$$ 1MOhm Widerstand auf den + 
Eingang legen und nicht auf den - Eingang!
Damit hast du eine Mitkopplung und Hysterese und keine Rückkopplung, die 
du da im Moment gebaut hast. Jetzt klar?

von Noch einer (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Eine kleine Hysterese brauchst du immer. Zumindest muss die Hysterese so 
gross, wie das Rauschen sein.

Invertierender und Nicht-Invertierender Komperator sind vollkommen 
gleich aufgebaut.

Du vertauscht nur Eingang und Referenzspannung. Wie z.B. hier 
beschrieben:
http://www.elv.de/module/community_expertenwissen/bilder_popup.aspx?id=89

von Joe F. (easylife)


Bewertung
0 lesenswert
nicht lesenswert
Ausserdem einen 100nF zwischen Pin 11 und Pin 4 nicht vergessen, und 
möglichst noch einen kleinen Kondensator zwischen Pin 6 und GND 
(Dimensionierung kommt auf deine max. Eingangsfrequenz an, mit 100nF 
hast du eine Grenzfrequenz ab 3.1 KHz - der genaue Wert hängt von der 
Potistellung ab).

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Joe F. schrieb:
> Ausserdem einen 100nF zwischen Pin 11 und Pin 4 nicht vergessen

Erstaunlich, aber das ist bei dem Chip sogar lt. Datenblatt nicht nötig. 
Zitat aus dem TI Datenblatt:
> It is usually unnecessary to use a bypass capacitor
> across the power supply line.

Das gleiche gilt auch für die LM139/239/339 4-fach Komps

: Bearbeitet durch User
von Sepp (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Oh man ist das peinlich. Danke leute. Habs grad nochmal simuliert -.- 
Hätt ich doch in PSpice mal näher hingesehen -.-

Danke euch... :)

Eine Frage hätte ich dann noch... Die Dimensionierung der Widerstände, 
ist die in Ordnung?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Sepp schrieb:
> Die Dimensionierung der Widerstände,
> ist die in Ordnung?
Die 47k Pullup, die du mal erwähnt hast, sind sehr gross. Besser und 
schneller wirds, wenn du den um Faktor 10 kleiner machst.

von Joe F. (easylife)


Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Erstaunlich, aber das ist bei dem Chip sogar lt. Datenblatt nicht nötig.

'Nötig' ist immer relativ. Klar, durch den Open-Collektor Ausgang 
entsteht beim Schalten keine so große Stromänderung im IC wie bei einem 
Push-Pull Ausgang, es ist aber halt eine gute Design-Praxis jedes IC zu 
entkoppeln. Man weiss ja nicht, was noch so drum rum sitzt, oder ob das 
ganze evtl. auf dem Steckbrett gebaut ist...

von Sepp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Übrigens hat der Chip nur 8 Pins... Also haut das nicht ganz hin ^^ Aber 
wofür soll der gut sein und wo muss der letztendlich immer hingeführt 
werden

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Joe F. schrieb:
> Man weiss ja nicht, was noch so drum rum sitzt, oder ob das
> ganze evtl. auf dem Steckbrett gebaut ist...

Stimmt schon, aber der Hersteller sagt eben mal eindeutig, das man es 
hier nicht braucht - liest man auch nicht jeden Tag in einem Datenblatt.

Sepp schrieb:
> Übrigens hat der Chip nur 8 Pins...

Deswegen den optionalen Abblock/Reservoir Kondensator zwischen 8 und 4 - 
von Vcc nach GND. So ein C dient neben der Reservoir Funktion auch als 
HF Blocker ( Entstörung) aus der und in die Schaltung.

von Sepp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ah herzlichen Dank für die Infos :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.