Forum: Analoge Elektronik und Schaltungstechnik [ERLEDIGT] LM567 merkwürdiges Verhalten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Wolfram F. (mega-hz)


Lesenswert?

Hallo,

ich brauche mal Hilfe mit dem LM567 Tondecoder....

Ich habe eine kleine Schaltung gemäß dem Datenblatt aufgebaut,
Mittenfrequenz soll 200Khz sein. R1=2K, C1= 1nF.
Eingang ist per 100nF vom Signal (TTL Oszillator) DC mäßig getrennt.
Nun ist es so, daß nach dem Einschalten sich der 567 für 1-2min richtig 
verhält, dann aber leuchtet die LED am Ausgang Pin8 ständig, ausser wenn 
die Frequenz gerade mal stimmt.
Der TTL-Oszillator "sweeped" zwischen 0 und 300Khz...

Weiss jemand, warum der 567 sich so komisch verhält?
VCC ist 4.8V (USB)

Gruß,
Wolfram

: Bearbeitet durch Moderator
von Ludwig (Gast)


Lesenswert?

> Ich habe eine kleine Schaltung gemäß dem Datenblatt aufgebaut ...

Seltsam: Mit der kleinen Schaltung aus dem Datenblatt habe ich noch nie 
Probleme gehabt.

von MaWin (Gast)


Lesenswert?

Wolfram F. schrieb:
> Ich habe eine kleine Schaltung gemäß dem Datenblatt aufgebaut,
> dann aber leuchtet die LED am Ausgang Pin8 ständig, ausser wenn
> die Frequenz gerade mal stimmt.

Im Datenblatt gibt es keine Schaltung mit LED. Es gäbe Schaltungen, bei 
denen das Verhalten richtig ist.

Vielleicht massiv übersteuert ? Der NE567 will ca. 0.3V Eingangssignal.

von Wolfram F. (mega-hz)


Lesenswert?

ich verstehe es auch nicht, habe damal erfolgreich nen 
Gebührenimpuls-Zähler damit gebaut, funzte super.
Das komische ist, wenn ich die Stromversorgung kurz, also 10sek., 
unterbreche, sind die LEDs (2, da ich die Schaltung doppelt aufgebaut 
habe) sofort an!
Das Eingangssignal ist absolut sauber.
Ist die Schaltung mehrere Std. aus gewesen, funktioniert sie kurz.

von Teo D. (teoderix)


Lesenswert?

Wolfram F. schrieb:
> Ist die Schaltung mehrere Std. aus gewesen, funktioniert sie kurz.

Den Aufbau schon x mal überprüft? OK, dann noch mal :)

von Wolfram F. (mega-hz)


Lesenswert?

ja, entweder übersehe ich immer wieder etwas oder.. k.A.

Zu dem Ausgangspin: da der ja nur open Kollektor ist, ist es klar, daß 
die LED mit der Kathode zum Ausgang und per Widerstand an +5V gehen 
muss.
Muss der Ausgang trotzdem noch zusätzlich nen Pullup bekommen?
Eigentlich nicht, oder?

von Christoph db1uq K. (christoph_kessler)


Lesenswert?

Der 567 ist ziemlich empfindlich, den muss man nicht mit TTL-Pegel 
anblasen. Laut Figure 5 im verlinkten Datenblatt beginnt es bei etwa 25 
mV_rms
Die 200 kHz ist schon nahe an der oberen Grenze bei 500 kHz. Die 
Datenblattbeispiele sind eher für Niederfrequenz.

von Teo (Gast)


Lesenswert?

Wolfram F. schrieb:
> Muss der Ausgang trotzdem noch zusätzlich nen Pullup bekommen?
> Eigentlich nicht, oder?

Warum, hängt doch NUR ne LED dran, die braucht doch keinen definierten 
Hi-Pegel!
Ich würd nochmals alle Kondensatoren prüfen (Elkos richtig rum 
drin....)

Wolfram F. schrieb:
> ja, entweder übersehe ich immer wieder etwas oder.. k.A.

Manchmal ist ein Abriss u. neu Aufbau schneller, als wenn immer die 
selben Augen suchen :)

von Christoph db1uq K. (christoph_kessler)


Lesenswert?

Das hier verlinkte Datenblatt von TI (früher NS) ist nicht sehr 
ausführlich.
Der ursprünglicher Hersteller Signetics/Philips/NXP hat die Produktion 
2004 beendet, aber das Datenblatt ist besser:
http://pdf1.alldatasheet.com/datasheet-pdf/view/17983/PHILIPS/NE567.html

von Joe F. (easylife)


Lesenswert?

Datenblätter haben wir ja jetzt genug. Wir wissen aber nicht viel über 
den konkreten Aufbau deiner Schaltung. Ausser dass sie klein ist.

von Wolfram F. (mega-hz)


Lesenswert?

shame on me :-(

Fehler gefunden, anstatt +5V war die VCC an +3.3V.. grrrrr :-)

Habe C1 nun erstmal auf 10+1nF und beim 2. 567 auf 10nF geändert, ergibt 
45.45Khz und 50Khz, funktioniert prima!

Sorry für die "Belästigung" am Sonntag!!!

Die Eingänge der beiden 567 sind mit je 100nF an 2 68nF/1600V 
Kondensatoren, die später an L+N gehen, verbunden. dazwischen sind noch 
2x 1n4148 antiparalell zur Spannungsbegrenzung.

von Wolfram F. (mega-hz)


Lesenswert?

@admin:

bitte als [ERLEDIGT] markieren!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.