Forum: Offtopic Digitalkamera - LCD defekt?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Alram L. (alram)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Leider ist unsere Digicam in Kinderhände gekommen und nun zeigt nun am 
LCD immer das Bild wie im Anhang gezeigt. Zusammengefasst:

- Etwa in der Mitte (genau genommen ist dieser leicht rechts) ist ein 
sehr heller, senkrechter Strich. Leuchtet immer weiss.
- Bild rechts von diesem Strich ist in schwarz/weiss.

ansonsten ist alles normal. Fotos werden ohne Fehler aufgenommen. 
Touchscreen funktioniert ebenfalls einwandfrei.

Zuerst hab ich sofort an ein defektes Display gedacht. Die Kamera 
geöffnet und das Display soweit ausgebaut. Man sieht aber keinerlei 
mechanische Beschädigung. Auch ein wenig drücken am Display und rütteln 
an den Kabeln ändert nichts. Das sollte einen Wackelkontakt daher auch 
ausschliessen.

Aufgrund des Fehlerbildes bin ich mir aber nicht mehr sicher, ob 
tatsächlich das Display defekt ist oder doch etwas anderes. Ein 
Ersatzdisplay gibts für 35,- auf AE.

Kann jemand auf grund dieser Beschreibung/Bildes einschätzen, was da 
defekt sein könnte? Wenn vieles für das Display spricht, würde ich 
einfach eines von AE ordern. Oder ist dieses eher gänzlich 
auszuschliessen?

Danke für eure Meinungen!

vG Alram

von Chris R. (hownottobeseen)


Bewertung
0 lesenswert
nicht lesenswert
Hi Alram,

die Hände deiner Kinder oder anderer Eltern?
Wenn es andere waren, auf zur Haftpflicht, die sollten zumindest die 
Kosten einer Reparatur halbwegs deckeln.

Ansonsten: Ich bin mir nicht 100 % sicher, kann mir aber schon 
vorstellen, dass das Display defekt ist. Es handelt sich übrigens nicht 
um ein LCD, sondern ein OLED, was vermutlich auch den bisschen höheren 
Preis erklärt.

Es könnte sein, dass der Controller einen Knacks hat, das würde die 
Hälfte s/w relativ gut erklären. Befindet der sich direkt am Display 
(Chip on Glass) oder auf der Flex: "Glück" gehabt. Wenn er auf dem Board 
vom Rest befindet, wirds schwieriger.

Was passiert, wenn du Druck auf den Controller ausübst? Wenn er auf dem 
Glas sitzt (viel hast du ja nicht zu verlieren), kannst du es selbiges 
auch etwas verwinden. Es kann dadurch besser, aber auch schlechter 
werden.

Ich nehme an, das Display verhält sich in allen Betriebsmodi gleich? Die 
Bildstörung ist immer konstant?!

Was macht die Kamera, wenn sie mit dem TV verbunden ist? Viele schalten 
das Display ab oder zeigen ein Dunkelbild.

Ich würde das noch prüfen und dann vielleicht in den sauren Apfel 
beißen.
Oder du findest bei eBay eine gleiche Kamera mit einem anderen Problem 
für weniger...

Just my 2ct.

HTH,

Chris

von Alram L. (alram)


Bewertung
0 lesenswert
nicht lesenswert
Hi Chris,

Danke für deine Antwort. War leider unsere kleine Prinzessin.

Am Kabel befindet sich leider nur der für den Touchscreen 
verantwortliche Chip. Am Display selber ist keiner mehr. Druck auf das 
Glas, Kabel oder Stecker bringt nichts - keine Veränderung.
Ich habe jetzt mal auf gut Glück das Display auf AE bestellt. Mal sehen, 
was es bringt.
HDMI kann ich leider nicht ausprobieren, das das mini (micro?) HDMI 
Kabel leider nicht mehr auffindbar ist.

vG Alram

von 1N 4. (1n4148)


Bewertung
0 lesenswert
nicht lesenswert
Du bist dir sicher, dass das kein Modus ist um eine Effekt-Vorschau zu 
erhalten?

von Alram L. (alram)


Bewertung
0 lesenswert
nicht lesenswert
1N 4. schrieb:
> Du bist dir sicher, dass das kein Modus ist um eine Effekt-Vorschau zu
> erhalten?

ziemlich sicher. das bild sieht immer so aus - auch wenn ich bereits 
aufgenommene fotos ansehe. die menüpunkte sind ausserdem auch in S/W.

von Alram L. (alram)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Zwischenzeitlich ist das Display von AE gekommen und ich hab es auch 
gleich angeschlossen. War ein Erfolg - Display funktionierte auf anhieb.

Beim Zusammenbau, ist mir allerdings ein anderes Mißgeschick passiert. 
Da wollte ich euch um Rat fragen, wie man das am besten lösen kann.

Um das Display einfacher ausbauen zu können, habe ich auch das Kabel zur 
Zoom-Optik entfernt. Beim Zusammenbau habe ich den Verriegelungshebel zu 
diesem Stecker leider etwas falsch/mit zu viel Kraft zusammengesteckt 
und der ist nun gebrochen. Siehe Foto anbei.

Effekt ist nun, dass die Kamera den Fehlercode E:60:10 anzeigt - was 
nach Google Recherche genau auf das Zoom hindeutet. Der Fehler erscheint 
NICHT wenn ich mit einem Finger den Verriegelungshebel manuell gegen die 
Platine presse. Somit ist es wohl eindeutig, dass hier ein Fehlkontakt 
aufgrund des gebrochenen Bügels vorliegt.

Mit der Lupe konnte ich so weit abklären, dass wirklich nur der Bügel 
selber defekt ist - der Stecker auf der Platine dürfte nicht beschädigt 
sein.

Jetzt stelle ich mir die Frage, wie das repariert werden kann? Ich 
dachte schon, ich suche einfach einmal den Stecker als einzelnen Bauteil 
und hol mir von diesem den Bügel. Aber ich hab eigentlich keine Ahnung, 
wie so ein Stecker überhaupt heissen kann.
Kann mir jemand helfen, so ein Bauteil zu finden? Oder Gibts andere 
Möglichkeiten?

Der notwendige Druck, damit der Kontakt wirklich gut sitzt, muss so 
gross/genau sein, dass es vermutlich nicht einfach damit getan ist, 
etwas in das Gehäuse zu legen.

Und da das Zeug recht filigran ist, habe ich nicht vor viel 
auszuprobieren. Das machts es wohl nur schlimmer ..

danke vorab!

vG Alram

von Rufus Τ. F. (rufus) (Moderator) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Alram L. schrieb:
> Aber ich hab eigentlich keine Ahnung, wie so ein Stecker überhaupt
> heissen kann.

Ein Stichwort ist "FFC" für "flat foil connector". Eventuell kombiniert 
mit "locking" für verriegelbar.

Parameter sind neben dem Hersteller das Rastermaß und natürlich die 
Kontaktanzahl.

Hersteller solcher Teile sind HRS (Hirose), Molex, JST ...

Viel Glück beim Suchen.

von Hardy F. (hardyf)


Bewertung
0 lesenswert
nicht lesenswert
Alram L. schrieb:
> Somit ist es wohl eindeutig, dass hier ein Fehlkontakt
> aufgrund des gebrochenen Bügels vorliegt.



Alram L. schrieb:
> Jetzt stelle ich mir die Frage, wie das repariert werden kann?

Mit einem Tropfen Epoxidharz ?

Oder Chinamäßig mit Heißkleber ?

Hab ich alles schon paarmal  so gemacht.

Festhalten bei Aushärten in der Lage wo du vorher sicheren Kontakt 
hattest.

von Frank D. (Firma: Spezialeinheit) (feuerstein7)


Bewertung
1 lesenswert
nicht lesenswert
Ich hatte dabei schon mal erfolg mit einem dünnen Papierstreifen, den 
habe ich zusammen mit dem Folienleiter in den Stecker gepresst.

von Alram L. (alram)


Bewertung
0 lesenswert
nicht lesenswert
Fred F. schrieb:
> Ich hatte dabei schon mal erfolg mit einem dünnen Papierstreifen

Danke für den Tipp. Hab das soeben mit einem Streifen aus 
Antistatic-Beuteln probierung und scheint bestens zu funktionieren ... 
manchmal kann die Lösung auch so einfach sein.

vG Alram

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.