Forum: Analoge Elektronik und Schaltungstechnik Supercap mit Solarzelle laden / ab Schwelle einschalten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Hi

ich bastle an einer Schaltung, die Solarenergie von einer Solarzelle 
sammeln soll und in einem Supercap speichern soll. Ab einer gewissen 
Schwelle sollte dann eine Mikrocontrollerschaltung versorgt werden und 
erst ab Absinken unter eine andere Schwelle soll der Mikrocontroller 
wieder abgetrennt werden.

Zur Zeit habe ich einen 74HC14, wo zwei Inverter in Reihe über einen 
Zener-Resistor Teiler versorgt werden. Klappt im Prinzip, der Ausgang 
geht HI sobald die Spannung am Goldcap ca. 4.2V überschreitet und geht 
wieder auf LO, sobald die Spannung unter 2V sinkt. Der Teiler ist 
2.7V+600kOhm. Die Schwellen lassen sich sicherlich mit den Werten 
(eventuell noch + Schottkydiode) tunen.

Das Problem was ich habe: die Schaltung braucht bis ca. 2mA Ruhestrom, 
d.h. solange der Ausgang des zweiten Inverters LO bleibt (HI zieht einen 
FET an und mein uC geht dann an...). Das heißt "so bisschen 
Energiesammeln" ist nicht, sobald die Solarzelle weniger als 2mA 
liefert, geht der uC nie an.

Liegt es an dem verwendeten 74HC? Scheint mir etwas viel für einen 74HC? 
Nur die beiden Inverter sind beschaltet, der Rest "hängt in der Luft" 
(noch).

Ich bräuchte etwas mit Ruheverbrauch in der Größenordnung um wenige µA - 
läßt sich das realisieren? Und wenn ja wie? Andere Schaltung? 
Dedizierter IC?

viele Grüße

von excurso (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wie so oft kann man auch hier einen 555-Timer verwenden. Der hat zwei 
Komparatoren und einen Schmitt-Trigger. Für deinen Fall ist ein CMOS-555 
interessant, da er einen Eigenverbrauch von wenigen Mikroampere hat.

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
Auch wenn ich sicher nicht das gleiche mache, habe ich hier mehrere 
Aufbauten, bei denen Goldcaps solar geladen werden, mit einem Atmel 
Mikrocontroller, der davon versorgt wird, und wenn genug 'Saft' da ist, 
ein paar LEDs ansteuert.

Die Versorgung habe ich aber anders gemacht. Der Mikrocontroller hängt 
immer an dem Goldcap, und ist die meiste Zeit im Sleep-Mode. In diesem 
Zustand ist der Taktteiler auf 8 gestellt, auch die CLKDIV8 Fuse ist 
programmiert. Bei dieser geringen Taktfrequenz reicht die Power-On-Reset 
Schwelle als Brown-Out Erkennung so daß auch die Bandgap-Referenz im 
Controller ausgeschaltet sein kann, so braucht der Controller nur ein 
paar uA. Zyklisch wacht der Controller (timergesteuert) auf, schaltet 
den Mess-Spannungsteiler an die Versorgung, misst mit dem internen ADC 
die Spannung, und entscheidet danach was zu tun ist. Ist die Spannung 
hoch genug, wird die Taktfrequenz hochgesetzt, und das Lichtspiel kann 
beginnen. Ist die Spannung nicht hoch genug, wird halt weiter 
geschlafen. Meine Strategie bei solchen Sachen ist, die Zahl der 
Komponenten klein zu halten, und so viele Strompfade wie möglich 
abzuschalten. Mit dem immer laufenden Timer im Controller habe ich 
gleich noch eine Uhr dabei, ohne dafür einen zusätzlichen Baustein zu 
brauchen.

Mit freundlichen Grüßen - Martin

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Hi

an den CMOS 555 habe ich auch schon gedacht, war aber nicht in meiner 
Bastelkiste drin.

Erklärt aber trotzdem nicht den hohen Verbrauch bei 74HC14... sind die 
gemessenen bis zu 2mA "normal"?

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
Noch ein Nachtrag:

Offene Eingänge an CMOS-Schaltkreisen sollte man vermeiden, dümpelt der 
(sehr hochohnige) Eingang bei VCC/2 rum, leiten beide Transistoren des 
CMOS-Päärchens, da können die 2 mA durchaus herkommen. Ein zweites 
Problem könnte sein, daß der 74HC14 geringfügig mehr Strom aufnimmt, 
wenn die Spannung am Eingang in der Nähe der Schaltschwelle ist, was bei 
Dir vermutlich oft so ist.

Mit freundlichen Grüßen - Martin

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Martin S. schrieb:

> Zyklisch wacht der Controller (timergesteuert) auf, schaltet
> den Mess-Spannungsteiler an die Versorgung, misst mit dem internen ADC
> die Spannung, und entscheidet danach was zu tun ist.

Hi,

das ist auch eine brauchbare Lösung, bin mir aber nicht sicher ob das 
bei mir klappt.

Eigentlich wollte ich einen ESP8266 versorgen, der ein paar Pakete über 
WLAN schicken soll, sobald genug Saft da ist (ich weiß noch nicht wie 
ich es dimensionieren soll, aber ich werde es ausprobieren. Das Teil 
kann bis zu 200mA brauchen). Ich kenne mich leider (noch) nicht mit den 
Eigenschaften von ESP8266 bezüglich low-power & brownout aus (ich habe 
mir die Sachen nur bei Atmel & Arduino mal angesehen). Dachte halt bevor 
ich die dicken Datenblätter von etwas, was ich nur einmal brauche 
studiere, müßten es auch ein paar CMOS Komponenten tun.

Ist deine Schaltung stabil? Hat die Hardware-basierte Brownout detection 
genug Hysterese, damit es nicht "schwingt"?

Vorteil "meiner" Lösung (wenn sie funktioniert) wäre weniger 
Programmieraufwand (ich kann's natürlich auch schreiben :). Das Programm 
wäre sozusagen "dumm", geht an, wickelt seine Aufgabe ab und Ende.

von Sebastian S. (amateur)


Bewertung
0 lesenswert
nicht lesenswert
Ein Winz-Atmel (8-Füssig).
Hat ein paar A/D-Wandler, die lauschen können.
Hat genügend Anschlüsse über um 'nen FET zu schalten.

Je nach Logik kann der auch im Ein- oder im Aus-Modus ein Nickerchen 
einlegen.

Soll das in Beiden "Richtungen" gehen, brauchst Du 'nen externen 
"Speicher".

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
Also die Stabilität ist kein Problem, die Power-On-Reset Schwelle hat 
ausreichend Hysterese, dieser Mechanismus tritt aber nur in Kraft, wenn 
gar nicht geladen wird, im Normalbetrieb liegt die Spannung immer 
deutlich darüber, und die durch ADC-Messung und Software gebildete 
Schwelle kommt zum tragen. Einer der Aufbauten läuft nun schn ca. 9 
Monate, ohne in den Reset gefallen zu sein. (Habe einen Zähler 
eingebaut, da kann man nachsehen, wie lange er schon läuft.)

Man könnte soetwas natürlich als gesonderten Schaltungsteil machen, mit 
einem kleinen ATtiny (8-Beiner). Dann ist aber der NE555 billiger, und 
muß nicht pogrammiert werden. Bei den Tinys muß man aber aufpassen, 
manche haben zwar einen ADC, aber keine interne Referenzspannungsquelle, 
AREF ist da dann üblicherweise VCC. Da kann man aber tricksen, statt 
einem Spannungsteiler kommt dann eine Kombination von Widerstand und 
Diode an den ADC-Eingang. Statt einer Diode kann man auch eine 
Leuchtdiode nehmen, die blitzt dann noch kurz auf, wenn gemessen wird. 
Bei kleinen Spannungen sind Leuchtdioden sogar oft besser, von der 
stabilisierenden Wirkung her, als entsprechende Z-Dioden.

Mir freundlichen Grüßen - Martin

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Ich sehe gerade der ESP8266 hat sogar einen ADC... also im Prinzip wäre 
die Lösung von Martin machbar. Allerdings müßte ich dann die nackten 
ESP8266 Module irgendwoher besorgen, zur Zeit habe ich nur das Breakout 
von Adafruit, da ist ja Linearregler drauf, also so wird das nix! Der 
müßte an eine An/Aus Schaltung.

Einen zweiten uC (Winz-Atmel) für diesen Zweck will ich nicht verwenden, 
dann lieber etwas diskrete Technik davor - wenn möglich!

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Vollständigkeitshalber habe ich noch die 4 verbliebenen Invertereingänge 
auf Masse gelegt - keine sichtbare Änderung bei Stromverbrauch.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Nochmal das ganze Ding gemessen mit den 4 Invertern auf Masse: der 
Zenerteiler hat max 5µA und der 75HC14 Chip "frisst" bis zu 2mA :/ Wobei 
der Strom linear mit der Spannung ansteigt.... IC irgendwie defekt?

Wenn ich den Chip komplett rausnehme, dann fällt der Verbrauch auf die 
gesagten wenigen µA...

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
excurso schrieb:
> Wie so oft kann man auch hier einen 555-Timer verwenden. Der hat zwei
> Komparatoren und einen Schmitt-Trigger. Für deinen Fall ist ein CMOS-555
> interessant, da er einen Eigenverbrauch von wenigen Mikroampere hat.

Kann leider nichts finden über so einen kleinen standby-Verbrauch...? 
Das Datenblatt von CMOS 555 sagt sogar "bis zu 250uA bei 5V"... Ich 
nehme an Du hast es nicht gemessen bei C555 als Schmitt-Trigger? Ob das 
keine Überraschung gibt? (bei 74HC dachte ich auch es seien nur wenige 
µA...)

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> IC irgendwie defekt?

Wir wissen ja trotz einem halben Dutzend Beiträgen nicht mal welcher 
Schaltplan.

Und wieso 4.2V bei einem GoldCap (der hat entweder 2.5 bis 2.7 oder 5 
bis 5.5V Maximum), dein Goldcap scheint eher ein LiIon zu sein und der 
will EXAKTE 4.2V, nicht irgendwelche 4.2V.

Falls man einen IC sucht der ab 4.2V einschalten kann und bei 2V wieder 
ausschaltet bietet sich ein ICL7665 an, der braucht 3uA.

Deine Schaltung, die mit HIGH einen MOSFET einschaltet kann eigentlich 
nur so sein (was aber meiner Meinung nach nicht funktioniert, nicht nur 
weil der MOSFET bei 2V nicht mehr durchschaltet):
1
 +----+--------+---------+
2
 |    |        |         |
3
 |    |        |   uC-Schaltumg
4
Gold  |        |         |
5
*Cap MAX6018--|>o--|>o--|I
6
 |    | 1.2    |'14      |S
7
 |    |        |         |
8
 |    |        |         |
9
 +----+--------+---------+
Wenn in der Schaltung der "abgeschaltete" uC noch irgendeine Verbindung 
zur Restelektronik hat,

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
"...könnten die Milliampere aus drm uC stammen." wollte ich den Satz 
firtsetzen.


Piter K. schrieb:
>> da er einen Eigenverbrauch von wenigen Mikroampere hat.
>
> Kann leider nichts finden über so einen kleinen standby-Verbrauch...

Natürlich nicht, der 555 enthält einen internen Spannungsteiler aus 3 x 
R und kann daher nicht wenig Strom verbrauchen.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> Piter K. schrieb:
>> IC irgendwie defekt?
>
> Wir wissen ja trotz einem halben Dutzend Beiträgen nicht mal welcher
> Schaltplan.
>
> Und wieso 4.2V bei einem GoldCap (der hat entweder 2.5 bis 2.7 oder 5
> bis 5.5V Maximum), dein Goldcap scheint eher ein LiIon zu sein und der
> will EXAKTE 4.2V, nicht irgendwelche 4.2V.
>

Ich dachte die Beschreibung wäre trivial, trotzdem hier ein Versuch 
eines Schaltplans:

+ ------------------------ +
|   |  |       |         L
|   |  Z       |         |
S   =  |---|74HC14|------T
|   |  |       |     |   |
|   |  R1      |     R2  |
|   |  |       |     |   |
 ------------------------- -

S : Solarzelle
= : Cap
Z : derzeit eine 2.7V Zener + Schaltdiode
R1: 500k
R2: 1.6M
T : 2n3904 (später gegebenfalls durch geeigneten FET zu ersetzen)
L : Last (LED+R derzeit)

74HC14 : zwei Inverter in Reihe

Die 2V/4.2V Spannungswerte ergaben sich aus den Eigenschaften der 
Komponenten :) Es ist nur ein "Test" und keine endgültige Schaltung.

Wie gesagt, was mir hier den Strom "frisst" ist der 74er... abgesehen 
davon funktioniert die Schaltung in etwa wie erwartet.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> Natürlich nicht, der 555 enthält einen internen Spannungsteiler aus 3 x
> R und kann daher nicht wenig Strom verbrauchen.

auch der CMOS 555?

von Hp M. (nachtmix)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> T : 2n3904 (später gegebenfalls durch geeigneten FET zu ersetzen)

Da hast du doch schon deinen Stromverbraucher. *)

P.S.: Was soll der R2 bewirken?
Weg damit!


*) P.P.S.:
Wenn du den MOSFET noch nicht hast, kannst du auch mal 20..50 kOhm 
zwischen Basis und Ausgang des HC14 legen.
Das senkt den Basisstrom dramatisch.

: Bearbeitet durch User
von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Hp M. schrieb:
> Piter K. schrieb:
>> T : 2n3904 (später gegebenfalls durch geeigneten FET zu ersetzen)
>
> Da hast du doch schon deinen Stromverbraucher.

Ne, der ist nicht leitend solange der Ausgang vom 74HC low ist - 
nachgemessen. Der 74HC "frisst" mir diese bis zu 2mA (wenn ich das 
Multimeter in die Zuleitung von 74HC auf dem Protoboard hänge dann sehe 
ich das). Stromverbrauch bis zu 2mA auch komplett ohne T am Ausgang! 
(keine Last gar nichts).

> P.S.: Was soll der R2 bewirken?
> Weg damit!

Falls T ein FET ist, je nach Vortreiber, könnte es notwendig sein - aber 
im obigen Beispiel hast Du recht. Kann aber auch auf keinen Fall für die 
2mA verantwortlich sein, R2 weg, Schaltung benimmt sich genau gleich.

Irgendwie habe ich den Eindruck ich habe irgendwelchen "faulen" 74HC... 
da steht nicht mal der Hersteller drauf.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Für den ES8266 brauche ich ziemlich genau 3.3V (Arbeitsbereich 3.0-3.6V, 
anders als ATtiny etc...), d.h. es ist keine gute Idee den direkt an den 
Goldcap zu hängen. So oder so braucht es einen Regler davor, also bleibt 
nur die Möglichkeit entweder mit diskreter Vorschaltung an/aus (an, wenn 
genug Energie drin, damit das Programm ablaufen kann) oder eben mit 
einem ATTiny an/aus der direkt an Goldcap hängt, wie Martin meinte...

Edit: der 3.3V Regler auf dem ESP8266 breakout Board ist entweder ein 
SPX3819 (EXAR) oder ein AP2112K-3.3 (BCD) - kann ich nicht erkennen, auf 
dem Teil kann man nur L349 ablesen (wahrscheinlich ein Nachfolger von 
SPX3819, der mit L319 beschriftet sein soll laut google). Insgesamt 
beide low dropout Regler (340mV vs 250mV), also recht gute Geschichte.

[Zum Verständnis: den ESP8266 gibt es als Breakout mit Regler für 3.5-6V 
Vin, oder als "nacktes" Platinchen ohne Regler - akzeptiert dann aber 
nur 3.0-3.6V].

: Bearbeitet durch User
von W.A. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> Nur die beiden Inverter sind beschaltet, der Rest "hängt in der Luft"
> (noch).

Dann solltest du das erstmal ändern. CMOS Eingänge in der Luft können zu 
lustigen Aktivitäten führen, wenn sich der Eingang aus eben dieser Luft 
irgendetwas einfängt, was ihn zu lustigem Schwingen animiert.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
W.A. schrieb:
> Piter K. schrieb:
>> Nur die beiden Inverter sind beschaltet, der Rest "hängt in der Luft"
>> (noch).
>
> Dann solltest du das erstmal ändern. CMOS Eingänge in der Luft können zu
> lustigen Aktivitäten führen, wenn sich der Eingang aus eben dieser Luft
> irgendetwas einfängt, was ihn zu lustigem Schwingen animiert.

s.o. : später an Masse geklemmt => keine Veränderung.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Mir ist noch folgendes zu meinem speziellen ESP8266 (Board mit Regler) 
eingefallen. Was wäre, wenn ich nun folgende Schaltung nehme:

        Vin
+ --+---+----------° V+
|   |   |------
|   |   |8266BB|
S   =   | Vo   |
|   |    ------|Masse
|   |     |  --|
|   |     Rb | D
|   |     +--T |
|   |     |  | D
|   |     Rx | |
+---+-----+--+-+----° V-

S : SOlarzelle
= : Goldcap
8266BB : ESP8266 Breakout board mit LDO linearregler
Rb: basis drive (1-10k)
Rx: 100k
D : Shottky/Signaldioden
Vin: Eingang des Boards zum Regulator
Vo: regulierter Ausgang mit 3.3V

Die Idee dahinter: Der LDO Regler hat eine steile switch-on 
Charakteristik bei ca. 3.3V. Er liegt aber über D+D auf über 1.4V über 
Masse, so daß er erst ab ca. 3.3+1.4=4.7V einschalten sollte. Dann geht 
der Vo am regulator von hochomig auf 3.3V damit wird T in die Sättigung 
getrieben und "überbruckt" die beiden Dioden D (bis auf ca. 0.2V dropout 
bei Sättigung). Damit stelle ich die notwendige Hysterese her...

Irgendwo Denkfehler?

----
Zur Vorständigkeitshalber hier das Breakout:

https://cdn-learn.adafruit.com/assets/assets/000/024/745/large1024/adafruit_products_schem.png?1429900999

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Dein 74HC14 scheint faul zu sein. Ruhestrom im statischen Betrieb sollte 
etwa bei 2µA liegen lt. dem NXP Datenblatt. Das schafft auch kein 7555 
(CMOS 555).

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> Mir ist noch folgendes zu meinem speziellen ESP8266 (Board mit Regler)
> eingefallen. Was wäre, wenn ich nun folgende Schaltung nehme:
>

klappt nicht... der Vout pin des Breakouts führt bereits Spannungen, 
bevor der Regler "ordenlich" hochgefahren ist... klappt nicht. Das Teil 
geht in einen Zwischenzustand über, wo ein paar mA in das Board fliessen 
aber nichts richtig angeht.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Also nochmal eine kleine info zu dem 74HC: ist wohl das floaten des 
ersten Eingangs die Ursache... Wenn ich direkt den Strom am pin #14 
messe, dann steigt er an bis etwa 1.5ma und wenn das ganze auf ON 
durschaltet, geht der Verbrauch auf #14 auf ca 200µA runter (IMO immer 
noch zu viel für einen simplen 74HC im statischen Zustand, die 
restlichen 4 Invertereingänge waren "genullt", Ausgänge frei).

Ich hätte für den Standby bei 74HC auf ON eher um 10µA erwartet, kann 
mich aber irren...

Kommentare?

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
PS: für die Schaltung mit dem HC74 aus Beitrag (2016-11-01 00:22) 
bräuchte ich für die Dioden etwas mit möglichst extrem starken Anstieg 
an der Schwelle und möglichst wenig Leckstrom darunter. Hat jemand einen 
Vorschlag, welche Typen ich noch probieren könnte?

von Hp M. (nachtmix)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> Irgendwie habe ich den Eindruck ich habe irgendwelchen "faulen" 74HC...
> da steht nicht mal der Hersteller drauf.

Ja dann...
Ist es wohl gar kein 74HC14, vielleicht nicht einmal ein 
Schmitt-Trigger, sondern etwas bipolares wie der 74ALS04.
Ob es sich um eine CMOS oder um eine bipolare Schatung handelt, kannst 
du leicht feststellen:
Bei den bipolaren 74ern kommt aus den Eingängen ein Strom heraus , den 
du leicht messen kannst, wenn du den Eingang über ein mA-Meter an GND 
legst.
Je nach Technologie (LS, ALS, S, ...) sind das ca. 0,2..2mA.

Bei CMOS-Eingängen hingegen fliesst ein nennenswerter Strom weder hinein 
noch hinaus. Mit einem sehr empfindlichen Meßgerät kann man vielleicht 
den Leckstrom der Schutzdioden nachweisen, aber der liegt normaler Weise 
unter 1µA.

Möglicher Weise ist es auch ein völlig anderer CMOS-Typ mit anderem 
Pinout und der hohe Strom fliesst, weil du zwei gegensätzliche Ausgänge 
miteinander verbunden hast, da wo du glaubst die beiden Inverter 
hintereinander geschaltet zu haben.
Unterbrich probeweise mal diese Verbindung.

P.S.:

Piter K. schrieb:
> PS: für die Schaltung mit dem HC74 aus Beitrag (2016-11-01 00:22)
> bräuchte ich für die Dioden etwas mit möglichst extrem starken Anstieg
> an der Schwelle und möglichst wenig Leckstrom darunter. Hat jemand einen
> Vorschlag, welche Typen ich noch probieren könnte?

Es gibt spezielle Shunt-Regler, wie den TL431, die eine sehr stabile 
Spannungreferenz ergeben, aber vielleicht probierst du es anstelle von 
Si-Dioden auch mal mit LEDs in Flußrichtung. Die Spannung hängt i.W. von 
der Farbe ab.
Bei den Zenerdioden für kleine Spannungen wie deinem 2,7V Typ handelt es 
sich meist auch nur um einen  Stapel gewöhnlicher Si-Dioden, die in 
Flußrichtung betrieben werden.

: Bearbeitet durch User
von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Hp M. schrieb:

> Ist es wohl gar kein 74HC14, vielleicht nicht einmal ein
> Schmitt-Trigger, sondern etwas bipolares wie der 74ALS04.
> Ob es sich um eine CMOS oder um eine bipolare Schatung handelt, kannst
> du leicht feststellen:
> Bei den bipolaren 74ern kommt aus den Eingängen ein Strom heraus , den
> du leicht messen kannst, wenn du den Eingang über ein mA-Meter an GND
> legst.

Den angenommenen Invertereingang auf Masse (über Messgerät 2000µa 
Bereich) : Messwert 0000-0001

Den angenommenen Invertereingang auf Vcc (über Messgerät 2000µa Bereich) 
: Messwert 0000-0001

=> ich kann also folgern CMOS richtig?

Mit kein Hersteller drauf meinte ich nicht, daß gar nichts drauf 
steht... nur 74HC14, sonst aber kein Logo, gar nichts.

Das Teil ist definitiv ein Hex-Schmitt-Trigger.

Der Chip (es ist der Chip selbst, nicht der Invertereingang, der 
floatet) scheint nur verdächtig große Stromwerte (bis zu 2mA) zu ziehen, 
wenn einer der Eingänge im "verbotenen" Bereich floatet (zwischen LO_max 
und HI_low). Umgeschaltet wird dann aber nicht (nicht instabil). Wenn 
der Eingang im "erlaubten" Bereich liegt, geht die Aufnahme deutlich 
zurück (ca 200µA).

Ist das normal bei 74HC oder ist der faul?

von excurso (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Teste den Chip doch mal mit einer konstanten Spannung z.B. 5V als 
Betriebsspannung sowie Schaltspannung. Ohne und mit Reihenschaltung der 
Trigger...

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> Wenn
> der Eingang im "erlaubten" Bereich liegt, geht die Aufnahme deutlich
> zurück (ca 200µA).

Hast du meinem Beitrag gelesen? NXP spricht von 2µA Ruhestrom im 
statischen Zustand. Deine 74HC14 sind also vermutlich Ausschuss.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
excurso schrieb:
> Teste den Chip doch mal mit einer konstanten Spannung z.B. 5V als
> Betriebsspannung sowie Schaltspannung. Ohne und mit Reihenschaltung der
> Trigger...

Wenn alle 6 Eingänge auf Masse ODER +5V liegen fließt am pin #14 kein 
meßbarer Strom.

Wie ich schon sagte, der Stromverbrauch  schnellt in die Höhe, sobald 
ein Eingang im "Verbotenen" Bereich floatet (also zwischen LO_max und 
HI_min) - (Stromverbrauch gemessen am #14, NICHT am Invertereingang, am 
Eingang fließt trotz floaten KEIN meßbarer Strom).

Alle 74-Typen haben LO_min/LO_max und HI_min/HI_max, dazwischen ist der 
Logiklevel streng genommen undefiniert. War mir allerdings nicht bewußt, 
daß der Chip dann dermaßen zum Stromfresser wird - kann das jemand 
bestätigen?

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Hm

die Schaltung wäre noch mit einem CMOS-OPamp zu versuchen (mir 
suggeriert wurden MCP6041, MAX951 oder LTC1440), ob man damit die 
floating-Probleme lösen kann weiß ich noch nicht.
Zuerst werde ich noch einen "Marken 74HC" nehmen, wenn ich einen kriege 
(auch als 74AC...). Mal sehen.

viele Grüße.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
https://s13.postimg.org/9k5zad85z/74ahc.png

hier noch vollständigkeitshalber die Charakteristik von 74AHC... scheint 
also doch normal zu sein, daß im Zwischenbereich am Eingang so viel 
Strom gezogen wird :(

Also werde ich es nun mit einem OPamp versuchen...

viele Grüße

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Hi

also zumindest laut LTSpice würde eine ähnliche Schaltung funktionieren:

https://s14.postimg.org/qkw1j60m9/solmos.png

R5 ist nur zur Messung da, R7 wäre die Last (ESP8266), ist hier als 1M 
eingetragen wegen Darstellung (Skala). Die Mosfet wären noch anzupassen 
(gegen erhältliche Typen), LTC6085 wäre in der Praxis ein 1.7V 1µA Typ 
(etwas aus der Liste oben).

Wäre diese Schaltung in der Praxis stabil?

Es geht nur darum ab einer Schwelle stabil einzuschalten und 
eingeschaltet halten (die untere OFF Schwelle ist in der Praxis egal, da 
entweder die Energie reicht, um das Programm abzuspulen und der µC 
schaltet sich selber aus, oder sie reicht eben nicht, dann bringt mir 
eine Schmitt-Schwelle auch nichts).

Ich vermute daß sich der Stromverbrauch in dem "linearen" Bereich (bis 
zur ON schwelle) auf 10µA oder weniger begrenzen läßt durch die Auswahl 
entsprechender Komponenten. Es wäre für mich jedenfalls ein Fortschritt 
im Vergleich zu den bis zu 1.5mA eines 74HC14....

Any comments?
thx

von Martin S. (led_martin)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mir ist da noch was eingefallen. Hier steht ein, von mit gebauter, LED 
Blitzer, schon seit Jahrzehnten in Betrieb, angetrieben von einem, aus 
Solarzellenbruch zusammengebrutzelten, Solarmodul (ca. 20 mA bei voller 
Sonne und Ausrichtung auf die Sonne, momentan liegt es in der Nähe das 
Fensters flach auf dem Regal), Energiespeicher sind 3 Elkos, ein, aus 
Transistoren aufgebauter, Schmitt Trigger steuert die LED. Auch bei 
trübem Wetter blitzt das so vor sich hin, dann halt nur ein Blitz pro 90 
Sekunden. Das ist eigentlich fast was Du suchst, nur viel kleiner. 
Schaltplan müsste ich suchen, das Ding ist enstanden, lange bevor ich 
einen Computer hatte, da ging das noch mit Papier und Bleistift. Für die 
Platine wurden die Leiterzüge, vor dem Ätzen, mit Asphaltlack aufs 
Basismaterial gepinselt. An das, recht simple, Funktionsprinzip kann ich 
mich aber noch gut erinnern. Auf dieser Basis habe ich mal was 
gezeichnet, angepasst an deine 200 mA, Dimensionierung ist eher Pi x 
Daumen, und nicht getestet. R4 muß klein genug sein, um Q3 den nötigen 
Basisstrom zu liefern. Bei R5 muß man etwas probieren, ist er zu hoch, 
fließt immer ein kleiner Strom durch Q3, ist er zu niedrig, kippt die 
Schaltung erst, wenn schon ein nennenswerter Strom durch Q2 und R4 
fließt. Bei kleinen Ladeströmen könnte die Schaltung dann in diesem 
Zustand 'hängenbleiben'. Auch bei dieser Schaltung steigt die 
Stromaufnahme in der Nähe der Schaltschwelle an, sollte aber deutlich 
besser sein als der 74HC14. Bei den anderen Widerständen ist durchaus 
noch Spielraum nach oben, aber das Ganze wird halt empfindlich, was 
Einkopplungen anbelangt. (Hand in der Nähe kann da schon Fehlfunktionen 
verursachen.) Ein Problem könnte der Eingangselko des ESP8266-Moduls 
sein.

Übrigens: Bei kleinen Spannungen sind LEDs, von der stabilisierenden 
Wirkung her, meist besser als Z-Dioden für die gleiche Spannung.

Mit freundlichen Grüßen - Martin

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
@Martin: jetzt das ganze noch mit MOSFETs :)

von Hp M. (nachtmix)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> Wenn
> der Eingang im "erlaubten" Bereich liegt, geht die Aufnahme deutlich
> zurück (ca 200µA).
>
> Ist das normal bei 74HC oder ist der faul?

Faul!
Der maximale Strom hängt zwar von der Betriebsspannung ab, aber 2mA sind 
definitiv zuviel und 200µA wahrscheinlich auch.

Die entsprechenden Diagramme für Betriebsspannungen von 2V, 4,5V und 6V 
findest du in diesem Dokument auf Seite 9:
http://cache.nxp.com/documents/data_sheet/74HC_HCT14.pdf

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
@Martin

ich habe das mal spaßeshalber in Spice eingegeben:

https://s18.postimg.org/efom9mf09/solmos2.png

Der Schwachpunkt ist der Strom durch R4, wenn die Schaltung an ist, aber 
sonst sieht es relativ gut aus, danke!

Ich habe Q3 versuchsweise durch MOSFET ersetzt, funktioniert (je nach 
Mosfet eben). Der Ursprung des Spikes an der Schaltschwelle ist mir 
nicht ganz klar: Umladestrom des Gates? Artefakt von Spice (Umschalten 
so schnell daß der Strom rechnerisch beliebig hoch wird?)?

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
Schönes Simulationsergebnis! Bei dem Spike hast Du vermutlich Recht, der 
MOSFET wird ja auch zügig eingeschaltet, Q2 wirkt da als Gate-Treiber. 
Beim Ausschalten gehts ja wesendlich ruhiger zu.

Ja, das wäre auch mein Gedanke gewesen, Q3 durch einen P-MOSFET zu 
ersetzen, sollte halt ein Typ sein, der für 2,5V UGS (genaugenommen 
-2,5V da P-Kanal) spezifiziert ist, Solche habe ich bei Reichelt schon 
mal gekauft. R7 (In deiner Simulation) könnte man vermutlich weglassen. 
Q2 brauchst Du wohl auch nicht, in der Ursprungsschaltung war er nötig, 
um genügend Basisstrom für Q3 zu haben. Q1 würde ich als 
Bipolartransistor belassen, einerseits ist die BE-Schwellspannung quasi 
die Referenz für die Schaltschwelle, und MOSFETs haben bei der 
Gate-Schwellspannung eine recht große Exemplarstreuung. Andererseits 
sollte ein kleiner Spannungshub an diesem Punkt schon für einen großen 
Spannungshub am Ausgang sorgen, für ein gutes Kipp-Verhalten. Man sollte 
darauf hin optimieren, das der Einschalt-Kipppunkt möglichst weit 
'vorne' liegt, damit der Aufbau nicht im Stromanstieg vorm Kippen 
'hängenbleibt'. Das Verhältnis von R4 zu R5+R6 (In deiner Simulation) 
könnte man auch noch optimieren, sprich R4 größer machen, das 
'Hyterese-Poti' ist ja schon weit aufgedreht. Bei der LED könnte man 
wohl eine mit höherer Flußspannung wählen, dann lässt sich die 
Schaltschwelle vielleicht besser einstellen.

Mit freundlichem Gruß - Martin

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> auch der CMOS 555?

Ja, auch der, und ziemlich niederohmig.

von MaWin (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hp M. schrieb:
> Es gibt spezielle Shunt-Regler, wie den TL431, die eine sehr stabile
> Spannungreferenz ergeben,

Klar, wenn man täglich Batterien nachlegt, der will mindestens 100uA 
sehen, eher 1mA.

Auch TLV431 bringt nicht wirklich Linderung wenn es Spannungsreferenzen 
gibt die mit unter 1uA auskommen.

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
@Martin: also ohne Q2 will das Ding nicht so richtig...

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
Piter K. schrieb:
> also ohne Q2 will das Ding nicht so richtig...

MOSFET mit recht hoher Gate-Kapazität? Für die 200 mA Ausgangsstrom 
braucht man keinen 50A-Prügel, versuche mal z.B. den IRLML6302, oder den 
IRLML2246. Sind kleine P-MOSFETs im SOT-23 Gehäuse.

Mit freundlichem Gruß - Martin

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Martin S. schrieb:
> IRLML2246. Sind kleine P-MOSFETs im SOT-23 Gehäuse.

Ja im SOT23 finde ich jede Menge, ist aber schlecht von Hand zu löten, 
bräuchte etwas mit TO92 oder HVMDIP (oder ähnlich), gibt's leider nicht 
so viel Auswahl. Ich wollte die Schaltung eigentlich auf Lochraster 
zusammenschustern (keine geätzte Platine).

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
SOT-23 lässt sich recht gut auf Lochraster verbauen, habe schon deutlich 
über 100 Stück verbaut, die passen gut auf 3 benachbarte Lötaugen, sogar 
so, daß noch Drähte in die Bohrungen dieser Lötaugen passen. Habe mich 
damit angefreundet, als ich gemerkt habe, daß es TO-92 (Bei 
Bastler-Shops) nur wenig gibt, und dann nur so 25 mA MOSFETs, und alles 
Größere halt solche zig A Brummer sind. Vielleicht geht ja auch SO-8, 
bei Denen sind alle 4 Anschlüsse, auf einer Seite Drain, auf der anderen 
Seite ist, in der Ecke, ein Pin Gate, und die restlichen 3 sind Source. 
Die können auch gut auf Lochraster gelötet werden, man muß halt nur 
darauf achten, daß das Gate seine eigene Lötinsel hat.

Mit freundlichem Gruß - Martin

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
@Martin: ich würde die Schaltung gerne "spiegeln", also Q1 PNP, Q2 NPN, 
Q3 n-mosfet... dann hätte ich wesentlich bessere Auswahl für Q3!

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
Das sollte problemlos gehen, nicht vergessen die LED umzudrehen. Du 
trennst dann halt die Masse, ist aber kein Problem, wenn die Masse mit 
nichts Anderem verbunden ist.

Mit freundlichem Gruß - Martin

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Wenn ich alle Polaritäten umdrehe (V1, D1, Q1-Q3) dann müßte die 
Schaltung doch genauso funktionieren? Oder muss ich auch noch die 
Spannungsteiler "drehen"? Bin gerade nicht ganz sicher...

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
also so richtig will es nicht klappen mit dem "umdrehen"

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
Dann hast Du zu viel, oder zu wenig umgedreht.

Bipolar-Transistoren: NPN gegen PNP, und umgekehrt, tauschen, B bleibt 
B, E bleibt E, C bleibt C.

MOSFET: P-Kanal gegen N-Kanal tauschen, G bleibt G, S bleibt S, D bleibt 
D.

LED: Umdrehen.

Versorgungsspannung umpolen, Eingangsspannung ist nun negativ gegen GND.

Alle anderen Bauteile (Widerstände, Trimmer) bleiben an ihrem Platz.

Mit freundlichem Gruß - Martin

von Piter K. (kurczaq)


Bewertung
0 lesenswert
nicht lesenswert
Ok, glaub der FET war falsch herum.

sieht jetzt so aus:

https://s16.postimg.org/gj8tkzuud/solmos3.png

die Last wäre dann R11 (hier als 1M zwecks "Eigenverbrauchsmessung" der 
Schaltung), die gegen Masse gezogen wird richtig?

Der Si4980 wäre IMO vergleichbar mit IRLD024 oder IRLD120, von denen ich 
wohl was herumliegen hatte (eignet sich gut fürs Protoboard...). Wenn 
ich den noch finde, dann kann ich es morgen testen :)

viele Grüße

von Martin S. (led_martin)


Bewertung
0 lesenswert
nicht lesenswert
Ja, das sieht gut aus!

Mit freundlichem Gruß - Martin

von Peter G. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Martin S. schrieb:
> Auch wenn ich sicher nicht das gleiche mache, habe ich hier mehrere
> Aufbauten, bei denen Goldcaps solar geladen werden, mit einem Atmel
> Mikrocontroller, der davon versorgt wird, und wenn genug 'Saft' da ist,
> ein paar LEDs ansteuert.
>
> Die Versorgung habe ich aber anders gemacht. Der Mikrocontroller hängt
> immer an dem Goldcap, und ist die meiste Zeit im Sleep-Mode.

interessant - welches Solarpanel und Goldcap benutzt du in deiner 
Schaltung?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.