Forum: Mikrocontroller und Digitale Elektronik ATMega16u2 auslöten geht nicht, warum?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Conny G. (conny_g)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe gerade versucht von einer Ultimaker 2 Platine den ATMega16u2 
auszulöten um ihn zu tauschen.
Und bin leider gerade daran gescheitert, vielleicht könnt ihr helfen?

Warum den ATMega16u2 tauschen?
Der geht zwar an sich noch, konnte ihn noch flashen, aber der USB-Port 
ist defekt, er wird nicht mehr erkannt. Den hab ich mir vor 1 Jahr mal 
gegrillt beim mit dem USB-Oszi herummessen... Danach einfach eine neue 
Platine gekauft, aber ich möchte diese jetzt gerne wiederherstellen für 
andere Projekte.

Das Ultimaker-Board ist ja eigentlich nur eine schöne Ausführung eines 
Arduino Mega 2560 plus Motortreiber auf der Platine.
Der USB-Port ist ein ATMega16u2, der Hauptprozessor ein ATMega2560.
Schaltpläne hier:
https://github.com/Ultimaker/Ultimaker2/blob/master/1091_Main_board_v2.1.1_(x1)/Main%20Board%20V2.1.1.pdf

Ich habe das Auslöten mit der regelbaren Heissluftpistole versucht, auf 
ca. 270 Grad eingestellt (genau gesagt: auf 370 Grad, dann kommen vorne 
270 Grad raus, das hab ich mal bei einer Messreihe mal bestimmt, was ich 
vorne wirklich bekomme), die Platine etwas von unten erwärmt und dann 
die entsprechende Stelle von oben für ein paar Minuten.

Dabei habe ich dann mit der Pinzette an dem 16u2 gezogen, der bewegte 
sich aber überhaupt nicht.
Während sich einer der Kondensatoren aber löste, als ich mit der 
Pinzette drankam, d.h. das Lötzinn wurde schon weich.

Was habe ich falsch gemacht, warum ging das nicht?

Foto der Platine angehängt.

Vg,
Conny

: Bearbeitet durch User
von derElf (Gast)


Bewertung
0 lesenswert
nicht lesenswert
1. 270°C ist wahrscheinlich etwas zu wenig für bleifreies Lötzinn
2. Wenn das Gehäuse ein großes Massepad in der Mitte hat leitet das die 
Wärme ganz gut auf die Platine ab.

-> Mehr Power!

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Ja, ein großes Massepad hat der QFN32:
http://i.ebayimg.com/images/g/dpwAAOSwZG9WkmQi/s-l300.jpg
(nächstbestes Bild)

Also nächster Versuch mit mehr Power. Hab mich da heute nicht mehr 
getraut...

von H.Joachim S. (crazyhorse)


Bewertung
0 lesenswert
nicht lesenswert
Platine vorwärmen.

von hp-freund (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Wenn er schon defekt ist, einfach Gehäuse abschleifen (Dremel) bis das 
Metall sichtbar wird und mit großem Lötkolben und einem richtigen Klecks 
Lötzinn erwärmen.
Dann ist das in Sekunden erledigt und die Platine und umliegenden 
Bauteile werden geschont.

von TestX (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Den Dremel kann man sich sparen.... 80watt Lötkolben mit viel Lötzinn in 
die Mitte des IC drücken...nach 10s klebt das ganzen Teil dran ...

von Harald (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Bei Heißluft kann man die umliegenden Bauteile auch sehr gut mit 
Alufolie schützen. Controller mit Cutter freilegen.

von Peter R. (pnu)


Bewertung
0 lesenswert
nicht lesenswert
Bei meinem Heißluftgebläse ist der Luftstrom allerdings so rabiat, dass 
das IC einfach weggeblasen wird. (Aufsatzdüse mit ca 10mm Durchmesser 
verwenden)

Bei der Bauform im Bild kann man sicher einen Drahtring um das IC 
knoten, an dem zwei Enden zum Hochziehen dran sind. Dann wird unter 
leichtem Zug und Heißluft das IC abhebbar sein. Wenn man dann noch eine 
Blechmaske macht, mit quadratischem Fenster für das IC, werden 
benachbarte Teile der Platine geschont.

Stecknadelmethode: das ganze IC mit Heißluft anblasen. Dabei Stecknadel 
am Spalt an einer Seite ansetzen und Druck ausüben. Wenn dann der 
Erweichungspunkt ereicht wird, nur ganz wenig anheben,wie es die 
Weichheit der Lötstellen erlaubt, sonst reißt man einige Pads los. Dann 
auf der Gegenseite etwas anheben und so wechselweise das IC hochruckeln.

Das Alles geht um noch einen Grad besser, wenn die Platine auf 70 bis 
100 Grad vorgewärmt wird.

: Bearbeitet durch User
von m.n. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich gebe die Heißluft von unten, sofern dort keine SMDs bestückt sind.
Da verkokelt nichts und man sieht gut, wann das Zinn flüssig wird.

von ui (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Meist ist es wirklich mit viel Lötzinn (und guten Lötkolben) am 
einfachsten. Habe von der Bauform schonmal 30 Stück innerhalb 2 Stunden 
von Platinen runterholt. Wirklich viel Lötzinn, und dann einigermaßen 
Flott rund um den IC fahren. Und schauen das genug Lötzinn drauf ist. 
Wenn du den IC mit dem Lötkolben verschieben kannst, dann einfach 
schnell auf den Tisch geklopft. Schon hastn in der Hand.

von Lukas (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ja hätte ich jetzt auch gesagt.

Biege dir ein Quadrat welches genau um den Chip passt aus ca 1,5mm² lege 
es passend auf die platine unf mache das ganze Teil mit viel Lötzinn 
heiß, dann kannst du den Chip apnehmen.

von Lötschmied (Gast)


Bewertung
0 lesenswert
nicht lesenswert
m.n. schrieb:
> Ich gebe die Heißluft von unten,

Käse, völlig überflüsseige thermische Belastung der Platine.

Bei uns in der (ich habe den Anspruch: profesionellen) Firma
wir die Platine vorgeheizt so dass der eigentliche Heissluft-
Strom keine Mühe hat das Bauteil lokal über die Schmelz-
temperatur zu bringen. Anstelle des Heissluftstroms kann man
dann auch den Lötkolben mit Drahtring zum Auslöten verwenden.

von m.n. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Lötschmied schrieb:
> Käse

Im Gegenteil: geht wie Butter.
Ich verwende keine Pertinax Platinen.

von Lötschmied (Gast)


Bewertung
0 lesenswert
nicht lesenswert
m.n. schrieb:
> Im Gegenteil: geht wie Butter.

Dann mach weiter so.

Aber empfiehl deine Dorf-Hufschmied Methoden nicht hier im Forum.

von Ordner (Gast)


Bewertung
0 lesenswert
nicht lesenswert
H.Joachim S. schrieb:
> Platine vorwärmen.

Bei Profi-Rework Stationen wird vum unten mit IR vorgeheizt und von oben 
kommt die heissluftdusche bis sich der Käfer mit der Vakuum Pipette 
abheben lässt. Da was improvisiertes: 
http://www.genstr.com/arduino-rework-station.html

von Blubb (Gast)


Bewertung
0 lesenswert
nicht lesenswert
ui schrieb:
> Schon hastn in der Hand.

g Ich hatte mal einen schönen TO-126-förmigen Transistorbrandfleck am 
Daumen...

von Paul B. (paul_baumann)


Bewertung
0 lesenswert
nicht lesenswert
Blubb schrieb:
> Ich hatte mal einen schönen TO-126-förmigen Transistorbrandfleck am
> Daumen...

Daumen hoch! (Zum Kühlen)

:)

MfG Paul

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Hehe, vielen Dank für die vielen Tipps.

Ich versuche das heute oder morgen noch einmal und berichte.
Ich würde diesmal mal 300 Grad statt 270 Grad nehmen, +10%.

Zum Vorwärmen könnte ich die Platine bei 100-120 Grad in den Backofen 
stecken für ein paar Minuten.
Oder in den selbstgebauten Reflow-Pizza-Ofen und ich breche das Programm 
vor der Reflow-Phase, also bei 120-170 Grad ab.

von Conny G. (conny_g)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, mit 440 Grad bei der Heissluftpistole - das dürften vorne raus ca. 
300-320 Grad sein - ist er jetzt raus. Nachdem ich von 420 auf 440 Grad 
erhöht hatte ging es schlagartig ganz leicht, das war die Schwelle.
Die LEDs daneben hat's aber weggeblasen....
Wenn ich mir die Umgebung so ansehe wie die Header daneben: sanft war 
das nicht, das muss ich wohl noch üben.

von Manfred (Gast)


Bewertung
-7 lesenswert
nicht lesenswert
Conny G. schrieb:
> So, mit 440 Grad bei der Heissluftpistole - das dürften vorne raus ca.
> 300-320 Grad sein - ist er jetzt raus. Nachdem ich von 420 auf 440 Grad
> erhöht hatte ging es schlagartig ganz leicht, das war die Schwelle.
> Die LEDs daneben hat's aber weggeblasen....
Hurrah, er hat die Temperatur erreicht.

Hast Du mal recherchiert, welche Lote welche Schmelztemperaturen haben? 
Mal nachgedacht, weshalb die uralte Lötspitze "7" vom Weller-Magnastat 
370°C hat?

Was sollen diese dusseligen Temperaturangaben? Es interessiert 
niemanden, was Deine Kasper-heisse-Luft-Station anzeigt, es muß die 
Schmelztemperatur des Lots erreicht werden. Wenn 100K zu wenig angezeigt 
werden, ist das ein Fall für den Service und muß nicht hier ausgeheult 
werden.

Bauteile nebenan weg geblasen kenne ich leider auch, mein Kollege kann 
das besser - der macht es aber auch jeden Tag mehrfach. Hast Du keine 
quadratischen Düsen, die solche ICs gezielt beföhnen?

von Conny G. (conny_g)


Bewertung
1 lesenswert
nicht lesenswert
Manfred schrieb:
> Was sollen diese dusseligen Temperaturangaben? Es interessiert
> niemanden, was Deine Kasper-heisse-Luft-Station anzeigt, es muß die
> Schmelztemperatur des Lots erreicht werden.

Ja klar ist die Temperaturanzeige Mist, das hab ich ja oben schon 
geschrieben, dass die am oberen Ende um 100K+ abweicht.

> Bauteile nebenan weg geblasen kenne ich leider auch, mein Kollege kann
> das besser - der macht es aber auch jeden Tag mehrfach. Hast Du keine
> quadratischen Düsen, die solche ICs gezielt beföhnen?

Nein, ist ja kein Profi-Equipment.

von Richard B. (r71)


Bewertung
0 lesenswert
nicht lesenswert
Conny G. schrieb:
> Nein, ist ja kein Profi-Equipment.

Kannst du nur die Temperatur einstellen?

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Richard B. schrieb:
> Conny G. schrieb:
>> Nein, ist ja kein Profi-Equipment.
>
> Kannst du nur die Temperatur einstellen?

Luft in 2 Stufen. Bläst nicht so wild, aber für die LEDs wohl genug.

von Günter Lenz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
m.n. schrieb:
>Ich gebe die Heißluft von unten,

Habe ich auch schon gemacht, aber nur zum ausschlachten.
Die Platine kann man danach nicht mehr gebrauchen.
Es gibt noch eine Methode, mit Rasierklinge. Man erwärmt
eine Reihe Anschlüsse und schiebt dann die Rasierklinge
zwischen Platine und Anschlußstifte. Mit den anderen
Reihen macht man es genauso. Die Rasierklinge nimmt
kein Lötzinn an, sie lötet sich also nicht fest. Wenn es
auf der Platine eng ist, kann man die Rasierklinge auch
durchbrechen. Der Lötkolben wird vorbereitet, mit Kupferblech,
bei dem man die Kante entlang verzinnt, so daß man eine
Reihe Anschlüsse gleichzeitig erwärmen kann. Dann gibt es
noch eine Methode, man fräst die einzelnen Anschlüsse mit
einen Zahnarztbohrer durch. Dieses IC kann man auch
zum experimentieren wiederverwenden, in dem man die einzelnen
Anschlüsse mit dünnen Kupferblankdraht verlängert. Es läst
sich dann auf eine Lochrasterplatte löten.

von Markus F. (mfro)


Bewertung
1 lesenswert
nicht lesenswert
Conny G. schrieb:
> Die LEDs daneben hat's aber weggeblasen....

Wenn Du das Drumrum vorher mit Aluklebeband abklebst, passiert da nix.

von m.n. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Günter Lenz schrieb:
> m.n. schrieb:
>>Ich gebe die Heißluft von unten,
>
> Habe ich auch schon gemacht, aber nur zum ausschlachten.
> Die Platine kann man danach nicht mehr gebrauchen.

Das kann ich nicht bestätigen.
Ich kann aber bestätigen, daß bei heißer Luft von oben die Stiftleisten 
+ Elkos verschmoren und Hühnerfutter 'weggewirbelt' wird.

von Rudolph R. (rudolph)


Bewertung
0 lesenswert
nicht lesenswert
Wo wir gerade schön im Thema sind, hat vielleicht wer einen Tipp für 
eine günstige Heizplatte?
In der Bucht finde ich nur teuer oder Quatsch mit "Heizplatte", ich kann 
weder eine heizbare Magnet-Rührer Platte gebrauchen, noch wäre einer 
dieser "Shisha Kohle-Anzünder" dafür zu gebrauchen... :-)

Und ich kann das auch nur noch mal empfehlen, wenn ich ein Teil aus 
einer Platine auslöte, dann decke ich die Teile drum herum ab. Für 
irgendwas muss die Rolle Capton-Klebeband doch gut sein, die war so 
teuer. :-)

von Peter R. (pnu)


Bewertung
1 lesenswert
nicht lesenswert
Zunächst mal: Da die meisten Heizplatten mit Zweipunktregler arbeiten, 
zeigen sie beim ersten Hochheizen einen saftigen Überschwinger im 
Temperaturverlauf. Erst nach den ersten zwei, drei Schaltspielen hat 
sich eine annähernde Solltemperatur eingestellt.

Ich selbst verwende z.B. ein uraltes Bügeleisen, mit Sohle nach oben im 
Schraubstock eingespannt. Beim Hochheizen versengt es erst mal die 
Plastikteile, auch wenn es nur auf einen Punkt eingestellt ist. Erst 
nach ca. 5 min ist dann die Temperatur zivil, sodass man die 
Leiterplatte drauf vorwärmen kann.

von Richard B. (r71)


Bewertung
0 lesenswert
nicht lesenswert

: Bearbeitet durch User
von Rudolph R. (rudolph)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Tipps, so ganz tauglich sieht das aber irgendwie nicht 
aus.
Die normale Kochplatte ist schon nicht so toll, weil die Dinger ja nicht 
plan sind.
Das Ceran-Feld hat da was, zum Beispiel auch das Ding hier:
https://www.amazon.de/Infrarot-Kochplatte-Kochgeschirr-demontierbar-Einzel-kochplatte-Glaskeramik-Kochfeld/dp/B014JB26RU/ref=pd_cp_79_1?_encoding=UTF8&psc=1&refRID=T356VBG6K3G4P3SCFK14

Nur werden die als Kochplatten nur die erwähnte Zweipunkt-Regelung 
haben, mit sowas gezielt auf 120°C oder so vorzuheizen dürfte schwer 
werden.
Da muss ich mir nur mal ansehen, was unser Herd so treibt, zum Kochen 
ist das ja voll in Ordnung.

Das Umzubauen ist auch keine Option, erstmal wegen dem Aufwand und dann 
weil das 230V Geräte sind.
Ich würde das auch gerne auf der Arbeit einsetzen, da kommt die 
Verwendung von manipulierten 230V Geräten nicht so gut an.

von H.Joachim S. (crazyhorse)


Bewertung
0 lesenswert
nicht lesenswert
So was reicht erstmal völlig:
Ebay-Artikel Nr. 172412230629

Es geht darum, die Platine selbst auf ca. 80° zu heizen, und das geht 
mit IR viel besser als mit direktem Kontakt. Da brauchste keine 
Regelung, nur ein bisschen Versuche und Erfahrung.

von Manfred (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Conny G. schrieb:
> Hast Du keine
>> quadratischen Düsen, die solche ICs gezielt beföhnen?
> Nein, ist ja kein Profi-Equipment.
Meinen Chinesen ZD-939L sehe ich auch keinesfalls in der Profi-Ecke. 
Dennoch hat er zwei IC-Düsen mitgebracht - siehe Bilder

Conny G. schrieb:
> Luft in 2 Stufen. Bläst nicht so wild, aber für die LEDs wohl genug.
Ich habe in die Lufteinstellung eingegriffen, bei mir ist es eine 
Membranpumpe (Aquarium) mit simpler Phasenanschnittsteuerung.

Günter Lenz schrieb:
>>Ich gebe die Heißluft von unten,
> Habe ich auch schon gemacht, aber nur zum ausschlachten.
Glaskeramikkochfeld: Platine drauf, anheizen und Bauteile zügig 
absammeln.

von Richard B. (r71)


Bewertung
0 lesenswert
nicht lesenswert
Rudolph R. schrieb:
> so ganz tauglich sieht das aber irgendwie nicht aus.

So natürlich nicht. Die Temperatur musst du manuell einstellen.
Zwischen Heizung und PCB kommt noch ein Blech oder Folie aus Alu.

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Gestern Abend den neuen 16u2 aufge-reflowt. Brauchte drei Anläufe bis 
die Menge an Lötpaste passte und alle Pads gut aussahen.
Leider funktioniert er jetzt nicht, vermutlich habe ich ihn gegrillt. 
:-)
Aber klar, diese Art von Operation muss man auch ein bisschen üben.
Es kommen in den nächsten Tagen nochmal 16u2, dann versuche ich es 
nochmal.

von Peter R. (pnu)


Bewertung
0 lesenswert
nicht lesenswert
Conny G. schrieb:
> Leider funktioniert er jetzt nicht, vermutlich habe ich ihn gegrillt.

Nach meiner Erfahrung halten die ICs sehr hohe Temperaturen beim Löten 
aus. Gegrillt hab ich ein IC noch nie. Da sind weitaus eher die Lötpads 
weggebrannt oder der Lötschutzlack verbrannt, sodass es zu Kurzschlüssen 
zwischen den Pins kommt.

Und vor Allem: viel, viel (bzw. mehrmals) Flussmittel verwenden. Sonst 
sorgt das nicht richtig fließende Zinn für die Verbindungen zwischen den 
pins.

Bei Youtube gibts herrliche Videos zu sehen, wie man ICs in SMD-Technik 
lötet. Da kriecht dank des Flussmittels das Lot von selbst an seinen 
Platz.

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Peter R. schrieb:
> Conny G. schrieb:
>> Leider funktioniert er jetzt nicht, vermutlich habe ich ihn gegrillt.
>
> Nach meiner Erfahrung halten die ICs sehr hohe Temperaturen beim Löten
> aus. Gegrillt hab ich ein IC noch nie. Da sind weitaus eher die Lötpads
> weggebrannt oder der Lötschutzlack verbrannt, sodass es zu Kurzschlüssen
> zwischen den Pins kommt.

Oder der Quarz tut nicht mehr oder sowas. Ist ein Quarz 
hitzeempfindlich?
Du meinst also es wäre wert erstmal andere Fehler zu suchen.

> Und vor Allem: viel, viel (bzw. mehrmals) Flussmittel verwenden. Sonst
> sorgt das nicht richtig fließende Zinn für die Verbindungen zwischen den
> pins.

Das tut die Reflowpaste ja sowieso und das war auch so, dass der IC wie 
mit Gummis zurückgezogen wurde, als ich mal mit der Pinzette dran 
rumrutschte während das Lot gerade flüssig war. Beeindruckend, wie das 
"haftet".

Ich habe nachher auch mal akribisch durchgemessen, ob ich irgendwo 
Brücken finde, waren keine. Was ich allerdings nicht 100%ig sagen kann, 
ob alle Pads des IC wirklich Kontakt haben, denn die sind ja unter dem 
Chip beim QFN32.
Optisch von der Seite sieht es ok aus.

> Bei Youtube gibts herrliche Videos zu sehen, wie man ICs in SMD-Technik
> lötet. Da kriecht dank des Flussmittels das Lot von selbst an seinen
> Platz.

Habe ich ja schon viele gesehen, auch zu BGA. Mental bin ich komplett 
vorbereitet.
Aber es selbst mal mit QFN zu machen (mit QFP schon gemacht) und als 
Reparatur, nicht Neubestückung, ist nochmal was anderes, das braucht - 
wie vieles im Leben - erstmal ein bisschen Übung und nach dem 3. bis 5. 
Mal ist es dann "easy".

Da muss man ja erstmal alles falsch machen, was man falsch machen kann - 
zu niedrige Temperatur, zu hohe Temperatur, zuviel Lot, zuwenig Lot, ...
Und wie immer muss man unperfektes Equipment mit Geschicklichkeit 
ersetzen (Heißluftpistole, Aufbringen der Lötpaste etc.).
3 Versuche hab ich ja jetzt schon und es wird auch schon leichter :-)

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Nochmal die Pads gecheckt und ein bisschen per Hand nachgelötet. Sieht 
jetzt alles gut aus. Geht aber nicht.
1
avrdude: AVR device initialized and ready to accept instructions
2
3
Reading | ################################################## | 100% 0.97s
4
5
avrdude: Device signature = 0x000000 (retrying)
6
7
Reading | ################################################## | 100% 0.97s
8
9
avrdude: Device signature = 0x000000 (retrying)
10
11
Reading | ################################################## | 100% 0.97s
12
13
avrdude: Device signature = 0x000000
14
avrdude: Yikes!  Invalid device signature.
15
avrdude: Expected signature for ATmega16U2 is 1E 94 89
16
avrdude: safemode: hfuse reads as 0
17
avrdude: safemode: efuse reads as 0
18
avrdude: reading lfuse memory:
19
20
Reading | ################################################## | 100% 0.32s
21
22
avrdude: writing output file "i"
23
avrdude: error opening i: No such file or directory
24
avrdude: can't determine file format for i, specify explicitly
25
avrdude: write to file 'i' failed
26
27
avrdude: safemode: hfuse reads as 0
28
avrdude: safemode: efuse reads as 0
29
avrdude: safemode: Fuses OK (E:00, H:00, L:00)
30
31
avrdude done.  Thank you.

Als nächstes mal mit dem Oszi den Quarz prüfen.

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Conny G. schrieb:
> Als nächstes mal mit dem Oszi den Quarz prüfen.

Der tut nix, muss er aber auch nicht. Die Dinger laufen doch aus der 
Fabrik mit internem Takt/8, oder?

Was könnte es jetzt noch sein... :-/

: Bearbeitet durch User
von Peter R. (pnu)


Bewertung
0 lesenswert
nicht lesenswert
Gut, was das Löten angeht, hast Du anscheinend mehr Ahnung als ich 
annahm.

Mir ist halt noch nie passiert dass ein Chip durchs Löten zerstört 
wurde. Auch Quarze sind erstaunlich robust. Ich habe eigentlich nur 
welche durch Abknipsen der Drähte per Seitenschneider gekillt. Der damit 
verbundene scharfe Knips bricht tatsächlich die Quarzscheibe los. (Bei 
Biegeschwingern 77,5 kHz kann man durch angelegte exakte DDS-Frequenz 
mit einigen V auch den Quarz zerspringen lassen). Dabei ging ich mit 
solchen Dingern rabiat um, wenn ich sie aus Schrottplatinen auslötete 
bzw. mit Heißluft wegblies.Da safteten die Platinen oft schon schwarze 
Blasen aus.

Wenn halt die Signatur nicht rauskommt, ist irgendetwas ganz daneben.

Da würde ich also zuerst die 6pins der ISP genauestens überprüfen : 
Masse- Schluss, Vcc-Schluss, Belastung durch andre Hardware, 
Verbindungen zum Pogrammiergerät, Takt des ISP ( 1/4 des Takts?)usw.

: Bearbeitet durch User
von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Es kommen die Tage nochmal Atmega16u2, dann versuche ich einfach 
nochmal. Aufgeben gibt's nicht. Ich muss das können. :-)

von Martin Beuttenmüller (Gast)


Bewertung
0 lesenswert
nicht lesenswert
@TO

Respekt für Deine Beharrlichkeit!

Ich krieg' derzeit nicht mal
"den ersten Schritt" gebacken.

Nu werde ich Dich als Vorbild nehmen:
Aufgeben ist keine Option!

Ich wünsch Dir gutes Gelingen ...
Martin

von tsaG (Gast)


Bewertung
0 lesenswert
nicht lesenswert
da schließe ich mich auch an. Bitte beschreibe dann auch, wie Du genau 
vorgegangen bist beim Einlöten, also welche und wieviel Paste wie und wo 
aufgetragen; ich habe Paste nur bei einem SOIC einmal verwendet, die ist 
mit der Heißluft dann auf die Pads gezogen (hätte ich mir sparen können, 
das wäre mit dem Kolben einfacher und schneller gegangen); aber ein QFN 
liegt ja platt auf, wie zieht die Paste dann raus?

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
tsaG schrieb:
> da schließe ich mich auch an. Bitte beschreibe dann auch, wie Du genau
> vorgegangen bist beim Einlöten, also welche und wieviel Paste wie und wo
> aufgetragen; ich habe Paste nur bei einem SOIC einmal verwendet, die ist
> mit der Heißluft dann auf die Pads gezogen (hätte ich mir sparen können,
> das wäre mit dem Kolben einfacher und schneller gegangen); aber ein QFN
> liegt ja platt auf, wie zieht die Paste dann raus?

Bei dem QFN ist es wichtig möglichst wenig Lötpaste zu verwenden. Beim 
ersten Versuch hatte ich zuviel und dann ging sie tlw. über 2 Pads, also 
verursachte Kurzschlüsse. Und im Unterschied zu den ICs mit Beinchen 
wäre ich mir hier nicht so sicher, dass man das so leicht gefixt 
bekommt, denn die Paste hängt ja unter dem IC rum.
Deshalb habe ich ihn dann nochmal ausgelötet, mit dem Lötkolben die Pads 
gereinigt (überschüssiges blieb am Lötkolben) und ihn dann nochmal 
draufgesetzt und angeföhnt. Das hat aber nicht so geklappt, weil da kein 
Flussmittel mehr im Zinn war.
Also dritter Versuch und ganz wenig Paste genommen, eine ganz dünne 
Wurst quer über die Pads, je eine auf allen 4 Seiten. Welche Menge? Kann 
ich nicht beschreiben, muss man ins Gefühl bekommen.
Nochmal angeheizt, ist wunderbar ge-reflowed und als ich mal mit der 
Pinzette am IC rutsche als alles grad flüssig war, schnalzte er förmlich 
wieder auf seine Position zurück. Sehr beeindruckend, da sind 
ordentliche Kräfte am Werk.
Und genau so findet die Paste und der IC ihren Platz auf den Pads, muss 
man sich nicht kümmern, die Oberflächenspannung des Flussmittels macht 
das.

von tsaG (Gast)


Bewertung
0 lesenswert
nicht lesenswert
[Werbung gelöscht]

Hier geht es ja um ein QFN:

@Conny:
Welche Paste inkl. Flußmittel verwendest Du da?

Ich frage deshalb so hartnäckig, weil ich evetuell ebenfalls ein QFN40 
mit Mittelfläche tauschen muß, den MT6627N eines (alten) Tablets.

Ich habe einmal mit ca. 420° draufgeblasen um die Lötstellen zu 
verflüssigen, falls es ein Kontaktproblem sein sollte; das wars offenbar 
nicht: WLAN und BT funktionieren einwandfrei, GPS geht extrem schlecht 
und ich habe vermutet dass ich beim Messen den Chip an diesem Eingang 
zerstört hätte.

: Bearbeitet durch Moderator
von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
tsaG schrieb:
> @Conny:
> Welche Paste inkl. Flußmittel verwendest Du da?

Ich habe gerade die hier im Einsatz (bleifrei):
https://www.conrad.de/de/smd-loetpaste-blf-03-inhalt-10-g-145009.html

Werde meine nächste selbstgemachte Platine aber mal hiermit versuchen 
(bleihaltig, Schmelzpunkt 183 Grad):
http://de.farnell.com/edsyn/cr44/solder-paste-62-36-2-182-deg-10g/dp/876768

Beim Reflow-Löten mit Heißluftpistole brauchst m.E. kein extra 
Flussmittel, das ist ja schon in der Lötpaste drin und das ist auch auf 
die Wärmekurve optimiert.
Flussmittel brauchst Du nur, wenn Du mit dem Lötkolben noch extra was 
machen muss, wie nachher überschüssiges Lot entfernen etc.

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Reiches schrieb im Beitrag #4817060:
> Da gibt es aber auch so Lernsätze zum üben:
> 
http://www.ramser-elektro.at/shop/bausaetze-und-platinen/platine-mit-smd-bauteilen-fuer-loetuebungen/
>
> Dann braucht man nicht gleich einen "guten" IC grillen,

Mit den 08/15 Bauteilen des Hobbybastlers hab ich schon ge-reflowed. 
Noch nicht häufig, aber hat geklappt.
Auch schon mal selber eine Schablone aus Messingblech geätzt, das hat 
super funktionert. Es steht an mal eine aus 150µ-Kunststoff mit dem 
Laser zu machen.

Aber QFN hab ich noch nicht gemacht, das ist schon nochmal etwas 
fummeliger.
Speziell mit der kleinen Menge an Lötpaste und wenn man keine Schablone 
hat oder bei einer Reparatur keine verwenden kann.

von tsaG (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Infos;
ich habe aber Glück: ich brauche den Chip nicht zu tauschen, der Defekt 
war nicht am Chip, sondern offenbar im Signalweg, wahrscheinlich habe 
ich mit einer Meßspitze eine Lötstelle beschädigt gehabt. Durch das 
Draufblasen mit der Heißluft - das habe ich nicht nur beim QFN, sondern 
gleich im ganzen Bereich rundherum gemacht, hat sich die Lötstelle 
offenbar wieder geschlossen.
So wie Du die Vorgensweise beschreibst, hätte ich den Tausch sowieso 
nicht ohne diverse Zerstörungen hinbekommen.

von H.Joachim S. (crazyhorse)


Bewertung
0 lesenswert
nicht lesenswert
Ich lass ja bei Prototypen inzwischen zumindest die ICs bestücken, die 
Augen lassen deutlich nach :-(

Letztens war aber die Zeit einfach zu knapp, also selbst probiert 
(AD5700). Sicherheitshalber 3 Stk aufgebaut, alle 3 funktionierten.

Alle pads mit normalem Lötzin von der Rolle leicht verzinnt, noch ein 
wenig Flussmittel drauf, Chip positioniert, Heissluft, fertig. Konnte 
man zusehen, wie der sich festgesaugt hat. Keine Paste, keine Schablone.

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
H.Joachim S. schrieb:
> Alle pads mit normalem Lötzin von der Rolle leicht verzinnt, noch ein
> wenig Flussmittel drauf, Chip positioniert, Heissluft, fertig. Konnte
> man zusehen, wie der sich festgesaugt hat. Keine Paste, keine Schablone.

Das hätte ich jetzt nicht gedacht, dass das funktionieren könnte. Gut zu 
wissen :-)

von Conny G. (conny_g)


Bewertung
0 lesenswert
nicht lesenswert
Übrigens bin ich wg. des Webblasens der LEDs auch dazu übergegangen die 
Heißluft von unten zu geben. Dauert 1min länger zum Aufwärmen, aber geht 
prima. Stört die Platine gar nicht.

von m.n. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Conny G. schrieb:
> Übrigens bin ich wg. des Webblasens der LEDs auch dazu übergegangen die
> Heißluft von unten zu geben. Dauert 1min länger zum Aufwärmen, aber geht
> prima. Stört die Platine gar nicht.

Sag ich doch ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.